Hello Shaun,
/*
* Multiline comments (except in the net subsystem) should
* start with "/*" on a separate line. see Documentation/CodingStyle
*/
If you are going to fix the comments you should get both the beginning
and the end.
More comments inline.
On Monday, February 08, 2016 05:31:17 PM S
> -Original Message-
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Sunday, February 07, 2016 9:34 PM
> To: Lijun Pan
> Cc: a...@arndb.de; de...@driverdev.osuosl.org; linux-
> ker...@vger.kernel.org; bhamc...@freescale.com; lijun.pan2...@gmail.com;
> bhupesh.sha...@freescale
On Mon, Feb 08, 2016 at 05:40:17PM -0600, Lijun Pan wrote:
> Add more introduction of restool driver and state why
> restool driver is needed in helping moving fsl-mc bus
> out of staging tree.
>
> Signed-off-by: Lijun Pan
> ---
> drivers/staging/fsl-mc/README.txt | 11 ++-
> drivers/s
This patch fixes the following naming convention issue in rtsx_transport.c,
as reported by checkpatch.pl:
CHECK: Avoid CamelCase:
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rts5
This patch removes all unnecessary parentheses found by checkpatch.pl.
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_transport.c
b/drivers/staging/rts5208/rtsx
This patch adds a dma_mapping_error call to debug potential DMA mapping
errors after the dma_map_single call in rtsx_transport.c.
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rts5208/rtsx
This patch changes all comparsions to NULL with !..., as reported by
checkpatch.pl.
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx_transport.c
b/drivers/staging/rts5208/
This patch fixes all comment style warnings in rtsx_transport.c reported by
checkpatch.pl:
WARNING: Block comments use a trailing */ on a separate line
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 21 ++---
1 file changed, 14 insertions(+), 7 deletions
This patch fixes the following styling issue in rtsx_transport.c
as reported by checkpatch.pl:
CHECK: spaces preferred around that '-' (ctx:VxV)
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/
This patch fixes the following issues in rtsx_transport.c as reported by
checkpatch.pl:
CHECK: Blank lines aren't necessary after an open brace '{'
CHECK: Please don't use multiple blank lines
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 3 ---
1 file changed, 3 delet
This set of patches fixes the coding style issues in rtsx_transport.c, and
dds a missing call dma_mapping_error() after dma_map_single().
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverd
This patch fixes the alignment issue reported by checkpatch.pl:
CHECK: Alignment should match open parenthesis
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 61 ++--
1 file changed, 35 insertions(+), 26 deletions(-)
diff --git a/drivers/sta
This patch removes all spaces after casts in rtsx_transport.c, as reported
by checkpatch.pl:
CHECK: No space is necessary after a cast
Signed-off-by: Shaun Ren
---
drivers/staging/rts5208/rtsx_transport.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/
Add the sysfs documentation for the rescan attribute of
fsl-mc bus.
Signed-off-by: Lijun Pan
---
Documentation/ABI/testing/sysfs-bus-fsl-mc | 11 +++
1 file changed, 11 insertions(+)
create mode 100644 Documentation/ABI/testing/sysfs-bus-fsl-mc
diff --git a/Documentation/ABI/testing/
The kernel support for the restool (a user space resource management
tool) is a driver for the /dev/dprc.N device file.
Its purpose is to provide an ioctl interface,
which the restool uses to interact with the MC bus driver
and with the MC firmware.
We allocate a dpmcp at driver initialization,
and
This series of patches are rebased on
https://git.kernel.org/cgit/linux/kernel/git/gregkh/staging.git/commit/?h=staging-next&id=c75955d1ee43b214c497cc297956866ca05ef22b
patch v1 1/5 "staging: fsl-mc: section mismatch bug fix" is already accepted.
Lijun Pan (8):
staging: fsl-mc: static inline fu
Introduce the rescan attribute as a device attribute to
synchronize the fsl-mc bus objects and the MC firmware.
To rescan the root dprc only, e.g.
echo 1 > /sys/bus/fsl-mc/devices/dprc.1/rescan
Signed-off-by: Lijun Pan
---
v3: rebased on top of greg's staging-testing
drivers/staging/fsl-mc/bus
Demonstrate why sysfs rescan attribute is helpful for
moving fsl-mc bus out of staging.
Signed-off-by: Lijun Pan
---
drivers/staging/fsl-mc/TODO |6 ++
1 file changed, 6 insertions(+)
diff --git a/drivers/staging/fsl-mc/TODO b/drivers/staging/fsl-mc/TODO
index 3894368..5065821 100644
--
Add more introduction of restool driver and state why
restool driver is needed in helping moving fsl-mc bus
out of staging tree.
Signed-off-by: Lijun Pan
---
drivers/staging/fsl-mc/README.txt | 11 ++-
drivers/staging/fsl-mc/TODO | 18 --
2 files changed, 26 ins
Define a static inline function is_root_dprc(dev) to tell whether
a device is root dprc or not via platform_bus_type.
Remove fsl_mc_is_root_dprc() because is_root_dprc() is simpler
and easier to understand.
Signed-off-by: Lijun Pan
---
v3: rebased on top of greg's staging-testing
v2: use static i
Introduce the rescan attribute as a bus attribute to
synchronize the fsl-mc bus objects and the MC firmware.
To rescan the fsl-mc bus, e.g.,
echo 1 > /sys/bus/fsl-mc/rescan
Signed-off-by: Lijun Pan
---
v3: rebased on top of greg's staging-testing
drivers/staging/fsl-mc/bus/mc-bus.c | 47
Add the sysfs documentation for the rescan attribute of
dprc devices.
Signed-off-by: Lijun Pan
---
Documentation/ABI/testing/sysfs-devices-dprc | 13 +
1 file changed, 13 insertions(+)
create mode 100644 Documentation/ABI/testing/sysfs-devices-dprc
diff --git a/Documentation/ABI/
The last two lines of these functions are compressed into one.
Also removed the variable ret as it is now not used.
Found using coccinelle:
@@
expression e, ret;
@@
-ret =
+return
e;
-return ret;
Signed-off-by: Bhumika Goyal
---
drivers/staging/wlan-ng/hfa384x_usb.c | 20 --
On 06/02/16 22:23, Ksenija Stanojevic wrote:
> Move mxs-lradc driver from drivers/staging/iio/adc to drivers/iio/adc.
>
> Signed-off-by: Ksenija Stanojevic
Given the input elements in here, cc'ing linux-input and Dmitry.
Will probably be the weekend before I get a chance to look at this.
Jonath
On Sun, Feb 07, 2016 at 02:14:56PM -0800, Greg Kroah-Hartman wrote:
> On Sun, Nov 22, 2015 at 10:30:55PM +0530, Sudip Mukherjee wrote:
> > We were returning ENOMEM on all types of errors. Lets return the actual
> > error code. At the same time remove the label which became unused as a
> > result of
We were returning ENOMEM on all types of errors. Lets return the actual
error code. At the same time remove the label which became unused as a
result of this patch.
Signed-off-by: Sudip Mukherjee
---
v1 failed to apply due to some other changes.
drivers/staging/most/mostcore/core.c | 27 ++
On error we were returning retval, but retval is not having the error
value. We will get the error value using PTR_ERR.
Signed-off-by: Sudip Mukherjee
---
v2: sent after rebasing
drivers/staging/most/aim-cdev/cdev.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/driver
On Sun, Feb 07, 2016 at 02:04:21PM -0800, Greg Kroah-Hartman wrote:
> On Tue, Dec 01, 2015 at 04:22:33PM +0530, Sudip Mukherjee wrote:
> > The success path and the error path both are first doing
> > spin_unlock_irqrestore() before returning. Use that in the common path
> > and return the success/e
On Mon, Feb 08, 2016 at 10:41:52AM -0500, Benjamin Romer wrote:
> From: Erik Arfvidson
>
> This patch fixes the following types of check patch warnings:
> else is not generally useful after a break or return
>
> Signed-off-by: Erik Arfvidson
> Signed-off-by: Benjamin Romer
>
> ---
> v2: the p
From: Erik Arfvidson
This patch fixes the following types of check patch warnings:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
parser_param_start() had a goto Away, which went to nothing but
a return statement. Remove the goto, the CamelCased label, and
just return directly.
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
---
drivers/staging/unisys/visorbus/visorchipset.c | 6 ++-
From: Erik Arfvidson
This patch simply fixes all trailing */ by modifying the comments
structures while trying to reduce the total number of lines
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
---
drivers/staging/unisys/
From: Erik Arfvidson
This patch fixes the following checkpatch warning:
spaces preferred around that ‘*’ or ‘|’
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: address Sudip's comment about a change being made to a NULL comparison
that should
From: Erik Arfvidson
This patch fixes checkpatch's no space is necessary after a cast
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
---
drivers/staging/unisys/visorbus/visorchipset.c | 6 +++---
1 file changed, 3 inserti
From: Erik Arfvidson
This patch fixes the following type of check patch warnings:
Comparison to NULL could be written
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: address a comment from Sudip about a change to a NULL comparison that
was ma
From: Erik Arfvidson
This patches resolves the NULL comparison checkpatch warnings
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
---
drivers/staging/unisys/visorbus/vbusdeviceinfo.h | 4 ++--
1 file changed, 2 insertions
From: Erik Arfvidson
This patch fixes all the Block comments by using a trailing */
on a separate line
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
---
drivers/staging/unisys/visorbus/visorchipset.c | 16 ++-
From: Erik Arfvidson
This patch fixes the following types of check patch warnings:
Block comments use a trailing */ on a separate line
Comment alignments
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
---
From: Erik Arfvidson
This patch fixes the following types of check patch warnings:
Block comments use * on subsequent lines
Block comments use a trailing */ on a separate line
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the pa
From: Erik Arfvidson
This patch fixes the following types of check patch warnings:
else is not generally useful after a break or return
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
---
drivers/staging/unisys/visornic/vi
From: Erik Arfvidson
Fixes checkpatch trailing */ comment in vbusdeviceinfo.h
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
---
drivers/staging/unisys/visorbus/vbusdeviceinfo.h | 3 ++-
1 file changed, 2 insertions(+), 1
From: Erik Arfvidson
This patch simply cleans up all checkpatch comment issues
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
---
drivers/staging/unisys/include/guestlinuxdebug.h | 13 +++--
1 file changed, 7 inse
From: Erik Arfvidson
this patch removes the following checkpatch warnings:
please use a blank line after …
Please don’t use multiple blank lines
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
---
v2: the patch was rebased.
v3: the patch was rebased.
---
drivers/s
This patch series cleans up all of the remaining checkpatch.pl issues in
the Unisys driver tree. The changes made were:
- The entire patch series has been rebased.
- A patch making parenthesis alignment changes to visornic_main.c was
dropped from the series, because the original code was accepta
On Mon, Feb 8, 2016 at 11:14 AM, Lars-Peter Clausen wrote:
> On 02/08/2016 07:48 AM, Bhumika Goyal wrote:
>> value = (s8)((data >> AD7816_TEMP_FLOAT_OFFSET) - 103);
>> data &= AD7816_TEMP_FLOAT_MASK;
>> if (value < 0)
>> - data = (1 <<
On Sun, 2016-02-07 at 14:03 -0800, Greg KH wrote:
> On Fri, Jan 29, 2016 at 10:21:26AM -0500, Benjamin Romer wrote:
> > This patch series cleans up all the remaining issues reported by
> > checkpatch.pl that can be fixed. The series was rebased against
> > the current contents of staging-next.
>
>
On 02/08/2016 07:48 AM, Bhumika Goyal wrote:
> This patch replaces bit shifting on 1 with the BIT(x) macro.
>
> This was done with coccinelle:
>
> @@ int g; @@
>
> -(1 << g)
> +BIT(g)
>
> Signed-off-by: Bhumika Goyal
Hi,
Thanks for the patch. This looks good.
> ---
> drivers/staging/iio/ad
On 02/08/2016 11:23 AM, Andrey Utkin wrote:
> On Mon, Feb 8, 2016 at 11:58 AM, Hans Verkuil wrote:
>> Hi Andrey,
>>
>> Hmm, it looks like I forgot to reply. Sorry about that.
>
> Thank you very much anyway.
>
>> I wouldn't change the memcpy: in my experience it is very useful to get a
>> well-fo
On Mon, Feb 8, 2016 at 11:58 AM, Hans Verkuil wrote:
> Hi Andrey,
>
> Hmm, it looks like I forgot to reply. Sorry about that.
Thank you very much anyway.
> I wouldn't change the memcpy: in my experience it is very useful to get a
> well-formed compressed stream out of the hardware. And the overh
Hi Andrey,
Hmm, it looks like I forgot to reply. Sorry about that.
On 01/15/2016 03:13 AM, Andrey Utkin wrote:
> On Mon, Jan 11, 2016 at 12:52 PM, Hans Verkuil wrote:
>> Did you also test with v4l2-compliance? Before I accept the driver I want to
>> see the
>> output of 'v4l2-compliance' and 'v
On 02/08/2016 07:48 AM, Bhumika Goyal wrote:
> This patch replaces bit shifting on 1 with the BIT(x) macro.
> This was done with coccinelle:
> @@ int g; @@
> -(1 << g)
> +BIT(g)
>
> Signed-off-by: Bhumika Goyal
Hi,
Thanks for the patch.
> ---
> drivers/staging/iio/adc/ad7816.c | 2 +-
> 1 fi
On Wed, Feb 03, 2016 at 03:39:22PM +0100, Maarten Lankhorst wrote:
> Op 03-02-16 om 14:25 schreef Gustavo Padovan:
> > From: Gustavo Padovan
> >
> > Turn sync_fence_info into __u64 type enable us to extend the struct in the
> > future without breaking the ABI.
> >
> > v2: use type __u64 for fence_
Hello John L. Hammond,
The patch f833ea10c7bb: "staging/lustre/obdecho: remove userspace LSM
handling" from Jan 3, 2016, leads to the following static checker
warning:
drivers/staging/lustre/lustre/obdecho/echo_client.c:1225
echo_create_object()
warn: we tested 'oa->o_valid & (1)
Dear Greg,
Greg Kroah-Hartman wrote:
On Wed, Dec 02, 2015 at 10:54:00PM +0100, Luca Ceresoli wrote:
Fix checkpatch issue:
CHECK: spaces preferred around that '*' (ctx:VxV)
Signed-off-by: Luca Ceresoli
Cc: Larry Finger
Cc: Greg Kroah-Hartman
Odd, I don't think I've ever used gre...@linu
54 matches
Mail list logo