On Saturday, January 30, 2016 05:41:10 PM Dan Carpenter wrote:
> ->KeyMaterial is declared as a 16 byte array, but we only ever allocate
> either 5 or 13 bytes of it. The problem is that we memset() all 16
> bytes to zero so we're memsetting past the end of the allocated memory.
>
> I fixed this
On Sat, 2016-01-30 at 18:12 +0300, Dan Carpenter wrote:
> We could make checkpatch.pl not complain if the line says checkpatch:
> on
> it. It would look like this.
>
> - in_voltage-voltage_thresh_low_value,
> + in_voltage-voltage_thresh_low_value, /* checkpatch:
> not
From: madiraju
Removed unnecessary spaces to match coding style.
Signed-off-by: Santosh Madiraju
---
drivers/staging/xgifb/XGI_main_26.c | 22 ++
1 file changed, 6 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/xgifb/XGI_main_26.c
b/drivers/staging/xgifb/XGI
This patch fixes the checkpatch.pl issue:
CHECK: Please use a blank line after function/struct/union/enum declarations
Signed-off-by: SirnamSwetha
---
drivers/staging/clocking-wizard/clk-xlnx-clock-wizard.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/clocking-wizard/clk-
This patch fixes the checkpatch.pl issue:
CHECK: Avoid CamelCase:
CHECK: Avoid CamelCase:
Signed-off-by: SirnamSwetha
---
drivers/staging/clocking-wizard/clk-xlnx-clock-wizard.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/clocking-wizard/clk-xl
Hi Gustavo,
> @@ -54,6 +59,7 @@ struct sync_file_info {
> __u32 len;
As mentioned previously - can we rework this variable to indicate the
total length (or the number) of fence_info struct instances. It seems
to be the more common approach afaict. Might also want to move it just
above th
Hi Gustavo,
s/__64/__u64/ in the commit message.
On 29 January 2016 at 23:20, Gustavo Padovan wrote:
> From: Gustavo Padovan
>
> Making fence_info a pointer enables us to extend the struct in the future
> without breaking the ABI.
>
> Signed-off-by: Gustavo Padovan
> diff --git a/drivers/stag
On 26/01/16 10:59, Geert Uytterhoeven wrote:
> On Mon, Jan 25, 2016 at 11:24 PM, Richard Weinberger wrote:
>> Not every arch has io memory.
>> So, unbreak the build by fixing the dependencies.
>>
>> Signed-off-by: Richard Weinberger
>
> Acked-by: Geert Uytterhoeven
Applied to the same obscure b
On 01/30/2016 04:12 PM, Dan Carpenter wrote:
> We could make checkpatch.pl not complain if the line says checkpatch: on
> it. It would look like this.
>
> - in_voltage-voltage_thresh_low_value,
> + in_voltage-voltage_thresh_low_value, /* checkpatch: not math
> */
>
>
We could make checkpatch.pl not complain if the line says checkpatch: on
it. It would look like this.
- in_voltage-voltage_thresh_low_value,
+ in_voltage-voltage_thresh_low_value, /* checkpatch: not math */
I suppose I could have made the explanation longer since the
On 01/30/2016 03:18 PM, Jonathan Cameron wrote:
> On 25/01/16 15:50, Arnd Bergmann wrote:
>> The ad5933_i2c_read function returns an error code to indicate
>> whether it could read data or not. However ad5933_work() ignores
>> this return code and just accesses the data unconditionally,
>> which ge
Calling synchronize_irq() right before free_irq() is quite useless. On one
hand the IRQ can easily fire again before free_irq() is entered, on the
other hand free_irq() itself calls synchronize_irq() internally (in a race
condition free way), before any state associated with the IRQ is freed.
Patc
->KeyMaterial is declared as a 16 byte array, but we only ever allocate
either 5 or 13 bytes of it. The problem is that we memset() all 16
bytes to zero so we're memsetting past the end of the allocated memory.
I fixed this in slightly lazy way, by just allocating 16 bytes. This
works but there
On 25/01/16 15:52, Arnd Bergmann wrote:
> The ade7753_spi_read_reg_16() will either successfully read a value
> from SPI, or return a failure code without delivering data. However,
> the ade7753_stop_device() and ade7753_reset() functions use the returned
> data without checking for an error condit
On 25/01/16 15:50, Arnd Bergmann wrote:
> The ad5933_i2c_read function returns an error code to indicate
> whether it could read data or not. However ad5933_work() ignores
> this return code and just accesses the data unconditionally,
> which gets detected by gcc as a possible bug:
>
> drivers/sta
On 24/01/16 17:14, Lars-Peter Clausen wrote:
> On 01/24/2016 05:36 PM, Jonathan Cameron wrote:
>> On 20/01/16 14:21, Dan Carpenter wrote:
>>> On Fri, Jan 15, 2016 at 09:15:52PM +0100, Lars-Peter Clausen wrote:
On 01/15/2016 08:42 PM, Bhumika Goyal wrote:
> This patch adds apace around '-'
On Sat, 2016-01-30 at 23:02 +1100, Julian Calaby wrote:
> Hi Bhakti,
>
> On Sat, Jan 30, 2016 at 5:53 PM, Bhakti Priya wrote:
> > Hi,
> >
> > Thank you for your reply. I've just sent version 2 of the patch with
> > the blank lines removed.
> > I will be happy to extend checkpatch.pl. As suggeste
Hi Bhakti,
On Sat, Jan 30, 2016 at 5:53 PM, Bhakti Priya wrote:
> Hi,
>
> Thank you for your reply. I've just sent version 2 of the patch with
> the blank lines removed.
> I will be happy to extend checkpatch.pl. As suggested by you, I am
> trying to detect such blank lines in a line removal patc
On Sat, Jan 30, 2016 at 4:57 PM, Bhaktipriya Shridhar
wrote:
> This patch fixes checkpatch.pl warning in rtw_mlme_ext.c file.
> WARNING: void function return statements are not generally useful
>
> Signed-off-by: Bhaktipriya Shridhar
Looks sane to me.
Reviewed-by: Julian Calaby
> ---
> Chang
19 matches
Mail list logo