> From: Olaf Hering [mailto:o...@aepfle.de]
> Sent: Tuesday, January 26, 2016 18:24
> To: Dexuan Cui
> Cc: gre...@linuxfoundation.org; da...@davemloft.net;
> step...@networkplumber.org; net...@vger.kernel.org; linux-
> ker...@vger.kernel.org; driverdev-devel@linuxdriverproject.org;
> a...@canonica
From: Leo Kim
This patch fixes the warning reported by smatch.
- wilc_wlan_get_firmware() warn: variable dereferenced before check 'vif'
- wilc_set_multicast_list() warn: variable dereferenced before check 'dev'
Just delete them and no need add null check since they are net_device from
ndo_set
From: Leo Kim
This patches replaces PRINT_XXX with netdev_xxx.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan.c | 100 +-
1 file changed, 49 insertions(+), 51 deletions(-)
diff --git a/drivers/staging/wilc1000/linux_wlan
From: Leo Kim
This patch renames u8IfIdx variable of wilc_vif structure to idx
to avoid camelcase.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/host_interface.c | 2 +-
drivers/staging/wilc1000/linux_wlan.c | 8
drivers/staging/wilc1
From: Leo Kim
This patch removes the warnings reported by checkpatch.pl
for line over 80 characters.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wilc1000/linu
From: Leo Kim
This patch renames hWILCWFIDrv pointer variable of wilc_priv structure
to hif_drv to avoid camelcase.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan.c | 8
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 22 ++
From: Leo Kim
This patch fixes the checks reported by checkpatch.pl
for spaces required around that '=' or '||' or '('.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/stag
From: Leo Kim
This patch removes unnecessary debug logs.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan.c | 154 ++
1 file changed, 24 insertions(+), 130 deletions(-)
diff --git a/drivers/staging/wilc1000/linux_wlan.c
b
From: Leo Kim
This patch fixes the warnings reported by checkpatch.pl
for Missing a blank line after declarations.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/staging/wilc1000/linux_wlan
From: Leo Kim
This patch removes the warning reported by checkpatch.pl
for void function return statements are not generally useful.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/wi
From: Leo Kim
This patch renames pBssid variable of tx_complete_data structure to bssid
to avoid camelcase.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan.c | 2 +-
drivers/staging/wilc1000/wilc_wlan.c| 2 +-
drivers/staging/wilc1000/wilc_wlan_if.
From: Leo Kim
This patch renames Firmware_ver variable to firmware_ver to avoid camelcase.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan.c | 15 ---
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/wilc1000/linu
From: Leo Kim
This patch fixes the check reported by checkpatch.pl
for 'no space is necessary after a cast'.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/li
From: Leo Kim
Null checking wilc_netdev and skb->dev are already done in the begining of the
function and they are just print printing error log, so delete them.
Null checking wilc is needed before is used so add null ckeck before it is
used.
Signed-off-by: Leo Kim
Signed-off-by: Glen Lee
---
This is a patch to the sync_debug.c file that rectifies a brace warning
that was found with the checkpatch.pl tool
Signed-off-by: Bopamo Osaisai
---
drivers/staging/android/sync_debug.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/android/sync_debug.c
b/
On Tue, Jan 26, 2016 at 07:31:01PM +0300, Alexey Mednyy wrote:
> Signed-off-by: Alexey Mednyy
> ---
> drivers/staging/fbtft/Kconfig | 6 ++
> drivers/staging/fbtft/Makefile | 1 +
> drivers/staging/fbtft/fb_ssd1305.c | 216
> +
> 3 files changed,
On Tue, Jan 26, 2016 at 07:31:16PM +0300, Alexey Mednyy wrote:
> Signed-off-by: Alexey Mednyy
Why?
I can't take patches without any changelog entries, sorry, we need some
more information here about what this is, why it's being submitted, etc.
thanks,
greg k-h
_
2016-01-26 Gustavo Padovan :
> From: Gustavo Padovan
>
> De-stage the remaining bit of sync framework: sync_timeline and sw_sync
> plus some debugging routines.
>
> Signed-off-by: Gustavo Padovan
> ---
> drivers/dma-buf/Kconfig| 10 +
> drivers/dma-buf/Makefile
On Mon, 2016-01-25 at 20:22 +, Hugo Camboulive wrote:
> alloc_etherdev() calls alloc_netdev_mqs(), which
> already uses kzalloc/vzalloc.
>
> This clears a sparse warning :
> drivers/staging/unisys/visornic/visornic_main.c:1366:15: warning:
> memset with byte count of 1460112
>
> Signed-off-by
Hi Boris,
On Mon, Dec 07, 2015 at 11:25:55PM +0100, Boris Brezillon wrote:
> Hello,
>
> This patchset aims at getting rid of the nand_ecclayout limitations.
> struct nand_ecclayout is defining fixed eccpos and oobfree arrays which
> can only be increased by modifying the MTD_MAX_ECCPOS_ENTRIES_LA
Here is what I get when I cat this patch to checkpatch.
$ cat email.txt | ~/kernel_src/scripts/checkpatch.pl -
WARNING: please write a paragraph that describes the config symbol fully
#24: FILE: drivers/staging/fbtft/Kconfig:120:
+config FB_TFT_SSD1305
WARNING: added, moved or deleted file(s), d
From: Gustavo Padovan
Move drv_name, the last field of sync_timeline_ops, to sync_timeline
and remove sync_timeline_ops.
struct sync_timeline_ops was just an extra abstraction on top of
fence_ops, and in the last few commits we removed all it ops in favor
of cleaner fence_ops.
Signed-off-by: Gu
From: Gustavo Padovan
De-stage the remaining bit of sync framework: sync_timeline and sw_sync
plus some debugging routines.
Signed-off-by: Gustavo Padovan
---
drivers/dma-buf/Kconfig| 10 +
drivers/dma-buf/Makefile | 3 +-
drivers/dma-buf/sw_sync.h
From: Gustavo Padovan
As we moved value storage to sync_timeline and fence those two structs
became useless and can be removed now.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sw_sync.c| 24 +++-
drivers/staging/android/sw_sync.h| 24 ++---
From: Gustavo Padovan
Enable reports of sync_files through /sync/info
Signed-off-by: Gustavo Padovan
---
drivers/dma-buf/sync_file.c | 7 +++
1 file changed, 7 insertions(+)
diff --git a/drivers/dma-buf/sync_file.c b/drivers/dma-buf/sync_file.c
index 92474dd..aa1215d 100644
--- a/drivers/
From: Gustavo Padovan
During the de-stage of sync framework it was easy to keep sync_dump() out
to avoid an early de-stage of all debug code, but now that sync_debug.c
was de-staged bring sync_dump() back.
Signed-off-by: Gustavo Padovan
---
drivers/dma-buf/sync_file.c | 8 ++--
1 file chan
From: Gustavo Padovan
We can glue the sw_sync file operations directly on the sync framework
without the need to pass through sw_sync wrappers.
It only builds sw_sync debugfs file support if CONFIG_SW_SYNC is enabled.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/Makefile |
From: Gustavo Padovan
We are moving out of staging/adroid so rename it to a name that is not
related to android anymore.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sync.c | 40
1 file changed, 20 insertions(+), 20 deletions(-)
diff --gi
From: Gustavo Padovan
Now fence timeline is aware of the last signaled fence, as it
receives the increment to the current value in sync_timeline_signal().
That allow us to remove .has_signaled() from timeline_ops as we can
directly compare using timeline->value and fence->seqno in sync.c
Signed
From: Gustavo Padovan
sync_file is useful to connect one or more fences to the file. The file is
used by userspace to track fences.
Signed-off-by: Gustavo Padovan
---
drivers/Kconfig | 2 +
drivers/dma-buf/Kconfig | 11 +
drivers/dma-buf/Makefile
From: Gustavo Padovan
Now that the value of fence and the timeline are not stored by sw_sync
anymore we can remove this extra abstraction to retrieve this data.
This patch changes both fence_ops (.fence_value_str and
.timeline_value_str) to return the str directly.
It also clean up struct sync_
From: Gustavo Padovan
The .fill_driver_data() ops was just a useless abstraction for
fence_ops op of the same name.
Now that we use fence->seqno to store the value it is cleaner to
remove the abstraction and fill the data directly.
Signed-off-by: Gustavo Padovan
---
drivers/staging/android/sw
From: Gustavo Padovan
This patch series de-stage the sync framework and it a follow up on the
clean up series I've sent last week:
http://thread.gmane.org/gmane.comp.video.dri.devel/145509
Now in part 2 we finish the de
Hello.
On 24/01/16 14:18, Herbert Xu wrote:
This patch replaces uses of blkcipher with skcipher.
Signed-off-by: Herbert Xu
---
net/mac802154/llsec.c | 41 +++--
net/mac802154/llsec.h |3 +--
2 files changed, 24 insertions(+), 20 deletions(-)
Signed-off-by: Alexey Mednyy
---
drivers/staging/fbtft/Kconfig | 6 ++
drivers/staging/fbtft/Makefile | 1 +
drivers/staging/fbtft/fb_ssd1325.c | 205 +
3 files changed, 212 insertions(+)
create mode 100644 drivers/staging/fbtft/fb_ssd1325.c
diff
Signed-off-by: Alexey Mednyy
---
drivers/staging/fbtft/Kconfig | 6 ++
drivers/staging/fbtft/Makefile | 1 +
drivers/staging/fbtft/fb_ssd1305.c | 216 +
3 files changed, 223 insertions(+)
create mode 100644 drivers/staging/fbtft/fb_ssd1305.c
diff
On 01/26/2016 05:09 PM, Dan Carpenter wrote:
Same stuff. Run checkpatch.pl.
+ gpio_set_value(par->gpio.dc, 1);
+ /* Write data */
+
+ ret =
+ par->fbtftops.write(par, par->txbuf.buf,
+ par->info->var.xres * par->info->var.yres / 2
On 01/26/2016 05:00 PM, Dan Carpenter wrote:
The subject should be:
[PATCH] Staging: fbtft: added ssd1305 controller support
On Tue, Jan 26, 2016 at 04:07:24PM +0300, Alexey Mednyy wrote:
Signed-off-by: Alexey Mednyy
---
drivers/staging/fbtft/Kconfig | 6 +
drivers/staging/fbtft/M
Same stuff. Run checkpatch.pl.
> + gpio_set_value(par->gpio.dc, 1);
> + /* Write data */
> +
> + ret =
> + par->fbtftops.write(par, par->txbuf.buf,
> + par->info->var.xres * par->info->var.yres / 2);
Clean that line.
> +static struct fbtft_dis
The subject should be:
[PATCH] Staging: fbtft: added ssd1305 controller support
On Tue, Jan 26, 2016 at 04:07:24PM +0300, Alexey Mednyy wrote:
> Signed-off-by: Alexey Mednyy
> ---
> drivers/staging/fbtft/Kconfig | 6 +
> drivers/staging/fbtft/Makefile | 1 +
> drivers/staging/fbtf
Signed-off-by: Alexey Mednyy
---
drivers/staging/fbtft/Kconfig | 6 +
drivers/staging/fbtft/Makefile | 1 +
drivers/staging/fbtft/fb_ssd1325.c | 266 +
3 files changed, 273 insertions(+)
create mode 100644 drivers/staging/fbtft/fb_ssd1325.c
diff
Signed-off-by: Alexey Mednyy
---
drivers/staging/fbtft/Kconfig | 6 +
drivers/staging/fbtft/Makefile | 1 +
drivers/staging/fbtft/fb_ssd1305.c | 271 +
3 files changed, 278 insertions(+)
create mode 100644 drivers/staging/fbtft/fb_ssd1305.c
diff
On Tue, Jan 26, 2016 at 12:29:57PM +0100, Ilya Dryomov wrote:
>
> LGTM. You want to take it through crypto?
That's probably the easiest route since I'd like to take the first
patch through cryptodev.
Thanks,
--
Email: Herbert Xu
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://g
On Tue, Jan 26, 2016 at 11:54 AM, Herbert Xu
wrote:
> On Mon, Jan 25, 2016 at 05:18:47PM +0100, Ilya Dryomov wrote:
>>
>> Could you get rid of ivsize instead of assigning to it - see the
>> attached diff?
>
> How about an incremental patch like this? Thanks!
>
> ---8<---
> From: Ilya Dryomov
> Su
On Mon, Jan 25, 2016 at 11:24 PM, Richard Weinberger wrote:
> Not every arch has io memory.
> So, unbreak the build by fixing the dependencies.
>
> Signed-off-by: Richard Weinberger
Acked-by: Geert Uytterhoeven
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's
On Mon, Jan 25, 2016 at 05:18:47PM +0100, Ilya Dryomov wrote:
>
> Could you get rid of ivsize instead of assigning to it - see the
> attached diff?
How about an incremental patch like this? Thanks!
---8<---
From: Ilya Dryomov
Subject: libceph: Remove unnecessary ivsize variables
This patch rem
On Tue, Jan 26, Dexuan Cui wrote:
> +#define AF_MAX 42 /* For now.. */
Maybe net/core/sock.c needs additional strings for the new socket?
Olaf
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.or
This patch fixes the check found by checkpatch.pl
CHECK: Alignment should match open parenthesis
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/host_interface.c | 90 +++
1 file changed, 45 insertions(+), 45 deletions(-)
diff --git a/drivers/staging/wilc100
Hyper-V socket (hvsock) supplies a byte-stream based communication
mechanism between the host and a guest. It's kind of like TCP over VMBus,
but the transportation layer (VMBus) is much simpler than IP. With
Hyper-V Socket, applications between the host and a guest can talk
to each other directly b
A function to send the type of message is also added.
The coming net/hvsock driver will use this function to proactively request
the host to offer a VMBus channel for a new hvsock connection.
Signed-off-by: Dexuan Cui
---
drivers/hv/channel.c | 15 +++
drivers/hv/channel_mgmt.c
The hvsock driver needs this API to release all the resources related
to the channel.
Signed-off-by: Dexuan Cui
---
drivers/hv/channel_mgmt.c | 33 -
drivers/hv/connection.c | 4 ++--
include/linux/hyperv.h| 2 ++
3 files changed, 32 insertions(+), 7 delet
This will be used by the coming hv_sock driver.
Signed-off-by: Dexuan Cui
---
drivers/hv/channel_mgmt.c | 11 +++
include/linux/hyperv.h| 9 +
2 files changed, 20 insertions(+)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/channel_mgmt.c
index 4611b50..b782944 100644
Only the coming hv_sock driver has a "true" value for this flag.
We treat the hvsock offers/channels as special VMBus devices.
Since the hv_sock driver handles all the hvsock offers/channels, we need to
tweak vmbus_match() for hv_sock driver, so we introduce this flag.
Signed-off-by: Dexuan Cui
When the hvsock channel's outbound ringbuffer is full (i.e.,
hv_ringbuffer_write() returns -EAGAIN), we should avoid the unnecessary
signaling the host.
Signed-off-by: Dexuan Cui
---
drivers/hv/channel.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/drivers/hv/channel.
A helper function is also added.
Signed-off-by: Dexuan Cui
---
include/linux/hyperv.h | 7 +++
1 file changed, 7 insertions(+)
diff --git a/include/linux/hyperv.h b/include/linux/hyperv.h
index e4867a7..c0eddd7 100644
--- a/include/linux/hyperv.h
+++ b/include/linux/hyperv.h
@@ -235,6 +235,
This will be used by the coming net/hvsock driver.
Signed-off-by: Dexuan Cui
---
include/linux/hyperv.h | 6 ++
1 file changed, 6 insertions(+)
diff --git a/include/linux/hyperv.h b/include/linux/hyperv.h
index 753dbad..e4867a7 100644
--- a/include/linux/hyperv.h
+++ b/include/linux/hyperv.
Changes since v1:
- updated "[PATCH 6/7] hvsock: introduce Hyper-V VM Sockets feature"
- added __init and __exit for the module init/exit functions
- net/hv_sock/Kconfig: "default m" -> "default m if HYPERV"
- MODULE_LICENSE: "Dual MIT/GPL" -> "Dual BSD/GPL"
Changes since v2:
- fixed various codi
57 matches
Mail list logo