[PATCH] staging: lustre: fix comment style

2016-01-17 Thread Sushuruth Sadagopan
Fix style of several comments. Signed-off-by: Sushuruth Sadagopan --- drivers/staging/lustre/lnet/lnet/config.c | 18 -- 1 file changed, 12 insertions(+), 6 deletions(-) diff --git a/drivers/staging/lustre/lnet/lnet/config.c b/drivers/staging/lustre/lnet/lnet/config.c index 284

Re: [PATCH] staging: ion: make the pte default none PTE_RDONLY

2016-01-17 Thread chenfeng
On 2016/1/16 7:23, Russell King - ARM Linux wrote: > On Fri, Jan 15, 2016 at 03:03:42PM -0800, Laura Abbott wrote: >> (adding linux-arm and a few people) >> >> On 01/14/2016 06:42 PM, Chen Feng wrote: >>> The page is already alloc at ion_alloc function, >>> ion_mmap map the alloced pages to user-

[PATCH] Staging: panel: fix the checkpatch issue

2016-01-17 Thread SirnamSwetha
Fix checkpatch.pl issue: WARNING: line over 80 characters CHECK: No space is necessary after a cast Signed-off-by: SirnamSwetha --- drivers/staging/panel/panel.c | 7 --- 1 file changed, 4 insertions(+), 3 deletions(-) diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/pan

[PATCH RESEND 17/18] staging: sm750fb: use BIT macro for POWER_MODE_CTRL single-bit fields

2016-01-17 Thread Mike Rapoport
Replace complex definition of POWER_MODE_CTRL register fields with BIT() macro and use open-coded implementation for register manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_power.c | 10 -- drivers/staging/sm750fb/ddk750_reg.h | 12 +++- 2 files

[PATCH RESEND 18/18] staging: sm750fb: change definition of POWER_MODE_CTRL multi-bit field

2016-01-17 Thread Mike Rapoport
Use more straight-forward definitions for multi-bit field of POWER_MODE_CTRL register and use open-coded implementation for register manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_power.c | 13 + drivers/staging/sm750fb/ddk750_reg.h | 8 2

[PATCH RESEND 12/18] staging: sm750fb: use BIT macro for CURRENT_GATE single-bit fields

2016-01-17 Thread Mike Rapoport
Replace complex definition of CURRENT_GATE register fields with BIT() macro and use open-coded implementation for register manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 3 +-- drivers/staging/sm750fb/ddk750_power.c | 18 +++--- drivers/staging/

[PATCH RESEND 14/18] staging: sm750fb: change definition of CURRENT_GATE multi-bit fields

2016-01-17 Thread Mike Rapoport
Use more straight-forward definitions for multi-bit fields of CURRENT_GATE register and use open-coded implementation for register manipulation. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 20 +-- drivers/staging/sm750fb/ddk750_reg.h | 36 +++

[PATCH RESEND 16/18] staging: sm750fb: change definition of MODE0_GATE multi-bit fields

2016-01-17 Thread Mike Rapoport
Use more straight-forward definitions for multi-bit fields of MODE0_GATE register. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_reg.h b/drivers/stag

[PATCH RESEND 10/18] staging: sm750fb: use BIT macro for GPIO_MUX single-bit fields

2016-01-17 Thread Mike Rapoport
Replace complex definition of GPIO_MUX register fields with BIT() macro and use open-coded implementation for register manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_hwi2c.c | 7 +- drivers/staging/sm750fb/ddk750_reg.h | 128 +

[PATCH RESEND 13/18] staging: sm750fb: set{Memory, Master}Clock: rename ulReg to reg

2016-01-17 Thread Mike Rapoport
Remove HungarianCamelCase notation Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 28 ++-- 1 file changed, 14 insertions(+), 14 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_chip.c b/drivers/staging/sm750fb/ddk750_chip.c index b11231

[PATCH RESEND 15/18] staging: sm750fb: use BIT macro for MODE0_GATE single-bit fields

2016-01-17 Thread Mike Rapoport
Replace complex definition of MODE0_GATE register fields with BIT() macro and use open-coded implementation for register manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 2 +- drivers/staging/sm750fb/ddk750_reg.h | 44 +--

[PATCH RESEND 07/18] staging: sm750fb: ddk750_initHw: rename ulReg to reg

2016-01-17 Thread Mike Rapoport
Remove HungarianCamelCase notation Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 52 +-- 1 file changed, 26 insertions(+), 26 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_chip.c b/drivers/staging/sm750fb/ddk750_chip.c index

[PATCH RESEND 00/18] staging: sm750fb: change some register fields defines

2016-01-17 Thread Mike Rapoport
Hi, This is the first set of patches that aim to replace custom defines for register fields. The ultimate goal is to have MSB:LSB notation for register fields and FIELD_* macros removed. Mike Rapoport (18): staging: sm750fb: hw_sm750(le)_deWait: rename dwVal to val staging: sm750fb: use BIT

[PATCH RESEND 02/18] staging: sm750fb: use BIT macro for DE_STATE1 single-bit field

2016-01-17 Thread Mike Rapoport
Replace complex definition of DE_STATE1 field and usage of FIELD_SET with BIT() macro and open-coded register value modifications Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 4 +--- drivers/staging/sm750fb/sm750_hw.c | 4 ++-- 2 files changed, 3 insertions(+), 5 del

[PATCH RESEND 11/18] staging: sm750fb: change definition of MISC_CTRL multi-bit fields

2016-01-17 Thread Mike Rapoport
Use more straight-forward definitions for multi-bit fields of MISC_CTRL register and use open-coded implementation for register manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 2 +- drivers/staging/sm750fb/ddk750_reg.h | 28 ++--

[PATCH RESEND 09/18] staging: sm750fb: ddk750_sii164: fix defines for i2c{Read, Write}reg

2016-01-17 Thread Mike Rapoport
For case when USE_HW_I2C is not defined, i2c{Read,Write}reg was wrongly defined to use old function names. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_sii164.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_sii164.c b/d

[PATCH RESEND 06/18] staging: sm750fb: change definition of SYSTEM_CTRL multi-bit fields

2016-01-17 Thread Mike Rapoport
Use more straight-forward definitions for multi-bit fields of SYSTEM_CTRL register and replace FIELD_GET/SET for these fields with open-coded implementation. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_power.c | 2 +- drivers/staging/sm750fb/ddk750_reg.h | 20 ++---

[PATCH RESEND 03/18] staging: sm750fb: use BIT macro for DE_STATE2 single-bit fields

2016-01-17 Thread Mike Rapoport
Replace complex definition of DE_STATE1 fields and usage of FIELD_GET with BIT() macro and open-coded register value modifications Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 12 +++- drivers/staging/sm750fb/sm750_hw.c | 8 2 files changed, 7 inser

[PATCH RESEND 08/18] staging: sm750fb: use BIT macro for MISC_CTRL single-bit fields

2016-01-17 Thread Mike Rapoport
Replace complex definition of MISC_CTRL register fields with BIT() macro and use open-coded implementation for register manipulations. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 4 +- drivers/staging/sm750fb/ddk750_power.h | 11 ++ drivers/staging/sm750fb/ddk7

[PATCH RESEND 01/18] staging: sm750fb: hw_sm750(le)_deWait: rename dwVal to val

2016-01-17 Thread Mike Rapoport
Remove HungarianCamelCase notation Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/sm750_hw.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/staging/sm750fb/sm750_hw.c b/drivers/staging/sm750fb/sm750_hw.c index 41822c6..f9908d9 100644 --- a

[PATCH RESEND 04/18] staging: sm750fb: remove unused DE_STATE2_DE_RESERVED

2016-01-17 Thread Mike Rapoport
Definition of reserved fields in a register is not interesting Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_reg.h | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_reg.h b/drivers/staging/sm750fb/ddk750_reg.h index db13bdf..38ebe95 100644 --

[PATCH RESEND 05/18] staging: sm750fb: use BIT macro for SYSTEM_CTRL single-bit fields

2016-01-17 Thread Mike Rapoport
Replace complex definition of SYSTEM_CTRL fields and usage of FIELD_GET/SET with BIT() macro and open-coded register value modifications Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_display.c | 24 -- drivers/staging/sm750fb/ddk750_reg.h | 76 --

[PATCH RESEND v4 5/7] staging: sm750fb: introduce sm750fb_frambuffer_release

2016-01-17 Thread Mike Rapoport
Use a function to unregister framebuffer info and release its resources. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/sm750.c | 25 + 1 file changed, 13 insertions(+), 12 deletions(-) diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm75

[PATCH RESEND v4 7/7] staging: sm750fb: lynxfb_pci_probe: remove some pr_info

2016-01-17 Thread Mike Rapoport
Several pr_info statements in lynxfb_pci_probe seem like debug leftovers and may be removed. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/sm750.c | 8 1 file changed, 8 deletions(-) diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c index c33c7ff

[PATCH RESEND v4 6/7] staging: sm750fb: introduce sm750fb_frambuffer_alloc

2016-01-17 Thread Mike Rapoport
Split framebuffer allocation and registration into a dedicated function to simplify lynxfb_pci_probe Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/sm750.c | 98 + 1 file changed, 41 insertions(+), 57 deletions(-) diff --git a/drivers/staging/sm

[PATCH RESEND v4 0/7] staging: sm750fb: refactor lynxfb_pci_probe

2016-01-17 Thread Mike Rapoport
Hi, These patches refactor the lynxfb_pci_probe. v4 changes: * address Dan's comments v3 changes: * rebased on current Greg's staging-testing v2 changes: * add pci_disable_device on the cleanup path * return actual error rather than ENODEV Mike Rapoport (7): staging: sm750fb: disable PCI dev

[PATCH RESEND v4 3/7] staging: sm750fb: lynxfb_pci_remove: remove unused variable

2016-01-17 Thread Mike Rapoport
The par variable in lynxfb_pci_remove is only assigned a value and never used afterwards. Remove it. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/sm750.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c index 7eb38

[PATCH RESEND v4 4/7] staging: sm750fb: replace dual member of sm750_dev with fb_count

2016-01-17 Thread Mike Rapoport
Will be used in futher refactoring of driver _probe and _remove methods. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/sm750.c | 24 +--- drivers/staging/sm750fb/sm750.h | 2 +- 2 files changed, 14 insertions(+), 12 deletions(-) diff --git a/drivers/staging/sm750

[PATCH RESEND v4 2/7] staging: sm750fb: lynxfb_pci_probe: return actual errors

2016-01-17 Thread Mike Rapoport
The lynxfb_pci_probe always returned -ENODEV in case of error. Modify it so that actual error code will be propogated to the caller. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/sm750.c | 37 + 1 file changed, 17 insertions(+), 20 deletions(-) dif

[PATCH RESEND v4 1/7] staging: sm750fb: disable PCI device if lynxfb_pci_probe fails

2016-01-17 Thread Mike Rapoport
In case of error during lynxfb_pci_probe, the function returned without calling pci_disable_device. Fix it by adding pci_disable_device on the error cleanup path. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/sm750.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/

Anyone working on gs_fpgaboot?

2016-01-17 Thread Ksenija Stanojević
Hi All, I'm helping Greg do a bit of cleanup in the staging tree. I noticed that nobody seems to have worked towards moving gs_fpgaboot out of staging in over a year. Are there any plans to clean it up and move it out soon? Or it should be deleted? Thanks, Ksenija