[PATCH] staging: nvec: fix block comments

2015-12-08 Thread Simon Guinot
This patch fixes a couple of checkpatch warnings about block comments. Signed-off-by: Simon Guinot --- drivers/staging/nvec/nvec.c | 6 -- drivers/staging/nvec/nvec_power.c | 14 +- 2 files changed, 13 insertions(+), 7 deletions(-) diff --git a/drivers/staging/nvec/nvec.c

Re: [PATCH] Staging: speakup: varhandlers: cleanup of function spk_get_punc_var

2015-12-08 Thread Sudip Mukherjee
On Mon, Dec 07, 2015 at 06:35:11PM +0530, Saurabh Sengar wrote: > This patch does the following: > * changed the complicated if statements to simple case statements > * in case of E_DEFAULT, no need to return error as ERESTART, > because this is the user asked for. Hence function should return succ

RE: [PATCH v2] storvsc: add logging for error/warning messages

2015-12-08 Thread KY Srinivasan
> -Original Message- > From: Long Li [mailto:lon...@microsoft.com] > Sent: Friday, December 4, 2015 12:07 AM > To: KY Srinivasan ; Haiyang Zhang > ; James E.J. Bottomley > Cc: de...@linuxdriverproject.org; linux-s...@vger.kernel.org; linux- > ker...@vger.kernel.org; Long Li > Subject: [

Re: [PATCH] staging: lustre: add __user attributes to llite/file.c

2015-12-08 Thread Greg KH
On Tue, Dec 08, 2015 at 09:34:16PM +0100, Wim de With wrote: > This fixes the following sparse warnings: > > drivers/staging/lustre/lustre/llite/file.c:1310:38:expected void const > [noderef] *from > drivers/staging/lustre/lustre/llite/file.c:1310:38:got struct > ll_recreate_obj * > driv

Re: [PATCH v2 00/25] mtd: nand: refactor the NAND subsystem (part 1)

2015-12-08 Thread Brian Norris
Hi, On Tue, Dec 01, 2015 at 12:02:57PM +0100, Boris Brezillon wrote: > Hello, > > This huge series aims at clarifying the relationship between the mtd and > nand_chip structures and hiding NAND framework internals to NAND > controller drivers. > > The first part of the series provide an mtd_to_n

Re: [PATCH v2 00/13] staging/rdma/hfi1: Driver cleanup and misc fixes

2015-12-08 Thread Jubin John
Hi Greg, Is this patch series still in your queue? I just wanted to make sure it didn't get dropped. Thanks, Jubin John ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH v3 bis 12/25] mtd: nand: use the mtd instance embedded in struct nand_chip

2015-12-08 Thread Brian Norris
Hi Boris, On Wed, Dec 02, 2015 at 09:50:01AM +0100, Boris Brezillon wrote: > struct nand_chip now embeds an mtd device. Patch all drivers to make use > of this mtd instance instead of using the instance embedded in their > private struct or dynamically allocated. > > Signed-off-by: Boris Brezillo

[PATCH v2 2/5] staging/rdma/hfi1: Unconditionally clean-up SDMA queues

2015-12-08 Thread ira . weiny
From: Mitko Haralanov There is no need to cleck if the packet queue is allocated when cleaning up a user context. The hfi1_user_sdma_free_queues() function already does all the required checks. Reviewed-by: Ira Weiny Signed-off-by: Mitko Haralanov --- drivers/staging/rdma/hfi1/file_ops.c | 3

[PATCH v2 4/5] staging/rdma/hfi1: Detect SDMA transmission error early

2015-12-08 Thread ira . weiny
From: Mitko Haralanov It is possible for an SDMA transmission error to happen during the processing of an user SDMA transfer. In that case it is better to detect it early and abort any further attempts to send more packets. Reviewed-by: Ira Weiny Signed-off-by: Mitko Haralanov --- drivers/sta

[PATCH v2 5/5] staging/rdma/hfi1: Add page lock limit check for SDMA requests

2015-12-08 Thread ira . weiny
From: Mitko Haralanov The driver pins pages on behalf of user processes in two separate instances - when the process has submitted a SDMA transfer and when the process programs an expected receive buffer. When pinning pages, the driver is required to observe the locked page limit set by the syst

[PATCH v2 3/5] staging/rdma/hfi1: Clean-up unnecessary goto statements

2015-12-08 Thread ira . weiny
From: Mitko Haralanov Clean-up unnecessary goto statements based on feedback from the mailing list on previous patch submissions. Reviewed-by: Ira Weiny Signed-off-by: Mitko Haralanov --- drivers/staging/rdma/hfi1/user_sdma.c | 37 +-- 1 file changed, 14 insert

[PATCH v2 1/5] staging/rdma/hfi1: Convert to use get_user_pages_fast

2015-12-08 Thread ira . weiny
From: Mitko Haralanov Convert hfi1_get_user_pages() to use get_user_pages_fast(), which is much fatster. The mm semaphore is still taken to update the pinned page count but is for a much shorter amount of time. Reviewed-by: Ira Weiny Signed-off-by: Mitko Haralanov --- drivers/staging/rdma/hfi

[PATCH v2 0/5] Clean up SDMA engine code

2015-12-08 Thread ira . weiny
From: Ira Weiny Various improvements to the SDMA engine code. --- Changes from V1: Fix off by one error in the last patch Mitko Haralanov (5): staging/rdma/hfi1: Convert to use get_user_pages_fast staging/rdma/hfi1: Unconditionally clean-up SDMA queues staging/rdma/hfi1: Clean-up

[PATCH] Staging: unisys: fix potential format string leak

2015-12-08 Thread Kees Cook
Since "name" is always used directly, force "%s" for the kthread format string to avoid any potential format string leaks. Signed-off-by: Kees Cook --- drivers/staging/unisys/visorhba/visorhba_main.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/unisys/visor

Re: [PATCH v7 3/7] PCI: Make it possible to implement a PCI MSI IRQ Domain in a module.

2015-12-08 Thread Thomas Gleixner
On Sat, 5 Dec 2015, ja...@microsoft.com wrote: > From: Jake Oshins > > The Linux kernel already has the concpet of IRQ domain, wherein a > component can expose a set of IRQs which are managed by a particular > interrupt controller chip or other subsystem. The PCI driver exposes > the notion of an

Re: [PATCH v7 7/7] PCI: hv: New paravirtual PCI front-end for Hyper-V VMs

2015-12-08 Thread Thomas Gleixner
On Sat, 5 Dec 2015, ja...@microsoft.com wrote: > From: Jake Oshins > > This patch introduces a new driver which exposes a root PCI bus whenever a > PCI Express device is passed through to a guest VM under Hyper-V. The > device can be single- or multi-function. The interrupts for the devices > ar

[PATCH] staging: lustre: add __user attributes to llite/file.c

2015-12-08 Thread Wim de With
This fixes the following sparse warnings: drivers/staging/lustre/lustre/llite/file.c:1310:38:expected void const [noderef] *from drivers/staging/lustre/lustre/llite/file.c:1310:38:got struct ll_recreate_obj * drivers/staging/lustre/lustre/llite/file.c:1328:35: warning: incorrect type in

Re: [PATCH v8 37/55] [media] omap4iss: stop MEDIA_ENT_T_V4L2_SUBDEV abuse

2015-12-08 Thread Mauro Carvalho Chehab
Em Sun, 06 Dec 2015 03:46:28 +0200 Laurent Pinchart escreveu: > Hi Mauro, > > Thank you for the patch. > > On Sunday 30 August 2015 00:06:48 Mauro Carvalho Chehab wrote: > > This driver is abusing MEDIA_ENT_T_V4L2_SUBDEV, as it uses a > > hack to check if the remote entity is a subdev. Get rid

Re: [PATCH v8 36/55] [media] davinci_vbpe: stop MEDIA_ENT_T_V4L2_SUBDEV abuse

2015-12-08 Thread Mauro Carvalho Chehab
Em Sun, 06 Dec 2015 03:52:01 +0200 Laurent Pinchart escreveu: > Hi Mauro, > > Thank you for the patch. > > On Sunday 30 August 2015 00:06:47 Mauro Carvalho Chehab wrote: > > This driver is abusing MEDIA_ENT_T_V4L2_SUBDEV: > > > > - it uses a hack to check if the remote entity is a subdev; > >

[PATCH v2 5/5] Drivers: hv: ring_buffer: eliminate hv_ringbuffer_peek()

2015-12-08 Thread Vitaly Kuznetsov
Currently, there is only one user for hv_ringbuffer_read()/ hv_ringbuffer_peak() functions and the usage of these functions is: - insecure as we drop ring_lock between them, someone else (in theory only) can acquire it in between; - non-optimal as we do a number of things (acquire/release the abo

[PATCH v2 2/5] Drivers: hv: ring_buffer: remove stray smp_read_barrier_depends()

2015-12-08 Thread Vitaly Kuznetsov
smp_read_barrier_depends() does nothing on almost all arcitectures including x86 and having it in the beginning of hv_get_ringbuffer_availbytes() does not provide any guarantees anyway. Signed-off-by: Vitaly Kuznetsov --- include/linux/hyperv.h | 2 -- 1 file changed, 2 deletions(-) diff --git

[PATCH v2 3/5] Drivers: hv: ring_buffer: remove code duplication from hv_ringbuffer_peek/read()

2015-12-08 Thread Vitaly Kuznetsov
hv_ringbuffer_peek() does the same as hv_ringbuffer_read() without advancing the read index. The only functional change this patch brings is moving hv_need_to_signal_on_read() call under the ring_lock but this function is just a couple of comparisons. Signed-off-by: Vitaly Kuznetsov --- drivers/

[PATCH v2 4/5] Drivers: hv: remove code duplication between vmbus_recvpacket()/vmbus_recvpacket_raw()

2015-12-08 Thread Vitaly Kuznetsov
vmbus_recvpacket() and vmbus_recvpacket_raw() are almost identical but there are two discrepancies: 1) vmbus_recvpacket() doesn't propagate errors from hv_ringbuffer_read() which looks like it is not desired. 2) There is an error message printed in packetlen > bufferlen case in vmbus_recvpack

[PATCH v2 1/5] Drivers: hv: ring_buffer.c: fix comment style

2015-12-08 Thread Vitaly Kuznetsov
Convert 6+-string comments repeating function names to normal kernel-style comments and fix a couple of other comment style issues. No textual or functional changes intended. Signed-off-by: Vitaly Kuznetsov --- drivers/hv/ring_buffer.c | 135 +-- 1 fil

[PATCH v2 0/5] Drivers: hv: ring_buffer: do some code cleanup and optimization

2015-12-08 Thread Vitaly Kuznetsov
Changes since v1: added PATCH 4/5 and 5/5. 1) Fix comment style in ring_buffer.c 2) Remove unneeded smp_read_barrier_depends() from hyperv.h 3) Unify hv_ringbuffer_peek/read() functions 4) Unify vmbus_recvpacket()/vmbus_recvpacket_raw() functions 5) Eliminate hv_ringbuffer_peek(). Vitaly Kuznetso

Re: [PATCH v8 33/55] [media] omap3/omap4/davinci: get rid of MEDIA_ENT_T_V4L2_SUBDEV abuse

2015-12-08 Thread Mauro Carvalho Chehab
Em Sun, 06 Dec 2015 04:08:17 +0200 Laurent Pinchart escreveu: > Hi Mauro, > > Thank you for the patch. > > On Sunday 30 August 2015 00:06:44 Mauro Carvalho Chehab wrote: > > On omap3/omap4/davinci drivers, MEDIA_ENT_T_V4L2_SUBDEV macro is > > abused in order to "simplify" the pad checks. > > A

[PATCH] staging: android: ashmem.c: destroy slabs when init fails

2015-12-08 Thread Wenwei Tao
when ashmem init fails, destroy the slabs, leave no garbage. Signed-off-by: Wenwei Tao --- drivers/staging/android/ashmem.c | 15 +++ 1 file changed, 11 insertions(+), 4 deletions(-) diff --git a/drivers/staging/android/ashmem.c b/drivers/staging/android/ashmem.c index 3f2a3d6..5bb1

Re: [PATCH v8 32/55] [media] media: use macros to check for V4L2 subdev entities

2015-12-08 Thread Mauro Carvalho Chehab
Em Sun, 06 Dec 2015 04:16:15 +0200 Laurent Pinchart escreveu: > Hi Mauro, > > Thank you for the patch. > > On Sunday 30 August 2015 00:06:43 Mauro Carvalho Chehab wrote: > > Instead of relying on media subtype, use the new macros to detect > > if an entity is a subdev or an A/V DMA entity. > >

Re: [PATCH] Staging: Skein: Moved macros from skein_block.c to header file.

2015-12-08 Thread Jason Cooper
Sanidhya, *Much* better. Only two two small nits (things which Greg may be able to fix up when applying), and one comment. nit: Patch subject should be 'staging: skein: ...' On Mon, Dec 07, 2015 at 09:37:24PM -0500, Sanidhya Solanki wrote: > The original code defined macros in the source code,

PLEASE CONFIRM

2015-12-08 Thread George Mathew
Dear Friend My name is Mr. George Mathew, I am a banker. It is true that we have not meet each other in person but I strongly believe that where there is no trust no friendship in every business. I have a deceased customer’s pending fund whom you share the same last name with, I am

PLEASE CONFIRM

2015-12-08 Thread George Mathew
Dear Friend My name is Mr. George Mathew, I am a banker. It is true that we have not meet each other in person but I strongly believe that where there is no trust no friendship in every business. I have a deceased customer’s pending fund whom you share the same last name with, I am

Re: [PATCH 05/23] mtd: nand: jz4770: kill the ->ecc_layout field

2015-12-08 Thread Boris Brezillon
On Tue, 8 Dec 2015 10:30:40 + Harvey Hunt wrote: > Hi Boris, > > On 07/12/15 22:26, Boris Brezillon wrote: > > ->ecc_layout is not used by any board file. Kill this field to avoid any > > confusion. New boards are encouraged to use the default ECC layout defined > > in NAND core. > > > > Sig

Re: [PATCH 05/23] mtd: nand: jz4770: kill the ->ecc_layout field

2015-12-08 Thread Harvey Hunt
Hi Boris, On 07/12/15 22:26, Boris Brezillon wrote: ->ecc_layout is not used by any board file. Kill this field to avoid any confusion. New boards are encouraged to use the default ECC layout defined in NAND core. Signed-off-by: Boris Brezillon --- arch/mips/include/asm/mach-jz4740/jz4740_na

[PATCH] Staging: rdma:Delete unnecessary NULL check before calling function "kmem_cache_destroy"

2015-12-08 Thread Shah, Yash (Y.)
From: Yash Shah The kmem_cache_destroy() function tests whether its argument is NULL and then returns immediately. Thus the NULL check before calling this function is not needed. This issue was detected by using the Coccinelle software. Signed-off-by: Yash Shah --- drivers/staging/rdma/ehca/

Re: [PATCH 19/23] mtd: nand: switch all drivers to mtd_ooblayout_ops

2015-12-08 Thread Ralf Baechle
On Mon, Dec 07, 2015 at 11:26:14PM +0100, Boris Brezillon wrote: Looking good, Acked-by: Ralf Baechle Ralf ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH v2 15/25] cris: nand: use the mtd instance embedded in struct nand_chip

2015-12-08 Thread Jesper Nilsson
On Tue, Dec 01, 2015 at 12:03:12PM +0100, Boris Brezillon wrote: > struct nand_chip now embeds an mtd device. Patch all drivers to make use > of this mtd instance instead of using the instance embedded in their > private struct or dynamically allocated. > > Signed-off-by: Boris Brezillon Acked-b

Re: [linux-sunxi] [PATCH 21/23] staging: mt29f_spinand: switch to mtd_ooblayout_ops

2015-12-08 Thread Boris Brezillon
Hi Julian, On Tue, 8 Dec 2015 10:59:53 +1100 Julian Calaby wrote: > Hi Boris, > > On Tue, Dec 8, 2015 at 9:26 AM, Boris Brezillon > wrote: > > Signed-off-by: Boris Brezillon > > --- > > drivers/staging/mt29f_spinand/mt29f_spinand.c | 44 > > --- > > 1 file changed, 2

Re: [PATCH v2 18/25] cris: nand: remove useless mtd->priv = chip assignments

2015-12-08 Thread Jesper Nilsson
On Tue, Dec 01, 2015 at 12:03:15PM +0100, Boris Brezillon wrote: > mtd_to_nand() now uses the container_of() approach to transform an > mtd_info pointer into a nand_chip one. Drop useless mtd->priv > assignments from NAND controller drivers. > > Signed-off-by: Boris Brezillon Acked-by: Jesper Ni

Re: [linux-sunxi] [PATCH 01/23] mtd: kill the ecclayout->oobavail field

2015-12-08 Thread Boris Brezillon
Hi Priit, On Tue, 08 Dec 2015 08:43:05 +0200 Priit Laes wrote: > On Mon, 2015-12-07 at 23:25 +0100, Boris Brezillon wrote: > > ecclayout->oobavail is just redundant with the mtd->oobavail field. > > Moreover, it prevents static const definition of ecc layouts since > > the > > NAND framework is