[PATCH 1/2] staging: most: return error value

2015-11-26 Thread Sudip Mukherjee
On error we were returning retval, but retval is not having the error value. We will get the error value using PTR_ERR. Signed-off-by: Sudip Mukherjee --- This series doesnot depend on my earlier pending series. drivers/staging/most/aim-cdev/cdev.c | 4 ++-- 1 file changed, 2 insertions(+), 2

[PATCH 2/2] staging: most: avoid assignment in if

2015-11-26 Thread Sudip Mukherjee
checkpatch is giving a warning about an assignment in the if condition. The assignment was there as the valid mbo pointer was used after we have woken up from wait_event_interruptible(). Now even though we donot assign the pointer to mbo but we will still be able to get the valid pointer for later

Re: [PATCH] driver:dma bug_fix : access freed memory

2015-11-26 Thread Sudip Mukherjee
On Fri, Nov 27, 2015 at 05:44:53AM +, 김정배 wrote: > From 8f6aeb362d9e44f29d46ae7694cdfee4408406ce Mon Sep 17 00:00:00 2001 > From: "KIM JUGNBAE" > Date: Thu, 26 Nov 2015 16:28:47 +0900 > Subject: [PATCH] bug_fix : access freed memory This part should not be present in the patch. > > sync_fen

[PATCH 3/3] staging: wilc1000: remove duplicate netdev

2015-11-26 Thread Glen Lee
There are two net_device pointer which is the same because two structures are merged into wilc_vif in previous patch. Remove wilc_netdev and change with ndev. Signed-off-by: Glen Lee --- drivers/staging/wilc1000/linux_wlan.c | 35 +++ drivers/staging/wilc1000/wilc

[PATCH 2/3] staging: wilc1000: change vif to pointer to refence real private data

2015-11-26 Thread Glen Lee
vif of struct has it's own memory which is not necessary because we have allocated vif from netdev_priv. Change vif to pointer type and assign vif which is netdev private data. Change it's operator on related codes as well. Signed-off-by: Glen Lee --- drivers/staging/wilc1000/linux_wlan.c

[PATCH 1/3] staging: wilc1000: move perInterface_wlan_t to wilc_vif

2015-11-26 Thread Glen Lee
perInterface_wlan_t and wilc_vif are all about interface control informations. We will combine those two structures and maintain as one network interface control information. Move all the members of perInterface_wlan_t to wilc_vif and remove the structure. Rename perInterace_wlan_t to wilc_vif and

[PATCH 0/3] clean up interface information structure

2015-11-26 Thread Glen Lee
This patch series combines perInterface_wlan_t and struct wilc_vif. vif of struct wilc can be the pointer of net device private data with perInterface_wlan_t. As a conseqeunce, there will be one interface information structure wilc_vif. Glen Lee (3): staging: wilc1000: move perInterface_wlan_t t

[PATCH] driver:dma bug_fix : access freed memory

2015-11-26 Thread 김정배
>From 8f6aeb362d9e44f29d46ae7694cdfee4408406ce Mon Sep 17 00:00:00 2001 From: "KIM JUGNBAE" Date: Thu, 26 Nov 2015 16:28:47 +0900 Subject: [PATCH] bug_fix : access freed memory sync_fenc_free & fence_check_cb_func would be executed at other cpu. fence_check_cb_func access freed fence memory after

Re: [PATCH v2] staging: lustre: remove IOC_LIBCFS_PING_TEST ioctl

2015-11-26 Thread Dilger, Andreas
On 2015/11/08, 09:34, "James Simmons" wrote: >The ioctl IOC_LIBCFS_PING_TEST has not been used in >ages. The recent nidstring changes which moved all >the nidstring operations from libcfs to the LNet >layer but this ioctl code was still using an >nidstring operation that was causing an circular >

Re: [PATCH 3/3] staging: lustre: Less function calls in class_register_type() after error detection

2015-11-26 Thread Dan Carpenter
These patches are often correct in the same way a stopped clock is correct twice a day, but I reject the motivation/approach/patch description. Just because there is a sanity check does not mean we should use it (ie, do an insane thing). It hurts readability to hide the NULL check. On the other

Re: [PATCH 3/3] staging: lustre: Less function calls in class_register_type() after error detection

2015-11-26 Thread SF Markus Elfring
l result in bigger effects than the source code fine-tuning I propose, won't it? I would like to acknowledge that changes like the following from this patch series can still be applied together for the software "Linux next-20151126". * 0001-staging-lustre-Delete-unnecessary-checks-before-two

Re: [PATCH] staging/dgap: move duplicated code from the dgap_cm.* functions

2015-11-26 Thread Alexander Kuleshov
On Thu, Nov 26, 2015 at 12:26 PM, Sudip Mukherjee wrote: > Signed-off-by ? Hello Sudip, I've put it in the v2 (https://lkml.org/lkml/2015/11/25/650) ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/lis

Re: [PATCH 3/3] staging: lustre: Less function calls in class_register_type() after error detection

2015-11-26 Thread Greg Kroah-Hartman
, 16 insertions(+), 10 deletions(-) > > > > Does not apply to my staging-next branch :( > > I get also a result like the following together with the software "Linux > next-20151126". ;-) > > elfring@Sonne:~/Projekte/Linux/next-patched> LANG=C git apply > ~/