Am 25.11.2015 um 17:39 schrieb Greg Kroah-Hartman:
> On Thu, Nov 05, 2015 at 01:20:33PM +0100, SF Markus Elfring wrote:
>> From: Markus Elfring
>> Date: Thu, 5 Nov 2015 12:48:58 +0100
>>
>> The functions "kfree" and "kobject_put" were called in a few cases by the
>> function "class_register_type"
On Wed, Nov 25, 2015 at 07:10:30PM +0600, Alexander Kuleshov wrote:
> The dgap driver contains three functions: dgap_cmdb(), dgap_cmdw()
> and dgap_cmdw_exit which are contain duplicated code which waits
> if necessary before updating the pointer to limit outstanding
> commands. This patch introduc
There are several similar function names, such as wilc_spi_write and
_wilc_spi_write. It is likely to be confused after merging linux_wlan_spi.c and
wilc_spi.c, so rename following functions properly.
Rename wilc_spi_write to wilc_spi_tx, wilc_spi_read to wilc_spi_rx,
wilc_spi_write_read to wilc_sp
This patch removes unnedded extern variable WILC_WFI_devs[] which is not used.
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_netdevice.h
b/drivers/staging/wilc1000/wilc_wfi_netdevice
This patch removes linux_wlan_spi.[ch] which are not used anymore.
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/Makefile | 2 +-
drivers/staging/wilc1000/linux_wlan_spi.c | 16
drivers/staging/wilc1000/linux_wlan_spi.h | 6 --
3 files changed, 1 insertion(+
This patch moves all the codes in linux_wlan_spi.c to wilc_spi.c to make
one spi module. Make wilc_spi_tx, wilc_spi_rx and wilc_spi_tx_rx static
functions. Remove function declaration in linux_wlan_spi.h, which is unnedded
now. No modification has been made inside the codes.
linux_wlan_spi.[ch] wil
wilc_spi_init in linux_wlan_spi.c is unneeded. It just return true. Rename
_wilc_spi_init in wlan_spi.c to wilc_spi_init.
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan_spi.c | 5 -
drivers/staging/wilc1000/linux_wlan_spi.h | 1 -
drivers/staging/wilc1000/wilc_spi.c |
Dear Beneficiary,
This is to inform you that you were among the lucky beneficiary selected to
receive this donations award sum of Eur 350,000.00,
as charity donations/aid from the Qatar Foundation held in Doha, Qatar, to
promote your business and personal Interest.
Kindly get back for more de
The dgap driver contains three functions: dgap_cmdb(), dgap_cmdw()
and dgap_cmdw_exit which are contain duplicated code which waits
if necessary before updating the pointer to limit outstanding
commands. This patch introduces the wait_for_fep_cmds_limit()
function which is will be called from these
This applies some janitorial work to rtl8712 driver.
Mauro Dreissig (4):
staging: rtl8712: Remove casts between void * and type *
staging: rtl8712: Rename local variable
staging: rtl8712: Make error handling check for failure
staging: rtl8712: Rename local variable
drivers/staging/rtl871
Renames all instances of struct _adapter to adapter in rtl871x_ioctl_rtl.c,
avoiding camel case.
Signed-off-by: Mauro Dreissig
---
drivers/staging/rtl8712/rtl871x_ioctl_rtl.c | 86 ++---
1 file changed, 43 insertions(+), 43 deletions(-)
diff --git a/drivers/staging/rtl87
Renames all instances of struct oid_par_priv to oid in rtl871x_ioctl_rtl.c
and rtl871x_ioctl_rtl.h, making the code cleaner.
Signed-off-by: Mauro Dreissig
---
drivers/staging/rtl8712/rtl871x_ioctl_rtl.c | 292 +---
drivers/staging/rtl8712/rtl871x_ioctl_rtl.h | 123 ---
This removes unnecessary explicit pointer casts in rtl871x_ioctl_rtl.c.
Signed-off-by: Mauro Dreissig
---
drivers/staging/rtl8712/rtl871x_ioctl_rtl.c | 45 ++---
1 file changed, 15 insertions(+), 30 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl871x_ioctl_rtl.c
b
Make all error handling paths check for failure instead of success
in rtl871x_ioctl_rtl.c, reducing indentation and avoiding else
statements.
Signed-off-by: Mauro Dreissig
---
drivers/staging/rtl8712/rtl871x_ioctl_rtl.c | 239 +++-
1 file changed, 124 insertions(+), 115 d
On Thu, Nov 05, 2015 at 01:20:33PM +0100, SF Markus Elfring wrote:
> From: Markus Elfring
> Date: Thu, 5 Nov 2015 12:48:58 +0100
>
> The functions "kfree" and "kobject_put" were called in a few cases by the
> function "class_register_type" during error handling even if the passed
> variable conta
struct sdu_stamp in the gdm_sdio.h is a timeval type.
'struct timeval now' is used for calculating elapsed time.
32-bit systems using 'struct timeval' will break in the year 2038,
so we have to replace that code with more appropriate types.
This patch changes the gdm72xx driver to use ktime_t.
kt
On 25-11-2015 12:56, Mauro Dreissig wrote:
> On 25-11-2015 09:44, Sudip Mukherjee wrote:
>> On Tue, Nov 24, 2015 at 10:19:41AM -0200, Mauro Dreissig wrote:
>>> Some error handling paths are checking for success
>>> instead of error on rtl871x_ioctl_rtl.c.
>>>
>>> Signed-off-by: Mauro Dreissig
>>>
On 25-11-2015 09:44, Sudip Mukherjee wrote:
> On Tue, Nov 24, 2015 at 10:19:41AM -0200, Mauro Dreissig wrote:
>> Some error handling paths are checking for success
>> instead of error on rtl871x_ioctl_rtl.c.
>>
>> Signed-off-by: Mauro Dreissig
>> ---
>> drivers/staging/rtl8712/rtl871x_ioctl_rtl.c
The dgap driver contains three functions: dgap_cmdb(), dgap_cmdw()
and dgap_cmdw_exit which are contain duplicated code which waits
if necessary before updating the pointer to limit outstanding
commands. This patch introduces the wait_for_fep_cmds_limit()
function which is will be called from these
On Tue, Nov 24, 2015 at 10:19:41AM -0200, Mauro Dreissig wrote:
> Some error handling paths are checking for success
> instead of error on rtl871x_ioctl_rtl.c.
>
> Signed-off-by: Mauro Dreissig
> ---
> drivers/staging/rtl8712/rtl871x_ioctl_rtl.c | 239
> ++--
> 1 file ch
To Combine linux_wlan_sdio.c and wilc_sdio.c as one file, move all the codes
in linux_wlan_sdio.c to wilc_sdio.c, and make functions static only.
No Modification has not been made except static, just moved them.
Function declaration in linux_wlan_sdio.h is needless, so just remove them.
linux_wlan_
return linux error value instead of 0 or 1 and use -EINVAL. Related codes
also changed together.
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan_spi.c | 14 +++---
drivers/staging/wilc1000/wilc_spi.c | 18 +-
2 files changed, 12 insertions(+), 20 del
Return ret from wilc_netdev_init instead of -1 for proper error handling.
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/linux_wlan_sdio.c | 9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/wilc1000/linux_wlan_sdio.c
b/drivers/staging/wilc1000/lin
This patch removes linux_wlan_sdio.[ch] which is not used anymore.
Signed-off-by: Glen Lee
---
drivers/staging/wilc1000/Makefile | 2 +-
drivers/staging/wilc1000/linux_wlan_sdio.c | 10 --
drivers/staging/wilc1000/linux_wlan_sdio.h | 1 -
3 files changed, 1 insertion(+), 12 de
24 matches
Mail list logo