Hi Tony and Johnny,
On Mon, Aug 10, 2015 at 3:58 PM, Tony Cho wrote:
> From: Johnny Kim
>
> The driver communicates with the chipset via the address of handlers
> to distinguish async data frame. The SendConfigPkt function gets the
> pointer address indicating the handlers as the last argument,
From: Johnny Kim
This patch changes the void pointer member of the tstrHostIFmsg to the
real data type because the void pointer type is ambiguous and not
readable.
Signed-off-by: Johnny Kim
Signed-off-by: Tony Cho
---
drivers/staging/wilc1000/host_interface.c | 2 +-
1 file changed, 1 inserti
From: Johnny Kim
The structure, WILC_WFIDrvHandle is used to save the pointer address
for the driver handler which is used throughout the driver but it's
not easy to understand what it means. In addition, it doesn't support
the 64 bit machine and also causes the warnings for the 64 bit build.
Th
From: Johnny Kim
This patch changes the type of gu8FlushedJoinReqDrvHandler with his real
data type becasue typecasting is not necessary. In result, typecasting
which is not necessary and some building warnings is removed.
Signed-off-by: Johnny Kim
Signed-off-by: Tony Cho
---
drivers/staging/
From: Johnny Kim
The driver communicates with the chipset via the address of handlers
to distinguish async data frame. The SendConfigPkt function gets the
pointer address indicating the handlers as the last argument, but this
requires redundant typecasting and does not support the 64 bit machine.
From: Johnny Kim
This patch replaces the void pointer type in the host interface
functions which process the message from host thread by the real data
type, tstrWILC_WFIDrv because the void pointer type as the arguments
is not clear and concise. In addition, typecasting to the void pointer
type i
This series of patch includes new design for 64 bits. The driver uses the
redundant typecasting to communicate with the chipset, which causes several
compile warnings.
However, this patch uses the real data type and removes unnecessary typecasting.
Also, the driver allocates the ID value to the
On Sun, Aug 09, 2015 at 11:48:34PM +0800, Swee Hua Law wrote:
> 1) do not initialise globals to NULL
> 2) improve readability of hlist_for_each_entry_safe()
> 3) move */ to a separate line
> 4) change symbol == NULL to !symbol
These were many different changes in a single patch. Please break them
On Sun, Aug 09, 2015 at 09:05:11PM +0530, Chandra S Gorentla wrote:
> Removed pointer check with integer; this fixes 'sparse' error -
> error: incompatible types for operation (>)
>left side has type unsigned char [usertype] *[usertype] pu8Tail
>right side has type int
>
> Signed-off-by: C
Remove WILC_strncmp function that is changed to strncmp.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_strutils.c | 21 -
drivers/staging/wilc1000/wilc_strutils.h | 20
2 files changed, 41 deletions(-)
diff --git a/drivers/staging/wilc100
Remove wilc_strutils.c and wilc_strutils.h that are not needed.
wilc_strutils.o is also removed in Makefile.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/Makefile | 2 +-
drivers/staging/wilc1000/wilc_msgqueue.h | 1 -
drivers/staging/wilc1000/wilc_oswrapper.h | 2 --
dri
Remove WILC_memcpy_INTERNAL that is used in the WILC_memcpy
because WILC_memcpy is replaced by memcpy.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_strutils.c | 9 -
drivers/staging/wilc1000/wilc_strutils.h | 11 ---
2 files changed, 20 deletions(-)
diff --git
Remove WILC_memcpy function that is changed to memcpy.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_strutils.h | 30 --
1 file changed, 30 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_strutils.h
b/drivers/staging/wilc1000/wilc_strutils.h
Use memcpy instead of WILC_memcpy that is a custom function.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/coreconfigurator.c | 22 +--
drivers/staging/wilc1000/host_interface.c | 200 +++---
drivers/staging/wilc1000/linux_wlan.c | 2 +-
dr
Remove commented code that is not used.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/coreconfigurator.c | 1 -
drivers/staging/wilc1000/host_interface.c | 2 --
2 files changed, 3 deletions(-)
diff --git a/drivers/staging/wilc1000/coreconfigurator.c
b/drivers/staging/wilc1000/cor
Use strncmp instead of WILC_strncmp.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
index
Use strncpy instead of WILC_strncpy that is a custom function
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/coreconfigurator.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wilc1000/coreconfigurator.c
b/drivers/staging/wilc1000/coreconfigurator.c
Remove WILC_strncpy function that is changed to strncpy.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_strutils.c | 10 --
drivers/staging/wilc1000/wilc_strutils.h | 14 --
2 files changed, 24 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_strutils.c
Use strlen instead of WILC_strlen that is a custom function.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/coreconfigurator.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wilc1000/coreconfigurator.c
b/drivers/staging/wilc1000/coreconfigurato
Remove WILC_strlen function that is changed to strlen.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/wilc_strutils.c | 9 -
drivers/staging/wilc1000/wilc_strutils.h | 10 --
2 files changed, 19 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_strutils.c
b/dri
On Sun, Jul 26, 2015 at 10:59:17AM +0530, Bharadwaaj wrote:
> From: "bhaaradw...@gmail.com"
>
> Fixed spelling mistake.
>
> Signed-off-by: Bharadwaaj Ramakrishnan
> ---
> drivers/staging/lustre/lnet/klnds/o2iblnd/o2iblnd.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
Same comme
On Sun, Jul 26, 2015 at 11:03:28AM +0530, Bharadwaaj wrote:
> From: "bhaaradw...@gmail.com"
That's not your "name", that you use down below:
>
> Fixed some spelling mistake.
>
> Signed-off-by: Bharadwaaj Ramakrishnan
That's your name. Put that in the from: section. And add a space
before th
This patch fixes the following sparse errors:
CHECK drivers/staging/rtl8723au/core/rtw_security.c
drivers/staging/rtl8723au/core/rtw_security.c:189:39: \
warning: incorrect type in assignment (different base types)
drivers/staging/rtl8723au/core/rtw_security.c:189:39:\
expected unsigne
On 08/09/2015 12:22 PM, Jacob Kiefer wrote:
This patch fixes the following sparse errors:
CHECK drivers/staging/rtl8723au/core/rtw_security.c
drivers/staging/rtl8723au/core/rtw_security.c:189:39: \
warning: incorrect type in assignment (different base types)
drivers/staging/rtl8723au/cor
This patch fixes the following sparse errors:
CHECK drivers/staging/rtl8723au/core/rtw_security.c
drivers/staging/rtl8723au/core/rtw_security.c:189:39: \
warning: incorrect type in assignment (different base types)
drivers/staging/rtl8723au/core/rtw_security.c:189:39:\
expected unsigne
On 08/09/2015 11:08 AM, Swee Hua Law wrote:
add space after , to fix coding style issue
Signed-off-by: Swee Hua Law
---
drivers/staging/rtl8723au/core/rtw_sreset.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723au/core/rtw_sreset.c
b/drivers/stagi
add space after , to fix coding style issue
Signed-off-by: Swee Hua Law
---
drivers/staging/rtl8723au/core/rtw_sreset.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723au/core/rtw_sreset.c
b/drivers/staging/rtl8723au/core/rtw_sreset.c
index 29a29d9..48
Fixed coding style issue "warning line over 80 characters"
detected by checkpatch.pl in dgnc_mgmt.c
Signed-off-by: Bhaktipriya Shridhar
---
drivers/staging/dgnc/dgnc_mgmt.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/dgnc/dgnc_mgmt.c b/drivers/staging/dg
Fixed coding style issue "warning line over 80 characters"
detected by checkpatch.pl in dgnc_mgmt.c
Signed-off-by: Bhaktipriya Shridhar
---
drivers/staging/dgnc/dgnc_mgmt.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/dgnc/dgnc_mgmt.c b/drivers/staging/dg
1) do not initialise globals to NULL
2) improve readability of hlist_for_each_entry_safe()
3) move */ to a separate line
4) change symbol == NULL to !symbol
Signed-off-by: Swee Hua Law
---
drivers/staging/lustre/lustre/llite/remote_perm.c | 17 -
1 file changed, 8 insertions(+),
Removed pointer check with integer; this fixes 'sparse' error -
error: incompatible types for operation (>)
left side has type unsigned char [usertype] *[usertype] pu8Tail
right side has type int
Signed-off-by: Chandra S Gorentla
---
Changes in v2: Subject line corrected wilc100 -> wilc1000
Removed pointer check with integer; this fixes 'sparse' error -
error: incompatible types for operation (>)
left side has type unsigned char [usertype] *[usertype] pu8Tail
right side has type int
Signed-off-by: Chandra S Gorentla
---
drivers/staging/wilc1000/host_interface.c | 2 +-
1 file
On 07.08.15 03:09, Stuart Yoder wrote:
> add README file providing an overview of the DPAA2 architecture
> and how it is integrated in Linux
>
> Signed-off-by: Stuart Yoder
> ---
> -v2: added changelog text
>
> drivers/staging/fsl-mc/README.txt | 364
> ++
Return NULL instead of 0 for invalid input.
Signed-off-by: Tomas Melin
---
drivers/staging/most/hdm-dim2/dim2_hal.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/most/hdm-dim2/dim2_hal.c
b/drivers/staging/most/hdm-dim2/dim2_hal.c
index 01b7489..a54cf2c 1006
Fixed coding style issue "warning line over 80 characters"
detected by checkpatch.pl in dgnc_mgmt.c
---
drivers/staging/dgnc/dgnc_mgmt.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/dgnc/dgnc_mgmt.c b/drivers/staging/dgnc/dgnc_mgmt.c
index b13318a..e8fd3da
35 matches
Mail list logo