From: Adi Ratiu
checkpatch.pl gives an error on line 188 because it uses more than
8 spaces indentation. This patch converts the 8 spaces to a tab.
Signed-off-by: Adi Ratiu
---
drivers/staging/media/lirc/lirc_sasem.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/s
> It's up to you. I think if the NV guys are ok with the tegra i2c change,
> Wolfram can merge it right away for 4.3.
I asked him to resend, because I *want* to merge it for 4.3 :) Only the
slave-mode enablement for i2c, of course. The other patches need to go
via some other tree (when they are
Steve Pennington writes:
> Repaced call to htons with call to cpu_to_be16s to fix the
> following sparse warning:
> drivers/staging/rtl8723au/core/rtw_recv.c:1557:21: warning: incorrect type in
> assignment (different base types)
> drivers/staging/rtl8723au/core/rtw_recv.c:1557:21:expected un
Repaced call to htons with call to cpu_to_be16s to fix the
following sparse warning:
drivers/staging/rtl8723au/core/rtw_recv.c:1557:21: warning: incorrect type in
assignment (different base types)
drivers/staging/rtl8723au/core/rtw_recv.c:1557:21:expected unsigned short
[unsigned] [assigned]
Hi,
On Wed, Jul 15, 2015 at 08:31:54AM +0200, Robert Baldyga wrote:
> Convert endpoint configuration to new capabilities model.
>
> Signed-off-by: Robert Baldyga
> ---
> drivers/usb/dwc3/gadget.c | 13 +
> 1 file changed, 13 insertions(+)
>
> diff --git a/drivers/usb/dwc3/gadget.c
From: Erik Arfvidson
This driver provides mouse and keyboard input to Unisys s-Par
Partition Desktop application. This device is created by the
visorbus device.
Signed-off-by: Erik Arfvidson
Signed-off-by: Benjamin Romer
Signed-off-by: Tim Sell
---
v2:
* address visorhid issues indicated by
On Tue, Jul 21, 2015 at 09:55:34AM -0400, Benjamin Romer wrote:
> This patch series consists of several technical fixes for the visornic
> driver.
>
> Neil Horman (15):
> staging: unisys: Remove num_visornic_open array
> staging: unisys: Check return code properly on
> visor_copy_fragsinfo
On Tue, Jul 21, 2015 at 05:23:54PM +0300, Dan Carpenter wrote:
> On Tue, Jul 21, 2015 at 02:08:10PM +, Kershner, David A wrote:
> > We don't have any scripts that access this debugfs file.
> >
>
> Then it's fine to delete the file (in a follow on patch). The kernel
> ABI is anything that pro
On Tue, Jul 21, 2015 at 05:05:22PM +0300, Dan Carpenter wrote:
> On Tue, Jul 21, 2015 at 09:55:35AM -0400, Benjamin Romer wrote:
> > static ssize_t enable_ints_write(struct file *file,
> > const char __user *buffer,
> > size_t count, loff_t
On Tue, Jul 21, 2015 at 02:08:10PM +, Kershner, David A wrote:
> We don't have any scripts that access this debugfs file.
>
Then it's fine to delete the file (in a follow on patch). The kernel
ABI is anything that programs rely on. If they don't rely on it, then
it's fine to change.
regard
We don't have any scripts that access this debugfs file.
David
> -Original Message-
> From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
> Sent: Tuesday, July 21, 2015 10:05 AM
> To: Romer, Benjamin M
> Cc: gre...@linuxfoundation.org; jes.soren...@redhat.com; *S-Par-
> Maintainer; dri
Dexuan Cui writes:
> This will be used by the coming net/hvsock driver.
>
> Signed-off-by: Dexuan Cui
> ---
> drivers/hv/channel.c | 133
> ++
> drivers/hv/hyperv_vmbus.h | 4 ++
> drivers/hv/ring_buffer.c | 14 +
> include/linux/hyperv.
On Tue, Jul 21, 2015 at 09:55:35AM -0400, Benjamin Romer wrote:
> static ssize_t enable_ints_write(struct file *file,
>const char __user *buffer,
>size_t count, loff_t *ppos)
> {
> - char buf[4];
> - int i, new_value;
> -
From: Neil Horman
Its possible to overwrite the old task pointer in visornic_resume. Add a
check to guard against that and a warning if we find that its already
running
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visornic/visornic_main.c | 9 +++--
From: Neil Horman
The netdev we're testing for can't be removed, because its never
unregistered, so don't bother checking for it
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visornic/visornic_main.c | 12
1 file changed, 12 deletions(-)
dif
This patch series consists of several technical fixes for the visornic
driver.
Neil Horman (15):
staging: unisys: Remove num_visornic_open array
staging: unisys: Check return code properly on
visor_copy_fragsinfo_from_skb
staging: unisys: BUG halt on error in I/O channel
staging: unisy
From: Neil Horman
dev_trans_start does this for us now
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visornic/visornic_main.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/unisys/visornic/visornic_main.c
b/drivers/staging/unisy
From: Neil Horman
As per the last commit, once a netdevice is registered, theres nothing to
unregister it, even if the module is removed. That's obviously a memory
leak and an easy oops vector.
Fixing it isn't hard, but it requires that some additional infrastructure
be put in place to handle de
From: Neil Horman
If we put them in the enable and disable paths, we don't need them in
several other places
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visornic/visornic_main.c | 9 +
1 file changed, 1 insertion(+), 8 deletions(-)
diff --git a
From: Neil Horman
All it does is return no supported. Removing the function entirely
accomplishes the same thing
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visornic/visornic_main.c | 16
1 file changed, 16 deletions(-)
diff --git a/d
From: Neil Horman
One call site for visor_copy_fragsinfo_from_skb was checking for an rc of
-1, but thhe function doesn't return that, it returns -errno. Correct it
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visornic/visornic_main.c | 2 +-
1 file cha
From: Neil Horman
If we can't fit an skb into a frag array, linaraize it so we don't have to
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visornic/visornic_main.c | 16
1 file changed, 16 insertions(+)
diff --git a/drivers/staging/unisy
From: Neil Horman
We precheck that we have enough space in an iochannel prior to writing to
it when we send in a fragmented skb. Given that there is no recovery from
this condition that I can see, turn it into a BUG halt
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/st
From: Neil Horman
Theres a lot of code duplication going on in visornic_serverdown_complete.
We should just be able to send it through the dev_close path and have it
do the right things.
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visornic/visornic_main
From: Neil Horman
I don't see why serverdown should be async on a workqueue. Just make it
synchronous, and remove some code in the process
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visornic/visornic_main.c | 25 ++---
1 file chang
From: Neil Horman
As pointed out in a recent review, the num_visornic_open array didn't do
anything useful, and it exposed a potential race in the visornic code that
could arise while taking down a net interface while reading from the
debugfs files. Fix that by removing the array entirely, and ju
From: Neil Horman
Using NETDEV_TX_BUSY is tricky. Its meant for situations where the error
in question is transient and quickly resolved. But the driver rarely is
able to know that to a certainty. And in the case of visornic, it just
uses it without any care for that, in the hopes that it won'
From: Neil Horman
Remove the has_stopped completion as theres already one available
internally.
Correct the while loops
Remove the while loop in drain_queue as it already exists in the top level
loop
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visorni
From: Neil Horman
I don't see why the server should stop responding, or that we should just
give up if it does. Wait forever when enabling/disabling the visornic
Signed-off-by: Neil Horman
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visornic/visornic_main.c | 16 +---
Multiple blank lines should be avoided.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/rtl8188eu/os_dep/usb_intf.c
b/drivers/staging/rtl8188eu/os_dep/usb_intf.c
index 29b7ea6..5f44c6a 100644
-
_HCI_INTF_C_ was only defined here but not being used anywhere.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/os_dep/usb_intf.c
b/drivers/staging/rtl8188eu/os_dep/usb_intf.c
index 5490b
Directly return NULL instead of using another label and goto.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/os_dep/usb_intf.c
b/drivers/staging/rtl8188eu/os_dep/usb
Success and error path was mixed. Separate them by directly returning 0
from the success path. In the process remove the variable which became
unused.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 8 +++-
1 file changed, 3 insertions(+), 5 deletions(-)
dif
Check for kzalloc failure and directly return from the error patch thus
simplifying the success path.
Suggested-by: Dan Carpenter
Signed-off-by: Sudip Mukherjee
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 7 +++
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/sta
Am Dienstag, 21. Juli 2015, 11:51:15 schrieb Andrey Danin:
> On 21.07.2015 11:25, Marc Dietrich wrote:
> > I think in this case it would be better to leave nvec and dt as it is for
> > now, and just add the slave function to tegra-i2c. Otherwise we will
> > again have two different "nvidia,nvec-sla
Remove unnecessary braces where appropriate.
This removes the following checkpatch warnings:
WARNING: braces {} are not necessary for single statement blocks
Signed-off-by: Maciek Borzecki
---
drivers/staging/media/lirc/lirc_imon.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
A tiny patch series that addresses warnings or errors identified by
checkpatch.
Changes since v1/v2:
- split braces/whitespace patch into 2 separate patches
- fix alignment problem with pr_debug() arguments
The first patch fixes minor warning with unnecessary brakes around
single statement bl
Fix non-tab indentation.
This resolves the following checkpatch problem:
ERROR: code indent should use tabs where possible
Signed-off-by: Maciek Borzecki
---
drivers/staging/media/lirc/lirc_sasem.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/media/lir
Replace custom debug macro dprintk() with pr_debug() or
dev_dbg(). Remove unused module param `debug`.
This removes the following checkpatch warning:
WARNING: Prefer [subsystem eg: netdev]_dbg([subsystem]dev, ... then
dev_dbg(dev, ... then pr_debug(... to printk(KERN_DEBUG ...
+
Hyper-V VM sockets (hvsock) supplies a byte-stream based communication
mechanism between the host and a guest. It's kind of TCP over VMBus, but
the transportation layer (VMBus) is much simpler than IP. With Hyper-V VM
Sockets, applications between the host and a guest can talk with each
other direc
In the SMP guest case, when the per-channel callback hvsock_events() is
running on virtual CPU A, if the guest tries to close the connection on
virtual CPU B: we invoke vmbus_close() -> vmbus_close_internal(),
then we can have trouble: on B, vmbus_close_internal() will send IPI
reset_channel_cb() t
A helper function is also added.
Signed-off-by: Dexuan Cui
---
include/linux/hyperv.h | 7 +++
1 file changed, 7 insertions(+)
diff --git a/include/linux/hyperv.h b/include/linux/hyperv.h
index 30d3a1f..2ca3ac1 100644
--- a/include/linux/hyperv.h
+++ b/include/linux/hyperv.h
@@ -236,6 +236,
With the 2 APIs supplied by the VMBus driver, the coming net/hvsock driver
can register 2 callbacks and can know when a new hvsock connection is
offered by the host, and when a hvsock connection is being closed by the
host.
Signed-off-by: Dexuan Cui
---
drivers/hv/Makefile | 4 ++-
dr
A function to send the type of message is also added.
The coming net/hvsock driver will use this function to proactively request
the host to offer a VMBus channel for a new hvsock connection.
Signed-off-by: Dexuan Cui
---
drivers/hv/channel.c | 15 +++
drivers/hv/channel_mgmt.c
This will be used by the coming net/hvsock driver.
Signed-off-by: Dexuan Cui
---
drivers/hv/channel.c | 133 ++
drivers/hv/hyperv_vmbus.h | 4 ++
drivers/hv/ring_buffer.c | 14 +
include/linux/hyperv.h| 32 +++
4 files changed
This will be used by the coming net/hvsock driver.
Signed-off-by: Dexuan Cui
---
include/linux/hyperv.h | 6 ++
1 file changed, 6 insertions(+)
diff --git a/include/linux/hyperv.h b/include/linux/hyperv.h
index fda9790..47c5c1a 100644
--- a/include/linux/hyperv.h
+++ b/include/linux/hyperv.
Changes since v1:
- updated "[PATCH 6/7] hvsock: introduce Hyper-V VM Sockets feature"
- added __init and __exit for the module init/exit functions
- net/hv_sock/Kconfig: "default m" -> "default m if HYPERV"
- MODULE_LICENSE: "Dual MIT/GPL" -> "Dual BSD/GPL"
Changes since
On 20/07/15 12:23, Chandra S Gorentla wrote:
Checkpatch.pl warning - suspect code indent for conditional statements -
is corrected
Signed-off-by: Chandra S Gorentla
---
drivers/staging/comedi/drivers/pcl816.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging
On Fri, 26 Jun 2015, Vitaly Kuznetsov wrote:
> As cpu_hotplug_enable/cpu_hotplug_disable functions are now available to
> modules we need to convert cpu_hotplug_disabled to a counter to properly
Actually this patch should be the first in the series. We don't expose
known to be broken infrastructu
On Fri, 26 Jun 2015, Vitaly Kuznetsov wrote:
> Hyper-V module needs to disable cpu hotplug (offlining) as there is no
> support from hypervisor side to reassing already opened event channels
s/reassing/reassign/
> to a different CPU. Currently it is been done by altering
> smp_ops.cpu_disable bu
On Tue, Jul 21, 2015 at 06:01:51AM +0200, Frans Klaver wrote:
> On 20 July 2015 21:42:39 CEST, Luis de Bethencourt
> wrote:
> >On Mon, Jul 20, 2015 at 09:54:56PM +0300, Dan Carpenter wrote:
> >> On Mon, Jul 20, 2015 at 06:35:42PM +0200, Luis de Bethencourt wrote:
> >> > Remove explicit true/false
On 21.07.2015 11:25, Marc Dietrich wrote:
I think in this case it would be better to leave nvec and dt as it is for now,
and just add the slave function to tegra-i2c. Otherwise we will again have two
different "nvidia,nvec-slave" bindings (one for the intermediate hack and one
for the final repre
On 20.07.2015 23:35, Andrey Danin wrote:
This version (v3) is for pushing tegra i2c driver to i2c tree.
NVEC driver will be reworked later to use i2c core slave framework.
NVEC driver contains code to manage tegra i2c controller in slave mode.
I2C slave support was implemented in linux kernel. T
Slow down. This patch is totally wrong. You're panicking and sending
nonsense patches without a description or signed off by. It deletes
code. The v2 isn't where it should be [PATCH 2/2 v2].
There is no need to rush. Fix this and send the patch tomorrow.
regards,
dan carpenter
_
On Tue, Jul 21, 2015 at 01:10:00PM +0530, Vinay Simha BN wrote:
> diff --git a/drivers/staging/sm750fb/sm750_help.h
> b/drivers/staging/sm750fb/sm750_help.h
> index 8dc6bd2..43d700b 100644
> --- a/drivers/staging/sm750fb/sm750_help.h
> +++ b/drivers/staging/sm750fb/sm750_help.h
> @@ -49,17 +49,23
On Tue, 2015-07-21 at 13:10 +0530, Vinay Simha BN wrote:
> scripts/checkpatch.pl kernel coding style fixes of WARNING
Please run your patches through scripts/checkpatch.pl --strict
> diff --git a/drivers/staging/sm750fb/ddk750_power.h
> b/drivers/staging/sm750fb/ddk750_power.h
> index b7cf6b2..a
Am Dienstag, 21. Juli 2015, 09:35:21 schrieb Andrey Danin:
> On 21.07.2015 1:19, Stephen Warren wrote:
> > On 07/20/2015 02:35 PM, Andrey Danin wrote:
> >> NVEC driver was reimplemented to use tegra i2c. Use common i2c bindings
> >> for NVEC node.
> >>
> >> diff --git a/arch/arm/boot/dts/tegra20-p
On Tue, Jul 21, 2015 at 11:43:52AM +0530, Sudip Mukherjee wrote:
> On Tue, Jul 21, 2015 at 11:39:49AM +0530, Sudip Mukherjee wrote:
> > On Mon, Jul 20, 2015 at 02:15:35PM +0300, Cihangir Akturk wrote:
> > > obd_device_list_sops and obd_device_list_fops are not
> > > referenced outside of linux-modu
---
drivers/staging/sm750fb/sm750_accel.h | 30 --
drivers/staging/sm750fb/sm750_help.h | 23 +--
2 files changed, 21 insertions(+), 32 deletions(-)
diff --git a/drivers/staging/sm750fb/sm750_accel.h
b/drivers/staging/sm750fb/sm750_accel.h
index d
scripts/checkpatch.pl kernel coding style fixes of WARNING
WARNING: line over 80 characters
Signed-off-by: Vinay Simha BN
---
drivers/staging/sm750fb/ddk750_display.h | 10 +-
drivers/staging/sm750fb/ddk750_hwi2c.h | 6 --
drivers/staging/sm750fb/ddk750_power.h | 6 +++---
dri
On Tue, Jul 21, 2015 at 12:48:00PM +0530, Vinay Simha wrote:
> Yes,
> Shall i send both the patches together, patch 1 and 2 ?
yes, please send a patch giving a version number like v2 or v3 which
should apply to staging-testing keeping in mind the review that Joe has
given on your previous patch.
r
target_send_reply_msg function is not referenced outside of ldlm_lib.c
file, so make it static.
Signed-off-by: Cihangir Akturk
---
drivers/staging/lustre/lustre/ldlm/ldlm_lib.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/ldlm/ldlm_lib.c
b/
On Tue, Jul 21, 2015 at 12:14:43PM +0530, Vinay Simha BN wrote:
> WARNING: line over 80 characters
> comment block , odd statement fixes
This is not applying. I think you have done the changes on top of your
previous patch.
regards
sudip
___
devel mailin
On Tue, Jul 21, 2015 at 08:28:06AM +0200, Maciek Borzecki wrote:
> On Tue, Jul 21, 2015 at 8:19 AM, Sudip Mukherjee
> wrote:
> > On Mon, Jul 20, 2015 at 06:10:04PM +0200, Maciek Borzecki wrote:
> >> Remove unnecessary braces where appropriate. Fix non-tab
> >> indentation.
> >>
> >> This removes t
64 matches
Mail list logo