On 07/17/2015 02:14 AM, Greg Kroah-Hartman (gre...@linuxfoundation.org)
wrote:
> On Thu, Jul 16, 2015 at 07:18:46PM +, Marciniszyn, Mike wrote:
>> Greg,
>>
>> We are in the process of submitting an RDMA driver for the Intel OPA
>> architecture.
>
> I have no idea what "OPA" is, sorry.
Omni-P
On Thu, Jul 16, 2015 at 07:18:46PM +, Marciniszyn, Mike wrote:
> Greg,
>
> We are in the process of submitting an RDMA driver for the Intel OPA
> architecture.
I have no idea what "OPA" is, sorry.
> The current massive patch set is submitted to add the driver to the
> infiniband tree.
>
On Thu, Jul 16, 2015 at 03:49:49PM +0200, Luis de Bethencourt wrote:
> Remove explicit true/false comparisons to bool variables.
>
> Signed-off-by: Luis de Bethencourt
> ---
>
> diff --git a/drivers/staging/rtl8192u/r8192U_core.c
> b/drivers/staging/rtl8192u/r8192U_core.c
> index b852396..41cf9
> -Original Message-
> From: Stefan Hajnoczi
> Sent: Thursday, July 16, 2015 23:59
> On Mon, Jul 06, 2015 at 07:39:35AM -0700, Dexuan Cui wrote:
> > Hyper-V VM Sockets (hvsock) is a byte-stream based communication
> mechanism
> > between Windowsd 10 (or later) host and a guest. It's kind of
On Fri, Jul 17, 2015 at 10:52:59AM +0530, Sudip Mukherjee wrote:
> On Thu, Jul 16, 2015 at 05:55:54PM +0200, antoine wrote:
> > This is a patch to the ddk750_power.c file that fixes up five "line over 80
> > characters" warnings and one "return is not a function, parentheses are not
> > required" e
On Thu, Jul 16, 2015 at 05:55:54PM +0200, antoine wrote:
> This is a patch to the ddk750_power.c file that fixes up five "line over 80
> characters" warnings and one "return is not a function, parentheses are not
> required" error found by the checkpatch.pl script.
That becomes two different change
劳动者主张入职以来的加班费如何应对.xls
Description: Binary data
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
fixed checkpatch.pl error:
ERROR: return is not a function, parentheses are not needed
Signed-off-by: Aaron Ouellette
---
drivers/staging/sm750fb/ddk750_power.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/sm750fb/ddk750_power.c
b/drivers/staging/sm750fb/d
On Thu, 16 Jul 2015, Incarnation P. Lee wrote:
> Signed-off-by: Li Pan (Incarnation P. Lee)
The signed off line should match the From line, which should match your
real name (passport, etc). And the signed off line should go after the
commit message.
> Fix one file coding sytle issue on li
On Fri, Jul 17, 2015 at 03:03:24AM +, Craig Inches wrote:
> Fixed multiple instances of:
>
> CHECK: Alignment should match open parenthesis
> CHECK: Blank lines aren't necessary before a close brace '}'
> CHECK: Please don't use multiple blank lines
> CHECK: Blank lines aren't necessary after
On Wed, Jul 15, 2015 at 11:25:19AM +0530, Sunil Shahu wrote:
> Remove all checkpatch error by using consistent spacing.
>
> Signed-off-by: Sunil Shahu
> ---
> drivers/staging/sm750fb/ddk750_chip.c | 14 +++---
> 1 file changed, 7 insertions(+), 7 deletions(-)
This doesn't apply to my tr
Fixed multiple instances of:
CHECK: Alignment should match open parenthesis
CHECK: Blank lines aren't necessary before a close brace '}'
CHECK: Please don't use multiple blank lines
CHECK: Blank lines aren't necessary after an open brace '{'
WARNING: line over 80 characters
Signed-off-by: Craig I
The current code returns from probe without waiting for the proper handling
of subchannels that may be requested. If the netvsc driver were to be rapidly
loaded/unloaded, we can trigger a panic as the unload will be tearing
down state that may not have been fully setup yet. We fix this issue by ma
update TODO list to provide more detail on remaining work
Signed-off-by: Stuart Yoder
---
drivers/staging/fsl-mc/TODO | 24 +++-
1 file changed, 23 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-mc/TODO b/drivers/staging/fsl-mc/TODO
index d78288b..c29516b 1006
On Fri, 2015-07-17 at 00:20 +, Craig Inches wrote:
> Hi Joe,
Rehi Craig.
> On Thu, Jul 16, 2015 at 08:30:53AM -0700, Joe Perches wrote:
> > On Thu, 2015-07-16 at 23:11 +, Craig Inches wrote:
> > > Fixed up some checkpatch.pl style issues.
> > > Line greater than 80 Chars in multiple locat
This is a patch to the ddk750_power.c file that fixes up five "line over 80
characters" warnings and one "return is not a function, parentheses are not
required" error found by the checkpatch.pl script.
Signed-off-by: Antoine BLIN
---
drivers/staging/sm750fb/ddk750_power.c | 19 -
Variable obd_device_cachep is only used inside the file it is declared,
so it is better set as static
Signed-off-by: Pedro Marzo Perez
---
drivers/staging/lustre/lustre/obdclass/genops.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/obdclass/ge
The copyright statements in the drivers need to be correct and
consistent; this patch fixes the year for all of them, and makes the
statement text cover just the GPL V2.
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/visorbus/controlvmchannel.h | 9 -
drivers/staging/u
On Thu, Jul 16, 2015 at 09:41:36AM +0200, Guillaume Bienkowski wrote:
> Fix spaces before comma and indentation.
That's two different things, so this should be two different patches
please.
thanks,
greg k-h
___
devel mailing list
de...@linuxdriverproje
Hi Joe,
On Thu, Jul 16, 2015 at 08:30:53AM -0700, Joe Perches wrote:
> On Thu, 2015-07-16 at 23:11 +, Craig Inches wrote:
> > Fixed up some checkpatch.pl style issues.
> > Line greater than 80 Chars in multiple locations.
>
> I think most all of these are not improvements.
Ok, can you
On Mon, Jul 06, 2015 at 07:39:35AM -0700, Dexuan Cui wrote:
> Hyper-V VM Sockets (hvsock) is a byte-stream based communication mechanism
> between Windowsd 10 (or later) host and a guest. It's kind of TCP over
> VMBus, but the transportation layer (VMBus) is much simpler than IP.
> With Hyper-V VM
On Thu, Jul 16, 2015 at 11:11:33PM +, Craig Inches wrote:
> Fixed up some checkpatch.pl style issues.
> Line greater than 80 Chars in multiple locations.
>
> Signed-off-by: Craig Inches
> ---
> drivers/staging/dgnc/dgnc_tty.c | 168
> ++--
> 1 file change
On Thu, Jul 16, 2015 at 04:04 AM CEST, Sreenath Madasu
wrote:
> This one of the TODO tasks for staging rtl8188eu driver. I have removed
> the code referring to channel > 14 for rtw_ap.c, rtw_ieee80211.c and
> rtw_mlme.c files. Please review.
>
> Signed-off-by: Sreenath Madasu
I would consider r
Fixed up some checkpatch.pl style issues.
Line greater than 80 Chars in multiple locations.
Signed-off-by: Craig Inches
---
drivers/staging/dgnc/dgnc_tty.c | 168 ++--
1 file changed, 110 insertions(+), 58 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_t
On Thu, 2015-07-16 at 23:11 +, Craig Inches wrote:
> Fixed up some checkpatch.pl style issues.
> Line greater than 80 Chars in multiple locations.
I think most all of these are not improvements.
Please use --strict when verifying your patches.
Please fix the time on your system.
From: Dexuan Cui
Date: Tue, 14 Jul 2015 03:00:48 -0700
> + pr_debug("hvsock_sk_destruct: called\n");
Debug logging just to state that a function is called is not appropriate,
we have very sophisticated tracing facilities in the kernel that can do
that transparently, and more.
PLease remove
From: Dexuan Cui
Date: Tue, 14 Jul 2015 02:58:56 -0700
> +int vmbus_sendpacket_hvsock(struct vmbus_channel *channel, void *buf, u32
> len)
> +{
> + struct vmpacket_descriptor desc;
> + struct vmpipe_proto_header pipe_hdr;
> + u32 packetlen;
> + u32 packetlen_aligned;
> + stru
Signed-off-by: Li Pan (Incarnation P. Lee)
Fix one file coding sytle issue on linux-next-20150708, including macro
aligned, missing blank lines after variable declarnation and brace missing
in one line if structure.
This patch can be one part of Eudyotula Task10.
---
drivers/staging/lus
From: Dexuan Cui
Date: Tue, 14 Jul 2015 02:58:03 -0700
> A helper function is also added.
>
> Signed-off-by: Dexuan Cui
> ---
> include/linux/hyperv.h | 7 +++
> 1 file changed, 7 insertions(+)
>
> diff --git a/include/linux/hyperv.h b/include/linux/hyperv.h
> index 30d3a1f..aa21814 10064
Hi,
On Thu, Jul 16, 2015 at 8:17 AM, Incarnation P. Lee
wrote:
> Signed-off-by: Li Pan (Incarnation P. Lee)
>
> Fix one file coding sytle issue on linux-next-20150708, including macro
> aligned, missing blank lines after variable declarnation and brace missing
> in one line if structure.
Oh
From: Haiyang Zhang
Date: Mon, 13 Jul 2015 13:09:16 -0700
> The current change mtu call only stops tx before removing RNDIS filter.
> In case ringbufer is not empty, the rndis_filter_device_remove() may
> hang on removing the buffers.
>
> This patch adds close of RNDIS filter before removing it,
Remove explicit true/false comparisons to bool variables.
Signed-off-by: Luis de Bethencourt
---
drivers/staging/rtl8192u/ieee80211/ieee80211_rx.c | 4 ++--
drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c | 2 +-
drivers/staging/rtl8192u/ieee80211/ieee80211_tx.c | 4 ++--
dri
> -Original Message-
> From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
> Sent: Tuesday, July 14, 2015 9:03 AM
> To: Dexuan Cui
> Cc: de...@linuxdriverproject.org; KY Srinivasan; Haiyang Zhang; linux-
> ker...@vger.kernel.org
> Subject: Re: [PATCH] Drivers: hv: vmbus: prevent new subch
In a later patch we will remove the duplicate codes. But the code also
needs to execute dgap_remove_driver_sysfiles() if it is being called
from dgap_remove_one() but if being called fron the error path of the
dgap_init_module() then the sysfiles should not be removed.
Signed-off-by: Sudip Mukherj
Remove the duplicate code of dgap_remove_one() and dgap_stop().
Signed-off-by: Sudip Mukherjee
---
drivers/staging/dgap/dgap.c | 15 +--
1 file changed, 1 insertion(+), 14 deletions(-)
diff --git a/drivers/staging/dgap/dgap.c b/drivers/staging/dgap/dgap.c
index 4f07a0c..b344e03 1006
Relocate the function dgap_stop() so that in a later patch we can remove
the duplicate codes between dgap_stop() and dgap_remove_one().
Signed-off-by: Sudip Mukherjee
---
drivers/staging/dgap/dgap.c | 30 +++---
1 file changed, 15 insertions(+), 15 deletions(-)
diff --gi
On Thu, 2015-07-16 at 10:11 -0700, Greg KH wrote:
> On Thu, Jul 16, 2015 at 09:41:36AM +0200, Guillaume Bienkowski wrote:
> > Fix spaces before comma and indentation.
>
> That's two different things, so this should be two different patches
> please.
I think it'd be better to do all the whitespace
Greg,
We are in the process of submitting an RDMA driver for the Intel OPA
architecture.
The current massive patch set is submitted to add the driver to the infiniband
tree.
I'm wondering if the staging area is a better spot to land the driver at first?
That way everyone can see it being rew
On Fri, Jul 17, 2015 at 12:20:42AM +, Craig Inches wrote:
> Hi Joe,
>
> On Thu, Jul 16, 2015 at 08:30:53AM -0700, Joe Perches wrote:
> > On Thu, 2015-07-16 at 23:11 +, Craig Inches wrote:
> > > Fixed up some checkpatch.pl style issues.
> > > Line greater than 80 Chars in multiple locations
The check for pstat and pdvobjpriv is not required here as we have
already checked for them before.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 2 +-
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
dif
The code in dgap_stop() is almost a duplicate of the code that will be
executed on pci_unregister_driver(). So the error code was stopping and
unregistering everything twice.
Signed-off-by: Sudip Mukherjee
---
we had a discussion about the init and error path few months back when
another patch w
> -Original Message-
> From: David Miller
> Sent: Thursday, July 16, 2015 12:16
>
> From: Dexuan Cui
> Date: Tue, 14 Jul 2015 02:58:56 -0700
>
> > +int vmbus_sendpacket_hvsock(struct vmbus_channel *channel, void *buf,
> u32 len)
> > +{
> > + struct vmpacket_descriptor desc;
> > + stru
The variable ret was always 0. So remove the variable and always
return 0 from the function.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 9 +++--
1 file changed, 3 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8188eu/os_dep/usb_intf.c
b/
Migrate hv driver to the new 'set-state' interface provided by
clockevents core, the earlier 'set-mode' interface is marked obsolete
now.
This also enables us to implement callbacks for new states of clockevent
devices, for example: ONESHOT_STOPPED.
Cc: "K. Y. Srinivasan"
Cc: Haiyang Zhang
Cc:
Stop using DBG_88E which is a custom macro for printing debugging
messages. Instead start using pr_debug and in the process define
pr_fmt.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 39 +++--
1 file changed, 20 insertions(+), 19 delet
> From: David Miller
> Sent: Thursday, July 16, 2015 12:13
>
> From: Dexuan Cui
> Date: Tue, 14 Jul 2015 02:58:03 -0700
>
> > A helper function is also added.
> >
> > diff --git a/include/linux/hyperv.h b/include/linux/hyperv.h
> > @@ -236,6 +236,7 @@ struct vmbus_channel_offer {
> > #define VMB
On Thu, 2015-07-16 at 00:16 +0530, Vinay Simha BN wrote:
> scripts/checkpatch.pl kernel coding style fixes of WARNING
Please don't be a checkpatch robot.
Use tools to prompt your brain, but don't ever turn
your brain off.
> diff --git a/drivers/staging/sm750fb/ddk750_help.h
> b/drivers/staging/
The default value of status was _FAIL, it was only changed if kzalloc
succeeds and the check for status is immediately following kzalloc. We
can have the failure code in the else part as the failure code will be
executed only if kzalloc fails.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/r
On Thu, Jul 16, 2015 at 06:47:40AM -0400, Sreenath Madasu wrote:
> Fixed the "unused variable" warning for the driver.
oops. no. You have done it on top of your previous patch. Please combine
these two patches and send a single patch which will remove the code
related to channel>14 and this unused
> From: David Miller
> Sent: Thursday, July 16, 2015 12:19
>
> From: Dexuan Cui
> Date: Tue, 14 Jul 2015 03:00:48 -0700
>
> > + pr_debug("hvsock_sk_destruct: called\n");
>
> Debug logging just to state that a function is called is not appropriate,
> we have very sophisticated tracing facilitie
Fixed the "unused variable" warning for the driver.
Signed-off-by: Sreenath Madasu
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_ap.c
b/drivers/staging/rtl8188eu/core/rtw_ap.c
index 1a32e7b..5bded92 100644
---
The inline function rtw_set_ips_deny() was only defined but was never
used.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/rtl8188eu/core/rtw_pwrctrl.c| 6 --
drivers/staging/rtl8188eu/include/rtw_pwrctrl.h | 1 -
2 files changed, 7 deletions(-)
diff --git a/drivers/staging/rtl8188e
By checking for the success of kzalloc we were able to remove the goto
label thus making the code more readable.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/rtl8188eu/os_dep/usb_intf.c | 11 ---
1 file changed, 4 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8188e
On 16/07/15 09:54, Dan Carpenter wrote:
On Thu, Jul 16, 2015 at 08:45:06AM +, Maninder Singh wrote:
where we are checking for (pTDInfo->skb), we are using it in above line.
and it does not look good, thats why we should remove thse checks and i have
suggested
changes.
code snippet:-
---
On Tue, Jul 14, 2015 at 10:04:03PM +0200, Mateusz Kulikowski wrote:
> This series does some more cleanup for driver.
>
> Changes in V2:
> - Added patch 6/23 (Remove rtllib_stats structure as suggested by Dan)
> - Updated patch 22/23 (remove whitespace - hint by Sudip)
> - Rebased into current stag
On Thu, Jul 16, 2015 at 08:45:06AM +, Maninder Singh wrote:
> where we are checking for (pTDInfo->skb), we are using it in above line.
> and it does not look good, thats why we should remove thse checks and i have
> suggested
> changes.
>
> code snippet:-
> ---
>
> if (p
Hi Dan,
>I hate these patches. I have told Markus to stop sending them but he
>has issues so now I only complain when they introduce a bug. There was
>one bug I have missed because it was a benchmark regression and I knew
>it was theoretically possible but I didn't know the code well enough to
>
Fix spaces before comma and indentation.
Signed-off-by: Guillaume Bienkowski
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 42 +--
1 file changed, 21 insertions(+), 21 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
b/drivers/staging/rtl818
On Wed, Jul 15, 2015 at 08:52:51AM +0530, Maninder Singh wrote:
> dev_kfree_skb checks for NULL pointer itself,
> Thus no need of explicit NULL check.
>
I hate these patches. I have told Markus to stop sending them but he
has issues so now I only complain when they introduce a bug. There was
on
On Wed, Jul 15, 2015 at 10:04:08PM -0400, Sreenath Madasu wrote:
> This one of the TODO tasks for staging rtl8188eu driver. I have removed
> the code referring to channel > 14 for rtw_ap.c, rtw_ieee80211.c and
> rtw_mlme.c files. Please review.
Your patch will give a new build warning:
warning: unu
60 matches
Mail list logo