[PATCHv4 2/2] staging: ion: debugfs to shrink pool

2015-07-05 Thread Gioh Kim
This patch enables debugfs file /sys/kernel/debug/ion/heaps/system_shrink to shrink pool and get pool size. This technically enables debugfs shrinking for all heaps, not just the system heap although the system heap is the only one with a shrinker right now. It is already implemented but not comple

[PATCHv4 0/2] staging: ion: enable shrinking of pool

2015-07-05 Thread Gioh Kim
Hello, The ion has internal page pool to keep freed pages. There is no way to shrink the pool so that the pool sometimes grows too big. For example my platform allocates some graphic memory via ion. Sometimes the pool can be several hundreds MB. I want to flush the pool before critical page short

[PATCHv4 1/2] staging: ion: shrink page-pool by page unit

2015-07-05 Thread Gioh Kim
This patch shrink page-pool by page unit. The system shrinker calls ion_heap_shrink_count() to get nr_to_scan, and pass it to ion_heap_shrink_scan(). The problem is the return value of ion_heap_shrink_count() is the number of pages but ion_system_heap_shrink(), which is called by ion_heap_shrink_s

Re: [PATCH] defines modified to match the 80-char rule

2015-07-05 Thread Krzysztof HaƂasa
Joe Perches writes: > Nah, you're not an extremist, you're just preferring narrowly > localized readability over global consistency. > > That's fine and all, until you come up to LCONSOLE_ERROR_MSG > type use which blows the nice old formatting up. > > So what I suggested is just a simple consist

Re: [PATCH] staging: board: Kconfig: Let STAGING_BOARD depend on CLKDEV_LOOKUP

2015-07-05 Thread Chen Gang
On 07/06/2015 06:48 AM, Stephen Rothwell wrote: > Hi all, > > On Sun, 5 Jul 2015 18:57:51 +0200 Geert Uytterhoeven > wrote: >> >> On Sat, Jul 4, 2015 at 11:35 PM, Chen Gang >> wrote: >>> It needs clk_add_alias() from clk drivers, which is implemented in >>> "drivers/clk/clkdev.c" which depends

Re: [PATCH] staging: board: Kconfig: Let STAGING_BOARD depend on CLKDEV_LOOKUP

2015-07-05 Thread Stephen Rothwell
Hi all, On Sun, 5 Jul 2015 18:57:51 +0200 Geert Uytterhoeven wrote: > > On Sat, Jul 4, 2015 at 11:35 PM, Chen Gang > wrote: > > It needs clk_add_alias() from clk drivers, which is implemented in > > "drivers/clk/clkdev.c" which depends on CLKDEV_LOOKUP. > > > > Normally, archs and clk driver i

[PATCH] staging: dgnc: Replace macro with flow control statement by a function

2015-07-05 Thread Arjun Krishna Babu
This patch fixes the checkpatch.pl warning: WARNING: Macros with flow control statements should be avoided Replace the macro with a function doing the exact same task as the macro. Signed-off-by: Arjun Krishna Babu --- drivers/staging/dgnc/dgnc_sysfs.c | 22 ++ 1 file chang

Re: [PATCH] staging: board: Kconfig: Let STAGING_BOARD depend on CLKDEV_LOOKUP

2015-07-05 Thread Geert Uytterhoeven
On Sat, Jul 4, 2015 at 11:35 PM, Chen Gang wrote: > It needs clk_add_alias() from clk drivers, which is implemented in > "drivers/clk/clkdev.c" which depends on CLKDEV_LOOKUP. > > Normally, archs and clk driver its own will decide whether select > CLKDEV_LOOKUP, and common drivers will decide whet