The virtpci driver is being rewritten, so remove the driver from the staging
tree.
Signed-off-by: Benjamin Romer
Reviewed-by: Don Zickus
Reviewed-by: Jes Sorensen
---
drivers/staging/unisys/Kconfig |1 -
drivers/staging/unisys/Makefile |1 -
drivers/staging/unisys/vi
This module is being removed completely, because it contained wrapper functions
and utility functions that were used in virtpci and virthba. Since these two
drivers are being rewritten to not use these wrappers and utilities, uislib
needs to go.
Signed-off-by: Benjamin Romer
Reviewed-by: Don Zick
The virthba driver is being rewritten and will be renamed to visorhba, so delete
the old driver from the source tree.
Signed-off-by: Benjamin Romer
Reviewed-by: Don Zickus
Reviewed-by: Jes Sorensen
---
drivers/staging/unisys/Kconfig |1 -
drivers/staging/unisys/Makefile
We need to remove the old bus model so it can be replaced with a better design.
By removing virthba and virtpci, we can eliminate uislib as well, which will
get rid of many undesirable wrapper and library functions.
These removals will be followed with the addition of a replacement driver called
v
On 14.04.2015 00:33, Dan Carpenter wrote:
> On Tue, Apr 14, 2015 at 12:15:57AM +0200, Mateusz Kulikowski wrote:
>> I made checkpatch regressions in v1 (that I missed at a time)
>
> As near as I can tell the only difference is that you left some curly
> braces in on patch 8 of first set and removed
On 08.04.2015 01:08, Mateusz Kulikowski wrote:
> This series of patches fixes another set of checkpatch.pl warnings.
>
Please ignore this patchset and use v2 once it is reviewed.
Best Regards,
Mateusz
___
devel mailing list
de...@linuxdriverproject.org
On Tue, Apr 14, 2015 at 12:15:57AM +0200, Mateusz Kulikowski wrote:
> I made checkpatch regressions in v1 (that I missed at a time)
As near as I can tell the only difference is that you left some curly
braces in on patch 8 of first set and removed them on the second set.
It's not worth resending t
If remaining space in a send buffer slot is too small for the whole message,
we only copy the RNDIS header and PPI data into send buffer, so we can batch
one more packet each time. It reduces the vmbus per-message overhead.
Signed-off-by: Haiyang Zhang
Reviewed-by: K. Y. Srinivasan
---
drivers/
On 14.04.2015 00:12, Dan Carpenter wrote:
> I don't know why you are doing a v2. I went back to the original thread
> and I see that no one complained about it.
>
> Since no one replied to v1 thread, then probably Greg is going to apply
> that one first because it is first in his inbox. Greg's i
I don't know why you are doing a v2. I went back to the original thread
and I see that no one complained about it.
Since no one replied to v1 thread, then probably Greg is going to apply
that one first because it is first in his inbox. Greg's inbox has
millions and millions of emails so he won't
Use dedicated macro to compare ethernet addresses in probe_rq_parse().
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib_softmac.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192e/rtllib_softmac.c
b/drivers/staging/rtl8192e/rtlli
Rework some conditions to bail out of functions faster therby
decreasing overall indent. This patch should not cause any negative
side effect (except for different execution time).
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c | 8 +-
drivers/staging/rtl8
Simplify function to make checkpatch.pl happy. Changes:
- Helper variables used
- Conditions were rephrased to return quickly (and decrease indent).
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c | 111 -
1 file changed, 53 insertions
Fix most of remaining PREFER_PR_LEVEL warnings in rtllib.
Replace printk() with pr_* where possible.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib.h| 4 +-
drivers/staging/rtl8192e/rtllib_crypt.c | 17
drivers/staging/rtl8192e/rtllib_crypt_tkip.
rtl8192_pci_findadapter() was looking for invalid DeviceID (0x8172),
instead of proper for rtl8192e/se devices (0x8192)
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/rtl_pci.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192e/r
Further reduction of checkpatch.pl LONG_LINE warnings:
- Local variables are compacted where it's needed
- Helper (local) variables are used (to avoid expressions like a.b.c.d.e)
Both changes should be optimized out by compilers.dd
Signed-off-by: Mateusz Kulikowski
---
.../staging/rtl8192e/rtl8
Replace temporary conditional (?:) with ordinary condition or max_t.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/rtl_dm.c | 30 +-
drivers/staging/rtl8192e/rtllib_rx.c | 2 +-
2 files changed, 22 insertions(+), 10 deletions(-)
diff
Remove the following private variables:
- force_mic_error - changes force_mic_error that is not used
- radio - changes sw_radio_on that is not used
- adhoc_peer_list - unimplemented
- firm_ver - unimplemented
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 1
Simplify function to make checkpatch.pl happy. Changes:
- Helper variables used
- Local variable names compacted
- Conditions were rephrased to return quickly (and decrease indent).
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib_rx.c | 170 +
Take out MIFE_TYPE_HT_CAP processing into separate function -
rtllib_parse_mfie_ht_cap()
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib_rx.c | 50 +---
1 file changed, 29 insertions(+), 21 deletions(-)
diff --git a/drivers/staging/rtl8192e/
Move MFIE_TYPE_GENERIC handler to rtllib_parse_mife_generic() function.
Code was not altered significantly, therefore in some places it generates
LONG_LINE checkpatch.pl warnings.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib_rx.c | 365 +--
Fix most of simple LONG_LINE warnings. None of the changes should affect
behaviour of code, so several modifications are included in this patch:
- Code is reindented where needed
- Local variable names are compacted (priv -> p)
- Unnecessary casts are removed
- Nested ifs are replaced with logical
rtl8192e driver uses memcpy() to copy hw addresses in several places.
checkpatch.pl suggests to use ether_addr_copy(), but most of
addresses in driver may be unaligned.
This patch replaces all memcpy occurences with single macro therby
silencing checkpatch.pl (single complaints in macro remains).
r8192_priv structure had 2 big arrays with tx gain register values:
- cck_txbbgain_table
- cck_txbbgain_ch14_table
- txbbgain_table
This arrays were read-only - filled in driver init code and look
like firmware/chip-specific.
This patch removes them from r8192_priv and puts them in (global) varia
- Replace ?: with min_t
- Remove condition that is always true
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtllib_rx.c | 21 -
1 file changed, 8 insertions(+), 13 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib_rx.c
b/drivers/staging/rtl8192e/rt
Separate parts of dm_TXPowerTrackingCallback_TSSI() into two new functions:
- dm_tx_update_tssi_weak_signal()
- dm_tx_update_tssi_strong_signal()
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/rtl_dm.c | 180 +++--
1 file changed, 95 insertions(+)
Fix several SPACING errors to make checkpatch happy.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/r8192E_phy.c | 2 +-
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 6 +++---
drivers/staging/rtl8192e/rtl8192e/rtl_core.h | 6 +++---
drivers/staging/rtl8192e/rtllib_
This file is not used and its contents are duplicated in r8192E_phyreg.h.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/r819xE_phyreg.h | 908 --
1 file changed, 908 deletions(-)
delete mode 100644 drivers/staging/rtl8192e/rtl8192e/r819xE_phyreg.h
Trivial fix - add newline in dm_InitializeTXPowerTracking_TSSI()
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/rtl_dm.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_dm.c
b/drivers/staging/rtl8192e/rtl8192e/rtl_dm.c
index c99
Both files have the same contents (with the exception of comments).
One of them will not survive future commits.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/r8192E_phyreg.h | 92 ---
1 file changed, 65 insertions(+), 27 deletions(-)
diff --git a/d
Reformat r8192E_phyreg.h to make checkpatch happy.
Signed-off-by: Mateusz Kulikowski
---
drivers/staging/rtl8192e/rtl8192e/r8192E_phyreg.h | 1442 ++---
1 file changed, 721 insertions(+), 721 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_phyreg.h
b/drivers/
New cleanup patchset for rtl8192e. It fixes (mostly) checkpatch.pl warnings.
When applied, checkpatch.pl warning count drops to 34 (from ).
It should apply cleanly to staging-next/testing (c610f7f7) branches.
Series was smoke tested on rtl8192e card vs staging-next:
- Module load/unload
- Inte
On Mon, Apr 13, 2015 at 09:02:25PM -, Thomas Gleixner wrote:
> oz_timer_add() modifies the expiry value of an active timer, which
> results in data corruption.
>
> Use hrtimer_start() and remove the silly conditional.
>
> While at it use the proper helper function to convert milliseconds to
>
oz_timer_add() modifies the expiry value of an active timer, which
results in data corruption.
Use hrtimer_start() and remove the silly conditional.
While at it use the proper helper function to convert milliseconds to
ktime.
Signed-off-by: Thomas Gleixner
Cc: Shigekatsu Tateno
Cc: Greg Kroah-
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/globals.h | 11
.../unisys/visorchipset/visorchipset_main.c| 33 +++---
2 files changed, 17 insertions(+), 27 deletions(-)
diff --git a/driver
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/globals.h | 2 --
drivers/staging/unisys/visorchipset/visorchipset.h | 2 ++
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/file.c | 6 +++--
drivers/staging/unisys/visorchipset/file.h | 2 --
drivers/staging/unisys/visorchipset/globals.h | 29 --
.../unisys/vis
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/visorchipset.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/visorchipset.h
b/drivers/staging/unisys/visorchipset/visorchipset.h
index 38
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/visorchipset.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/visorchipset.h
b/drivers/staging/unisys/visorchipset/visorchipset.h
index 3c
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/visorchipset_main.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/visorchipset_main.c
b/drivers/staging/unisys/visorch
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
.../staging/unisys/visorchipset/visorchipset_main.c | 20
1 file changed, 12 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/visorchipset_main.c
b/drivers/staging
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
.../unisys/visorchipset/visorchipset_main.c| 36 +++---
1 file changed, 18 insertions(+), 18 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/visorchipset_main.c
b/drivers/stagin
From: Jes Sorensen
kmem_cache statistics are available through SLAB anyway
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/visorchipset_main.c | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/visorchipset_
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/visorchipset_main.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/visorchipset_main.c
b/drivers/staging/unisys/visorch
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/parser.c | 24 +++---
drivers/staging/unisys/visorchipset/parser.h | 8 +-
drivers/staging/unisys/visorchipset/visorchipset.h | 10 +--
.../unisys/visorchipset/visorchi
From: Jes Sorensen
struct visorcipset_device_info defines bus_no and dev_no as u32, while
the deprecated ulong type is 64 bits. Hence avoid promoting the values
to 64 bit just to truncate them again later.
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorc
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/file.c | 6 +++---
drivers/staging/unisys/visorchipset/parser.c | 16
drivers/staging/unisys/visorchipset/parser.h | 2 +-
3 files changed, 12 insertions(+), 12
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/visorchipset_main.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/visorchipset_main.c
b/drivers/staging/unisys/visorchipset/visorchip
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/visorchipset_umode.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/visorchipset_umode.h
b/drivers/staging/unisys/visor
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/visorchipset_main.c | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/visorchipset_main.c
b/drivers/staging/unisys/visorchipset/visorch
From: Jes Sorensen
visorchipset_bus_info.dev_no is only assigned the value of
controlvm_message_packet.create_bus.dev_count, which is a u32. No
point promoting it to a u64.
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/visorchipset.h | 3 +--
1
From: Jes Sorensen
Hi,
I did some cleanups of drivers/staging/unisys/visorchipset. There is
more to come, but this should improve the code, and also get rid of
some dead code that is no longer needed.
Thanks for Benjamin Romer @ Unisys for testing the changes.
Cheers,
Jes
Jes Sorensen (19):
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/file.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/file.c
b/drivers/staging/unisys/visorchipset/file.c
index
From: Jes Sorensen
Signed-off-by: Jes Sorensen
Tested-by: Benjamin Romer
---
drivers/staging/unisys/visorchipset/parser.h | 1 -
drivers/staging/unisys/visorchipset/visorchipset.h | 1 -
2 files changed, 2 deletions(-)
diff --git a/drivers/staging/unisys/visorchipset/parser.h
b/drivers
On Mon, Apr 13, 2015 at 01:25:15PM +0200, Peter Senna Tschudin wrote:
> Line 4677 of http://pastebin.com/2bi9Dg7k looks like a bug
>
> diff -u -p a/arch/powerpc/kernel/signal_32.c b/arch/powerpc/kernel/signal_32.c
> - regs->nip = (unsigned long) (unsigned long)ksig->ka.sa.sa_handler;
I don'
Line 4677 of http://pastebin.com/2bi9Dg7k looks like a bug
diff -u -p a/arch/powerpc/kernel/signal_32.c b/arch/powerpc/kernel/signal_32.c
- regs->nip = (unsigned long) (unsigned long)ksig->ka.sa.sa_handler;
On Mon, Apr 13, 2015 at 1:21 PM, Geert Uytterhoeven
wrote:
> Hi Peter,
>
> On Mon,
Hi Peter,
On Mon, Apr 13, 2015 at 1:14 PM, Peter Senna Tschudin
wrote:
>> Perhaps checkpatch should complain about casts outside header files?
> Cocinelle found 664 double casts:
> http://pastebin.com/2bi9Dg7k
>
> and 9 triple casts:
> http://pastebin.com/RkJhPTTV
I think double casts are only n
On Sun, Apr 12, 2015 at 5:38 PM, Geert Uytterhoeven
wrote:
> On Sun, Apr 12, 2015 at 3:48 PM, Peter Senna Tschudin
> wrote:
>> On Sun, Apr 12, 2015 at 3:05 PM, Geert Uytterhoeven
>> wrote:
>>> On Sun, Apr 12, 2015 at 11:26 AM, Peter Senna Tschudin
>>> wrote:
Sparse compalins about casting
Commit 96c1d0581d00f7abe033350edb021a9d947d8d81 ("Drivers: hv: vmbus: Add
support for VMBus panic notifier handler") introduced
atomic_notifier_chain_register() call on module load. We also need to call
atomic_notifier_chain_unregister() on module unload as otherwise the following
crash is observed
In case we do request_resource() in vmbus_acpi_add() we need to tear it down
to be able to load the driver again. Otherwise the following crash in observed
when hv_vmbus unload/load sequence is performed on a Generation2 instance:
[ 38.165701] BUG: unable to handle kernel paging request at f
"Drivers: hv: vmbus: introduce vmbus_acpi_remove" patch was sent a while ago
but it wasn't accepted as it collided with Jake's MMIO work. As this work is
still ongoing I suggest we have this small fix for the meantime in the mainline.
"Drivers: hv: vmbus: unregister panic notifier on module unload
On Mon, Apr 13, 2015 at 11:16:49AM +0200, Peter Senna Tschudin wrote:
> On Mon, Apr 13, 2015 at 11:10 AM, Dan Carpenter
> wrote:
> > On Sun, Apr 12, 2015 at 11:26:43AM +0200, Peter Senna Tschudin wrote:
> >> Sparse compalins about casting void * to u64 on i386.
> >> Change the cast to resource_siz
Greg, can you drop this one. I replied to the earlier thread.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Mon, Apr 13, 2015 at 11:10 AM, Dan Carpenter
wrote:
> On Sun, Apr 12, 2015 at 11:26:43AM +0200, Peter Senna Tschudin wrote:
>> Sparse compalins about casting void * to u64 on i386.
>> Change the cast to resource_size_t.
>>
>> Signed-off-by: Peter Senna Tschudin
>> ---
>>
>> Tested by compilati
On Sun, Apr 12, 2015 at 11:26:43AM +0200, Peter Senna Tschudin wrote:
> Sparse compalins about casting void * to u64 on i386.
> Change the cast to resource_size_t.
>
> Signed-off-by: Peter Senna Tschudin
> ---
>
> Tested by compilation only. Tested for x86 and x86_64.
>
> drivers/staging/goldf
Dan Carpenter writes:
> On Thu, Apr 09, 2015 at 10:38:32AM +0200, Vitaly Kuznetsov wrote:
>> ..., make it inline and rename it to hv_poll_channel() so it can be reused
>> in other hv_util modules.
>>
>
> The "...," is fine in the git log but I noticed recently that if you're
> reading patches in
As- Salaam Alaikum,
Pardon my intrusion; my name is Miss. Eisha Ghanem, daughter of Late Mr. Shukri
Ghanem whom was the former petroleum Minister of Libya.
I have an obscured business proposal that will be of mutual benefit to both of
us. In April 2012 my father was killed in Vienne, Austria b
67 matches
Mail list logo