free_channel() has been invoked in
vmbus_remove() -> hv_process_channel_removal(), or vmbus_remove() ->
... -> vmbus_close_internal() -> hv_process_channel_removal().
We also change to use list_for_each_entry_safe(), because the entry
is removed in hv_process_channel_removal().
Thank Dan Carpente
Remove conditional flock/aops code that was only for out-of-tree
vendor kernels but is not relevant for in-kernel code.
Signed-off-by: Andreas Dilger
---
drivers/staging/lustre/lustre/llite/llite_internal.h | 4
drivers/staging/lustre/lustre/llite/llite_lib.c | 8
drivers/st
On 03/27/2015 10:01 PM, J. German Rivera wrote:
Before this change, we were requiring a complete version match (major and
minor version numbers) between MC objects and corresponding drivers, to
allow MC objects to be bound to their drivers. We realized that a mismatch
in minor version numbers sho
On 03/27/2015 10:01 PM, J. German Rivera wrote:
This patch series includes some cleanup/refactoring and minor correction
patches for the Freescale fsl-mc bus driver.
Patch 1: Name MC object devices using decimal numbers
Patch 2: Removed reordering of MC objects during bus scan
Patch 3: Bind/unbi
On Wed, Apr 08, 2015 at 03:27:37PM +0300, Dan Carpenter wrote:
> On Wed, Apr 08, 2015 at 05:20:10PM +0530, Sudip Mukherjee wrote:
> > On Wed, Apr 08, 2015 at 02:38:32PM +0300, Dan Carpenter wrote:
> > > 1) We can't apply this patch on its own so this way of breaking up the
> > > patches doesn't wor
On Fri, 2015-03-27 at 00:26 -0700, K. Y. Srinivasan wrote:
> This patch-set addresses perf issues discovered on the Azure storage stack.
> These patches also fix a couple of bugs.
>
> As in the first version of this patch-set, some of the patches are simply a
> resend.
> I have bumped up the vers
Fixed error by removing space after open parenthesis '('
Problem found using checkpatch.pl
ERROR: space prohibited after that open parenthesis '('
Signed-off-by: Amitoj Kaur Chawla
---
drivers/staging/sm750fb/ddk750_chip.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/d
David Miller writes:
> From: Vitaly Kuznetsov
> Date: Wed, 8 Apr 2015 17:54:04 +0200
>
>> This patch series fixes the same issue which was fixed in Xen with commit
>> 97a6d1bb2b658ac85ed88205ccd1ab809899884d ("xen-netfront: Fix handling
>> packets on
>> compound pages with skb_linearize").
>
>
From: Vitaly Kuznetsov
Date: Wed, 8 Apr 2015 17:54:04 +0200
> This patch series fixes the same issue which was fixed in Xen with commit
> 97a6d1bb2b658ac85ed88205ccd1ab809899884d ("xen-netfront: Fix handling packets
> on
> compound pages with skb_linearize").
This patch series only applies on
> -Original Message-
> From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
> Sent: Wednesday, April 8, 2015 9:01 AM
> To: KY Srinivasan
> Cc: de...@linuxdriverproject.org; Haiyang Zhang; linux-
> ker...@vger.kernel.org; Dexuan Cui; Radim Krcmar; Greg Kroah-Hartman;
> linux-...@vger.kernel
KY Srinivasan writes:
>> -Original Message-
>> From: Vitaly Kuznetsov [mailto:vkuzn...@redhat.com]
>> Sent: Wednesday, March 11, 2015 6:29 AM
>> To: KY Srinivasan; de...@linuxdriverproject.org
>> Cc: Haiyang Zhang; linux-ker...@vger.kernel.org; Dexuan Cui; Radim Krcmar;
>> Greg Kroah-Hart
... which validly uses dev_kfree_skb_any() instead of dev_kfree_skb().
Setting ret to -EFAULT and -ENOMEM have no real meaning here (we need to set
it to anything but -EAGAIN) as we drop the packet and return NETDEV_TX_OK
anyway.
Signed-off-by: Vitaly Kuznetsov
---
drivers/net/hyperv/netvsc_drv
This patch series fixes the same issue which was fixed in Xen with commit
97a6d1bb2b658ac85ed88205ccd1ab809899884d ("xen-netfront: Fix handling packets on
compound pages with skb_linearize").
It is relatively easy to create a packet which is small in size but occupies
more than 30 (MAX_PAGE_BUFFER
In netvsc_start_xmit() we can handle packets which are scattered around not
more than MAX_PAGE_BUFFER_COUNT-2 pages. It is, however, easy to create a
packet which is not big in size but occupies more pages (e.g. if it uses frags
on compound pages boundaries). When we drop such packet it cases sende
On Wed, Apr 08, 2015 at 04:32:57PM +0300, Sergei Shtylyov wrote:
> Hello.
>
> On 4/8/2015 2:20 PM, Sudip Mukherjee wrote:
>
> >now that we are monitoring the return value from attach, make the
>
>So you've first changed the method prototype and follow up with
> the changes to the actual impl
Hello.
On 4/8/2015 2:20 PM, Sudip Mukherjee wrote:
now that we are monitoring the return value from attach, make the
So you've first changed the method prototype and follow up with the
changes to the actual implementations? That's backward. I'm afraid such
changes can't be done piecemeal
Remove some dead code that will never be executed or which serves no purpose
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/dgnc/dgnc_tty.c | 16
1 file changed, 16 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_tty.c b/drivers/staging/dgnc/dgnc_tty.c
index ce418
On Wed, Apr 08, 2015 at 08:09:03AM -0300, Mauro Carvalho Chehab wrote:
> Em Sun, 8 Feb 2015 20:55:36 +
> luisbg escreveu:
>
> > Improve code readability by moving out all pre-init values from the init
> > function.
> >
> > Signed-off-by: Luis de Bethencourt
> > ---
> > drivers/staging/medi
On Wed, Apr 08, 2015 at 05:20:10PM +0530, Sudip Mukherjee wrote:
> On Wed, Apr 08, 2015 at 02:38:32PM +0300, Dan Carpenter wrote:
> > 1) We can't apply this patch on its own so this way of breaking up the
> > patches doesn't work.
> yes, if the first patch is reverted for any reason all the others
On Wed, Apr 08, 2015 at 02:44:37PM +0300, Dan Carpenter wrote:
> On Wed, Apr 08, 2015 at 02:38:32PM +0300, Dan Carpenter wrote:
>
> Then we convert one driver to use the new function pointer and see if
> it simplifies the code. If so we can transition the others as well. If
> not then we give up
On Wed, Apr 08, 2015 at 02:38:32PM +0300, Dan Carpenter wrote:
> 1) We can't apply this patch on its own so this way of breaking up the
> patches doesn't work.
yes, if the first patch is reverted for any reason all the others need
to be reverted also. so then everything in one single patch?
>
> 2)
On Wed, Apr 08, 2015 at 02:38:32PM +0300, Dan Carpenter wrote:
> 1) We can't apply this patch on its own so this way of breaking up the
> patches doesn't work.
>
The right thing is to do add an attach_ret().
static int do_attach(drv)
{
if (drv->attach_ret)
return drv->att
1) We can't apply this patch on its own so this way of breaking up the
patches doesn't work.
2) I was thinking that all the ->attach() calls would have to succeed or
we would bail. Having some of them succeed and some fail doesn't seem
like it will simplify the driver code very much. But I can a
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
drivers/char/lp.c | 16 +++-
1 file changed, 11 insertions(+), 5 deletions(-)
diff --git a/drivers/char/lp.c b/drive
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
drivers/char/ppdev.c | 10 +++---
1 file changed, 7 insertions(+), 3 deletions(-)
diff --git a/drivers/char/ppdev.c b/driver
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
drivers/pps/clients/pps_parport.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/pps/clients/
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
drivers/i2c/busses/i2c-parport.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/i2c/busses/i2
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
drivers/pps/generators/pps_gen_parport.c | 9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/pps
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
drivers/spi/spi-lm70llp.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/spi/spi-lm70llp.c b/
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
also return the proper error code in module_init.
Signed-off-by: Sudip Mukherjee
---
drivers/net/plip/plip.c | 16 ++--
1 file changed, 10 insertions(+)
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
drivers/scsi/ppa.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/scsi/ppa.c b/drivers/scsi/ppa.
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
drivers/staging/panel/panel.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/pan
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
drivers/scsi/imm.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/scsi/imm.c b/drivers/scsi/imm.
as of now, we are not checking if attach or parport_register_driver
has succeeded or failed. But attach can fail in the places where they
have been used. Lets check the return of attach, and if attach fails
then parport_register_driver should also fail. We can have multiple
parallel port so we only
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
drivers/spi/spi-butterfly.c | 7 ---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/spi/spi-butterfly.
Currently we are not checking if attach has succeeded or not. Also
parport_register_driver() always return 0 even if attach fails.
But in many places where attach has been used, it can fail.
So, modified the parport code to check the return value of attach and
accordingly return either 0 or error c
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
sound/drivers/mts64.c | 13 -
1 file changed, 8 insertions(+), 5 deletions(-)
diff --git a/sound/drivers/mts64.c b/s
now that we are monitoring the return value from attach, make the
required changes to return proper value from its attach function.
Signed-off-by: Sudip Mukherjee
---
sound/drivers/portman2x4.c | 15 ++-
1 file changed, 10 insertions(+), 5 deletions(-)
diff --git a/sound/drivers/por
If memdup_user() fails then "pparmbuf" is an error pointer and we can't
pass it to kfree(). I changed the "goto _r871x_mp_ioctl_hdl_exit" to a
direct return.
I changed the earlier goto to a direct return as well for consistency
and removed the "pparmbuf = NULL" initializer since it's no longer
ne
Em Sun, 8 Feb 2015 20:55:36 +
luisbg escreveu:
> Improve code readability by moving out all pre-init values from the init
> function.
>
> Signed-off-by: Luis de Bethencourt
> ---
> drivers/staging/media/cxd2099/cxd2099.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff
On 7 April 2015 at 05:32, wrote:
> From: Micky Ching
>
> rts5250 chip failed handle 64 bit ADMA for address below 4G.
> Add 64 BIT quirks to disable this feature.
>
> Signed-off-by: Micky Ching
Thanks! Applied, with a minor updated commit message header.
Kind regards
Uffe
> ---
> drivers/mm
41 matches
Mail list logo