On Wed, 25 Feb 2015, 敬锐 wrote:
>
> On 02/16/2015 10:28 PM, Lee Jones wrote:
> >
> > +static int rts524a_optimize_phy(struct rtsx_pcr *pcr)
> > +{
> > + int err;
> > +
> > + err = rtsx_pci_write_register(pcr, RTS524A_PM_CTRL3,
> > + D3_DELINK_MODE_EN, 0x00);
> > + if (err < 0)
> >
From: Micky Ching
To enable/disable ASPM we should find LINK CONTROL register
in PCI config space. All old chip use 0x80 address, but new
chip may use another address, so we using pci_find_capability()
to get LINK CONTROL address.
rtsx_gops.c was removed, we consider to put some common operation
From: Micky Ching
pcr_dbg is a wrapper of dev_dbg, which can save some code,
and help to enable/disable debug message static.
Signed-off-by: Micky Ching
Acked-by: Lee Jones
---
drivers/mfd/rtl8411.c | 11 +--
drivers/mfd/rts5209.c | 4 ++--
drivers/mfd/rts5227.c | 4 ++--
drivers
From: Micky Ching
add support for new chip rts524A.
Signed-off-by: Micky Ching
---
drivers/mfd/rts5249.c| 186 ---
drivers/mfd/rtsx_pcr.c | 25 +-
drivers/mfd/rtsx_pcr.h | 7 ++
include/linux/mfd/rtsx_pci.h | 132 ++
From: Micky Ching
Update some phy register name and value for rts5249,
the updated value makes chip more stable on some platform.
Signed-off-by: Micky Ching
---
drivers/mfd/rts5249.c| 29 +++-
include/linux/mfd/rtsx_pci.h | 109 ++-
2 fi
From: Micky Ching
add support for new chip rts525A.
Signed-off-by: Micky Ching
---
drivers/mfd/rts5249.c| 103 +++
drivers/mfd/rtsx_pcr.c | 13 --
drivers/mfd/rtsx_pcr.h | 1 +
include/linux/mfd/rtsx_pci.h | 15 +++
4 file
From: Micky Ching
It is more readable to place register address and values define
togather. The values define add two leading space indicate belong
to the register address defined above.
Signed-off-by: Micky Ching
Acked-by: Lee Jones
---
include/linux/mfd/rtsx_pci.h | 836 +++-
From: Micky Ching
update card drive settings, This setting can be used for rts5249
rts524A and rts525A.
Signed-off-by: Micky Ching
Acked-by: Lee Jones
---
drivers/mfd/rts5249.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/mfd/rts5249.c b/drivers/mfd
From: Micky Ching
v3:
- define member pcr->reg_pm_ctrl3 for PM_CTRL3 address
- update phy register without change the indent
- define macro for switch output voltage
resend:
- add lee jones ack for some patch.
v2:
- remove debug info when access failed.
- using macro list for phy register init.
From: Micky Ching
PETXCFG is defined at 0xFF03, the old 0xFE49 not used any more.
Signed-off-by: Micky Ching
Acked-by: Lee Jones
---
drivers/mfd/rts5227.c| 6 ++
drivers/mfd/rts5249.c| 6 ++
include/linux/mfd/rtsx_pci.h | 2 +-
3 files changed, 5 insertions(+), 9 delet
From: Micky Ching
Re-format coding-style, using uniform SPC after "#define" keyword
instead of mixing using TAB and SPC.
Signed-off-by: Micky Ching
Acked-by: Lee Jones
---
include/linux/mfd/rtsx_pci.h | 254 +--
1 file changed, 127 insertions(+), 127 de
This changes us using the incorrect error,-ETIMEOUT when checking if
the channel we are allocating to on the device structure pointer passed
to this function is greater then the maximum available channels for this
device to the correct error for a channel being out of range,-ECHRNG.
Signed-off-b
On 02/16/2015 10:28 PM, Lee Jones wrote:
>
> +static int rts524a_optimize_phy(struct rtsx_pcr *pcr)
> +{
> + int err;
> +
> + err = rtsx_pci_write_register(pcr, RTS524A_PM_CTRL3,
> + D3_DELINK_MODE_EN, 0x00);
> + if (err < 0)
> + return err;
> +
> + rtsx_pci
Fix checkpatch.ph errors "space prohibited between function name and
open parenthesis" in socklnd.h
Signed-off-by: Adrien Descamps
---
.../staging/lustre/lnet/klnds/socklnd/socklnd.h| 130 ++---
1 file changed, 65 insertions(+), 65 deletions(-)
diff --git a/drivers/staging/l
On Fri, Feb 20, 2015 at 06:43:53PM +0530, Tapasweni Pathak wrote:
> To avoid deadlock, do not call blocking functions with spinlocks held.
>
> Replace GFP_KERNEL with GFP_ATOMIC, as the latter will fail if the pile
> doesn't have enough free pages but will not sleep and hence deadlock can
> be avo
This fixes the following checkpatch.pl warnings:
WARNING: min() should probably be min_t()
---
drivers/staging/dgnc/dgnc_neo.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/dgnc/dgnc_neo.c b/drivers/staging/dgnc/dgnc_neo.c
index c9a8a98..1268aa9 100644
--- a/d
On Tue, Feb 24, 2015 at 11:00:31PM +0200, Ameen Ali wrote:
> else if at line 406 has the same condition as the else if at line 404.
>
The changelog should really say why you think 0x5 is correct. Could you
update and resend?
regards,
dan carpenter
__
else if at line 406 has the same condition as the else if at line 404.
Signed-off-by : Ameen Ali
---
drivers/staging/rtl8188eu/hal/Hal8188ERateAdaptive.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/hal/Hal8188ERateAdaptive.c
b/drivers/staging/rt
On Tue, Feb 24, 2015 at 11:21:37AM -0800, Greg KH wrote:
> On Tue, Feb 24, 2015 at 07:15:11PM +, Daniel Lockyer wrote:
> > On Tue, Feb 24, 2015 at 09:56:39AM -0800, Greg KH wrote:
> > > On Tue, Feb 24, 2015 at 05:53:55PM +, Daniel Lockyer wrote:
> > > > Fixed a coding style issue.
> > > >
On Tue, Feb 24, 2015 at 07:15:11PM +, Daniel Lockyer wrote:
> On Tue, Feb 24, 2015 at 09:56:39AM -0800, Greg KH wrote:
> > On Tue, Feb 24, 2015 at 05:53:55PM +, Daniel Lockyer wrote:
> > > Fixed a coding style issue.
> > >
> > > Signed-off-by: Daniel Lockyer
> > > ---
> > > drivers/stagi
On Tue, Feb 24, 2015 at 09:56:39AM -0800, Greg KH wrote:
> On Tue, Feb 24, 2015 at 05:53:55PM +, Daniel Lockyer wrote:
> > Fixed a coding style issue.
> >
> > Signed-off-by: Daniel Lockyer
> > ---
> > drivers/staging/wlan-ng/hfa384x.h | 1 +
> > 1 file changed, 1 insertion(+)
> >
> > diff -
On Sat, 2015-02-21 at 13:16 +0100, Jean Delvare wrote:
> Signed-off-by: Jean Delvare
> Cc: Benjamin Romer
> Cc: David Kershner
> Cc: Greg Kroah-Hartman
> ---
> This is an humble proposal if you like it. I don't use the driver
> myself, I don't even know what it is for ;-)
>
I like this idea a
On Tue, Feb 24, 2015 at 05:53:55PM +, Daniel Lockyer wrote:
> Fixed a coding style issue.
>
> Signed-off-by: Daniel Lockyer
> ---
> drivers/staging/wlan-ng/hfa384x.h | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/drivers/staging/wlan-ng/hfa384x.h
> b/drivers/staging/wlan-ng/hfa38
Fixed a coding style issue.
Signed-off-by: Daniel Lockyer
---
drivers/staging/wlan-ng/hfa384x.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/wlan-ng/hfa384x.h
b/drivers/staging/wlan-ng/hfa384x.h
index 8f20910..3bb8c1b 100644
--- a/drivers/staging/wlan-ng/hfa384x.h
+++ b/d
Convert this driver to use the comedi_8254 module to provide the 8254 timer
support.
Add 'clock_src' and 'gate_src' members to the comedi_8254 data for convienence.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
v3: As pointed out by Ian Abbott, fix the 'offset' us
On Tuesday, February 24, 2015 6:20 AM, Ian Abbott wrote:
> On 23/02/15 21:58, H Hartley Sweeten wrote:
>> Convert this driver to use the comedi_8254 module to provide the 8254 timer
>> support.
>>
>> Add 'clock_src' and 'gate_src' members to the comedi_8254 data for
>> convienence.
>>
>> Signed-o
From: Matteo Semenzato
This patch fixes the following error:
Do not use C99 // comments
Signed-off-by: Matteo Semenzato
---
drivers/staging/fbtft/fb_ssd1331.c | 30 +++---
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ssd1331.c
From: Matteo Semenzato
This patch fixes the following errors:
Code indent should use tabs where possible
Space prohibited before that ','
Signed-off-by: Matteo Semenzato
---
drivers/staging/fbtft/fbtft-core.c | 2 +-
drivers/staging/fbtft/fbtft.h | 8
2 files changed, 5 insertion
On 23/02/15 20:22, H Hartley Sweeten wrote:
The "stalled" variable this function is used to detect if the DMA operation
is stalled while trying to disable DMA on a full comedi sample. The reset
of this variable should only occur when the remaining bytes of the DMA
transfer does not equal the rema
On 23/02/15 21:57, H Hartley Sweeten wrote:
This series introduces a new module. comedi_8254, to support the 8254 timer
devices that are commonly found on data acquisition card. This module replaces
the current support provided by the inline functions in 8253.h and consolidates
the subdevice supp
On 23/02/15 21:58, H Hartley Sweeten wrote:
Convert this driver to use the comedi_8254 module to provide the 8254 timer
support.
Add 'clock_src' and 'gate_src' members to the comedi_8254 data for convienence.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
v2: no
Fixes: 817bd7253291 ("dma-buf: cleanup dma_buf_export() to make it
easily extensible")
Stupid copy-paste from me in the above patch leads to the following static
checker warning:
drivers/staging/android/ion/ion.c:1112 ion_share_dma_buf()
error: potentially dereferencing uninitiali
On 23/02/15 22:13, H Hartley Sweeten wrote:
During the attach of this driver a couple commands are sent to the hardware
with usb_bulk_msg() to read the firmware version information. This information
is then dumped as dev_info() kernel messages. Thee messages are just added
noise and don't effect
The regmap_config struct may be const because it is not modified by the
driver and regmap_init() accepts pointer to const.
Signed-off-by: Krzysztof Kozlowski
---
drivers/iio/light/jsa1212.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/iio/light/jsa1212.c b/drivers/
The regmap_access_table and regmap_config structures may be const
because they are not modified by the driver and regmap_init() accepts
pointer to const.
Signed-off-by: Krzysztof Kozlowski
---
drivers/staging/iio/magnetometer/hmc5843_i2c.c | 8
drivers/staging/iio/magnetometer/hmc5843_s
35 matches
Mail list logo