Re: [PATCH 1/1] Staging: i2o: i2o_scsi: Fixed coding style issue

2015-02-18 Thread Dan Carpenter
Also you sent three patches with the exact same subject. Don't do that. The subject should be more specific. Also the word "fix" is sort of reserved for actual fixes, this is a cleanup. The tutorials all suggest terrible subjects so everyone makes these mistakes. regards, dan carpenter ___

Re: [PATCH 1/1] Staging: i2o: i2o_scsi: Fixed coding style issue

2015-02-18 Thread Dan Carpenter
On Wed, Feb 18, 2015 at 04:45:50PM -0800, Tolga Ceylan wrote: > Removed assignment in if condition > This patch looks good, but it's not really worth cleaning up i2o. We just moved it to staging to see if anyone noticed that it was gone. Next kernel release we want to delete it entirely. regard

[PATCH 2/2] Staging: i2o: i2o_block: Fixed coding style issue

2015-02-18 Thread Tolga Ceylan
1) Spaces prohibited after that '&' 2) No space is necessary after a cast Signed-off-by: Tolga Ceylan --- drivers/staging/i2o/i2o_block.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/i2o/i2o_block.c b/drivers/staging/i2o/i2o_block.c index 9164569..a8f94

[PATCH 1/2] Staging: i2o: i2o_block: Fixed coding style issue

2015-02-18 Thread Tolga Ceylan
"u32 ** mptr" should be "u32 **mptr" Signed-off-by: Tolga Ceylan --- drivers/staging/i2o/i2o_block.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/i2o/i2o_block.c b/drivers/staging/i2o/i2o_block.c index 0a13c64..9164569 100644 --- a/drivers/staging/i2o/i2o_b

[PATCH 1/1] Staging: i2o: i2o_scsi: Fixed coding style issue

2015-02-18 Thread Tolga Ceylan
Removed assignment in if condition Signed-off-by: Tolga Ceylan --- drivers/staging/i2o/i2o_scsi.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/i2o/i2o_scsi.c b/drivers/staging/i2o/i2o_scsi.c index 1b11dcb..f320366 100644 --- a/drivers/staging/i2o/i2o_scsi

[3.13.y-ckt stable] Patch "x86, hyperv: Mark the Hyper-V clocksource as being continuous" has been added to staging queue

2015-02-18 Thread Kamal Mostafa
This is a note to let you know that I have just added a patch titled x86, hyperv: Mark the Hyper-V clocksource as being continuous to the linux-3.13.y-queue branch of the 3.13.y-ckt extended stable tree which can be found at: http://kernel.ubuntu.com/git?p=ubuntu/linux.git;a=shortlog;h=re

[PATCH 3.13.y-ckt 095/103] x86, hyperv: Mark the Hyper-V clocksource as being continuous

2015-02-18 Thread Kamal Mostafa
3.13.11-ckt16 -stable review patch. If anyone has any objections, please let me know. -- From: "K. Y. Srinivasan" commit 32c6590d126836a062b3140ed52d898507987017 upstream. The Hyper-V clocksource is continuous; mark it accordingly. Signed-off-by: K. Y. Srinivasan Acked-by:

[PATCH 1/1] Lustre: single statement macros should not use do {} while (0)

2015-02-18 Thread Mario J. Rugiero
This fixes all appearances of the warning but one, as that one seems to be intentional: WARNING: Single statement macros should not use a do {} while (0) loop #1221: FILE: lustre/include/lustre_dlm.h:1221: +#define LDLM_LOCK_RELEASE(lock) \ +do {

[PATCH v2 1/4] staging: unisys: declare visorchipset_ioctl static

2015-02-18 Thread Frederico Cadete
This symbol is not exported nor referenced anywhere else in the kernel. Signed-off-by: Frederico Cadete --- drivers/staging/unisys/visorchipset/file.c | 6 -- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/drivers/staging/unisys/visorchipset/file.c b/drivers/staging/unisys/vi

[PATCH v2 0/4] staging: unisys: a few checkpatch fixes

2015-02-18 Thread Frederico Cadete
Here are a few fixes of style warnings detected by checkpatch.pl in drivers/staging/unisys. Compared to v1 of the patch, changed the name of the structs in visorchipset_main.c to be lowercase, according to feedback from Dan Carpenter. Thanks, Dan. Regards, Frederico Cadete Frederico Cadete (4):

[PATCH v2 3/4] staging: unisys: style: Replace typedefs with structs in visorchipset_main.c

2015-02-18 Thread Frederico Cadete
Signed-off-by: Frederico Cadete --- .../unisys/visorchipset/visorchipset_main.c| 22 +++--- 1 file changed, 11 insertions(+), 11 deletions(-) diff --git a/drivers/staging/unisys/visorchipset/visorchipset_main.c b/drivers/staging/unisys/visorchipset/visorchipset_main.c in

[PATCH v2 4/4] staging: unisys: style: remove unnecessary braces

2015-02-18 Thread Frederico Cadete
Signed-off-by: Frederico Cadete --- drivers/staging/unisys/visorchannel/visorchannel_funcs.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/drivers/staging/unisys/visorchannel/visorchannel_funcs.c b/drivers/staging/unisys/visorchannel/visorchannel_funcs.c index 0188ef8

[PATCH v2 2/4] staging: unisys: remove unused MESSAGE_ENVELOPE typedef

2015-02-18 Thread Frederico Cadete
Signed-off-by: Frederico Cadete --- drivers/staging/unisys/visorchipset/visorchipset_main.c | 5 - 1 file changed, 5 deletions(-) diff --git a/drivers/staging/unisys/visorchipset/visorchipset_main.c b/drivers/staging/unisys/visorchipset/visorchipset_main.c index f606ee9..848afaa 100644 ---

RE: [PATCH 2/3] drivers:hv Convert VMBus and its descendants to PnP

2015-02-18 Thread Jake Oshins
> -Original Message- > From: Dan Carpenter [mailto:dan.carpen...@oracle.com] > Sent: Wednesday, February 18, 2015 2:24 AM > To: Jake Oshins > Cc: rafael.j.wyso...@intel.com; gre...@linuxfoundation.org; KY Srinivasan; > linux-ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.

[PATCH v2] Drivers: hv: hv_balloon: eliminate the trylock path in acquire/release_region_mutex

2015-02-18 Thread Vitaly Kuznetsov
When many memory regions are being added and automatically onlined the following lockup is sometimes observed: INFO: task udevd:1872 blocked for more than 120 seconds. ... Call Trace: [] schedule_timeout+0x22c/0x350 [] wait_for_common+0x10f/0x160 [] ? default_wake_function+0x0/0x20 [] wait_for

Re: [PATCH 2/3] drivers:hv Convert VMBus and its descendants to PnP

2015-02-18 Thread Dan Carpenter
On Tue, Feb 17, 2015 at 11:41:50AM -0800, Jake Oshins wrote: > > + ret = pnp_add_descendant(child_device_obj->pnp_dev); > if (ret) > + goto register_exit; > + > + added = TRUE; > + > + ret = pnp_activate_dev(child_device_obj->pnp_dev); > + > +register_exit: > + > +