Re: [PATCH v2] staging: lustre: fix coding style errors in drivers/staging/lustre/lustre/libcfs/linux/linux-proc.c

2015-02-08 Thread Dan Carpenter
On Sun, Feb 08, 2015 at 07:57:01PM +0200, Tal Shorer wrote: > Signed-off-by: Tal Shorer > --- > Decided not to #define the constants away because their addresses are > used later in the file. I don't understand what this means. > 1) The subject is crap (which coding style issues are you fixing

[PATCH v2 6/7] staging: ft1000: ft1000-usb: remove conditional statement

2015-02-08 Thread Pushpendra Singh
their is no statements for if condition, but else have so instead of using else condition ,use a single condition statement if(!qtype) Signed-off-by: Puhspendra Singh --- drivers/staging/ft1000/ft1000-usb/ft1000_debug.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/driver

[PATCH v2 7/7] staging: ft1000: ft1000-usb: remove unnecessary out of memory warning

2015-02-08 Thread Pushpendra Singh
Remove checkpatch.pl warning WARNING: Possible unnecessary 'out of memory' message + if (skb == NULL) { + pr_debug("No Network buffers available\n"); Signed-off-by: Pushpendra Singh --- drivers/staging/ft1000/ft1000-usb/ft1000_hw.c | 1 - 1 file changed, 1 deletion(-) diff -

[PATCH v2 5/7] staging: ft1000: ft1000-usb: removed unnecessary braces

2015-02-08 Thread Pushpendra Singh
Removed Checkpatch.pl warning WARNING: braces {} are not necessary for single statement blocks + if (dev->app_info[i].fileobject == NULL) { + break; + } Signed-off-by: Pushpendra Singh --- drivers/staging/ft1000/ft1000-usb/ft1000_debug.c | 9 +++-

[PATCH v2 1/7] staging: ft1000: ft1000-pcmcia: removed unnecessary braces

2015-02-08 Thread Pushpendra Singh
Remove checkpatch.pl warning WARNING: braces {} are not necessary for any arm of this statement + if (tempword & 0x1f) { [...] + } else { [...] Signed-off-by: Pushpendra Singh --- drivers/staging/ft1000/ft1000-pcmcia/ft1000_hw.c | 5 ++-

[PATCH v2 4/7] staging: ft1000: ft1000-usb: remove unnecessary parentheses

2015-02-08 Thread Pushpendra Singh
Remove checkpatch.pl warning WARNING: Unnecessary parentheses - maybe == should be = ? + if ((dev->app_info[i].fileobject == NULL)) Signed-off-by: Pushpendra Singh --- drivers/staging/ft1000/ft1000-usb/ft1000_debug.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH v2 2/7] staging: ft1000: ft1000-pcmcia: add blank line after declarations

2015-02-08 Thread Pushpendra Singh
Removed Checkpatch.pl warning WARNING: Missing a blank line after declarations + struct ft1000_info *ft_info; + ft_info = netdev_priv(dev); Signed-off-by: Pushpendra Singh --- drivers/staging/ft1000/ft1000-pcmcia/ft1000_hw.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH v2 3/7] staging: ft1000: ft1000-pcmcia: remove unnecessary parentheses

2015-02-08 Thread Pushpendra Singh
Remove checkpatch.pl warning WARNING: Unnecessary parentheses + if ((tempword != *ppseudohdr)) { Signed-off-by: Pushpendra Singh --- drivers/staging/ft1000/ft1000-pcmcia/ft1000_hw.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/ft1000/ft1000-pc

[PATCH] Staging: rtl8192u: r8190_rtl8256: coding style and format string type connections

2015-02-08 Thread Tolga Ceylan
Lines over 80 were corrected RT_TRACE format strings should specify unsigned instead of signed int Signed-off-by: Tolga Ceylan --- drivers/staging/rtl8192u/r8190_rtl8256.c | 244 ++- 1 file changed, 174 insertions(+), 70 deletions(-) diff --git a/drivers/staging/rtl8

Re: [PATCH 1/1] Staging: rtl8192u: Coding Style Improvements

2015-02-08 Thread Tolga Ceylan
Thank you, I'll resubmit this with additional corrections to format strings. On Sun, Feb 8, 2015 at 1:54 AM, Joe Perches wrote: > On Sun, 2015-02-08 at 01:49 -0800, Tolga Ceylan wrote: >> Lines over 80 were corrected > [] >> diff --git a/drivers/staging/rtl8192u/r8190_rtl8256.c >> b/drivers/stag

Re: Question regarding sparse warning in staging/lustre

2015-02-08 Thread Greg Kroah-Hartman
On Sun, Feb 08, 2015 at 10:27:23PM +0100, Adrian Remonda wrote: > Hello, > > I'm cleaning the drivers/staging/lustre driver. > I have got the next warning from sparse: > > drivers/staging/lustre/lnet/selftest//conctl.c:918:30: warning: incorrect > type in argument 1 (different address spaces) >

[PATCH] media: bcm2048: remove unused return of function

2015-02-08 Thread Luis de Bethencourt
Integer return of bcm2048_parse_rds_rt () is never used, changing the return type to void. Signed-off-by: Luis de Bethencourt --- drivers/staging/media/bcm2048/radio-bcm2048.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/staging/media/bcm2048/radio-bcm2048.c b/

Question regarding sparse warning in staging/lustre

2015-02-08 Thread Adrian Remonda
Hello, I'm cleaning the drivers/staging/lustre driver. I have got the next warning from sparse: drivers/staging/lustre/lnet/selftest//conctl.c:918:30: warning: incorrect type in argument 1 (different address spaces) drivers/staging/lustre/lnet/selftest//conctl.c:918:30:expected void [nodere

[PATCH] media: cxd2099: move pre-init values out of init()

2015-02-08 Thread luisbg
Improve code readability by moving out all pre-init values from the init function. Signed-off-by: Luis de Bethencourt --- drivers/staging/media/cxd2099/cxd2099.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/media/cxd2099/cxd2099.c b/drivers/staging/med

[PATCH v2] staging: iio: trigger: iio-trig-periodic-rtc: Change frequency type to unsigned int

2015-02-08 Thread Rickard Strandqvist
Change struct iio_prtc_trigger_info frequency type from int to unsigned int. Since it is always treated as such in the driver so they type should probably reflect this. Signed-off-by: Rickard Strandqvist --- drivers/staging/iio/trigger/iio-trig-periodic-rtc.c | 12 +--- 1 file changed,

[PATCH v2] staging: lustre: fix coding style errors in drivers/staging/lustre/lustre/libcfs/linux/linux-proc.c

2015-02-08 Thread Tal Shorer
Signed-off-by: Tal Shorer --- Decided not to #define the constants away because their addresses are used later in the file. drivers/staging/lustre/lustre/libcfs/linux/linux-proc.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/lustre/lustre/libcfs/linux/lin

Re: [PATCH] staging:lustre:libcfs:linux: Define insert_proc and remove_proc in separate header file

2015-02-08 Thread Greg KH
On Sun, Feb 08, 2015 at 09:26:15PM +0800, Matthew Tyler wrote: > Sparse is currently throwing warnings as insert_proc and remove_proc > are not defined. > > The patch adds definitions for these files in a suitable header file. > > These only seem to be exported by one location - libcfs/module.c

[PATCH] staging:lustre:libcfs:linux: Define insert_proc and remove_proc in separate header file

2015-02-08 Thread Matthew Tyler
Sparse is currently throwing warnings as insert_proc and remove_proc are not defined. The patch adds definitions for these files in a suitable header file. These only seem to be exported by one location - libcfs/module.c Can we remove the export and import from the header? Signed-off-by: Matt

Re: [PATCH] staging: iio: adc: mxs-lradc: Change type in printf format string

2015-02-08 Thread Jonathan Cameron
On 27/01/15 22:59, Marek Vasut wrote: > On Tuesday, January 27, 2015 at 11:23:33 PM, Rickard Strandqvist wrote: >> Wrong type in printf format string, requires 'int' >> but the argument type is 'unsigned int' >> >> This was found using a static code analysis program called cppcheck >> >> Signed-off

Re: [PATCH] staging: iio: resolver: ad2s1210: Change type in printf format string

2015-02-08 Thread Jonathan Cameron
On 27/01/15 22:22, Rickard Strandqvist wrote: > Wrong type in printf format string, requires 'int' > but the argument type is 'unsigned int' > > This was found using a static code analysis program called cppcheck > > Signed-off-by: Rickard Strandqvist Finally one I don't already have a fix in pl

Re: [PATCH] staging: iio: magnetometer: hmc5843_core: Change type in printf format string

2015-02-08 Thread Jonathan Cameron
On 27/01/15 22:21, Rickard Strandqvist wrote: > Wrong type in printf format string, requires 'int' > but the argument type is 'unsigned int' > > This was found using a static code analysis program called cppcheck > > Signed-off-by: Rickard Strandqvist This one is fixed to I'm afraid. Very bad l

Re: [PATCH] staging: iio: light: tsl2x7x_core: Change type in printf format string

2015-02-08 Thread Jonathan Cameron
On 27/01/15 22:20, Rickard Strandqvist wrote: > Wrong type in printf format string, requires 'int' > but the argument type is 'unsigned int' > > This was found using a static code analysis program called cppcheck > > Signed-off-by: Rickard Strandqvist Another one with a fix already in place. > -

Re: [PATCH] staging: iio: light: tsl2583: Change type in printf format string

2015-02-08 Thread Jonathan Cameron
On 27/01/15 22:19, Rickard Strandqvist wrote: > Wrong type in printf format string, requires 'int' > but the argument type is 'unsigned int' > > This was found using a static code analysis program called cppcheck > > Signed-off-by: Rickard Strandqvist This one is already fixed as well I'm afraid

Re: [PATCH] staging: iio: impedance-analyzer: ad5933: Change type in printf format string

2015-02-08 Thread Jonathan Cameron
On 27/01/15 22:18, Rickard Strandqvist wrote: > Wrong type in printf format string, requires 'int' > but the argument type is 'unsigned int' > > This was found using a static code analysis program called cppcheck > > Signed-off-by: Rickard Strandqvist Sorry, you were beaten to this one by Asaf V

Re: [PATCH] staging: iio: trigger: iio-trig-periodic-rtc: Change type in printf format string

2015-02-08 Thread Jonathan Cameron
On 27/01/15 21:32, Rickard Strandqvist wrote: > Wrong type in printf format string, requires 'unsigned int' > but the argument type is 'int' > > This was found using a static code analysis program called cppcheck > > Signed-off-by: Rickard Strandqvist Whilst you have identified a bug, I think th

Re: [PATCH 1/1] Staging: iio: Coding style correction

2015-02-08 Thread Jonathan Cameron
On 08/02/15 07:40, Tolga Ceylan wrote: > Line over 80 characters corrected > > Signed-off-by: Tolga Ceylan Applied, again with an amended patch title to reflect the driver it is changing rather that simply the subsystem. > --- > drivers/staging/iio/meter/ade7854-i2c.c | 3 ++- > 1 file changed,

Re: [PATCH 1/1] Staging: iio: Coding Style Correction

2015-02-08 Thread Jonathan Cameron
On 08/02/15 08:04, Tolga Ceylan wrote: > Indentation corrections in struct initializations and > one line over 80 characters split into two lines > > Signed-off-by: Tolga Ceylan Whilst I find it hard to be inspired by these sort of patches, you have presented the patch well and it's entirely sens

Re: [PATCH 1/2] staging: unisys: remove unused variable

2015-02-08 Thread Sudip Mukherjee
On Sat, Feb 07, 2015 at 05:22:16PM +0800, Greg Kroah-Hartman wrote: > On Fri, Feb 06, 2015 at 06:13:21PM +0530, Sudip Mukherjee wrote: > > we were getting lots of warnings about _tempresult set but not used. > > _tempresult was used in the macro ISSUE_IO_VMCALL_POSTCODE_SEVERITY > > which was again

[PATCH] staging: lustre: Make the function 'llog_cat_process_cb' static

2015-02-08 Thread Arjun AK
This patch defines the function 'llog_cat_process_cb' as static Signed-off-by: Arjun AK --- drivers/staging/lustre/lustre/obdclass/llog_cat.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/staging/lustre/lustre/obdclass/llog_cat.c b/drivers/staging/lustre/lustr

Re: [PATCH 1/1] Staging: rtl8192u: Coding Style Improvements

2015-02-08 Thread Joe Perches
On Sun, 2015-02-08 at 01:49 -0800, Tolga Ceylan wrote: > Lines over 80 were corrected [] > diff --git a/drivers/staging/rtl8192u/r8190_rtl8256.c > b/drivers/staging/rtl8192u/r8190_rtl8256.c [] > @@ -37,43 +37,71 @@ void PHY_SetRF8256Bandwidth(struct net_device *dev, > HT_CHANNEL_WIDTH Bandwidth)

[PATCH 1/1] Staging: rtl8192u: Coding Style Improvements

2015-02-08 Thread Tolga Ceylan
Lines over 80 were corrected Signed-off-by: Tolga Ceylan --- drivers/staging/rtl8192u/r8190_rtl8256.c | 244 ++- 1 file changed, 174 insertions(+), 70 deletions(-) diff --git a/drivers/staging/rtl8192u/r8190_rtl8256.c b/drivers/staging/rtl8192u/r8190_rtl8256.c index

[PATCH 1/1] Staging: iio: Coding Style Correction

2015-02-08 Thread Tolga Ceylan
Indentation corrections in struct initializations and one line over 80 characters split into two lines Signed-off-by: Tolga Ceylan --- drivers/staging/iio/magnetometer/hmc5843_i2c.c | 34 +- 1 file changed, 17 insertions(+), 17 deletions(-) diff --git a/drivers/staging/i