As the if and else branch body are identical the condition has no effect and
can be dropped.
Signed-off-by: Nicholas Mc Guire
---
As the if and the else branch of the inner conditional paths are the same
the condition is without effect. Given the comments indicate that
the else branch *should*
On Wed, Jan 21, 2015 at 1:12 PM, Romer, Benjamin M
wrote:
> Hi,
>
> I've built and tested your set of patches on an s-Par guest, and with
> the changes I get a kernel oops during boot, but I haven't determined
> the cause yet. I'll let you know what I find. :)
>
> -- Ben
>
Hello,
Sorry for the l
On Sunday, January 25, 2015 at 05:28:18 PM, Kristina Martšenko wrote:
> These patches fix some issues with using the touchscreen and reading
> other ADC channels at the same time.
[...]
Hi!
Thanks!
Entire series
Reviewed-by: Marek Vasut
Best regards,
Marek Vasut
_
Telekom Malaysia Berhad
G.03B, Ground Floor, Kompleks Antarabangsa, Jln Sultan Ismail, Off Jalan
Ampang
50250 Kuala Lumpur
Malaysia.
NOTIS RASMI HADIAH TELEKOM MALAYSIA
Pihak Telekom Malaysia @Program Kemenangan yang telah diadakan pada 24th
Januari 2015 di mana alamat email anda yang disertaka
As the if completes with a unconditional goto the else branch
is not needed here.
Signed-off-by: Nicholas Mc Guire
---
v2: added missing subsystem string in subject line - patch unchanged
All paths of execution that did not exit through the if branch will
go through the else branch so no need
This patch fixes warnings/errors raised by checkpatch.pl relating to whitespace
in r8192U_dm.c, removes inconsistent whitespace, and additionally fixes some
vertical alignment issues.
Signed-off-by: Lorenzo Stoakes
---
drivers/staging/rtl8192u/r8192U_dm.c | 1604 +
This patch fixes warnings/errors raised by checkpatch.pl relating to redundant
code in r8192U_dm.c.
Signed-off-by: Lorenzo Stoakes
---
drivers/staging/rtl8192u/r8192U_dm.c | 153 ---
1 file changed, 68 insertions(+), 85 deletions(-)
diff --git a/drivers/staging/r
This patch fixes warnings raised by checkpatch.pl relating to heavily indented
lines in r8192U_dm.c by refactoring code to achieve the same outcome indented by
one less tab.
Signed-off-by: Lorenzo Stoakes
---
drivers/staging/rtl8192u/r8192U_dm.c | 27 ---
1 file changed,
This patch fixes errors raised by checkpatch.pl relating to use of C99 comments
in r8192U_dm.c, and cleans up existing ANSI C comments.
Signed-off-by: Lorenzo Stoakes
---
drivers/staging/rtl8192u/r8192U_dm.c | 807 ++-
1 file changed, 416 insertions(+), 391 deleti
> -Original Message-
> From: Nicholas Mc Guire [mailto:der.h...@hofr.at]
> Sent: Sunday, January 25, 2015 12:47 AM
> To: KY Srinivasan
> Cc: Haiyang Zhang; de...@linuxdriverproject.org; net...@vger.kernel.org;
> linux-ker...@vger.kernel.org; Nicholas Mc Guire
> Subject: [PATCH] hyperv: el
> -Original Message-
> From: Nicholas Mc Guire [mailto:der.h...@hofr.at]
> Sent: Sunday, January 25, 2015 6:48 AM
> To: KY Srinivasan
> Cc: Haiyang Zhang; Jiri Kosina; de...@linuxdriverproject.org; linux-
> ker...@vger.kernel.org; Nicholas Mc Guire
> Subject: [PATCH 3/3 v2] hyperv: hid-hy
Removes some functions that are not used anywhere:
CAM_empty_entry() get_bsstype() rtw_get_oper_choffset()
rtw_get_oper_bw() is_ap_in_wep() should_forbid_n_rate()
This was partially found by using a static code analysis program called
cppcheck.
Signed-off-by: Rickard Strandqvist
---
drivers/st
On 25 January 2015 at 11:51, Greg KH wrote:
>
> This patch fails to apply to my staging-testing branch of staging.git,
> so I can't apply it :(
>
> Please refresh your series and resend.
Apologies Greg, it turns out I clearly lost my mind last weekend and
rebased against the test branch instead o
tree: git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/char-misc.git
char-misc-testing
head: 930c796ad9a62bdc8384cbb71d5af332d9ec92f7
commit: 71123d54fb2346c7652d8d05dac2cee28cd69954 [54/73] Drivers: hv: vmbus:
Implement a clockevent device
reproduce:
# apt-get install sparse
git chec
drivers/hv/vmbus_drv.c:582:6: sparse: symbol 'hv_process_timer_expiration' was
not declared. Should it be static?
Signed-off-by: Fengguang Wu
---
vmbus_drv.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
index 7488111..35e
Using the touchscreen while running buffered capture results in the
buffer reporting lots of wrong values, often just zeros. This is because
we push readings to the buffer every time a touchscreen interrupt
arrives, including when the buffer's own conversions have not yet
finished. So let's only pu
Reading a channel through sysfs, or starting a buffered capture, can
occasionally turn off the touchscreen.
This is because the read_raw() and buffer preenable()/postdisable()
callbacks unschedule current conversions on all channels. If a delay
channel happens to schedule a touchscreen conversion
Reading a channel through sysfs, or starting a buffered capture, will
currently turn off the touchscreen. This is because the read_raw() and
buffer preenable()/postdisable() callbacks disable interrupts for all
LRADC channels, including those the touchscreen uses.
So make the callbacks only disabl
The touchscreen was initially designed [1] to map all of its physical
channels to one virtual channel, leaving buffered capture to use the
remaining 7 virtual channels. When the touchscreen was reimplemented
[2], it was made to use four virtual channels, which overlap and
conflict with the channels
These patches fix some issues with using the touchscreen and reading
other ADC channels at the same time.
The main issue is that the "virtual" channels the touchscreen uses can
overlap with the channels that the iio buffer is configured to read,
causing the touchscreen to read those channels inste
On Fri, Jan 09, 2015 at 10:18:51PM -0800, K. Y. Srinivasan wrote:
> From: Vitaly Kuznetsov
>
> fcopyd in missing in the Makefile, add it there.
>
> Signed-off-by: Vitaly Kuznetsov
> Signed-off-by: K. Y. Srinivasan
> ---
> tools/hv/Makefile |4 ++--
> 1 files changed, 2 insertions(+), 2 de
On Mon, Jan 12, 2015 at 05:50:11PM +0100, Vitaly Kuznetsov wrote:
> When an SMP Hyper-V guest is running on top of 2012R2 Server and secondary
> cpus are sent offline (with echo 0 > /sys/devices/system/cpu/cpu$cpu/online)
> the system freeze is observed. This happens due to the fact that on newer
>
On Mon, Jan 19, 2015 at 12:38:06PM +0200, Mohamed Lotfy Hammad wrote:
> This patch fixes the following checkpatch.pl error:
> fix space prohibited before that ','
>
> Signed-off-by: Mohamed Lotfy Hammad
> ---
> drivers/staging/vt6655/mac.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
On Fri, Jan 23, 2015 at 08:15:53AM +0100, Nicholas Mc Guire wrote:
> This is only an API consolidation and should make things more readable
>
> Converting milliseconds to jiffies by val * HZ / 1000 is technically
> not wrong but msecs_to_jiffies(val) is the cleaner solution and handles
> corner ca
On Sat, Jan 17, 2015 at 10:39:53PM +1100, Zachary Warren wrote:
> Avoids the following warnings from sparse:
> visorchannel_funcs.c:457:9: warning:
> context imbalance in 'visorchannel_signalremove' - different lock contexts
> for basic block
> visorchannel_funcs.c:512:9: warning:
> context imba
On Wed, Jan 21, 2015 at 12:01:10PM +0200, MariamMohamedFawzy wrote:
> This patch fixes the following checkpatch.pl error:
> fix that open brace { should be on the previous line
>
> Signed-off-by: MariamMohamedFawzy
Please use the name you use to sign a legal document (odds are there
should be a
On Sun, Jan 18, 2015 at 09:11:39AM +0200, Asaf Vertz wrote:
> Fixed the following warnings (reported by sparse):
> drivers/staging/wlan-ng/hfa384x_usb.c:3828:36: warning: cast to restricted
> __le16
> drivers/staging/wlan-ng/hfa384x_usb.c:3229:16: warning: cast to restricted
> __le16
> drivers/st
On Sun, Jan 18, 2015 at 02:21:29AM +0100, Rickard Strandqvist wrote:
> Removes some functions that are not used anywhere:
> CAM_empty_entry() get_bsstype() rtw_get_oper_choffset()
> rtw_get_oper_bw() is_ap_in_wep() should_forbid_n_rate()
>
> This was partially found by using a static code analysis
On Sat, Jan 17, 2015 at 11:57:53PM -0800, Shirish Gajera wrote:
> This patch fixes the checkpatch.pl warning:
>
> WARNING: line over 80 characters
>
> All line over 80 characters in driver/staging/speakup/* are fixed
>
> Signed-off-by: Shirish Gajera
> ---
> drivers/staging/speakup/main.c
On Sun, Jan 18, 2015 at 10:36:57AM +, Lorenzo Stoakes wrote:
> This patch fixes errors raised by checkpatch.pl relating to use of C99
> comments
> in r8192U_dm.c, and cleans up existing ANSI C comments.
>
> Signed-off-by: Lorenzo Stoakes
> ---
> drivers/staging/rtl8192u/r8192U_dm.c | 811
>
On Wed, Jan 21, 2015 at 12:02:48PM +0100, Noralf Trønnes wrote:
> Add missing static keyword to function reset().
> This was detected by the kbuild test robot.
>
> Signed-off-by: Noralf Trønnes
> ---
> drivers/staging/fbtft/fb_agm1264k-fl.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
On Mon, Jan 19, 2015 at 02:30:25PM +0200, Mohamed Lotfy Hammad wrote:
> This patch fixes the following checkpatch.pl error:
> fix space prohibited before that ','
>
> Signed-off-by: Mohamed Lotfy Hammad
> Reviewed-by: Aya Mahfouz
> ---
> drivers/staging/vt6655/mac.h | 2 +-
> 1 file changed, 1
On Sat, Jan 24, 2015 at 10:20:53PM +0200, Heba Aamer wrote:
> This patch fixes the following checkpatch.pl warning:
> fix Prefer [subsystem eg: netdev]_info([subsystem]dev, ... then
> dev_info(dev, ... then pr_info(... to printk(KERN_INFO ...
>
> netdev_info was used since it is a network subsyst
On Sat, Jan 17, 2015 at 07:04:23PM -0700, mathieu.poir...@linaro.org wrote:
> From: Mathieu Poirier
>
> mpoirier@t430:~/work/kernel1$ make C=1 M=drivers/staging/vt6655/
> LD drivers/staging/vt6655/built-in.o
> CHECK drivers/staging/vt6655/device_main.c
> drivers/staging/vt6655/device_m
On Sat, Jan 24, 2015 at 05:11:42PM -0200, Murilo Opsfelder Araujo wrote:
> This patch gets rid of the following error when compiling r8192U_core.c
> and CONFIG_WIRELESS_EXT is not defined:
>
> drivers/staging/rtl8192u/r8192U_core.c: In function ‘rtl8192_usb_probe’:
> drivers/staging/rtl8192u/r8192
return type of wait_for_completion_timeout is unsigned long not int, this
patch just fixes up the declarations.
Signed-off-by: Nicholas Mc Guire
---
v2: fixed subject line
The return type of wait_for_completion_timeout is unsigned long not
int. This patch fixes up the declarations only.
Patch
Signed-off-by: Nicholas Mc Guire
---
v2: fixed subject line
The return type of wait_for_completion_timeout is unsigned long not
int. This patch fixes up the declarations only.
Patch was compile tested only for x86_64_defconfig + CONFIG_X86_VSMP=y
CONFIG_HYPERV=m, CONFIG_HID_HYPERV_MOUSE=m
Patc
Signed-off-by: Nicholas Mc Guire
---
v2: fixed subject line
The return type of wait_for_completion_timeout is unsigned long not
int. This patch fixes up the declarations only.
Patch was compile tested only for x86_64_defconfig + CONFIG_X86_VSMP=y
CONFIG_HYPERV=m, CONFIG_FB_HYPERV=m
Patch is ag
Signed-off-by: Nicholas Mc Guire
---
v2: fixed subject line
The return type of wait_for_completion_timeout is unsigned long not
int. This patch fixes up the declarations only.
Patch was compile tested only for x86_64_defconfig + CONFIG_X86_VSMP=y
CONFIG_HYPERV=m, CONFIG_HYPERV_NET=m
Patch is a
On Sat, Jan 24, 2015 at 10:20:53PM +0200, Heba Aamer wrote:
> This patch fixes the following checkpatch.pl warning:
> fix Prefer [subsystem eg: netdev]_info([subsystem]dev, ... then
> dev_info(dev, ... then pr_info(... to printk(KERN_INFO ...
>
> netdev_info was used since it is a network subsyst
Hello.
On 1/25/2015 2:03 PM, Nicholas Mc Guire wrote:
You probably want to replace hyphens with spaces in the subject of this
and other patches.
And you're not fixing the return type of wait_for_completion_timeout(),
you're fixing the variables to match this type.
Signed-off-by: Nicho
(the initial post had a typo in the short summary, reposting)
This fixes some of the code style issues in the flexfb driver by removing
unnecessary initializations of static variables to 0 or to NULL.
Signed-off-by: Mauro Stettler
Cc: Greg Kroah-Hartman
Cc: Thomas Petazzoni
Cc: Noralf Tronnes
Signed-off-by: Nicholas Mc Guire
---
The return type of wait_for_completion_timeout is unsigned long not
int. This patch fixes up the declarations only.
Patch was compile tested only for x86_64_defconfig + CONFIG_X86_VSMP=y
CONFIG_HYPERV=m, CONFIG_HYPERV_NET=m
Patch is against 3.19.0-rc5 -next-
Signed-off-by: Nicholas Mc Guire
---
The return type of wait_for_completion_timeout is unsigned long not
int. This patch fixes up the declarations only.
Patch was compile tested only for x86_64_defconfig + CONFIG_X86_VSMP=y
CONFIG_HYPERV=m, CONFIG_FB_HYPERV=m
Patch is against 3.19.0-rc5 -next-2
Signed-off-by: Nicholas Mc Guire
---
The return type of wait_for_completion_timeout is unsigned long not
int. This patch fixes up the declarations only.
Patch was compile tested only for x86_64_defconfig + CONFIG_X86_VSMP=y
CONFIG_HYPERV=m, CONFIG_HID_HYPERV_MOUSE=m
Patch is against 3.19.0-rc5
This fixes some of the code style issues in flexfb.c by removing
unnecessary initializations of static variables to 0 or to NULL.
Signed-off-by: Mauro Stettler
Cc: Greg Kroah-Hartman
Cc: Thomas Petazzoni
Cc: Noralf Tronnes
---
drivers/staging/fbtft/flexfb.c | 18 +-
1 file cha
Correct one coding style problem(detected by checkpatch.pl) in pcl818.c.
- please, no space before tabs
Signed-off-by: Simon Guo
---
drivers/staging/comedi/drivers/pcl818.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/pcl818.c
b/drivers/stag
Correct one coding style problem(detected by checkpatch.pl) in pcl818.c.
- line over 80 characters
Signed-off-by: Simon Guo
---
drivers/staging/comedi/drivers/pcl818.c | 14 ++
1 file changed, 10 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/comedi/drivers/pcl818.c
b/d
Correct one coding style problem(detected by checkpatch.pl) in pcl818.c.
- code indent should use tabs where possible
Signed-off-by: Simon Guo
---
drivers/staging/comedi/drivers/pcl818.c | 26 +-
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/drivers/stag
return type of wait_for_completion_timeout is unsigned long not int, this
patch just fixes up the declarations.
Signed-off-by: Nicholas Mc Guire
---
The return type of wait_for_completion_timeout is unsigned long not
int. This patch fixes up the declarations only.
Patch was compile tested only
As the if completes with a unconditional goto the else branch
is not needed here.
Signed-off-by: Nicholas Mc Guire
---
All paths of execution that did not exit through the if branch will
go through the else branch so no need for an explicit else here
Patch was compile tested only for x86_64_de
51 matches
Mail list logo