Re: [PATCH 3/4] iio: mxs-lradc: make ADC reads not unschedule touchscreen conversions

2015-01-18 Thread Marek Vasut
On Monday, January 19, 2015 at 08:20:31 AM, Juergen Borleis wrote: > Hi Kristina, Hi all, > On Saturday 17 January 2015 01:22:10 Kristina Martšenko wrote: > > Reading a channel through sysfs, or starting a buffered capture, can > > occasionally turn off the touchscreen. > > [...] > > I have my o

Re: [PATCH 01/10] mfd: rtsx: replace TAB by SPC after #define

2015-01-18 Thread Lee Jones
On Mon, 19 Jan 2015, 敬锐 wrote: > > On 01/18/2015 08:39 PM, Lee Jones wrote: > > On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > > > >> From: Micky Ching > >> > >> Re-format coding-style, using uniform SPC after "#define" keyword > >> instead of mixing using TAB and SPC. > > Tabs and spa

Re: [PATCH 06/10] mfd: rtsx: update phy register

2015-01-18 Thread Lee Jones
On Mon, 19 Jan 2015, 敬锐 wrote: > On 01/18/2015 08:29 PM, Lee Jones wrote: > > On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > > > >> From: Micky Ching > >> > >> update phy register value and using direct value instead of macros. > >> It is much easier to debug using constant value than a

Re: [PATCH 09/10] mfd: rtsx: add support for rts525A

2015-01-18 Thread Lee Jones
On Mon, 19 Jan 2015, 敬锐 wrote: > > On 01/18/2015 07:13 PM, Lee Jones wrote: > >> @@ -97,7 +97,7 @@ static void rts5249_force_power_down(struct rtsx_pcr > >> *pcr, u8 pm_state) > >> > rtsx_pci_write_register(pcr, AUTOLOAD_CFG_BASE + 3, 0x01, 0); > >> > > >> > if (pm_state == H

Re: [PATCH 08/10] mfd: rtsx: add support for rts524A

2015-01-18 Thread Lee Jones
On Mon, 19 Jan 2015, 敬锐 wrote: > > On 01/18/2015 08:20 PM, Lee Jones wrote: > >> +static int rts524a_optimize_phy(struct rtsx_pcr *pcr) > >> >+{ > >> >+ int err; > >> >+ > >> >+ err = rtsx_pci_write_register(pcr, RTS524A_PM_CTRL3, > >> >+ D3_DELINK_MODE_EN, 0x00); > >> >+ if (err < 0) > >

Re: [PATCH 08/10] mfd: rtsx: add support for rts524A

2015-01-18 Thread Lee Jones
On Mon, 19 Jan 2015, 敬锐 wrote: > > On 01/18/2015 08:20 PM, Lee Jones wrote: > >> +}; > >> >+ > >> >+void rts524a_init_params(struct rtsx_pcr *pcr) > >> >+{ > >> >+ rts5249_init_params(pcr); > >> >+ > >> >+ pcr->ops = &rts524a_pcr_ops; > >> >+} > > I see a couple of these now. Why don't you make

[PATCH] staging: rts5028: use msecs_to_jiffies for timeouts

2015-01-18 Thread Nicholas Mc Guire
This is only an API consolidation and should make things more readable Signed-off-by: Nicholas Mc Guire --- Converting milliseconds to jiffies by val * HZ / 1000 is technically not wrong but msecs_to_jiffies(val) is the cleaner solution and handles corner cases correctly. This patch was only co

Re: [PATCH 3/4] iio: mxs-lradc: make ADC reads not unschedule touchscreen conversions

2015-01-18 Thread Juergen Borleis
Hi Kristina, On Saturday 17 January 2015 01:22:10 Kristina Martšenko wrote: > Reading a channel through sysfs, or starting a buffered capture, can > occasionally turn off the touchscreen. > [...] I have my old ChumbyOne around (i.MX23). How to test this buffered capture while using the touchscre

Re: [PATCH 08/10] mfd: rtsx: add support for rts524A

2015-01-18 Thread 敬锐
On 01/18/2015 08:20 PM, Lee Jones wrote: >> +}; >> >+ >> >+void rts524a_init_params(struct rtsx_pcr *pcr) >> >+{ >> >+ rts5249_init_params(pcr); >> >+ >> >+ pcr->ops = &rts524a_pcr_ops; >> >+} > I see a couple of these now. Why don't you make 'ops' a parameter of > *_init_params(). > *_init_p

Re: [PATCH 09/10] mfd: rtsx: add support for rts525A

2015-01-18 Thread 敬锐
On 01/18/2015 07:13 PM, Lee Jones wrote: >> @@ -97,7 +97,7 @@ static void rts5249_force_power_down(struct rtsx_pcr *pcr, >> u8 pm_state) >> >rtsx_pci_write_register(pcr, AUTOLOAD_CFG_BASE + 3, 0x01, 0); >> > >> >if (pm_state == HOST_ENTER_S3) { >> >- if (PCI_PID(pcr) == 0x524A

Re: [PATCH 08/10] mfd: rtsx: add support for rts524A

2015-01-18 Thread 敬锐
On 01/18/2015 08:20 PM, Lee Jones wrote: >> +static int rts524a_optimize_phy(struct rtsx_pcr *pcr) >> >+{ >> >+ int err; >> >+ >> >+ err = rtsx_pci_write_register(pcr, RTS524A_PM_CTRL3, >> >+ D3_DELINK_MODE_EN, 0x00); >> >+ if (err < 0) >> >+ return err; > if (err) > err

Re: [PATCH 08/10] mfd: rtsx: add support for rts524A

2015-01-18 Thread 敬锐
On 01/18/2015 08:20 PM, Lee Jones wrote: >> @@ -72,8 +72,10 @@ static void rts5249_fetch_vendor_settings(struct rtsx_pcr >> *pcr) >> >rtsx_pci_read_config_dword(pcr, PCR_SETTING_REG1, ®); >> >dev_dbg(&(pcr->pci->dev), "Cfg 0x%x: 0x%x\n", PCR_SETTING_REG1, reg); >> > >> >- if (!rtsx_ve

Re: [PATCH v7] Staging: comedi: patch to fix line over 80 characters warning

2015-01-18 Thread Greg KH
A: No. Q: Should I include quotations after my reply? http://daringfireball.net/2007/07/on_top On Sun, Jan 18, 2015 at 07:47:50PM +0530, jitendra kumar khasdev wrote: > Will you give reason for not apply my patch on your tree. I have > tested by appling on linux main tree. Probably because some

Re: [PATCH 00/29] staging: add drivers from the fbtft project

2015-01-18 Thread Greg KH
On Sun, Jan 18, 2015 at 01:00:31PM +0100, Noralf Tronnes wrote: > Den 18.01.2015 03:54, skrev Greg KH: > >On Sun, Jan 18, 2015 at 03:26:56AM +0100, Noralf Tronnes wrote: > >>When I started this rewrite I didn't anticipate fbtft entering the kernel, > >>and to me it was easier to just start from scr

Re: [PATCH 06/10] mfd: rtsx: update phy register

2015-01-18 Thread 敬锐
On 01/18/2015 08:29 PM, Lee Jones wrote: > On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > >> From: Micky Ching >> >> update phy register value and using direct value instead of macros. >> It is much easier to debug using constant value than a lot of macros. >> We usually need compare th

Re: [PATCH 01/10] mfd: rtsx: replace TAB by SPC after #define

2015-01-18 Thread 敬锐
On 01/18/2015 08:39 PM, Lee Jones wrote: > On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > >> From: Micky Ching >> >> Re-format coding-style, using uniform SPC after "#define" keyword >> instead of mixing using TAB and SPC. > Tabs and spaces in this context usually have different meaning

Re: [PATCH 07/10] mfd: rtsx: remove LCTLR defination

2015-01-18 Thread 敬锐
On 01/18/2015 08:28 PM, Lee Jones wrote: > On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > >> From: Micky Ching >> >> To enable/disable ASPM we should find LINK CONTROL register >> in PCI config space. All old chip use 0x80 address, but new >> chip may use another address, so we using pc

Re: [PATCH] staging: rtl8723au: hal: rtl8723au_led.c: Remove some unused functions

2015-01-18 Thread Rickard Strandqvist
2015-01-17 22:58 GMT+01:00 Greg Kroah-Hartman : > On Sun, Dec 21, 2014 at 01:59:39PM +0100, Rickard Strandqvist wrote: >> Removes some functions that are not used anywhere: >> rtl8723au_DeInitSwLeds() rtl8723au_InitSwLeds() >> >> This was partially found by using a static code analysis program call

Re: [PATCH 29/29] staging: fbtft: add NOTES file

2015-01-18 Thread Thomas Petazzoni
Dear Greg Kroah-Hartman, On Sat, 17 Jan 2015 16:42:45 -0800, Greg Kroah-Hartman wrote: > > diff --git a/drivers/staging/fbtft/NOTES b/drivers/staging/fbtft/NOTES > > new file mode 100644 > > index 000..d57c6ef > > --- /dev/null > > +++ b/drivers/staging/fbtft/NOTES > > @@ -0,0 +1,6 @@ > > +Th

Re: [PATCH] drivers: staging: rtl8723au: get rid of unneeded memset/memcpy

2015-01-18 Thread Jes Sorensen
Greg Kroah-Hartman writes: > On Sun, Dec 07, 2014 at 03:37:20PM +0100, Emil Renner Berthing wrote: >> This also fixes a sparse warning. > > What sparse warning? What's wrong with the original code? Unless Jes > resends this to me, I don't see the need to apply it, sorry. I agree, I cannot see w

Re: [PATCH] staging: vt6655: fix space prohibted before that ',' Signed-off-by: Ahmadposten

2015-01-18 Thread Giedrius Statkevičius
On 2015.01.19 01:38, Ahmadposten wrote: > --- > drivers/staging/vt6655/device_main.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/staging/vt6655/device_main.c > b/drivers/staging/vt6655/device_main.c > index f5cc78e..34e3a76 100644 > --- a/drivers/staging/vt66

Re: [PATCH v7] Staging: comedi: patch to fix line over 80 characters warning

2015-01-18 Thread jitendra kumar khasdev
Will you give reason for not apply my patch on your tree. I have tested by appling on linux main tree. On Sat, Jan 10, 2015 at 10:20:03AM +0530, jitendra kumar khasdev wrote: > This is patch to pcl812.c that fix line over 80 characters warning > which is found by checkpatch.pl tool. Reduce the ex

[PATCH 6/6] staging: lustre: lnet: declare internal symbols as static

2015-01-18 Thread Luca Ceresoli
Fixes sparse warnings like: warning: symbol '...' was not declared. Should it be static? Signed-off-by: Luca Ceresoli Cc: Peng Tao Cc: Jinshan Xiong Cc: Srikrishan Malik Cc: hpdd-disc...@lists.01.org Cc: de...@driverdev.osuosl.org Cc: linux-ker...@vger.kernel.org --- drivers/staging/lustre/

[PATCH 4/6] staging: lustre: llite: declare internal symbols as static

2015-01-18 Thread Luca Ceresoli
Fixes sparse warnings like: warning: symbol '...' was not declared. Should it be static? Signed-off-by: Luca Ceresoli Cc: Peng Tao Cc: Jinshan Xiong Cc: Srikrishan Malik Cc: hpdd-disc...@lists.01.org Cc: de...@driverdev.osuosl.org Cc: linux-ker...@vger.kernel.org --- drivers/staging/lustre/

[PATCH 5/6] staging: lustre: fld: declare internal symbols as static

2015-01-18 Thread Luca Ceresoli
Fixes sparse warnings like: warning: symbol '...' was not declared. Should it be static? Signed-off-by: Luca Ceresoli Cc: Peng Tao Cc: Jinshan Xiong Cc: Srikrishan Malik Cc: hpdd-disc...@lists.01.org Cc: de...@driverdev.osuosl.org Cc: linux-ker...@vger.kernel.org --- drivers/staging/lustre/

[PATCH 1/6] staging: lustre: mdc: declare internal symbols as static

2015-01-18 Thread Luca Ceresoli
Fixes sparse warnings like: warning: symbol '...' was not declared. Should it be static? Signed-off-by: Luca Ceresoli Cc: Peng Tao Cc: Jinshan Xiong Cc: Srikrishan Malik Cc: hpdd-disc...@lists.01.org Cc: de...@driverdev.osuosl.org Cc: linux-ker...@vger.kernel.org --- drivers/staging/lustre/

[PATCH 3/6] staging: lustre: libcfs: declare internal symbols as static

2015-01-18 Thread Luca Ceresoli
Fixes sparse warnings like: warning: symbol '...' was not declared. Should it be static? Signed-off-by: Luca Ceresoli Cc: Peng Tao Cc: Jinshan Xiong Cc: Srikrishan Malik Cc: hpdd-disc...@lists.01.org Cc: de...@driverdev.osuosl.org Cc: linux-ker...@vger.kernel.org --- drivers/staging/lustre/

[PATCH 2/6] staging: lustre: lmv: declare internal symbols as static

2015-01-18 Thread Luca Ceresoli
Fixes sparse warnings like: warning: symbol '...' was not declared. Should it be static? Signed-off-by: Luca Ceresoli Cc: Peng Tao Cc: Jinshan Xiong Cc: Srikrishan Malik Cc: hpdd-disc...@lists.01.org Cc: de...@driverdev.osuosl.org Cc: linux-ker...@vger.kernel.org --- drivers/staging/lustre/

[PATCH 0/6] staging: lustre: declare internal symbols as static

2015-01-18 Thread Luca Ceresoli
Hi, this small patch series fixes dozens of sparse warnings like: warning: symbol '...' was not declared. Should it be static? I previously sent it as one larger patch [1], but Greg couldn't apply it to his staging-next because other patches had fixed some of the same issues in the meantime. So

Re: [PATCH 2/2] staging: lustre: declare internal symbols as static

2015-01-18 Thread Luca Ceresoli
Dear Greg, Greg Kroah-Hartman wrote: On Tue, Jan 13, 2015 at 11:33:03PM +0100, Luca Ceresoli wrote: Fixes dozens of sparse warnings like: warning: symbol 'cfs_tracefile_sem' was not declared. Should it be static? Signed-off-by: Luca Ceresoli Cc: Peng Tao Cc: Jinshan Xiong Cc: Srikrishan

[PATCH] staging: vt6655: fix space prohibited before that ','

2015-01-18 Thread heba-aamer
This patch fixes the following checkpatch.pl error: fix space prohibited before that ',' --- drivers/staging/vt6655/mac.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/vt6655/mac.c b/drivers/staging/vt6655/mac.c index 63c9c7e..3653a2b 100644 --- a/drivers/

Re: [PATCH 01/10] mfd: rtsx: replace TAB by SPC after #define

2015-01-18 Thread Lee Jones
On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > Re-format coding-style, using uniform SPC after "#define" keyword > instead of mixing using TAB and SPC. Tabs and spaces in this context usually have different meanings i.e. space after #define usually denotes that t

[PATCH] staging: vt6655: fix space prohibted before that ',' Signed-off-by: Ahmadposten

2015-01-18 Thread Ahmadposten
--- drivers/staging/vt6655/device_main.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/vt6655/device_main.c b/drivers/staging/vt6655/device_main.c index f5cc78e..34e3a76 100644 --- a/drivers/staging/vt6655/device_main.c +++ b/drivers/staging/vt6655/device_mai

[PATCH RFC] comedi: rtd520: if condition with no effect - if identical to else

2015-01-18 Thread Nicholas Mc Guire
The if and the else branch code are identical - so the condition has no effect on the effective code - this patch removes the condition and the duplicated code. Signed-off-by: Nicholas Mc Guire --- Patch is against 3.19.0-rc4 -next-20150116 This patch was only compile tested with x86_64_defconf

Re: [PATCH 02/10] mfd: rtsx: place register address and values togather

2015-01-18 Thread Lee Jones
On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > It is more readable to place register address and values define > togather. The values define add two leading space indicate belong > to the register address defined above. > > Signed-off-by: Micky Ching > --- > in

Re: [PATCH 03/10] mfd: rtsx: add debug info when access register failed

2015-01-18 Thread Lee Jones
On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > Add debug info when access register failed, this is useful for > debug. Pull the creation of the macro into another patch. I'm happy to apply that, but I don't really want dbg prints scattered everywhere. Feel free

Re: [PATCH 05/10] mfd: rtsx: update driving settings

2015-01-18 Thread Lee Jones
On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > update card drive settings, This setting can be used for rts5249 > rts524A and rts525A. > > Signed-off-by: Micky Ching > --- > drivers/mfd/rts5249.c | 12 ++-- > 1 file changed, 6 insertions(+), 6 deletions

Re: [PATCH 04/10] mfd: rtsx: update PETXCFG address

2015-01-18 Thread Lee Jones
On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > PETXCFG is defined at 0xFF03, the old 0xFE49 not used any more. > > Signed-off-by: Micky Ching > --- > drivers/mfd/rts5227.c| 6 ++ > drivers/mfd/rts5249.c| 6 ++ > include/linux/mfd/rtsx_pc

Re: [PATCH 06/10] mfd: rtsx: update phy register

2015-01-18 Thread Lee Jones
On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > update phy register value and using direct value instead of macros. > It is much easier to debug using constant value than a lot of macros. > We usually need compare the value directly to check the configure. NACK.

Re: [PATCH 07/10] mfd: rtsx: remove LCTLR defination

2015-01-18 Thread Lee Jones
On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > To enable/disable ASPM we should find LINK CONTROL register > in PCI config space. All old chip use 0x80 address, but new > chip may use another address, so we using pci_find_capability() > to get LINK CONTROL address

Re: [PATCH 08/10] mfd: rtsx: add support for rts524A

2015-01-18 Thread Lee Jones
On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > add support for new chip rts524A. > > Signed-off-by: Micky Ching > --- > drivers/mfd/rts5249.c| 112 > +++ > drivers/mfd/rtsx_pcr.c | 5 ++ > drivers/mfd/rts

Re: [PATCH 00/29] staging: add drivers from the fbtft project

2015-01-18 Thread Noralf Tronnes
Den 18.01.2015 03:54, skrev Greg KH: On Sun, Jan 18, 2015 at 03:26:56AM +0100, Noralf Tronnes wrote: When I started this rewrite I didn't anticipate fbtft entering the kernel, and to me it was easier to just start from scratch. However I'd much rather go with proven practices, so I will do as yo

Re: [PATCH 0/4] iio: mxs-lradc: fix interactions between the touchscreen and the ADC

2015-01-18 Thread Stefan Wahren
Hi Kristina, > Kristina Martšenko hat am 17. Januar 2015 um > 01:22 geschrieben: > > > Hi, > > These patches fix some issues with using the touchscreen and reading > other ADC channels at the same time. > > The main issue is that the "virtual" channels the touchscreen uses can > overlap with the

Re: [PATCH 09/10] mfd: rtsx: add support for rts525A

2015-01-18 Thread Lee Jones
On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > add support for new chip rts525A. > > Signed-off-by: Micky Ching > --- > drivers/mfd/rts5249.c | 93 > +- > drivers/mfd/rtsx_pcr.c | 13 +-- > drivers/mfd/rtsx_

Re: [PATCH 10/10] mfd: rtsx: using pcr_dbg replace dev_dbg

2015-01-18 Thread Lee Jones
On Thu, 15 Jan 2015, micky_ch...@realsil.com.cn wrote: > From: Micky Ching > > pcr_dbg is a wrapper of dev_dbg, which can save some code, > and help to enable/disable debug message static. > > Signed-off-by: Micky Ching > --- > drivers/mfd/rtl8411.c | 11 +-- > drivers/mfd/rts5209.c

[PATCH RESEND 2 2/4] staging: rtl8192u: fix whitespace and alignment

2015-01-18 Thread Lorenzo Stoakes
This patch fixes warnings/errors raised by checkpatch.pl relating to whitespace in r8192U_dm.c, removes inconsistent whitespace, and additionally fixes some vertical alignment issues. Signed-off-by: Lorenzo Stoakes --- drivers/staging/rtl8192u/r8192U_dm.c | 1697 +

[PATCH RESEND 2 1/4] staging: rtl8192u: fix comments

2015-01-18 Thread Lorenzo Stoakes
This patch fixes errors raised by checkpatch.pl relating to use of C99 comments in r8192U_dm.c, and cleans up existing ANSI C comments. Signed-off-by: Lorenzo Stoakes --- drivers/staging/rtl8192u/r8192U_dm.c | 811 ++- 1 file changed, 420 insertions(+), 391 deleti

[PATCH RESEND 2 3/4] staging: rtl8192u: remove redundant code

2015-01-18 Thread Lorenzo Stoakes
This patch fixes warnings/errors raised by checkpatch.pl relating to redundant code in r8192U_dm.c. Signed-off-by: Lorenzo Stoakes --- drivers/staging/rtl8192u/r8192U_dm.c | 165 --- 1 file changed, 74 insertions(+), 91 deletions(-) diff --git a/drivers/staging/r

[PATCH RESEND 2 4/4] staging: rtl8192u: Refactor heavy nesting

2015-01-18 Thread Lorenzo Stoakes
This patch fixes warnings raised by checkpatch.pl relating to heavily indented lines in r8192U_dm.c by refactoring code to achieve the same outcome indented by one less tab. Signed-off-by: Lorenzo Stoakes --- drivers/staging/rtl8192u/r8192U_dm.c | 27 --- 1 file changed,

Re: [PATCH] staging: speakup: Fix warning of line over 80 characters.

2015-01-18 Thread Ben Hutchings
On Sat, 2015-01-17 at 23:57 -0800, Shirish Gajera wrote: > This patch fixes the checkpatch.pl warning: > > WARNING: line over 80 characters > > All line over 80 characters in driver/staging/speakup/* are fixed [...] It is not important to fix all such warnings. The code seems perfectly readable

Re: [PATCH] staging: speakup: Fix warning of line over 80 characters.

2015-01-18 Thread Robin Schroer
On Sat, Jan 17, 2015 at 11:57:53PM -0800, Shirish Gajera wrote: > diff --git a/drivers/staging/speakup/main.c b/drivers/staging/speakup/main.c > index e9f0c15..141abb7 100644 > --- a/drivers/staging/speakup/main.c > +++ b/drivers/staging/speakup/main.c > @@ -422,8 +422,10 @@ static void announce_ed