On Mon, Oct 27, 2014 at 11:17:02PM +0100, Mikael Svantesson wrote:
> Signed-off-by: Mikael Svantesson
The patch is corrupt (and in a totally weird way as well). Please read
the first paragraph for Documentation/email-clients.txt.
regards,
dan carpenter
_
On Mon, Oct 27, 2014 at 05:14:02PM -0400, Erik Arfvidson wrote:
> This patch fixes all logical continuations issues in virthba.c
>
> Signed-off-by: Erik Arfvidson
> ---
> drivers/staging/unisys/virthba/virthba.c | 42
>
> 1 file changed, 21 insertions(+), 21 del
This patch enables debugfs files /sys/kernel/debug/ion/heaps/system_shrink
,which was commented out, to shrink pool or get pool size
Reading the file returns pool size and writing occurs to shrink pool.
Signed-off-by: Gioh Kim
---
drivers/staging/android/ion/ion.c | 31
This patch limits pool size by page unit.
Signed-off-by: Gioh Kim
---
drivers/staging/android/ion/Kconfig |8
drivers/staging/android/ion/ion_page_pool.c | 24 ++--
2 files changed, 22 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/android
Hello,
Current shrinking is not page unit, block unit.
But shrinker returns the pool size in page unit,
so it is confused.
And there is no way to control pool size and shrink pool directly.
I have 3 patches:
1. Patch 1/3: make pool be shrinked by page unit
This patch trys to shrink pool in page
This patch shrink page-pool by page unit.
Shrinker usually get the pool size with the pool-scanner
and pass the size to the pool-counter to shrink entire pool.
But the pool-scanner is working in block unit.
and pool-counter page unit.
So it is confused.
Signed-off-by: Gioh Kim
---
drivers/stagi
Signed-off-by: Mikael Svantesson
---
drivers/staging/skein/skein_api.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/skein/skein_api.c
b/drivers/staging/skein/skein_api.c
index 6e700ee..5bfce07 100644
--- a/drivers/staging/skein/skein_api.c
+++ b/drivers/stag
This patch removes all unnecessary spaces after cast for visorchannel_funcs
Signed-off-by: Erik Arfvidson
---
.../unisys/visorchannel/visorchannel_funcs.c | 61 +++---
1 file changed, 31 insertions(+), 30 deletions(-)
diff --git a/drivers/staging/unisys/visorchannel/visorc
this patch adds braces to an else statement to remove check in
checkpatch.pl for visorchannel_funcs.c
Signed-off-by: Erik Arfvidson
---
drivers/staging/unisys/visorchannel/visorchannel_funcs.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/unisys/visorchann
this patch fixes all aligment issues in virthba.c
Signed-off-by: Erik Arfvidson
---
drivers/staging/unisys/virthba/virthba.c | 82
1 file changed, 42 insertions(+), 40 deletions(-)
diff --git a/drivers/staging/unisys/virthba/virthba.c
b/drivers/staging/unisys/v
this patch fixes a logical continuation check in visorchannel
Signed-off-by: Erik Arfvidson
---
drivers/staging/unisys/visorchannel/visorchannel_funcs.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/unisys/visorchannel/visorchannel_funcs.c
b/drivers/sta
This patch fixes all spaces after cast for virthba
Signed-off-by: Erik Arfvidson
---
drivers/staging/unisys/virthba/virthba.c | 130 +++
1 file changed, 65 insertions(+), 65 deletions(-)
diff --git a/drivers/staging/unisys/virthba/virthba.c
b/drivers/staging/unisys/
This patch adds comment documentation to visorchannel_tag struct
Signed-off-by: Erik Arfvidson
---
drivers/staging/unisys/visorchannel/visorchannel_funcs.c | 10 +++---
1 file changed, 7 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/unisys/visorchannel/visorchannel_funcs.c
b/d
This patch fixes all logical continuations issues in virthba.c
Signed-off-by: Erik Arfvidson
---
drivers/staging/unisys/virthba/virthba.c | 42
1 file changed, 21 insertions(+), 21 deletions(-)
diff --git a/drivers/staging/unisys/virthba/virthba.c
b/drivers/sta
this patch fixes aligment for visorchanne_funcs
Signed-off-by: Erik Arfvidson
---
drivers/staging/unisys/visorchannel/visorchannel_funcs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/unisys/visorchannel/visorchannel_funcs.c
b/drivers/staging/unisys/visorc
this patch removes unnecessary blank line in visorchannel_funcs
Signed-off-by: Erik Arfvidson
---
drivers/staging/unisys/visorchannel/visorchannel_funcs.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/unisys/visorchannel/visorchannel_funcs.c
b/drivers/staging/unisys/visorch
This patch removes unnecessary blanks lines and adds necessary blank lines in
virthba.
Signed-off-by: Erik Arfvidson
---
drivers/staging/unisys/virthba/virthba.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/staging/unisys/virthba/virthba.c
b/drivers/staging
--
Caro usuário
sua conta de e-mail ultrapassou 2 GB criados pelo webmaster, atualmente
funcionando em 2.30GB , não poderá enviar ou receber uma nova mensagem
dentro do
próximas 24 horas para verificar a sua conta de e-mail .
Por favor, digite suas informações abaixo para verificar a sua conta
On Mon, Oct 27, 2014 at 06:51:43PM +, Daniel Thompson wrote:
> Since commit cd678fce4280 ("switch logger to ->write_iter()"), any
> attempt to write to the log results in the log data being written over
> its own metadata, thus rendering the log unreadable.
>
> The problem was first detected w
Since commit cd678fce4280 ("switch logger to ->write_iter()"), any
attempt to write to the log results in the log data being written over
its own metadata, thus rendering the log unreadable.
The problem was first detected when I ran an Android userspace on the
v3.18-rc1 kernel. However the issue c
This patch series cleans up virtpci.h for checkpatch.pl errors, warnings, and
strict checks.
Benjamin Romer (4):
staging: unisys: fix CamelCase in net_adap_info
staging: unisys: get rid of typedef for VIRTPCI_DEV_TYPE
staging: unisys: fix CamelCase members of virtpci_dev
staging: unisys: f
Fix CamelCase names in this structure:
busNo => bus_no
deviceNo => device_no
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virthba/virthba.c | 28 ++--
drivers/staging/unisys/virtpci/virtpci.c | 15 +--
drivers/staging/unisys/virtpci/virtpci.h | 4
Fix the CamelCase member name in this structure:
zoneGuid => zone_uuid
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.c | 4 ++--
drivers/staging/unisys/virtpci/virtpci.h | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/unisys/virt
Clean up misaligned indentation in virtpci.h.
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/unisys/virtpci/virtpci.h
b/drivers/staging/unisys/virtpci/virtpci.h
index 42a98de..9
Remove the typedef and use enum virtpc_dev_type instead. Update references.
Signed-off-by: Benjamin Romer
---
drivers/staging/unisys/virtpci/virtpci.c | 3 ++-
drivers/staging/unisys/virtpci/virtpci.h | 6 +++---
2 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/unis
On Mon, Oct 27, 2014 at 02:17:38PM +0300, Dan Carpenter wrote:
> On Sun, Oct 26, 2014 at 10:56:34AM -0700, Insop Song wrote:
> > Devendra
> >
> > Since these are small changes, I want one patch set instead of three unless
> > Greg says otherwise.
> >
>
> Normally in staging/ we would insist on
ERROR: space required before the open brace '{'
Signed-off-by: Paul McQuade
---
drivers/staging/rtl8188eu/hal/bb_cfg.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/hal/bb_cfg.c
b/drivers/staging/rtl8188eu/hal/bb_cfg.c
index 80e8cc9..c2d166f 10064
Register with kernel power-off handler instead of setting pm_power_off
directly. Register with default priority since we don't know any better.
Cc: Julian Andres Klode
Cc: Marc Dietrich
Cc: Greg Kroah-Hartman
Acked-by: Greg Kroah-Hartman
Signed-off-by: Guenter Roeck
---
v3:
- Replace poweroff
On Mon, 2014-10-27 at 09:43 +0100, Jes Sorensen wrote:
> Sanjeev Sharma writes:
> > This is a patch to the rtw_cmd.c file that fixes
> > Error reported by checkpatch.
[]
> > diff --git a/drivers/staging/rtl8723au/core/rtw_cmd.c
> > b/drivers/staging/rtl8723au/core/rtw_cmd.c
[]
> > @@ -957,7 +957,
Attn: Beneficiary,
We want to officially notify you that your funds approved only US$10 Million,
being part payment for your Overdue Inheritance/Contract entitlements has been
programmed to be transferred to a Bank Account in the USA, following series of
documents tendered by your Representativ
Greg,
On Fri, Oct 24, 2014 at 05:29:09PM -0500, Eric Rost wrote:
> Adds CryptoAPI and loadable module support to the Skein Hashing
> Algorithm. Collapses threefish module into skein module. Renames skein.c
> and skein.h to skein_base.c and skein_base.h so module can be named
> skein.ko. Inlines ro
On Fri, Oct 24, 2014 at 05:34:56PM -0500, Eric Rost wrote:
> Removes skein_debug.h include since skein_debug.h is nonexistent.
>
> Signed-off-by: Eric Rost
> ---
> drivers/staging/skein/skein_base.h | 9 +
> 1 file changed, 1 insertion(+), 8 deletions(-)
>
> diff --git a/drivers/staging
On Mon, Oct 27, 2014 at 02:42:40PM +0300, Dan Carpenter wrote:
> On Thu, Oct 23, 2014 at 09:52:20PM +0900, Gioh Kim wrote:
> > This patch creates debugfs files, /sys/kernel/debug/ion/heaps/system_shrink,
> > to shrink pool or get pool size.
> > Reading the file returns pool size and writing occurs
On Mon, Oct 27, 2014 at 03:12:57PM +0300, Dan Carpenter wrote:
> On Mon, Oct 27, 2014 at 05:22:21PM +0530, Sudip Mukherjee wrote:
> > On Mon, Oct 27, 2014 at 02:13:12PM +0300, Dan Carpenter wrote:
> > > On Sun, Oct 26, 2014 at 06:03:33PM +0530, Sudip Mukherjee wrote:
> > > > @@ -262,7 +257,7 @@ sta
unused variables are removed. These variables were only assigned some
values and after that they were never being used. So they are safe to
be removed , and it has been build tested.
I left a call to r8712_read32(padapter, TCR) and
r8712_read8(padapter, SDIO_HCPWM) .
r8712_read32() and r8712_read
On Mon, Oct 27, 2014 at 05:22:21PM +0530, Sudip Mukherjee wrote:
> On Mon, Oct 27, 2014 at 02:13:12PM +0300, Dan Carpenter wrote:
> > On Sun, Oct 26, 2014 at 06:03:33PM +0530, Sudip Mukherjee wrote:
> > > @@ -262,7 +257,7 @@ static u8 rtl8712_dl_fw(struct _adapter *padapter)
> > > if (tmp
On Wed, Oct 22, 2014 at 05:52:23PM -0400, Erik Arfvidson wrote:
> @@ -301,13 +302,13 @@ del_scsipending_entry(struct virthba_info *vhbainfo,
> uintptr_t del)
>
> if (del >= MAX_PENDING_REQUESTS) {
> LOGERR("Invalid queue position <<%lu>> given to delete.
> MAX_PENDING_REQUES
On Wed, Oct 22, 2014 at 05:52:25PM -0400, Erik Arfvidson wrote:
> This patch adds comment documentation to visorchannel_tag struct
>
> Signed-off-by: Erik Arfvidson
> Signed-off-by: Benjamin Romer
> ---
> drivers/staging/unisys/visorchannel/visorchannel_funcs.c | 4 ++--
> 1 file changed, 2 ins
On Mon, Oct 27, 2014 at 02:13:12PM +0300, Dan Carpenter wrote:
> On Sun, Oct 26, 2014 at 06:03:33PM +0530, Sudip Mukherjee wrote:
> > @@ -262,7 +257,7 @@ static u8 rtl8712_dl_fw(struct _adapter *padapter)
> > if (tmp8_a != (tmp8|BIT(2)))
> > goto exit_fail;
> >
> >
On Thu, Oct 23, 2014 at 09:52:20PM +0900, Gioh Kim wrote:
> This patch creates debugfs files, /sys/kernel/debug/ion/heaps/system_shrink,
> to shrink pool or get pool size.
> Reading the file returns pool size and writing occurs to shrink pool.
The patch looks fine. Of course, the original code wa
On Sun, Oct 26, 2014 at 10:56:34AM -0700, Insop Song wrote:
> Devendra
>
> Since these are small changes, I want one patch set instead of three unless
> Greg says otherwise.
>
Normally in staging/ we would insist on three patches for this. The one
thing per patch rule is a bit ambiguous at tim
On Sun, Oct 26, 2014 at 06:03:33PM +0530, Sudip Mukherjee wrote:
> @@ -262,7 +257,7 @@ static u8 rtl8712_dl_fw(struct _adapter *padapter)
> if (tmp8_a != (tmp8|BIT(2)))
> goto exit_fail;
>
> - tmp32 = r8712_read32(padapter, TCR);
> + r87
Sanjeev Sharma writes:
> This is a patch to the rtw_cmd.c file that fixes
> Error reported by checkpatch.
>
> Signed-off-by: Sanjeev Sharma
> ---
> drivers/staging/rtl8723au/core/rtw_cmd.c | 83
> +++-
> 1 file changed, 40 insertions(+), 43 deletions(-)
>
> diff --gi
This is a patch to the rtw_cmd.c file that fixes
Error reported by checkpatch.
Signed-off-by: Sanjeev Sharma
---
drivers/staging/rtl8723au/core/rtw_cmd.c | 83 +++-
1 file changed, 40 insertions(+), 43 deletions(-)
diff --git a/drivers/staging/rtl8723au/core/rtw_cmd.
Look ok.
Regards
Sanjeev Sharma
-Original Message-
From: Greg Donald [mailto:gdon...@gmail.com]
Sent: Monday, October 27, 2014 1:49 AM
To: Greg Kroah-Hartman; Ana Rey; Peter P Waskiewicz Jr; Chaitanya Hazarey;
Sharma, Sanjeev; Roxana Blaj; Antoine Schweitzer-Chaput;
de...@driverdev.osu
45 matches
Mail list logo