[PATCH] staging: rtl8188eu: include missing header

2014-09-05 Thread Nicolas Thery
This patch fixes the following sparse warnings: drivers/staging/rtl8188eu/hal/phy.c:46:5: warning: symbol 'phy_query_bb_reg' was not declared. Should it be static? drivers/staging/rtl8188eu/hal/phy.c:56:6: warning: symbol 'phy_set_bb_reg' was not declared. Should it be static? drivers/staging/rtl8

[PATCH] staging: ozwpan: Fix coding style warnings

2014-09-05 Thread anicoara
The warnings addressed: 1. Missing a blank line after declarations. 2. else is not generally useful after a break or return Signed-off-by: Adrian Nicoara --- Patch submitted as part of the Eudyptula challenge. drivers/staging/ozwpan/ozpd.c | 16 ++-- 1 file changed, 10 insertions(+

Re: [patch -next] hyperv: NULL dereference on error

2014-09-05 Thread David Miller
From: Dan Carpenter Date: Thu, 4 Sep 2014 14:11:23 +0300 > We try to call free_netvsc_device(net_device) when "net_device" is NULL. > It leads to an Oops. > > Fixes: f90251c8a6d0 ('hyperv: Increase the buffer length for > netvsc_channel_cb()') > Signed-off-by: Dan Carpenter Applied, thanks Da

RE: [PATCH 1/1] Drivers: hv: vmbus: Enable interrupt driven flow control

2014-09-05 Thread KY Srinivasan
> -Original Message- > From: Greg KH [mailto:gre...@linuxfoundation.org] > Sent: Friday, September 5, 2014 12:12 PM > To: KY Srinivasan > Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org; > o...@aepfle.de; a...@canonical.com; jasow...@redhat.com > Subject: Re: [PATCH 1/1] Dr

[PATCH V2 1/1] Drivers: hv: vmbus: Enable interrupt driven flow control

2014-09-05 Thread K. Y. Srinivasan
In win8 we have a feature that allows for interrupt driven flow management for host/guest communication. For instance, if the host were blocked because there was no space available in the ringbuffer, the host could request that the guest send an interrupt when space becomes available in the ringbuf

Re: [PATCH 1/1] Drivers: hv: vmbus: Enable interrupt driven flow control

2014-09-05 Thread Greg KH
On Fri, Sep 05, 2014 at 08:53:01PM +, KY Srinivasan wrote: > > > > -Original Message- > > From: Greg KH [mailto:gre...@linuxfoundation.org] > > Sent: Friday, September 5, 2014 12:12 PM > > To: KY Srinivasan > > Cc: linux-ker...@vger.kernel.org; de...@linuxdriverproject.org; > > o...@a

Re: [PATCH 1/1] Drivers: hv: vmbus: Enable interrupt driven flow control

2014-09-05 Thread Greg KH
On Fri, Sep 05, 2014 at 11:23:22AM -0700, K. Y. Srinivasan wrote: > This is a win8 feature that has been implemented. Turn on the feature bit > to enable the feature. What does those two sentances even mean? > With this feature turned on, What is "this"? > when the host is waiting > for space t

Re: [PATCH] rtl8188eu: Replace rcu_dereference() with rcu_access_pointer()

2014-09-05 Thread Andreea Bernat
2014-09-05 0:38 GMT+03:00 Greg KH : > On Thu, Sep 04, 2014 at 11:58:36PM +0300, Andreea Bernat wrote: >> Hello, >> >> I cloned this: >> git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git >> >> and after moved to staging-next branch, but in both cases, in >> those files I don't find an

[PATCH 1/1] Drivers: hv: vmbus: Enable interrupt driven flow control

2014-09-05 Thread K. Y. Srinivasan
This is a win8 feature that has been implemented. Turn on the feature bit to enable the feature. With this feature turned on, when the host is waiting for space to become available on the ringbuffer (host to guest), the guest will interrupt the host when space becomes available (as part of draining

[PATCH 02/17] staging: comedi: adl_pci9118: don't reset digital outputs

2014-09-05 Thread H Hartley Sweeten
Currently this driver resets the digital output channels to a low state when the driver is attached and detached. Since the digital output state can be read, initialize the subdevice state when the driver is attached and don't reset them. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg

[PATCH 08/17] staging: comedi: adl_pci9118: fix ai range/aref programming

2014-09-05 Thread H Hartley Sweeten
Currently the analog input range and aref are set in setup_channel_list(). This works for the (*insn_read) but the (*do_cmd) has a problem. In (*do_cmd) the ai control register is reset to 0 before the function works out the bits needed to control the acquisition. This happens after the setup_chan

[PATCH 11/17] staging: comedi: adl_pci9118: rename 'IntControlReg'

2014-09-05 Thread H Hartley Sweeten
Rename this CamelCase member of the private data. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/adl_pci9118.c | 28 1 file changed, 12 insertions(+), 16 deletions(-) diff --git a/drivers/staging/comedi/dr

[PATCH 03/17] staging: comedi: adl_pci9118: move digitial input (*insn_bits) function

2014-09-05 Thread H Hartley Sweeten
For aesthetics, move the digital inputs (*insn_bits) function so it is not located in the middle of the analog input functions. Also, rename it for consistency. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/adl_pci9118.c | 32

[PATCH 07/17] staging: comedi: adl_pci9118: ai (*insn_read) does not use interrupts

2014-09-05 Thread H Hartley Sweeten
The analog input (*insn_read) in this driver is done as a software-triggered, polled operation. The PCI9118_AI_CTRL_INT bit in the control register, which is actually set in setup_channel_list(), should not be set. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- driv

[PATCH 01/17] staging: comedi: adl_pci9118: move digitial output (*insn_bits) function

2014-09-05 Thread H Hartley Sweeten
For aesthetics, move the digital outputs (*insn_bits) function so it is not located in the middle of the analog input functions. Also, rename it for consistency. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/adl_pci9118.c | 40 +++

[PATCH 16/17] staging: comedi: adl_pci9118: tidy up some wordy comments

2014-09-05 Thread H Hartley Sweeten
Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/adl_pci9118.c | 26 -- 1 file changed, 4 insertions(+), 22 deletions(-) diff --git a/drivers/staging/comedi/drivers/adl_pci9118.c b/drivers/staging/comedi/drivers/

[PATCH 15/17] staging: comedi: adl_pci9118: no need to reset ai FIFO after (*insn_read)

2014-09-05 Thread H Hartley Sweeten
The analog input FIFO is reset at the start of every (*insn_read) and (*do_cmd) operation. It's also reset for the analog input (*cancel). There's no reason to reset the FIFO if an (*insn_read) times out or after all the samples have been acquired. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott

[PATCH 13/17] staging: comedi: adl_pci9118: introduce pci9118_amcc_dma_ena()

2014-09-05 Thread H Hartley Sweeten
Introduce a helper function to program the AMCC master control/status register to enable/disable dma. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/adl_pci9118.c | 25 - 1 file changed, 16 insertions(+), 9 dele

[PATCH 10/17] staging: comedi: adl_pci9118: rename 'AdControlReg'

2014-09-05 Thread H Hartley Sweeten
Rename this CamelCase member of the private data. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/adl_pci9118.c | 48 ++-- 1 file changed, 24 insertions(+), 24 deletions(-) diff --git a/drivers/staging/comedi/dr

[PATCH 12/17] staging: comedi: adl_pci9118: introduce pci9118_amcc_int_ena()

2014-09-05 Thread H Hartley Sweeten
Introduce a helper function to program the AMCC interrupt control/ status register to enable/disable interrupts. Fix the analog input (*cancel). The analog input async command support is the only interrupt generator. The (*cancel) should always disable interrupts. Signed-off-by: H Hartley Sweeten

[PATCH 00/17] staging: comedi: adl_pci9118: tidy up driver

2014-09-05 Thread H Hartley Sweeten
Cleans up all the non-async command support code. This series applies after: [PATCH 00/21] staging: comedi: adl_pci9118: cleanup the boardinfo and attach [PATCH 00/19] staging: comedi: adl_pci9118: tidy up register map H Hartley Sweeten (17): staging: comedi: adl_pci9118: move digitial output (

[PATCH 09/17] staging: comedi: adl_pci9118: rename 'AdFunctionReg'

2014-09-05 Thread H Hartley Sweeten
Rename this CamelCase member of the private data. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/adl_pci9118.c | 54 ++-- 1 file changed, 27 insertions(+), 27 deletions(-) diff --git a/drivers/staging/comedi/dr

[PATCH 05/17] staging: comedi: adl_pci9118: move analog output (*insn_write) function

2014-09-05 Thread H Hartley Sweeten
For aesthetics, move the analog output (*insn_write) function so it is not located in the middle of the analog input functions. Also, rename it for consistency. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/adl_pci9118.c | 38

[PATCH 17/17] staging: comedi: adl_pci9118: move analog input (*insn_read) function

2014-09-05 Thread H Hartley Sweeten
For aesthetics, move the analog input (*insn_read) function so it is not located in the middle of the async command support functions. Also, rename it for consistency. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/adl_pci9118.c | 123

[PATCH 04/17] staging: comedi: adl_pci9118: use comedi_subdevice 'readback'

2014-09-05 Thread H Hartley Sweeten
Use the new comedi_subdevice 'readback' member and the core provided (*insn_read) for the readback of the analog output subdevice channels. The board is "reset" prior to the subdevice init. Part of this reset sets all the analog output channels to 0V. Move the initialization of the 'readback' valu

[PATCH 14/17] staging: comedi: adl_pci9118: introduce pci9118_amcc_setup_dma()

2014-09-05 Thread H Hartley Sweeten
Introduce a helper function to program the AMCC master write address and transfer count registers to setup a DMA transaction. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/adl_pci9118.c | 29 1 file change

[PATCH 06/17] staging: comedi: adl_pci9118: cleanup and simplify pci9118_reset()

2014-09-05 Thread H Hartley Sweeten
Change the return type to void, this function always succeeds and the callers never check the return value. According to the The User Manual for the PCI-9118, the hardware does not require any particular "reset" in order to function. Simplify the reset so it justs gets the board info a known state

[PATCH] staging: xgifb: remove unnecessary else

2014-09-05 Thread Thomas Gummerer
Signed-off-by: Thomas Gummerer --- drivers/staging/xgifb/XGI_main_26.c | 10 +++- drivers/staging/xgifb/vb_init.c | 50 - drivers/staging/xgifb/vb_setmode.c | 3 +-- 3 files changed, 26 insertions(+), 37 deletions(-) diff --git a/drivers/staging/xgif

[PATCH] staging: xgifb: remove unnecessary else

2014-09-05 Thread Thomas Gummerer
Signed-off-by: Thomas Gummerer --- drivers/staging/xgifb/XGI_main_26.c | 10 +++- drivers/staging/xgifb/vb_init.c | 50 - drivers/staging/xgifb/vb_setmode.c | 3 +-- 3 files changed, 26 insertions(+), 37 deletions(-) diff --git a/drivers/staging/xgif

[PATCH] [next-20140904] staging: gs_fpgaboot: remove checks for CONFIG_B4860G100

2014-09-05 Thread Paul Bolle
There are two checks for CONFIG_B4860G100 in this driver. But there's no Kconfig symbol B4860G100. These checks will always evaluate to false. Remove them and the code they hide. Signed-off-by: Paul Bolle --- Build tested only (by building just drivers/staging/gs_fpgaboot/io.o). Perhaps this ena

Re: [PATCH 00/19] staging: comedi: adl_pci9118: tidy up register map

2014-09-05 Thread Ian Abbott
On 2014-09-04 20:14, H Hartley Sweeten wrote: Rename the register map defines and remove all the CamelCase. This series applies after: [PATCH 00/21] staging: comedi: adl_pci9118: cleanup the boardinfo and attach H Hartley Sweeten (19): staging: comedi: adl_pci9118: all registers are 32-bit

Re: [PATCH 14/18] staging: xillybus: Fix incorrect cast

2014-09-05 Thread Eli Billauer
On 05/09/14 12:26, Dan Carpenter wrote: Sorry, I was just wrong on here. I misread the code and also my review comments were too vague and must have puzzled you. (Feel free to call me out on this if I'm wrong next time.) I beg to differ on this one: Your comments were crystal clear. The fac

[PATCH] staging: xillybus: Removed unnecessary cast

2014-09-05 Thread Eli Billauer
Suggested-by: Dan Carpenter Signed-off-by: Eli Billauer --- drivers/staging/xillybus/xillybus_core.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/drivers/staging/xillybus/xillybus_core.c b/drivers/staging/xillybus/xillybus_core.c index 30bb7ac..b827fa0 100644 --- a/

Re: [PATCH] staging: iio: adc: mxs-lradc.c: sparse warning of incorrect type

2014-09-05 Thread Sudip Mukherjee
On Fri, Sep 05, 2014 at 12:34:13PM +0300, Dan Carpenter wrote: > On Thu, Sep 04, 2014 at 10:15:42PM +0530, Sudip Mukherjee wrote: > > fixed sparse warning : incorrect type in argument 1 > >(different address spaces) > > > > The change log is not clear. It's the IS_ERR() whic

Re: [PATCH] staging: iio: adc: mxs-lradc.c: sparse warning of incorrect type

2014-09-05 Thread Dan Carpenter
On Thu, Sep 04, 2014 at 10:15:42PM +0530, Sudip Mukherjee wrote: > fixed sparse warning : incorrect type in argument 1 > (different address spaces) > The change log is not clear. It's the IS_ERR() which is the problem? This is a false positive which is fixed in a later vers

Re: [PATCH 00/18] staging: xillybus: Coding style fixes

2014-09-05 Thread Dan Carpenter
Thanks for his! Reviewed-by: Dan Carpenter regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH 14/18] staging: xillybus: Fix incorrect cast

2014-09-05 Thread Dan Carpenter
On Thu, Sep 04, 2014 at 05:47:53PM +0300, Eli Billauer wrote: > Suggested-by: Dan Carpenter > Signed-off-by: Eli Billauer > --- > drivers/staging/xillybus/xillybus_core.c |2 +- > 1 files changed, 1 insertions(+), 1 deletions(-) > > diff --git a/drivers/staging/xillybus/xillybus_core.c > b

Re: [PATCH 00/21] staging: comedi: adl_pci9118: cleanup the boardinfo and attach

2014-09-05 Thread Ian Abbott
On 2014-09-04 18:39, H Hartley Sweeten wrote: Remove all the unused information in the boardinfo and tidy it up. Clenaup the attach of this driver a bit. H Hartley Sweeten (21): staging: comedi: adl_pci9118: remove unused boardinfo staging: comedi: adl_pci9118: remove 'rangelist_ao' board

[PATCH] staging: unisys: uislib: uislib.c: sparse warning of context imbalance

2014-09-05 Thread Sudip Mukherjee
fixed sparse warning : context imbalance in 'pause_device' unexpected unlock this patch will generate warning from checkpatch for lines over 80 character , but since those are user-visible strings so it was not modified. Signed-off-by: Sudip Mukherjee --- hi , can you p

Re: [PATCH 1/1] Drivers: scsi: storvsc: Get rid of warning messages

2014-09-05 Thread Sitsofe Wheeler
On Thu, Sep 04, 2014 at 10:40:14PM -0700, Christoph Hellwig wrote: > Looks good to me. > > Olaf, Hannes - can I get another review for this (and the older hyperv > scanning patch set)? I agree this looks useful because on a 59753a805499f1ffbca4ac0a24b3dff67bf1 3.17rc2 kernel with 92578ea Dri