[PATCH] staging: lustre: lustre: mdc: mdc_reint: fix coding style issue

2014-08-31 Thread sunwxg
From: Sun Wang Coding style issues, the changes include: -Remove '{}' Signed-off-by: Sun Wang --- drivers/staging/lustre/lustre/mdc/mdc_reint.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/lustre/lustre/mdc/mdc_reint.c b/drivers/staging/lustre/lustr

[PATCH 1/4] staging: comedi: hwdrv_apci1500: remove unneeded braces

2014-08-31 Thread Chase Southwood
We don't need braces around single-statement blocks. Signed-off-by: Chase Southwood Cc: Ian Abbott Cc: H Hartley Sweeten --- .../comedi/drivers/addi-data/hwdrv_apci1500.c | 30 +- 1 file changed, 12 insertions(+), 18 deletions(-) diff --git a/drivers/staging/comedi/dr

[PATCH 4/4] staging: comedi: hwdrv_apci1500: miscellaneous cleanup

2014-08-31 Thread Chase Southwood
This patch completes two final matters of cleanup which are each too small for their own patch. It corrects a couple of indentation issues and removes a return statement at the end of a void function. Signed-off-by: Chase Southwood Cc: Ian Abbott Cc: H Hartley Sweeten --- .../staging/comedi/d

[PATCH 3/4] staging: comedi: hwdrv_apci1500: clean some whitespace style issues

2014-08-31 Thread Chase Southwood
Now that commented out code has been removed, else statements can move to the same line as the close brace of the if statement. Also, a blank line has been added between declarations and code where needed. Signed-off-by: Chase Southwood Cc: Ian Abbott Cc: H Hartley Sweeten --- .../comedi/driv

[PATCH 2/4] staging: comedi: hwdrv_apci1500: remove commented out code

2014-08-31 Thread Chase Southwood
Signed-off-by: Chase Southwood Cc: Ian Abbott Cc: H Hartley Sweeten --- .../comedi/drivers/addi-data/hwdrv_apci1500.c | 249 ++--- 1 file changed, 123 insertions(+), 126 deletions(-) diff --git a/drivers/staging/comedi/drivers/addi-data/hwdrv_apci1500.c b/drivers/staging/

[PATCH 0/4] staging: comedi: hwdrv_apci1500: coding style cleanups

2014-08-31 Thread Chase Southwood
This patchset begins by removing unneeded braces and commented out lines of code, and then tidies whitespace issues that are revealed after the braces/dead code is removed. Chase Southwood (4): staging: comedi: hwdrv_apci1500: remove unneeded braces staging: comedi: hwdrv_apci1500: remove comm

[PATCH] staging: comedi: hwdrv_apci035: remove useless return statement

2014-08-31 Thread Chase Southwood
Checkpatch pointed out a void function with a return statement. It can be removed. Signed-off-by: Chase Southwood Cc: Ian Abbott Cc: H Hartley Sweeten --- drivers/staging/comedi/drivers/addi-data/hwdrv_apci035.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/comedi/drive

[PATCH] staging: comedi: hwdrv_apci3501: change printk to dev_err

2014-08-31 Thread Chase Southwood
dev_err() is preferred to printk() in device drivers. Signed-off-by: Chase Southwood Cc: Ian Abbott Cc: H Hartley Sweeten --- drivers/staging/comedi/drivers/addi-data/hwdrv_apci3501.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers/addi-data/h

Re: [PATCH RFC v2 3/8] component: add support for component match array

2014-08-31 Thread Inki Dae
On 2014년 08월 31일 06:33, Russell King - ARM Linux wrote: > On Thu, Jul 03, 2014 at 12:26:39AM +0900, Inki Dae wrote: >> 2014-07-01 23:22 GMT+09:00 Russell King - ARM Linux : >>> On Thu, Jun 26, 2014 at 03:46:01PM +0100, Russell King - ARM Linux wrote: On Thu, Jun 26, 2014 at 02:34:17PM +0200, P

[RFC PATCH 0/2] Replace the static array with the list

2014-08-31 Thread Konrad Zapalowicz
These patches replace the fixed-size, static array used to keep track of board structures with dynamic solution based on the list. I marked this series as RFC since I need input on if this can be done better. Konrad Zapalowicz (2): staging: dgnc: Make the struct dgnc_board possible to use list

[PATCH 2/2] staging: dgnc: Replace fixed-size board array with list

2014-08-31 Thread Konrad Zapalowicz
Each registered board is asigned a data structure to keep it's state. So far this was implemented using the static array of fixed-size. This commit changes the implementation by replacing the array with dynamic solution based on the kernel list. Signed-off-by: Konrad Zapalowicz --- drivers/stagi

[PATCH 1/2] staging: dgnc: Make the struct dgnc_board possible to use list facility

2014-08-31 Thread Konrad Zapalowicz
This commit adds the struct list_head to the struct dgnc_board so that it is now possible to use it with the Linux list facility. Signed-off-by: Konrad Zapalowicz --- drivers/staging/dgnc/dgnc_driver.h | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/dgnc/dgnc_driver.h b/driv

Re: [PATCH] checkpatch: Remove unnecessary + after {8,8}

2014-08-31 Thread Sören Brinkmann
Hi Joe, On Fri, 2014-07-11 at 07:09PM -0700, Joe Perches wrote: > There's a useless "+" use that needs to be removed as perl 5.20 > emits a "Useless use of greediness modifier '+'" message each > time it's hit. I saw this Perl warning today as well and wondered whether this patch is coming or not

[PATCH] staging: android: add a blank line after declarations

2014-08-31 Thread Grzegorz Swirski
Signed-off-by: Grzegorz Swirski --- drivers/staging/android/sync.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c index e7b2e02..0d37495 100644 --- a/drivers/staging/android/sync.c +++ b/drivers/staging/android/sync.c @@ -705,6

[PATCH 1/2] staging: octeon-usb: use generic control packet header

2014-08-31 Thread Aaro Koskinen
Use generic control packet header structure definition. Signed-off-by: Aaro Koskinen --- drivers/staging/octeon-usb/octeon-hcd.c | 50 + 1 file changed, 14 insertions(+), 36 deletions(-) diff --git a/drivers/staging/octeon-usb/octeon-hcd.c b/drivers/staging/octe

[PATCH 2/2] staging: octeon-usb: use USB_DIR_IN

2014-08-31 Thread Aaro Koskinen
Replace a magic value with #defined macro. Signed-off-by: Aaro Koskinen --- drivers/staging/octeon-usb/octeon-hcd.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/staging/octeon-usb/octeon-hcd.c b/drivers/staging/octeon-usb/octeon-hcd.c index f478f59.

[PATCH] staging: dgnc: Fix sleeping under spinlock bug

2014-08-31 Thread Konrad Zapalowicz
From: Konrad Zapalowicz This commit changes the memory allocation flags to ATOMIC in order to avoid sleeping in the nowait/nolock code. Signed-off-by: Konrad Zapalowicz --- drivers/staging/dgnc/dgnc_tty.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/dgnc/

Re: [PATCH] staging: goldfish_audio.c: sparse warning of incorrect type

2014-08-31 Thread Greg Kroah-Hartman
Adding Alan Cox, as he pushed this driver upstream... On Sun, Aug 31, 2014 at 09:46:22PM +0530, Sudip Mukherjee wrote: > fixed sparse warning of incorrect type in argument 1 and incorrect type in > argument 2 > it was directly dereferencing a __iomem pointer , which will work in x86 but > will f

[PATCH] staging: comedi: usbduxsigma: fix more sparse endianness warnings

2014-08-31 Thread Chase Southwood
Sparse shows a couple of warnings like: drivers/staging/comedi/drivers/usbduxsigma.c:787:23: warning: cast to restricted __be32 Looking at the indicated lines shows that the issue is caused by an incorrect cast to uint32_t instead of __be32. Fix this cast. Signed-off-by: Chase Southwood Cc: I

[PATCH] staging: comedi: usbdux: fix more sparse endianness warnings

2014-08-31 Thread Chase Southwood
Sparse shows a couple of warnings like: drivers/staging/comedi/drivers/usbdux.c:889:20: warning: incorrect type in assignment (different base types) drivers/staging/comedi/drivers/usbdux.c:889:20:expected unsigned short [unsigned] [short] [usertype] drivers/staging/comedi/drivers/usbdux.c:8

Re: [PATCH] staging: comedi: usbdux: fix sparse endianness warnings

2014-08-31 Thread Chase Southwood
On Sat, Aug 30, 2014 at 5:40 AM, Ian Abbott wrote: > > That seems fine. Perhaps the variable 'p' in usbdux_ao_insn_write() should > also be of type '__le16 *'? > You're entirely correct. I had seen this in the output from Sparse, but for some reason at first glance I had convinced myself that t

Re: [PATCH] staging: lustre: lustre: ptlrpc: events: fix coding style issue

2014-08-31 Thread Drokin, Oleg
Apparently this was already fixed by commit 1d8cb70c7bdda47125ed551fc390aa9597c5f264 a few days ago. On Aug 31, 2014, at 1:02 PM, Sun Wang wrote: > From: sunwxg <743559...@qq.com> > > Coding style issues, the changes include: > -Add sapce after ',' > > Signed-off-by: Sun Wang <743559...@qq.com

[PATCH] staging: lustre: lustre: ptlrpc: events: fix coding style issue

2014-08-31 Thread Sun Wang
From: sunwxg <743559...@qq.com> Coding style issues, the changes include: -Add sapce after ',' Signed-off-by: Sun Wang <743559...@qq.com> --- drivers/staging/lustre/lustre/ptlrpc/events.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/staging/lustre/lustre/ptlr

[PATCH] staging: goldfish_audio.c: sparse warning of incorrect type

2014-08-31 Thread Sudip Mukherjee
fixed sparse warning of incorrect type in argument 1 and incorrect type in argument 2 it was directly dereferencing a __iomem pointer , which will work in x86 but will fail in other architectures. Signed-off-by: Sudip Mukherjee --- hi, can you please reveiew the patch and check if the approach

Re: [PATCH 3/8] staging: et131x: Use for loop to initialise contiguous registers to zero

2014-08-31 Thread Greg KH
On Sun, Aug 31, 2014 at 03:25:03PM +0100, Mark Einon wrote: > On Sat, Aug 30, 2014 at 01:32:16PM -0700, Greg KH wrote: > > On Wed, Aug 20, 2014 at 11:17:53PM +0100, Mark Einon wrote: > > > Replace a long list of contiguous writel() calls with a for loop iterating > > > over the same values. > > >

[PATCH] staging: dgnc: remove some unused macros

2014-08-31 Thread Seunghun Lee
These macros do nothing, so remove it. CC: Lidza Louina CC: Mark Hounschell Signed-off-by: Seunghun Lee --- drivers/staging/dgnc/dgnc_driver.h |7 ++- 1 file changed, 2 insertions(+), 5 deletions(-) diff --git a/drivers/staging/dgnc/dgnc_driver.h b/drivers/staging/dgnc/dgnc_driver.h

Re: [PATCH 3/8] staging: et131x: Use for loop to initialise contiguous registers to zero

2014-08-31 Thread Mark Einon
On Sat, Aug 30, 2014 at 01:32:16PM -0700, Greg KH wrote: > On Wed, Aug 20, 2014 at 11:17:53PM +0100, Mark Einon wrote: > > Replace a long list of contiguous writel() calls with a for loop iterating > > over the same values. > > > > Signed-off-by: Mark Einon > > --- > > drivers/staging/et131x/et1

FROM: Husam Al Sayed

2014-08-31 Thread Husam Al Sayed
FROM: Husam Al Sayed. EMAIL: husamalsayed...@hotmail.com Hello, I decided to write you this proposal in good faith, believing that you will not betray me. I am Mr. Husam Al Sayed, a Bank officer here in U.A.E. One Mr. Peter Adams, a citizen of your country and Crude Oil dealer made a fixed

[PATCH] staging: lustre: lustre: ptlrpc: Fix space required

2014-08-31 Thread Hema Prathaban
This patch fixes the checkpatch.pl issue Error: Required space after " '+' ',' '=' '(' ' if' " Signed-off-by: Hema Prathaban --- drivers/staging/lustre/lustre/ptlrpc/client.c | 2 +- drivers/staging/lustre/lustre/ptlrpc/import.c | 4 ++-- drivers/staging/lustre/lustre/ptlrpc/llog_cli

Re: [PATCH] staging: ad7606_core: Fix checkpatch warning

2014-08-31 Thread Jonathan Cameron
On 31/08/14 07:57, Sören Brinkmann wrote: > Fix the checkpatch complaint regarding unnecessary line continuation. > WARNING: Avoid unnecessary line continuations > #143: FILE: ad7606_core.c:143: > > Signed-off-by: Sören Brinkmann Applied to the togreg branch of iio.git. Initially pushed out

[PATCH] staging: lustre: lnet: lib-ptl.c: sparsa warning: symbol not declared

2014-08-31 Thread Sudip Mukherjee
fixed sparse warning of following symbol not declared: warning: symbol 'lnet_ptl_cleanup' was not declared. Should it be static? warning: symbol 'lnet_ptl_setup' was not declared. Should it be static? Signed-off-by: Sudip Mukherjee --- As of now these functions are not being called from any ot

Re: [PATCH] Staging: bcm: fixed a comment coding style issue

2014-08-31 Thread Matthias Beyer
Reviewed-by: Matthias Beyer On 31-08-2014 12:24:50, Anh Le wrote: > Fixed a C99 comment issue in InterfaceMisc.h. > > Signed-off-by: Anh Le > --- > drivers/staging/bcm/InterfaceMisc.h | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/staging/bcm/InterfaceMisc.h

[PATCH 8/9] staging: rtl8188eu: Rename rtl8188e_rf6052.c to rf.c

2014-08-31 Thread navin patidar
Signed-off-by: navin patidar --- drivers/staging/rtl8188eu/Makefile |2 +- drivers/staging/rtl8188eu/hal/rf.c | 316 +++ drivers/staging/rtl8188eu/hal/rtl8188e_rf6052.c | 316 --- 3 files changed, 317 insertions(+), 317 delet

[PATCH 9/9] staging: rtl8188eu: Remove unused function SetBcnCtrlReg()

2014-08-31 Thread navin patidar
Signed-off-by: navin patidar --- drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c | 18 -- drivers/staging/rtl8188eu/include/rtl8188e_hal.h |1 - 2 files changed, 19 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c b/drivers/staging/rtl8188eu/h

[PATCH 7/9] staging: rtl8188eu: Remove file rtl8188e_rf.h

2014-08-31 Thread navin patidar
Move macros from rtl8188e_rf.h to rf.h and then remove rtl8188e_rf.h . Signed-off-by: navin patidar --- drivers/staging/rtl8188eu/hal/rtl8188e_rf6052.c |1 + drivers/staging/rtl8188eu/include/rf.h |3 ++ drivers/staging/rtl8188eu/include/rtl8188e_hal.h |1 - drivers/stagin

[PATCH 5/9] staging: rtl8188eu: Rework function writeOFDMPowerReg88E()

2014-08-31 Thread navin patidar
Rename CamelCase variables and function name. Remove a block of the code which is executed only if RF type is T2R2 but rtl8188eu's RF is a T1R1 type, so driver doesn't need that code. Signed-off-by: navin patidar --- drivers/staging/rtl8188eu/hal/rtl8188e_rf6052.c | 50 +++

[PATCH 6/9] staging: rtl8188eu: Rework function get_rx_power_val_by_reg()

2014-08-31 Thread navin patidar
Rename CamelCase variables. Remove block of the code which is specific to the bluetooth. Signed-off-by: navin patidar --- drivers/staging/rtl8188eu/hal/rtl8188e_rf6052.c | 92 +++ 1 file changed, 45 insertions(+), 47 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/

[PATCH 4/9] staging: rtl8188eu: Rework function rtl8188e_PHY_RF6052SetOFDMTxPower()

2014-08-31 Thread navin patidar
Rename CamelCase variables and function name. Signed-off-by: navin patidar --- drivers/staging/rtl8188eu/hal/phy.c |2 +- drivers/staging/rtl8188eu/hal/rtl8188e_rf6052.c | 61 +++ drivers/staging/rtl8188eu/include/rf.h |4 ++ drivers/staging/rtl

[PATCH 1/9] staging: rtl8188eu: Rework function rtl8188e_PHY_RF6052SetBandwidth()

2014-08-31 Thread navin patidar
Rename CamelCase variables and function name. Signed-off-by: navin patidar --- drivers/staging/rtl8188eu/hal/phy.c |3 +- drivers/staging/rtl8188eu/hal/rtl8188e_rf6052.c | 58 +-- drivers/staging/rtl8188eu/include/rf.h |2 + 3 files changed, 16

[PATCH 2/9] staging: rtl8188eu: Rework function rtl8188e_PHY_RF6052SetCckTxPower()

2014-08-31 Thread navin patidar
Rename CamelCase variables and function name. Remove redundant variable TurboScanOff. Signed-off-by: navin patidar --- drivers/staging/rtl8188eu/hal/phy.c |2 +- drivers/staging/rtl8188eu/hal/rtl8188e_rf6052.c | 124 --- drivers/staging/rtl8188eu/include/rf.h

[PATCH 3/9] staging: rtl8188eu: Rework function getpowerbase88e()

2014-08-31 Thread navin patidar
Rename CamelCase variables. Signed-off-by: navin patidar --- drivers/staging/rtl8188eu/hal/rtl8188e_rf6052.c | 33 --- 1 file changed, 17 insertions(+), 16 deletions(-) diff --git a/drivers/staging/rtl8188eu/hal/rtl8188e_rf6052.c b/drivers/staging/rtl8188eu/hal/rtl8188e_r

Re: [PATCH 03/20] staging: rtl8188eu: Rework function PHY_QueryBBReg()

2014-08-31 Thread navin patidar
On Sun, Aug 31, 2014 at 2:14 AM, Greg KH wrote: > On Sat, Aug 23, 2014 at 07:48:24PM +0530, navin patidar wrote: >> Rename CamelCase variables and function name. >> >> Signed-off-by: navin patidar > > This patch fails to apply: > > checking file drivers/staging/rtl8188eu/hal/HalHWImg8188E_RF.c >