On Wed, 20 Aug 2014 23:17:58 +0100
Mark Einon wrote:
>
> + if (budget > MAX_PACKETS_HANDLED)
> + limit = MAX_PACKETS_HANDLED;
Why this artificial restriction?
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxd
On Wed, 20 Aug 2014 23:17:58 +0100
Mark Einon wrote:
> - bool done = true;
> + int count = 0;
> + int limit = budget;
> + bool not_done = false;
Don't use negative variables. Better to keep the original done variable.
___
devel mailing
Ladies and Gentlemen.
In order to have your company inserted in the registry of World Businesses
for 2014/2015 edition, please print, complete and submit the attached
form (PDF file) to the following address:
European Coampany Network
P.O. BOX 3079
3502 GB, Utrecht
The Netherlands
email: regis..
On Wed, Aug 20, 2014 at 7:17 PM, Mark Einon wrote:
> do {
> pci_read_config_dword(pdev,
> - LBCIF_DATA_REGISTER, &val);
> + LBCIF_DATA_REGISTER,
> +
Replace a long list of contiguous writel() calls with a for loop iterating
over the same values.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c | 27 +++
1 file changed, 3 insertions(+), 24 deletions(-)
diff --git a/drivers/staging/et131x/et131x.c b/driver
There's no need to handle any rx/tx interrupts in the middle of an mtu
change, so don't.
After this change, receive and transmit interrupts are only handled in
one place, which paves the way to using NAPI.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c | 2 --
1 file changed, 2 d
Replace a long list of contiguous writel() calls with a for loop iterating
over the same address values.
Also remove redundant comments on the macstat registers, the variable names
are good enough.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c | 59 +++--
dri
To better describe it's use as a hard limit.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/et131x/et131x.c b/drivers/staging/et131x/et131x.c
index 551b250..df83ea3 100644
--- a/drivers/stagi
This implements NAPI support for et131x by:
-adding a napi_struct to the private adapter struct
-changing netfif_rx_skb() call to netif_receive_skb()
-changing et131x_handle_recv_interrupt() to et131x_handle_recv_pkts()
and taking a budget allocation.
-changing et131x_handle_send_interrupt() to e
i2c_wack is only used to implement a while(1) loop, so let's remove it.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/et131x/et131x.c b/drivers/staging/et131x/et131x.c
index fc18e8d..55
We actually mean to clear the ET_INTR_TXDMA_ISR reg after handling
a completed transfer, not the ET_INTR_TXDMA_ERR reg, which should
get handled immediately after.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/dr
There's already working code to set the mac address, so let's use it.
Signed-off-by: Mark Einon
---
drivers/staging/et131x/et131x.c | 53 +
1 file changed, 1 insertion(+), 52 deletions(-)
diff --git a/drivers/staging/et131x/et131x.c b/drivers/staging/et13
Let's put a NAPI on this baby...
NAPI support was identified by Dave Miller as a
must to get this driver out of staging. This patchset first tidies up
the code enough to make adding NAPI easier, and the final patch mostly
adds the 'boilerplate' NAPI code as described by:
http://www.linuxfoundati
checkpatch.pl fix. Use #include instead of
Signed-off-by: Kieron Browne
---
drivers/staging/dgnc/dgnc_tty.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/dgnc/dgnc_tty.c b/drivers/staging/dgnc/dgnc_tty.c
index 281491a..c844fac 100644
--- a/drivers/staging/
Hi Philipp,
Thank you for the patch.
On Tuesday 19 August 2014 15:02:44 Philipp Zabel wrote:
> Using the for_each_... macro should make the code a bit shorter and
> easier to read.
>
> Signed-off-by: Philipp Zabel
Acked-by: Laurent Pinchart
> ---
> drivers/gpu/drm/drm_of.c | 8 ++--
> 1
Hi Philipp,
Thank you for the patch.
On Tuesday 19 August 2014 15:02:43 Philipp Zabel wrote:
> This patch adds a function to get a port device tree node by port id,
> or reg property value.
>
> Signed-off-by: Philipp Zabel
> ---
> drivers/of/base.c| 30 ++
>
Hi Philipp,
Thank you for the patch.
On Tuesday 19 August 2014 15:02:42 Philipp Zabel wrote:
> Note that while of_graph_get_next_endpoint decrements the reference count
> of the child node passed to it, of_node_put(child) still has to be called
> manually when breaking out of the loop.
I think t
Signed-off-by: Purnendu Kapadia
---
drivers/staging/android/sync.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c
index e7b2e02..0d37495 100644
--- a/drivers/staging/android/sync.c
+++ b/drivers/staging/android/sync.c
@@ -705,6
On Wed, 2014-08-20 at 15:13 +0100, Purnendu Kapadia wrote:
> checkpatch fix. add a line before the switch statement
Hello Purnendu.
This is a suboptimal patch description.
There is no generic style asking for a blank line
before a switch statement.
You are actually adding a blank line separatin
On Wed, 2014-08-20 at 12:42 +0300, Andy Shevchenko wrote:
> This allows user to print a given buffer as an escaped string. The rules are
> applied according to an optional mix of flags provided by additional format
> letters.
Thanks Andy. Looks good to me.
Very trivial note:
> diff --git a/lib/
checkpatch fix. add a line before the switch statement
Signed-off-by: Purnendu Kapadia
---
drivers/staging/android/sync.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/android/sync.c b/drivers/staging/android/sync.c
index e7b2e02..0d37495 100644
--- a/drivers/staging/androi
> -Original Message-
> From: Sitsofe Wheeler
> Sent: Wednesday, August 20, 2014 19:40 PM
> > I suppose you're using the latest mainline v3.17-rc1(7d1311b9).
>
> That's right - Linux 3.17-rc1
> (7d1311b93e58ed55f3a31cc8f94c4b8fe988a2b9).
Ok, let me try to reproduce it first.
> > Can you p
On Aug 20, 2014 at 06:19am, Greg Kroah-Hartman wrote:
> On Wed, Aug 20, 2014 at 04:53:22PM +0800, Hoang Tran wrote:
> > This patch fixes the following sparse warnings in rtl8821ae/stats.c
> >
> > drivers/staging/rtl8821ae/stats.c:62:6: warning: symbol
> > 'rtl_translate_todbm' was not declared. S
Hi,
On Wed, Aug 20, 2014 at 11:15:39AM +, Dexuan Cui wrote:
> > -Original Message-
> > From: Sitsofe Wheeler
> > Sent: Wednesday, August 20, 2014 17:27 PM
> > To: Dexuan Cui
> > Cc: KY Srinivasan; Greg Kroah-Hartman; Haiyang Zhang;
> > de...@linuxdriverproject.org; linux-ker...@vger.ke
This patch fixes the following sparse warnings in rtl8821ae/stats.c
drivers/staging/rtl8821ae/stats.c:62:6: warning: symbol 'rtl_translate_todbm'
was not declared. Should it be static?
drivers/staging/rtl8821ae/stats.c:101:6: warning: symbol 'rtl_process_ui_rssi'
was not declared. Should it be s
On Wed, Aug 20, 2014 at 04:53:22PM +0800, Hoang Tran wrote:
> This patch fixes the following sparse warnings in rtl8821ae/stats.c
>
> drivers/staging/rtl8821ae/stats.c:62:6: warning: symbol 'rtl_translate_todbm'
> was not declared. Should it be static?
> drivers/staging/rtl8821ae/stats.c:101:6: w
> -Original Message-
> From: Sitsofe Wheeler
> Sent: Wednesday, August 20, 2014 17:27 PM
> To: Dexuan Cui
> Cc: KY Srinivasan; Greg Kroah-Hartman; Haiyang Zhang;
> de...@linuxdriverproject.org; linux-ker...@vger.kernel.org; Jean-Christophe
> Plagniol-Villard; linux-fb...@vger.kernel.org
>
A: No.
Q: Should I include quotations after my reply?
http://daringfireball.net/2007/07/on_top
On Wed, Aug 20, 2014 at 12:32:52PM +0530, sanjeev sharma wrote:
> Hi,
>
> I have only moved some header files because other header files are already
> present there and these are only pending files wh
The introduced function is a kind of opposite to string_unescape. We have
several users of such functionality each of them created custom implementation.
The series contains clean up of test suite, adding new call, and switching few
users to use it via %*pE specifier.
Test suite covers all of exis
Instead of custom approach this allows to print escaped strings via recently
added kernel extension: %*pE.
Signed-off-by: Andy Shevchenko
---
drivers/net/wireless/ipw2x00/ipw2100.c | 22 +--
drivers/net/wireless/ipw2x00/ipw2200.c | 270 ++-
drivers/net/wireless/i
Instead of custom approach this allows to print escaped strings via recently
added kernel extension: %*pE.
Signed-off-by: Andy Shevchenko
---
drivers/net/wireless/libertas/cfg.c | 8 ++--
drivers/net/wireless/libertas/mesh.c | 7 +++
2 files changed, 5 insertions(+), 10 deletions(-)
di
In kernel we have %*pE specifier to print an escaped buffer. All users now
switched to that approach.
This fixes a bug as well. The current implementation wrongly prints octal
numbers: only two first digits are used in case when 3 are required and the
rest of the string ends up cut off.
Additiona
This allows user to print a given buffer as an escaped string. The rules are
applied according to an optional mix of flags provided by additional format
letters.
For example, if the given buffer is:
1b 62 20 5c 43 07 22 90 0d 5d
The result strings would be:
%*pE"\eb \
The documentation of API belongs to c-file. This patch moves it accordingly.
There is no functional change.
Signed-off-by: Andy Shevchenko
---
include/linux/string_helpers.h | 34 --
lib/string_helpers.c | 38 ++
2 fi
Let's use kernel's native specifier to escape a buffer.
Signed-off-by: Andy Shevchenko
---
drivers/staging/rtl8192u/ieee80211/ieee80211.h | 14 +-
1 file changed, 1 insertion(+), 13 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211.h
b/drivers/staging/rtl8192u/
This is a generic specifier to print an escaped buffer by given criteria. Let's
use it instead of custom approach.
Signed-off-by: Andy Shevchenko
---
drivers/staging/wlan-ng/prism2sta.c | 28 ++--
1 file changed, 2 insertions(+), 26 deletions(-)
diff --git a/drivers/stag
This patch prepares test suite for a following update. It introduces
test_string_check_buf() helper which checks the result and dumps an error.
Signed-off-by: Andy Shevchenko
---
lib/test-string_helpers.c | 39 +++
1 file changed, 27 insertions(+), 12 deletion
Instead of substituting non-printable characters by '_' let's print SSID
properly escaped by using recently added %*pE specifier.
Signed-off-by: Andy Shevchenko
---
drivers/net/wireless/hostap/hostap_proc.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/net/wirele
This is almost the opposite function to string_unescape(). Nevertheless it
handles \0 and could be used for any byte buffer.
The documentation is supplied together with the function prototype.
The test cases covers most of the scenarios and would be expanded later on.
Signed-off-by: Andy Shevche
Let's use kernel's native specifier to escape a buffer.
Signed-off-by: Andy Shevchenko
---
drivers/staging/rtl8192e/rtllib.h | 14 +-
1 file changed, 1 insertion(+), 13 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib.h
b/drivers/staging/rtl8192e/rtllib.h
index 83f5f57..98
While booting a Hyper-V 3.17.0-rc1 guest on a 2012 R2 host a BUG was
triggered while registering hyperv_fb which in turn caused a panic.
Various kernel debugging options (CONFIG_DEBUG_PAGEALLOC,
CONFIG_SLUB_DEBUG=y...) were on at the time. This only seems to happen
if the guest is being booted with
This patch removes the .owner field for drivers which use the
platform_driver_register api because this is overriden in
_platform_driver_register.
Signed-off-by: Sanjeev Sharma
---
drivers/iio/accel/hid-sensor-accel-3d.c | 1 -
drivers/iio/adc/exynos_adc.c | 1 -
drivers/i
This patch fixes the following sparse warnings in rtl8821ae/stats.c
drivers/staging/rtl8821ae/stats.c:62:6: warning: symbol 'rtl_translate_todbm'
was not declared. Should it be static?
drivers/staging/rtl8821ae/stats.c:101:6: warning: symbol 'rtl_process_ui_rssi'
was not declared. Should it be s
This patch fixes the following sparse warnings in rtl8821ae/stats.c
drivers/staging/rtl8821ae/stats.c:62:6: warning: symbol 'rtl_translate_todbm'
was not declared. Should it be static?
drivers/staging/rtl8821ae/stats.c:101:6: warning: symbol 'rtl_process_ui_rssi'
was not declared. Should it be s
44 matches
Mail list logo