51h
新《劳动合同法》、《社会保险法》、《工伤保险条例》实操应对策略
ARVFKVTE
防范用工风险和化解劳动争议的技能.txt
Description: Binary data
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Don't explain things to me in this thread.
Instead, tell the whole world and everyone who would ever see this
commit, in the commit log message.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo
Also remove the code previously under #ifndef USE_ONE_PIPE.
Signed-off-by: Antoine Schweitzer-Chaput
---
drivers/staging/rtl8192u/Makefile | 1 -
drivers/staging/rtl8192u/r8192U_core.c | 19 ---
2 files changed, 20 deletions(-)
diff --git a/drivers/staging/rtl8192u/Makefil
Signed-off-by: Antoine Schweitzer-Chaput
---
drivers/staging/rtl8192u/r8192U_core.c | 21 -
1 file changed, 21 deletions(-)
diff --git a/drivers/staging/rtl8192u/r8192U_core.c
b/drivers/staging/rtl8192u/r8192U_core.c
index 0f59605..4f3fa35 100644
--- a/drivers/staging/rtl819
Also remove related unreachable code.
Signed-off-by: Antoine Schweitzer-Chaput
---
drivers/staging/rtl8192u/Makefile | 1 -
drivers/staging/rtl8192u/r8192U_core.c | 174 +++--
2 files changed, 11 insertions(+), 164 deletions(-)
diff --git a/drivers/staging/rtl
Also remove the unreachable code.
Signed-off-by: Antoine Schweitzer-Chaput
---
drivers/staging/rtl8192u/Makefile | 1 -
drivers/staging/rtl8192u/r8192U_core.c | 250 +
2 files changed, 4 insertions(+), 247 deletions(-)
diff --git a/drivers/staging/rtl8192u
Signed-off-by: Antoine Schweitzer-Chaput
---
drivers/staging/rtl8192u/r8192U_core.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/rtl8192u/r8192U_core.c
b/drivers/staging/rtl8192u/r8192U_core.c
index bd15651..0f59605 100644
--- a/drivers/staging/rtl8192u/r8192U_core.c
+++
Also remove the code now unreachable.
Signed-off-by: Antoine Schweitzer-Chaput
---
drivers/staging/rtl8192u/r8192U_core.c | 13 -
1 file changed, 13 deletions(-)
diff --git a/drivers/staging/rtl8192u/r8192U_core.c
b/drivers/staging/rtl8192u/r8192U_core.c
index 7640386..ccf00f7 1006
The following changes since commit 9a3c4145af32125c5ee39c0272662b47307a8323:
Linux 3.16-rc6 (2014-07-20 21:04:16 -0700)
are available in the git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git/
tags/staging-3.16-rc8
for you to fetch changes up to 4aa0abed3a2
The 8255 driver (*io) callback now includes the comedi_device pointer.
Using this we can get the ioremap'ed base address.
Instead of passing the (cast) mmio address to subdev_8255_init(), pass
the 'iobase' of the 8255 registers (dioP2ExpansionIO8Bit).
Signed-off-by: H Hartley Sweeten
Cc: Ian Abb
This driver uses two iobase addresses, found in PCI bars 2 and 3.
Currently, the address in PCI bar 3 is saved in the comedi_device as
the 'iobase' and the one in PCI bar 2 is just passed to subdev_8255_init()
as the 'iobase' parameter.
Save the PCI bar 3 address in the private data as 'daqio' and
This driver uses three iobase addresses, found in PCI bars 2, 3, and 4.
Currently, the address in PCI bar 2 is saved in the comedi_device as
the 'iobase', the PCI bar 3 address is saved in the private data as
'BADR3' and the one in PCI bar 4 is just passed to subdev_8255_init()
as the 'iobase' para
There are a couple comedi drivers that duplicate some of the register
defines used by the 8255 module. Move these defines into the header
so the duplication can be removed.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/8255.c
This driver uses two iobase addresses, found in PCI bars 2 and 3.
Currently, the address in PCI bar 2 is saved in the private data as
'iobase1' and the address in PCI bar 3 is saved in the comedi_device
as the 'iobase'. The 'iobase' is the base address of the daq
registers (ai/ao) of the board. The
Currently, all users of is module that use the default (*io) function
pass an 'iobase' to subdev_8255_init() of the form:
dev->iobase + OFFSET_TO_8255_BASE_REG
Now that the (*io) callback includes the comedi_device 'dev' pointer
the 'dev->iobase' does not need to be included.
Modify the defaul
The 8255 driver (*io) callback now includes the comedi_device pointer.
Instead of passing the (cast) pointer to subdev_8255_init(), pass the
'iobase' of the 8255 registers (Port_A).
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_mi
The 8255 driver (*io) callback now includes the comedi_device pointer.
Instead of passing the (cast) pointer to subdev_8255_init(), pass the
'iobase' of the 8255 registers (DIO_BASE_REG).
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers
The 8255 driver uses an (*io) callback to read/write the registers
of the 8255 device. The default callback provided by the driver uses
inb()/outb() calls to access to registers based on an 'iobase' that
was initialized during the subdev_8255_init() and a 'port' value.
The users of this module can
The 8255 driver (*io) callback now includes the comedi_device pointer.
Using this we can get the ioremap'ed base address.
Instead of passing the (cast) mmio address to subdev_8255_init(), pass
the 'iobase' of the 8255 registers (DIO_8255_OFFSET).
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
The drivers that use this module with memory mapped io all have the
ioremap'ed base address stored in the comedi_device 'mmio' member.
Modify subdev_8255_io() to handle the memory mapped io. This allows
removing the private callbacks from some of the drivers.
Signed-off-by: H Hartley Sweeten
Cc:
Now that the comedi_device has a 'mmio' and a 'iobase' member, this module
can detect if the (*io) operations need to use readb/writeb for memory mapped
I/O or inb/outb for port I/O. This can be use to cleanup a lot of the code
duplication in the drivers that use the 8255 module.
1) Modify a coupl
The 8255 driver (*io) callback now includes the comedi_device pointer.
Using this we can get the ioremap'ed base address.
Instead of passing the (cast) mmio address to subdev_8255_init(), pass
the 'iobase' of the 8255 registers (i * 4).
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg K
Currently the base address of the 8254 and 8255 devices, found in
PCI bar 3, is saved in the private data as 'pacer_counter_dio'.
The 'iobase' in the comedi_device is currently unused.
Save the address from PCI bar 3 in the comedi_device and remove
the unnecessary member from the private data.
Th
The 8255 driver (*io) callback now includes the comedi_device pointer.
Using this we can get the ioremap'ed base address.
Instead of passing the (cast) mmio address to subdev_8255_init(), pass
the 'iobase' of the 8255 registers (I8255_4020_REG).
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
C
This driver currently duplicates the functionality of the 8255 module.
The only difference is in how the i/o access is handled.
Provide a private (*io) callback for the 8255 module to handle the
differences. We can then use that module and initialize the subdevice
with subdev_8255_init().
Update
This struct is used to provide part of the boardinfo data. Using the extra
indirection does not provide any additional clarity to the driver.
Absorb the members from dio200_layout into dio200_board and remove the
extra 'layout' indirection.
For aesthetics, rename all the local variables used for
The function names provide enough description. The extra comments are not
necessary. Remove them.
Also, tidy up some of the function declarations.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
.../staging/comedi/drivers/amplc_dio200_common.c | 225 ++
For aesthetics, add some whitespace to the declaration.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/amplc_dio200.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/comedi/drivers/amp
The private data in this driver only has one member, 'intr_sd', which is
the index to the interrupt subdevice.
This member is initialized during the attach of the driver when the sd_intr
subdevice is detected in the boadinfo 'layout'. The member is then used in
the interrupt handler to get the poi
The local variable 'irq' is not necessary in dio200_attach(). Just
pass the it->options[1] value directly.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/amplc_dio200.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --
This function is only called by amplc_dio200_common_attach() and it
can never fail. For aesthetics, absorb it into that function.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
.../staging/comedi/drivers/amplc_dio200_common.c| 21 ++---
1 file ch
This member of the boardinfo is only set for the PCIE boards. Use the
'is_pcie' flag to determine if the offset needs to be shifted when
reading/writing the registers.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/amplc_dio200.h
This member of the boardinfo is not used by the drivers. Remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/amplc_dio200.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/amplc_dio200.h
b/drive
This member of the boardinfor is only set for the PCIE boards. For
aeshetics, rename it to 'is_pcie'.
For clarity, use this flag in the (*auto_attach) to determine if the
dio200_pcie_board_setup() function needs to be called instead of using
the switch (context_model).
Signed-off-by: H Hartley Sw
This member of the boardinfo is not used by the driver. Remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/amplc_dio200.c | 5 -
drivers/staging/comedi/drivers/amplc_dio200.h | 3 ---
drivers/staging/comedi/drivers/a
All the ISA DIO200 boards have an i/o region size of 0x20 (DIO200_IO_SIZE).
Remove the boardinfo and open code the size in the comedi_request_region()
call.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/amplc_dio200.c | 8 +---
1
The 'mainsize' member in the boardinfo for the DIO200 PCI boards is only used
for a sanity check of the pci_resource_len(). This sanity check is not needed.
Remove the sanity check along with the 'mainsize' values in the boardinfo.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-
For aesthetics, add some whitespace to these declarations.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/amplc_dio200_pci.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/comedi/dr
Remove some cruft leftover from when this driver was a single module that
include support for both the ISA and PCI boards.
Do a bit of additional cleanup.
H Hartley Sweeten (13):
staging: comedi: amplc_dio200: remove private data
staging: comedi: amplc_dio200: remove 'bustype' from boardinfo
This function can be used by comedi pci drivers for the driver
(*detach) callback when all that is required is to release the
regions and disable the PCI device.
Enhance this function to work like comedi_legacy_detach().
* Rename the function to comedi_pci_detach().
* free the irq if it has b
GREAT BRITIAN!
OFFICE OF THE PERMANENT SECRETARY FOR NON RESIDENTIAL TAXATION ON INTERNATIONAL
LOTTERY AWARD OF THE BRITISH MINISTRY OF FINANCE LONDON UNITED KINGDOM
ADDRESS,
FINANCE HOUSE
KING CHARLES STREET,
LONDON,SW1A
EMAIL: thefinancenottification.b...@live.co.uk
Tel: + 447014229459
OUR RE
On Thu, Jul 24, 2014 at 07:40:36AM +0200, Hannes Reinecke wrote:
> On 07/22/2014 01:06 AM, K. Y. Srinivasan wrote:
> >Add blist flags to permit the reading of the VPD pages even when
> >the target may claim SPC-2 compliance. MSFT targets currently
> >claim SPC-2 compliance while they implement post
On Fri, Aug 01, 2014 at 07:31:10PM +0200, Antoine Schweitzer-Chaput wrote:
> On Fri, Aug 01, 2014 at 08:54:07AM -0700, Greg KH wrote:
> > On Tue, Jun 24, 2014 at 03:52:05PM +0200, Antoine Schweitzer-Chaput wrote:
> > > The code which was only reachable using these options is also removed.
> > >
>
On Wed, Jul 30, 2014 at 09:52:35AM +0800, micky wrote:
> Documentation/printk-formats.txt
>
> Raw buffer as a hex string:
> %*ph00 01 02 ... 3f
> %*phC 00:01:02: ... :3f
> %*phD 00-01-02- ... -3f
> %*phN 000102 ... 3f
>
> For printing a small buffers (up
> -Original Message-
> From: David Miller [mailto:da...@davemloft.net]
> Sent: Thursday, July 31, 2014 9:59 PM
> To: KY Srinivasan
> Cc: net...@vger.kernel.org; linux-ker...@vger.kernel.org;
> de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com;
> jasow...@redhat.com
> Subjec
On Fri, Aug 01, 2014 at 08:54:07AM -0700, Greg KH wrote:
> On Tue, Jun 24, 2014 at 03:52:05PM +0200, Antoine Schweitzer-Chaput wrote:
> > The code which was only reachable using these options is also removed.
> >
> > Signed-off-by: Antoine Schweitzer-Chaput
> > ---
> > drivers/staging/rtl8192u/M
> -Original Message-
> From: Dexuan Cui [mailto:de...@microsoft.com]
> Sent: Friday, August 1, 2014 7:27 AM
> To: gre...@linuxfoundation.org; jkos...@suse.cz; linux-
> in...@vger.kernel.org; linux-ker...@vger.kernel.org; driverdev-
> de...@linuxdriverproject.org; o...@aepfle.de; a...@cano
> -Original Message-
> From: Dexuan Cui [mailto:de...@microsoft.com]
> Sent: Friday, August 1, 2014 7:28 AM
> To: gre...@linuxfoundation.org; dmitry.torok...@gmail.com; linux-
> in...@vger.kernel.org; linux-ker...@vger.kernel.org; driverdev-
> de...@linuxdriverproject.org; o...@aepfle.de;
On Tue, Jun 24, 2014 at 03:52:05PM +0200, Antoine Schweitzer-Chaput wrote:
> The code which was only reachable using these options is also removed.
>
> Signed-off-by: Antoine Schweitzer-Chaput
> ---
> drivers/staging/rtl8192u/Makefile | 3 -
> drivers/staging/rtl8192u/r8192U_core.c | 482
Fix sparse warning:
drivers/staging/rtl8723au/core/rtw_efuse.c:579:5: warning: symbol
'efuse_GetCurrentSize23a' was not declared. Should it be static?
by removing efuse_GetCurrentSize23a since its never used
Signed-off-by: Miguel Oliveira
---
drivers/staging/rtl8723au/core/rtw_efuse.c | 25 --
On 08/01/2014 08:06 AM, Miguel Oliveira wrote:
> Fix sparse warning:
> drivers/staging/rtl8723au/core/rtw_efuse.c:579:5: warning: symbol
> 'efuse_GetCurrentSize23a' was not declared. Should it be static?
>
> Signed-off-by: Miguel Oliveira
> ---
> drivers/staging/rtl8723au/include/rtw_efuse.h |
With this patch, we can press a key to wake up the VM after the VM executes
"echo freeze > /sys/power/state".
This addresses part of https://bugzilla.redhat.com/show_bug.cgi?id=1086100
Cc: K. Y. Srinivasan
Signed-off-by: Dexuan Cui
---
drivers/input/serio/hyperv-keyboard.c | 13 +
With this patch, we can move the mouse to wake up the VM after the VM executes
"echo freeze > /sys/power/state".
This addresses part of https://bugzilla.redhat.com/show_bug.cgi?id=1086100
Cc: K. Y. Srinivasan
Signed-off-by: Dexuan Cui
---
drivers/hid/hid-hyperv.c | 6 ++
1 file changed, 6
On 01/08/14 02:55, Chase Southwood wrote:
This patchset creates a simple subdevice to allow for reading of the
board's diagnostic status, and then removes any code which is related to
diagnostic interrupts, as the driver will not support these at this time.
Chase Southwood (2):
staging: comed
On Fri, 2014-08-01 at 14:06 +0100, Miguel Oliveira wrote:
> Fix sparse warning:
> drivers/staging/rtl8723au/core/rtw_efuse.c:579:5: warning: symbol
> 'efuse_GetCurrentSize23a' was not declared. Should it be static?
>
> Signed-off-by: Miguel Oliveira
> ---
> drivers/staging/rtl8723au/include/rtw
Fix sparse warning:
drivers/staging/rtl8723au/core/rtw_efuse.c:579:5: warning: symbol
'efuse_GetCurrentSize23a' was not declared. Should it be static?
Signed-off-by: Miguel Oliveira
---
drivers/staging/rtl8723au/include/rtw_efuse.h |1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/
Currently the VSC has no chance to notify the VSP of the dirty rectangle on VM
panic because the notification work is done in a workqueue, and in panic() the
kernel typically ends up in an infinite loop, and a typical kernel config has
CONFIG_PREEMPT_VOLUNTARY=y and CONFIG_PREEMPT is not set, so a
> -Original Message-
> From: Tomi Valkeinen [mailto:tomi.valkei...@ti.com]
> Sent: Thursday, July 31, 2014 21:38 PM
> > I think in hvfb_on_panic() we should be able to get the
> > hvfb_info pointer by
> > hvfb_info = container_of(nb, struct hv_fb_panic_nb, nb).
> >
> > If you like that or h
The code which was only reachable using these options is also removed.
Signed-off-by: Antoine Schweitzer-Chaput
---
drivers/staging/rtl8192u/Makefile | 3 -
drivers/staging/rtl8192u/r8192U_core.c | 482 ++---
2 files changed, 16 insertions(+), 469 deletions(-)
On Fri, Aug 01, 2014 at 12:59:43AM -0700, Greg KH wrote:
> > /* this is only for debug */
> > +#ifdef DEBUG_EPROM
>
> how can this ever be set? If no one sets it, just remove the code
> entirely please.
I guess it's supposed to be set manually in the code (there's a large
list around l.60).
>
Some functions were prototyped as static but the actual definition
wasn't. While this is valid (the function is static because the two
declarations don't conflict and the first one is static), this makes
sparse unhappy and cause confusion of normal people too.
Signed-off-by: Vincent Bernat
---
.
On Fri, Aug 01, 2014 at 10:10:22AM +0200, Vincent Bernat wrote:
> Some functions were prototyped as static but the actual definition
> wasn't. While this is valid (the function is static because the two
> declarations don't conflict and the first one is static), this makes
> sparse unhappy and caus
Some functions were prototyped as static but the actual definition
wasn't. While this is valid (the function is static because the two
declarations don't conflict and the first one is static), this makes
sparse unhappy and cause confusion of normal people too.
Signed-off-by: Vincent Bernat
---
.
On Tue, Jun 24, 2014 at 02:46:55PM +0200, Antoine Schweitzer-Chaput wrote:
> function dump_eprom is only used when DEBUG_EPROM is set.
> function txqueue2outpipe is only used when USE_ONE_PIPE is unset.
> function GetRxPacketShiftBytes819xUsb is only used when
> USB_RX_AGGREGATION_SUPPORT is set.
64 matches
Mail list logo