- this fixes sparse warning for directly deferencing user space buffer
./lustre/ldlm/ldlm_resource.c:202:35: warning: incorrect type in argument 2
(different address spaces)
./lustre/ldlm/ldlm_resource.c:202:35:expected void const [noderef]
*from
./lustre/ldlm/ldlm_resource.c:202:35:got
Hi Greg,
I have resent all the patches in order. Please review.
Regards
Sanjeev Sharma
-Original Message-
From: Greg KH [mailto:gre...@linuxfoundation.org]
Sent: Thursday, July 31, 2014 5:51 AM
To: Sharma, Sanjeev
Cc: de...@driverdev.osuosl.org; oor...@gmail.com; linux-ker...@vger.kerne
This is a patch to the r8190_rtl8256.c file that fixes
checkpatch reported space & coding style issues.
Signed-off-by: Sanjeev Sharma
---
Changes in v2:
- Added space character in the signed-off-by field.
drivers/staging/rtl8192u/r8190_rtl8256.c | 169 +++
1 file c
This is a patch to the r8180_93cx6.h file that fixes
long lines along with some additional warning.
Signed-off-by: Sanjeev Sharma
---
Changes in v2:
- Added signed-off field.
drivers/staging/rtl8192u/r8180_93cx6.h | 11 +++
1 file changed, 7 insertions(+), 4 deletions(-)
diff --git a
This is a patch to the r8180_93cx6.c file that fixes
commenting style warning
Signed-off-by: Sanjeev Sharma
---
Changes in v2:
- Added signed-off field.
drivers/staging/rtl8192u/r8180_93cx6.c | 15 +--
1 file changed, 9 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/r
AddedSigned-off-by: line that was missing.
Sanjeev Sharma (3):
staging:r8180: coding style: Fixed commenting style
staging:r8180: coding style: Fixed too long lines
staging:r8190: coding style: Fixed checkpatch reported Error
drivers/staging/rtl8192u/r8180_93cx6.c | 15 +--
drivers/stag
When a configration file is parsed with dgap_parsefile(),
makes nodes for saving configrations for board.
Making a node will allocate node memory and strings for saving
configrations with kstrdup().
So these are freed when dgap is unloaded or failed to initialize.
Signed-off-by: Daeseok Youn
--
On Thursday 31 July 2014 05:38 AM, Greg KH wrote:
>
> This patch doesn't apply against my tree at all, what did you make it
> against?
>
> Always work against linux-next, or the staging-next branch of my
> staging.git tree on git.kernel.org.
>
> thanks,
>
> greg k-h
Hi,
I am working on staging.gi
For forwarding scenarios, it will be useful to allocate larger
sendbuf. Make the necessary adjustments to permit this.
Signed-off-by: K. Y. Srinivasan
---
drivers/net/hyperv/hyperv_net.h |2 +-
drivers/net/hyperv/netvsc.c |7 ++-
2 files changed, 3 insertions(+), 6 deletions(-)
> -Original Message-
> From: David Miller [mailto:da...@davemloft.net]
> Sent: Wednesday, July 30, 2014 5:25 PM
> To: KY Srinivasan
> Cc: net...@vger.kernel.org; linux-ker...@vger.kernel.org;
> de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com;
> jasow...@redhat.com
> Subje
From: "K. Y. Srinivasan"
Date: Wed, 30 Jul 2014 18:20:16 -0700
> For forwarding scenarios, it will be useful to allocate larger
> sendbuf. Make the necessary adjustments to permit this.
>
> Signed-off-by: K. Y. Srinivasan
Please submit this with a proper Subject line, something like
"[PATCH 1/
On Tue, Jul 29, 2014 at 04:41:53PM +0530, Sanjeev Sharma wrote:
> This is a patch to the r8190_rtl8256.c file that fixes
> checkpatch reported space & coding style issues.
>
> Signed-off-by: Sanjeev Sharma
Please use a ' ' character...
Please resend all of your patches, they don't have signed-of
On Tue, Jul 29, 2014 at 03:18:52PM +0530, Sanjeev Sharma wrote:
> This is a patch to the r8180_93cx6.c file that fixes
> commenting style warning
> ---
> drivers/staging/rtl8192u/r8180_93cx6.c | 15 +--
> 1 file changed, 9 insertions(+), 6 deletions(-)
Hi,
This is the friendly patch-
On Mon, Jul 28, 2014 at 08:03:46PM -0300, Murilo Opsfelder Araujo wrote:
> Fix coding style issue.
>
> Signed-off-by: Murilo Opsfelder Araujo
> ---
> drivers/staging/android/sync.c |2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/android/sync.c b/drive
For forwarding scenarios, it will be useful to allocate larger
sendbuf. Make the necessary adjustments to permit this.
Signed-off-by: K. Y. Srinivasan
---
drivers/net/hyperv/hyperv_net.h |2 +-
drivers/net/hyperv/netvsc.c |7 ++-
2 files changed, 3 insertions(+), 6 deletions(-)
On Mon, Jul 28, 2014 at 07:38:23PM -0300, Murilo Opsfelder Araujo wrote:
> Fix coding style issue.
>
> Signed-off-by: Murilo Opsfelder Araujo
> ---
> drivers/staging/android/sw_sync.c |2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/drivers/staging/android/sw_sync.c
> b/drivers/st
On Tue, Jul 29, 2014 at 03:09:41PM -0400, Benjamin Romer wrote:
> This patch switches all use of the U16 typedef to use the kernel's u16 type
> instead.
>
> Signed-off-by: Benjamin Romer
> ---
> .../include/channels/controlframework.h| 18
> .../include/channels/cont
On Wed, Jul 30, 2014 at 06:29:57PM +0530, Anil Belur wrote:
> - private_ioctl() internally calls copy_{to,from}_user() and does
> not use '__user' which gives out several sparse warnings
> - these sparse warnings were fixed by adding __user annotation to
> the data member of struct tagSCmdReque
On Mon, Jul 28, 2014 at 05:52:46PM +0200, Antoine Schweitzer-Chaput wrote:
> Some functions defined in r8192U_core.c and only used locally are marked as
> static.
> This fixes some warnings issued by sparse.
>
> Signed-off-by: Antoine Schweitzer-Chaput
And it creates new warnings with gcc, whic
On Wed, Jul 30, 2014 at 11:33:41PM +0200, fernando.apesteg...@gmail.com wrote:
> From: Fernando Apesteguia
>
> Add static to debug method.
>
> Signed-off-by: Fernando Apesteguia
> ---
> drivers/staging/rtl8192u/r8192U_core.c |2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff
On Wed, Jul 30, 2014 at 11:20:49PM +0200, Fernando Apesteguía wrote:
> On Wed, Jul 30, 2014 at 9:16 PM, Guillaume Clement
> wrote:
> > Hello,
> >
> >> Add static to variable.
> >> Signed-off-by: Fernando Apesteguia
> >> ---
> >> drivers/staging/vt6655/ioctl.c |2 +-
> >> 1 file changed, 1 i
On Wed, Jul 30, 2014 at 04:15:23PM +, Hartley Sweeten wrote:
> On Wednesday, July 30, 2014 7:28 AM, Ian Abbott wrote:
> > On 2014-07-30 15:09, Dan Carpenter wrote:
> >> On Wed, Jul 30, 2014 at 03:04:03PM +0100, Ian Abbott wrote:
> >>> On 2014-07-30 14:41, Dan Carpenter wrote:
> On Wed, Jul
Thanks for reviewing my first patch, Joe. How about this new one,
guys?
-- >8 --
Consequently, made checkpatch.pl happy.
Signed-off-by: Murilo Opsfelder Araujo
---
drivers/staging/android/timed_gpio.c | 15 ---
1 file changed, 8 insertions(+), 7 deletions(-)
diff --git a/drivers
On Mon, Jul 28, 2014 at 11:07:40PM +0200, adrianremo...@gmail.com wrote:
> From: Adrian Remonda
>
Your changelog text is up there in the subject, not down here in the
body of the email :(
___
devel mailing list
de...@linuxdriverproject.org
http://driv
From: Fernando Apesteguia
Add static to debug method.
Signed-off-by: Fernando Apesteguia
---
drivers/staging/rtl8192u/r8192U_core.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/r8192U_core.c
b/drivers/staging/rtl8192u/r8192U_core.c
index 7640
On Wed, Jul 30, 2014 at 9:16 PM, Guillaume Clement wrote:
> Hello,
>
>> Add static to variable.
>> Signed-off-by: Fernando Apesteguia
>> ---
>> drivers/staging/vt6655/ioctl.c |2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/staging/vt6655/ioctl.c
>> b/driver
Hello,
> Add static to variable.
> Signed-off-by: Fernando Apesteguia
> ---
> drivers/staging/vt6655/ioctl.c |2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/vt6655/ioctl.c
> b/drivers/staging/vt6655/ioctl.c
> index 65e5933..cc6e47b 100644
> --- a/drive
From: Fernando Apesteguia
Add static to variable.
Signed-off-by: Fernando Apesteguia
---
drivers/staging/vt6655/ioctl.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/vt6655/ioctl.c b/drivers/staging/vt6655/ioctl.c
index 65e5933..cc6e47b 100644
--- a/dri
On Wednesday, July 30, 2014 7:28 AM, Ian Abbott wrote:
> On 2014-07-30 15:09, Dan Carpenter wrote:
>> On Wed, Jul 30, 2014 at 03:04:03PM +0100, Ian Abbott wrote:
>>> On 2014-07-30 14:41, Dan Carpenter wrote:
On Wed, Jul 30, 2014 at 12:53:47PM +0100, Ian Abbott wrote:
> Signed-off-by: Ian A
On 2014-07-30 15:09, Dan Carpenter wrote:
On Wed, Jul 30, 2014 at 03:04:03PM +0100, Ian Abbott wrote:
On 2014-07-30 14:41, Dan Carpenter wrote:
On Wed, Jul 30, 2014 at 12:53:47PM +0100, Ian Abbott wrote:
Signed-off-by: Ian Abbott
---
v2: Be less aggressive in brace removal. Keep them for out
On 09/07/14 06:04, Dexuan Cui wrote:
> Currently the VSC has no chance to notify the VSP of the dirty rectangle on VM
> panic because the notification work is done in a workqueue, and in panic() the
> kernel typically ends up in an infinite loop, and a typical kernel config has
> CONFIG_PREEMPT_VOL
On Wed, Jul 30, 2014 at 1:43 PM, Tobias Klauser wrote:
>
> On 2014-07-29 at 19:44:24 +0200, fernando.apesteg...@gmail.com
> wrote:
> > From: Fernando Apesteguia
> >
> > Add static to the definition of the pci device table.
> >
> > Signed-off-by: Fernando Apesteguia
>
> This change is already p
On Wed, Jul 30, 2014 at 03:04:03PM +0100, Ian Abbott wrote:
> On 2014-07-30 14:41, Dan Carpenter wrote:
> >On Wed, Jul 30, 2014 at 12:53:47PM +0100, Ian Abbott wrote:
> >>Signed-off-by: Ian Abbott
> >>---
> >>v2: Be less aggressive in brace removal. Keep them for outer nested
> >>'if's. Keep the
On 2014-07-30 14:41, Dan Carpenter wrote:
On Wed, Jul 30, 2014 at 12:53:47PM +0100, Ian Abbott wrote:
Signed-off-by: Ian Abbott
---
v2: Be less aggressive in brace removal. Keep them for outer nested
'if's. Keep them in outer control statements where the inner control
statement uses braces.
On Wed, Jul 30, 2014 at 12:53:47PM +0100, Ian Abbott wrote:
> Signed-off-by: Ian Abbott
> ---
> v2: Be less aggressive in brace removal. Keep them for outer nested
> 'if's. Keep them in outer control statements where the inner control
> statement uses braces.
Really every multi-line indent shou
On Wed, Jul 30, 2014 at 06:29:57PM +0530, Anil Belur wrote:
> - private_ioctl() internally calls copy_{to,from}_user() and does
> not use '__user' which gives out several sparse warnings
> - these sparse warnings were fixed by adding __user annotation to
> the data member of struct tagSCmdReque
On 2014-07-29 23:01, H Hartley Sweeten wrote:
Some of the comedi drivers use memory mapped I/O. Currently all of these
drivers save the ioremap'ed base address in their private data.
Add a new member, 'mmio' to the comedi_device struct so the drivers don't
need to carry it in the private data. F
On Tue, Jul 29, 2014 at 03:09:43PM -0400, Benjamin Romer wrote:
> -#define CHANNEL_u32_MISMATCH(chType, chName, field, expected, actual, fil, \
> +#define CHANNEL_U32_MISMATCH(chType, chName, field, expected, actual, fil, \
>lin, logCtx) \
>
- private_ioctl() internally calls copy_{to,from}_user() and does
not use '__user' which gives out several sparse warnings
- these sparse warnings were fixed by adding __user annotation to
the data member of struct tagSCmdRequest:
drivers/staging/vt6655/ioctl.c:78:51: warning: incorrect type
On 2014-07-30 01:54, Hartley Sweeten wrote:
On Tuesday, July 29, 2014 4:58 AM, Ian Abbott wrote:
Tidy up the "amplc_pci230" driver a bit. There are more changes to come
after this. The only one of these that should alter the object code is
patch 06, which replaces a udelay() call with usleep_
Remove some pairs of parentheses that don't really improve readability.
Also, reduce the amount of leading whitespace in a few places.
Signed-off-by: Ian Abbott
---
v2: fixed conflict with v2 on an earlier patch in the series.
---
drivers/staging/comedi/drivers/amplc_pci230.c | 78 +-
Signed-off-by: Ian Abbott
---
v2: Be less aggressive in brace removal. Keep them for outer nested
'if's. Keep them in outer control statements where the inner control
statement uses braces.
---
drivers/staging/comedi/drivers/amplc_pci230.c | 120 ++
1 file changed, 46 in
On 2014-07-29 at 19:44:24 +0200, fernando.apesteg...@gmail.com
wrote:
> From: Fernando Apesteguia
>
> Add static to the definition of the pci device table.
>
> Signed-off-by: Fernando Apesteguia
This change is already part of Greg's tree, see commit
9e4c5c2837a4 ("staging: vt6655: statify so
On 2014-07-30 at 12:41:59 +0200, Anil Belur wrote:
> From: Anil Belur
This line is only necessary if you're sending the patch on behalf of
someone else. Also there is no need to have the 1/1 in the Subject line
as you're only sending one patch, not an entire series.
> v2:
> - private_ioctl() in
From: Anil Belur
v2:
- private_ioctl() internally calls copy_{to,from}_user() and does
not use '__user' which gives out several sparse warnings
- this patch adds __user annotation to the data member of struct
tagSCmdRequest as suggested by tklau...@distanz.ch
- sparse warnings fixed:
drivers
45 matches
Mail list logo