On Sat, May 24, 2014 at 10:44:12PM -0700, Chaitanya Hazarey wrote:
> Fixed a lot of errors of the type "ERROR: space required after that ','
> (ctx:VxV)"
>
Add a tab at the start of the line as well.
regards,
dan carpenter
___
devel mailing list
de..
Fixed a lot of errors of the type "ERROR: space required after that ','
(ctx:VxV)"
Signed-off-by: Chaitanya Hazarey
---
drivers/staging/rtl8192u/r819xU_firmware_img.c | 1036
1 file changed, 518 insertions(+), 518 deletions(-)
diff --git a/drivers/staging/rtl8192u/r819
On Sat, 2014-05-24 at 20:47 +0200, Manuel Schölling wrote:
> To be future-proof and for better readability the time comparisons are
> modified to use time_before_eq() instead of plain, error-prone math.
A couple of unrelated, trivial notes: (repeated a few times)
> diff --git a/drivers/staging/me
The addi_private struct defined in addi-data/addi_common.h is very bloated
and contains many fields which addi_apci_1564 does not require. In the
interest of eventually removing this driver's dependency on
addi_common.h, we can create a private data struct specifically for
addi_apci_1564 containin
The addi-data drivers use send_sig() to let the user know when an
interrupt has occurred. The "standard" way to do this in the comedi
subsystem is to have a subdevice that supports asynchronous commands
and use comedi_event() to signal the user.
Remove the send_sig() usage in this driver.
Signed-
This board supports an interrupt that can be generated by an AND/OR
combination of 16 of the input channels.
Create a separate subdevice to handle this interrupt.
In doing this, this patch moves the apci1564_di_config() operation from
the digital input subdevice to this new subdevice, and also re
This patchset adds the required subdevice for supporting DI COS interrupts,
as well as introducing a driver-specific private data struct that will
make the COS interrupt operations much more straightforward and clean.
Chase Southwood (3):
staging: comedi: addi_apci_1564: add a subdevice for Chan
To be future-proof and for better readability the time comparisons are
modified to use time_before_eq() instead of plain, error-prone math.
Signed-off-by: Manuel Schölling
---
drivers/staging/media/msi3101/sdr-msi3101.c |8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git
This commit fixes the sparse warning:
"warning: symbol 'X' was not declared. Should it be static?"
Where the X is one of the following:
bt_profile_string
bt_spec_string
bt_link_role_string
h2c_state_string
io_state_string
btc_dbg_buf
halbtc_is_bt_coexist_available
This commit fixes the sparse warning:
"warning: symbol 'X' was not declared. Should it be static?"
Where the X is one of the following
rtl_btc_operation
Signed-off-by: Konrad Zapalowicz
---
drivers/staging/rtl8821ae/btcoexist/rtl_btc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletio
This commit fixes the compiler -Wunused-function warning. Several
functions had to be removed.
Removed symbols
halbtc_is_hw_mailbox_exist
halbtc_set_macreg
halbtc_get_macreg
halbtc_under_ips
Signed-off-by: Konrad Zapalowicz
---
drivers/staging/rtl8821ae/btcoexist/halbtcoutsrc.c
This commit fixes the compiler -Wunused-function warning. It was enough
to put #define around them to supress this warning. One was a special
case because it's usage was commented-out therefore, as I did not want
to remove it completely, I disabled it with #if 0
Conditionally compiled symbols
This commit fixes the sparse warning:
"warning: symbol 'X' was not declared. Should it be static?"
Where the X is one of the following:
glbt_info_src_8723b_2ant
glcoex_ver_date_8723b_2ant
glcoex_ver_8723b_2ant
halbtc8723b2ant_bt_rssi_state
halbtc8723b2ant_wifi_rssi_state
This commit fixes the sparse warnings and compiler warnings in
drivers/staging/rtl8821ae/btcoexist module of rtl8821ae driver.
The most of the changes adds 'static' for local symbols plus
the -Wunused-function compiler warnings are fixed too.
Konrad Zapalowicz (7):
staging: rtl8821ae: add stati
This commit fixes the sparse warning:
"warning: symbol 'X' was not declared. Should it be static?"
Where the X is one of the following:
glbt_info_src_8723b_2ant
glcoex_ver_date_8723b_2ant
glcoex_ver_8723b_2ant
halbtc8723b2ant_bt_rssi_state
halbtc8723b2ant_wifi_rssi_state
This commit fixes the compiler -Wunused-function warning. Most of the
unused functions were removed however for a few of them it was enough
to put #define around them.
Removed symbols:
halbtc8723b1ant_rf_shrink
halbtc8723b1ant_dac_swing
halbtc8723b1ant_adc_backoff
halbtc8723b1ant_
I changed dereferences from iomem into the adequate ioread function.
Signed-off-by: Pascal COMBES
---
NB: -I didn't replace the old style ioread[bwl] by their newer
equivalents (ioread[8/16/32]). Is it worth?
-I did this for task 16 of the eudyptula challenge.
diff --git a/drivers/st
This patch remove variables that are initialized with a constant,
are never updated, and are only used as parameter of return.
Return the constant instead of using a variable.
Verified by compilation only.
The coccinelle script that find and fixes this issue is:
//
@@
type T;
constant C;
identif
On Thu, May 22, 2014 at 01:04:41PM -0400, Jason Cooper wrote:
> I do not, I'm unsure if Anton has anything pending capable of
> upstreaming.
I have two simple patches. But I don't know is it necessary to send
this patches. First is export of functions in *api.c files.
But it is trivial part of api
This patch removes all usage of _malloc() and the function itself. Most
uses are straightforward replacements by kmalloc(..., GFP_ATOMIC),
because this was the definition of _malloc(). In a few places it
was possible to use kzalloc() or memdup_user.
A further improvement would be to replace GFP_AT
Yep. That applies now.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
21 matches
Mail list logo