On Tue, May 20, 2014 at 12:34 AM, Dan Carpenter
wrote:
> On Mon, May 19, 2014 at 09:19:07PM +0530, navin patidar wrote:
>> > You have changed it to return _FAIL instead of true. Perhaps that is ok
>> > but you need to explain it in the changelog.
>> >
>> oops, I'll resend this patch with proper c
This patchset fixes a broken checksum function and removes a struct
that was being used to ignore bad checksum values.
V2 Changes:
* Change subject to make clear this patchset fixes a bug.
* Explicitly comment that the checksum algorithm is RFC 1071.
* Remove byte swapping code.
* Add deta
Remove fail_on_bad_eeprom, which was always 0 and thus being used
to ignore incorrect checksumming. This means devices with corrupt
eeprom will now cause the driver to fail.
Since fail_on_bad_eeprom was the last member in use of struct
slic_reg_params, remove that struct altogether.
Signed-off-by
Rewrite slic_eeprom_cksum() to fix bugs and make readable. This patch
technically has no effect on the user as failed eeprom checksums are
ignored anyway.
The original implementation had the following issues:
1. 2 of the 3 unrolled loops had the following bug:
while ((len -= 32) >= 0) {
On Mon, May 19, 2014 at 03:17:30PM +0100, Rupesh Gujare wrote:
> I will be not able to work on ozwpan driver anymore.
> Remove my name & add Tateno as maintainer.
>
> Signed-off-by: Rupesh Gujare
> ---
> MAINTAINERS |2 +-
> drivers/staging/ozwpan/TODO |2 +-
> 2 files ch
On Mon, May 19, 2014 at 10:57:08PM +0300, Dan Carpenter wrote:
> On Mon, May 19, 2014 at 09:42:22AM -0500, Romer, Benjamin M wrote:
> > On Sun, 2014-05-18 at 09:49 -0700, Greg KH wrote:
> > > Also, why are these entries moving to debugfs at all? Why are they
> > > needed? Who will use them? Are
Clean up file names and locations. Get rid of include/ directory and move
those up to the top-level. Rename files to get rid of upper case. Remove
skeinBlockNo3F.c as it was unused (temporary file or something?).
Signed-off-by: Jake Edge
---
v3: against staging-next branch of staging tree
v2
Remove prohibited space between function name and
open parenthesis to meet kernel coding style.
Also fix indenting due to changes to keep readability.
I undid modifications to memset(...) which I made in
previous patches as it could be removed based on
the fact LIBCFS_ALLOC is executed before mems
On Mon, May 19, 2014 at 07:45:10AM -0600, Jake Edge wrote:
> On Mon, 19 May 2014 12:09:59 +0400 Anton Saraev wrote:
>
> > --- a/drivers/staging/skein/Makefile
> > +++ b/drivers/staging/skein/Makefile
> > @@ -4,10 +4,10 @@
> > subdir-ccflags-y := -I$(src)/include/
>
> as part of the rearranging o
On Sun, May 18, 2014 at 12:56:15PM -0600, Jake Edge wrote:
>
> Clean up file names and locations. Get rid of include/ directory and move
> those up to the top-level. Rename files to get rid of upper case. Remove
> skeinBlockNo3F.c as it was unused (temporary file or something?).
>
> Signed-off
There is otherwise a risk of a possible null pointer dereference.
Was largely found by using a static code analysis program called cppcheck.
Signed-off-by: Rickard Strandqvist
---
drivers/staging/lustre/lustre/ptlrpc/sec_config.c | 10 ++
1 file changed, 6 insertions(+), 4 deletions(-
There is otherwise a risk of a possible null pointer dereference.
Was largely found by using a static code analysis program called cppcheck.
Signed-off-by: Rickard Strandqvist
---
drivers/staging/lustre/lustre/lov/lov_obd.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
dif
There is otherwise a risk of a possible null pointer dereference.
Was largely found by using a static code analysis program called cppcheck.
Signed-off-by: Rickard Strandqvist
---
drivers/staging/line6/toneport.c | 14 --
1 file changed, 8 insertions(+), 6 deletions(-)
diff --git
When you resend, please put in the changelog what the affect of this fix
is for the user. Even if it's something like "It doesn't affect the
user normally." that is useful information.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproj
Sounds great.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Mon, May 19, 2014 at 12:52 PM, Dan Carpenter
wrote:
>
> You have to understand that I review a lot of staging patches every day.
> Most patches try to remove struct members but the code should still work
> exactly as it did before (a clean up). Some patches remove struct
> members and the beha
On Mon, May 19, 2014 at 2:16 AM, Dan Carpenter wrote:
> This patch is great, thanks, don't resend. But I wish the subject said
> "fix" instead of "rewrite". I was expecting it to just be a cleanup.
>
> It helps a lot if `git log --oneline` says which patches should be
> backported.
>
> regards,
Hello, Eli.
On Sat, May 17, 2014 at 03:19:21PM +0300, Eli Billauer wrote:
> >>+ if (dma_mapping_error(dev, dma_handle)) {
> >>+ devres_free(dr);
> >>+ return 0;
> >Can't we just keep returning dma_handle? Even if that means invoking
> >->mapping_error() twice? It's yucky to
On Mon, May 19, 2014 at 09:42:22AM -0500, Romer, Benjamin M wrote:
> On Sun, 2014-05-18 at 09:49 -0700, Greg KH wrote:
> > Also, why are these entries moving to debugfs at all? Why are they
> > needed? Who will use them? Are tools relying on them to be there?
>
> The tuning entries are sometime
On Mon, May 19, 2014 at 01:44:18PM -0600, Jake Edge wrote:
> Not sure it's useful (or even the right way to go about it), but, if it
> is, Greg (or Jason or whoever) can add my:
>
> Reviewed-by: Jake Edge
>
Yep. Great. Greg will add it.
regards,
dan carpenter
___
On Mon, May 19, 2014 at 08:57:49AM -0700, David Matlack wrote:
> On Mon, May 19, 2014 at 2:21 AM, Dan Carpenter
> wrote:
> >
> > Looking at the patch, this looks like a bugfix but the changelog doesn't
> > give any clues.
>
> Yeah this isn't a bug fix.
>
> The only member of struct slic_reg_par
On Mon, 19 May 2014 22:21:12 +0300 Dan Carpenter wrote:
> So, Jake, you're right, but if he redoes patch 2/6 then he has to redo
> the rest as well. The bad names were bad in the original code already,
> so normally we let people fix things up in follow on patches in that
> case.
>
> Is that ok w
So, Jake, you're right, but if he redoes patch 2/6 then he has to redo
the rest as well. The bad names were bad in the original code already,
so normally we let people fix things up in follow on patches in that
case.
Is that ok with you?
I totally do appreciate your review comments and agree wit
On Mon, May 19, 2014 at 09:19:07PM +0530, navin patidar wrote:
> > You have changed it to return _FAIL instead of true. Perhaps that is ok
> > but you need to explain it in the changelog.
> >
> oops, I'll resend this patch with proper changelog.
> I have one question, do i need to send v2 of whole
On 2014-05-19 17:19, Raghavendra Ganiga wrote:
This is a patch to remove warnings reported by checkpatch tool on
comedi_test.c file
Signed-off-by: Raghavendra Chandra Ganiga
---
drivers/staging/comedi/drivers/comedi_test.c | 2 ++
1 file changed, 2 insertions(+)
Thanks!
Reviewed-by: Ian A
On 2014-05-19 17:11, Raghavendra Ganiga wrote:
This is a patch to fix the warnings shown by checkpatch tool on
file cb_das16_cs.c
Signed-off-by: Raghavendra Chandra Ganiga
---
drivers/staging/comedi/drivers/cb_das16_cs.c | 1 +
1 file changed, 1 insertion(+)
Thanks!
Reviewed-by: Ian Abbot
On 2014-05-10 17:24, Raghavendra Ganiga wrote:
This is a patch to remove warnings reported
by checkpatch tool on cb_pcimdas.c file
Signed-off-by: Raghavendra Chandra Ganiga
---
drivers/staging/comedi/drivers/cb_pcimdas.c | 11 ---
1 file changed, 8 insertions(+), 3 deletions(-)
On 2014-05-07 20:45, Christian Engelmayer wrote:
This driver supports the PCI-20001C-1a and PCI-20001C-2a carrier boards.
The -2a version has 32 on-board DIO channels. In case this variant is
detected, local variable 'has_dio' is set accordingly. Otherwise it is
left uninitialized and the followi
This patch enhances kernel style usage for the rts5208 driver.
We should prefer `struct pci_device_id` over `DEFINE_PCI_DEVICE_TABLE` to meet
kernel coding style guidelines. This issue was reported by checkpatch.
Signed-off-by: Benoit Taine
---
drivers/staging/rts5208/rtsx.c |2 +-
1 file ch
This is a patch to remove warnings reported by checkpatch tool on
comedi_test.c file
Signed-off-by: Raghavendra Chandra Ganiga
---
drivers/staging/comedi/drivers/comedi_test.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/staging/comedi/drivers/comedi_test.c
b/drivers/staging/co
This is a patch to fix the warnings shown by checkpatch tool on
file cb_das16_cs.c
Signed-off-by: Raghavendra Chandra Ganiga
---
drivers/staging/comedi/drivers/cb_das16_cs.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/comedi/drivers/cb_das16_cs.c
b/drivers/staging/comedi
On Mon, May 19, 2014 at 2:21 AM, Dan Carpenter wrote:
>
> Looking at the patch, this looks like a bugfix but the changelog doesn't
> give any clues.
Yeah this isn't a bug fix.
The only member of struct slic_reg_params that was in use was fail_on_bad_eeprom
(implicitly set to zero by alloc_etherd
On Mon, May 19, 2014 at 4:22 PM, Dan Carpenter wrote:
> On Sun, May 18, 2014 at 08:48:58PM +0530, navin patidar wrote:
>> Signed-off-by: navin patidar
>> ---
>> drivers/staging/rtl8188eu/hal/usb_halinit.c |8
>> 1 file changed, 8 deletions(-)
>>
>> diff --git a/drivers/staging/rtl81
On Sun, 2014-05-18 at 09:49 -0700, Greg KH wrote:
> There's no need to keep this dentry around, you can just remove all the
> debugfs files in your directory recursively when you exit. That will
> save you code and logic overall.
Ah, thanks! I wasn't aware that I could do that. That's an easy fix
On Mon, 19 May 2014 12:09:55 +0400 Anton Saraev wrote:
> struct skein_ctx_hdr {
> - size_t hashBitLen; /* size of hash result, in bits */
> - size_t bCnt; /* current byte count in buffer b[] */
> - u64 T[SKEIN_MODIFIER_WORDS]; /* tweak: T[0]=byte cnt
I will be not able to work on ozwpan driver anymore.
Remove my name & add Tateno as maintainer.
Signed-off-by: Rupesh Gujare
---
MAINTAINERS |2 +-
drivers/staging/ozwpan/TODO |2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/MAINTAINERS b/MAINTAINERS
Dan,
On Mon, May 19, 2014 at 11:53:21AM +0300, Dan Carpenter wrote:
> Was there really a v1 version of this patchset because I don't see it in
> my inbox?
There was. Anton is doing this as part of the Eudyptula Challenge [1],
and he sent the first version to me offlist. I helped him with some o
Terrific, thanks. :)
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Mon, May 19, 2014 at 07:29:26AM -0600, Jake Edge wrote:
> On Mon, 19 May 2014 12:09:59 +0400 Anton Saraev wrote:
>
> > rename drivers/staging/skein/{skeinBlockNo3F.c =>
> > skein_block_no_3f.c} (99%)
>
> fwiw, this file (skeinBlockNo3F.c) seems to be unused ... it kind of looks
> like a tempor
On Mon, May 19, 2014 at 12:08:39PM +0300, Dan Carpenter wrote:
> On Mon, May 19, 2014 at 12:09:58PM +0400, Anton Saraev wrote:
> > +/* ignore all asserts, for performance */
> > +#define skein_assert_ret(x, ret_code)
> > +#define skein_assert(x)
>
> Not related to this patch, but defining away ass
On Mon, 19 May 2014 12:09:59 +0400 Anton Saraev wrote:
> --- a/drivers/staging/skein/Makefile
> +++ b/drivers/staging/skein/Makefile
> @@ -4,10 +4,10 @@
> subdir-ccflags-y := -I$(src)/include/
as part of the rearranging of files, I think you want to get rid of
this include directory, move the fi
This fixes the following sparse error:
drivers/staging/lustre/lustre/obdclass/llog_ioctl.c:388:39: error: incompatible
types for operation (>)
drivers/staging/lustre/lustre/obdclass/llog_ioctl.c:388:39:left side has
type char *ioc_inlbuf2
drivers/staging/lustre/lustre/obdclass/llog_ioctl.c:3
On Mon, 19 May 2014 12:09:59 +0400 Anton Saraev wrote:
> rename drivers/staging/skein/{skeinBlockNo3F.c =>
> skein_block_no_3f.c} (99%)
fwiw, this file (skeinBlockNo3F.c) seems to be unused ... it kind of looks
like a temporary file that got checked in by mistake. It's probably worth
deleting it
Dan Carpenter writes:
> On Mon, May 19, 2014 at 12:49:03PM +0200, Jes Sorensen wrote:
>> You should be running your tools against the staging tree automatically,
>> that way you catch it before it hits the mainline tree.
>>
>> Just flooding mailing lists for the sake of flooding them doesn't add
>
On Mon, May 19, 2014 at 12:49:03PM +0200, Jes Sorensen wrote:
> You should be running your tools against the staging tree automatically,
> that way you catch it before it hits the mainline tree.
>
> Just flooding mailing lists for the sake of flooding them doesn't add
> any value either.
We are us
On Mon, May 19, 2014 at 12:55:11PM +0200, Martin Kepplinger wrote:
> For obvious error messages, use dev_err() in order to provide userspace
> with more useful information and use the common kernel coding style.
>
> Signed-off-by: Martin Kepplinger
> ---
> i just waited a week or so. this applies
For obvious error messages, use dev_err() in order to provide userspace
with more useful information and use the common kernel coding style.
Signed-off-by: Martin Kepplinger
---
i just waited a week or so. this applies to next-20140516.
greetings from Linuxdays Vienna, Austria
drivers/staging/
On Sun, May 18, 2014 at 08:48:58PM +0530, navin patidar wrote:
> Signed-off-by: navin patidar
> ---
> drivers/staging/rtl8188eu/hal/usb_halinit.c |8
> 1 file changed, 8 deletions(-)
>
> diff --git a/drivers/staging/rtl8188eu/hal/usb_halinit.c
> b/drivers/staging/rtl8188eu/hal/usb_
Dan Carpenter writes:
> On Mon, May 19, 2014 at 12:25:13PM +0200, Jes Sorensen wrote:
>> Dan,
>>
>> Calm down, I haven't been bombarding the list, due to the sheer volume
>> of commits. If you want me to spam the list, tell me where and I'll add
>> that to the CC list next time.
>
> We provide t
On Mon, May 19, 2014 at 12:25:13PM +0200, Jes Sorensen wrote:
> Dan,
>
> Calm down, I haven't been bombarding the list, due to the sheer volume
> of commits. If you want me to spam the list, tell me where and I'll add
> that to the CC list next time.
We provide the scripts/get_maintainer.pl scri
I got a patch from the original author, Fred Brooks, to add a small
settling delay after setting the AI channel multiplexor. The lack of
delay resulted in unstable or scrambled data on faster processors.
Signed-off-by: Ian Abbott
Reported-by: Fred Brooks
Cc: # 3.7.x - 3.15.x
---
drivers/stagi
Dan Carpenter writes:
> On Sun, May 18, 2014 at 07:39:23AM +0100, Karim Raslan wrote:
>> This should fix a few sparse warnings like the following:
>>
>> CHECK drivers/staging/rtl8723au/core/rtw_ap.c
>> drivers/staging/rtl8723au/core/rtw_ap.c:1054:45: warning: incorrect
>> type in argument 3 (
Awesome. Thanks.
Reviewed-by: Dan Carpenter
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Sun, May 18, 2014 at 07:39:23AM +0100, Karim Raslan wrote:
> This should fix a few sparse warnings like the following:
>
> CHECK drivers/staging/rtl8723au/core/rtw_ap.c
> drivers/staging/rtl8723au/core/rtw_ap.c:1054:45: warning: incorrect type in
> argument 3 (different base types)
> drive
- alloc_tty_driver() is deprecated so it is changed to
tty_alloc_driver()
- Pointers which are allocated by alloc_tty_driver() and kzalloc()
can be NULL so it need to check NULL for them.
- If one of those is failed, it need to add proper handler for
avoiding memory leak.
- If both of drivers are r
2014-05-19 18:39 GMT+09:00 DaeSeok Youn :
> 2014-05-19 17:02 GMT+09:00 Dan Carpenter :
>> Nice, but it needs a couple style improvements below.
>>
>> On Mon, May 19, 2014 at 11:10:30AM +0900, Daeseok Youn wrote:
>>> + brd->dgap_major_serial_registered = TRUE;
>>> + dgap_boards_by_major[brd-
From: Anil Belur
Fixed the warning message by replacing memcpy() with ether_addr_copy()
Signed-off-by: Anil Belur
---
drivers/staging/ozwpan/ozproto.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ozwpan/ozproto.c b/drivers/staging/ozwpan/ozproto.c
index f
2014-05-19 17:02 GMT+09:00 Dan Carpenter :
> Nice, but it needs a couple style improvements below.
>
> On Mon, May 19, 2014 at 11:10:30AM +0900, Daeseok Youn wrote:
>> + brd->dgap_major_serial_registered = TRUE;
>> + dgap_boards_by_major[brd->serial_driver->major] = brd;
>> + brd->dgap_
On Sat, May 17, 2014 at 09:00:04PM -0700, David Matlack wrote:
> Remove uninitialized struct that is only used to regulate whether
> incorrect eeprom checksums are ignored.
>
Looking at the patch, this looks like a bugfix but the changelog doesn't
give any clues.
regards,
dan carpenter
This patch is great, thanks, don't resend. But I wish the subject said
"fix" instead of "rewrite". I was expecting it to just be a cleanup.
It helps a lot if `git log --oneline` says which patches should be
backported.
regards,
dan carpenter
___
deve
On Mon, May 19, 2014 at 12:09:58PM +0400, Anton Saraev wrote:
> +/* ignore all asserts, for performance */
> +#define skein_assert_ret(x, ret_code)
> +#define skein_assert(x)
Not related to this patch, but defining away asserts like this is a bad
idea. What if they have side affects like:
On Mon, May 19, 2014 at 12:09:55PM +0400, Anton Saraev wrote:
> #if SKEIN_UNROLL_256 == 0
> -#define R256(p0, p1, p2, p3, ROT, rNum) /* fully unrolled */ \
> +#define R256(p0, p1, p2, p3, ROT, r_num) /* fully unrolled */ \
> do { \
> - Round256(p0, p1, p2, p3, ROT, rNum) \
> - Skein_Show_
Was there really a v1 version of this patchset because I don't see it in
my inbox?
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Mon, May 19, 2014 at 11:10:30AM +0900, Daeseok Youn wrote:
> diff --git a/drivers/staging/dgap/dgap.c b/drivers/staging/dgap/dgap.c
> index d7cfc45..e4cb7aa 100644
> --- a/drivers/staging/dgap/dgap.c
> +++ b/drivers/staging/dgap/dgap.c
> @@ -1212,7 +1212,9 @@ static int dgap_tty_register(struct
Nice, but it needs a couple style improvements below.
On Mon, May 19, 2014 at 11:10:30AM +0900, Daeseok Youn wrote:
> + brd->dgap_major_serial_registered = TRUE;
> + dgap_boards_by_major[brd->serial_driver->major] = brd;
> + brd->dgap_serial_major = brd->serial_driver->major;
> +
>
65 matches
Mail list logo