On 02/14/2014 05:44 PM, Lee Jones wrote:
On Wed, 12 Feb 2014, rogera...@realtek.com wrote:
From: Roger Tseng
Realtek USB card reader provides a channel to transfer command or data to flash
memory cards. This driver exports host instances for mmc and memstick subsystems
and handles basic works
On 02/15/2014 02:41 PM, Greg KH wrote:
On Sat, Feb 15, 2014 at 12:38:11PM -0800, Greg KH wrote:
I've applied this series up to here.
Nevermind, the others applied, so I've merged them, just not this patch.
I have split this patch into two parts that I will send tomorrow. The first one
just
Hi Micky,
On Mon, Feb 17, 2014 at 10:00:54AM +0800, micky_ch...@realsil.com.cn wrote:
> From: Micky Ching
>
> First we fix the card poweroff bug: the card power is not shutdown when sd/mmc
> card removed, this will make UHS-card failed to running in high speed mode if
> we
> insert the card aga
From: Micky Ching
Add support for non-blocking request, pre_req() runs dma_map_sg() and
post_req() runs dma_unmap_sg(). This patch can increase card read/write
speed, especially for high speed card and slow CPU(for some embedded
platform).
Users can get a great benefit from this patch. if CPU fr
From: Micky Ching
If the host driver removed while card in the slot, the host will not
power off card power correctly. This bug is produced because host
eject flag set before the last mmc_set_ios callback, we should set the
eject flag after power off.
Signed-off-by: Micky Ching
---
drivers/mmc
From: Micky Ching
The new phase searching method is more concise and easier to
understand.
Signed-off-by: Micky Ching
---
drivers/mmc/host/rtsx_pci_sdmmc.c | 112 +++--
include/linux/mfd/rtsx_pci.h |2 +-
2 files changed, 33 insertions(+), 81 deletions
From: Micky Ching
First we fix the card poweroff bug: the card power is not shutdown when sd/mmc
card removed, this will make UHS-card failed to running in high speed mode if we
insert the card again.
We offer a concise tuning searching method, it is much easier to read.
At last we add support
Looks like phys_addr_t's are fully plumbed in the kernel.
Signed-off-by: Tomas Winkler
---
V2: remove one more comment regarding ion_phys_addr_t
drivers/staging/android/ion/ion.c | 2 +-
drivers/staging/android/ion/ion.h | 12 +++-
drivers/staging/android/io
Get rid of the buffer allocation in the receive path for normal packets.
Signed-off-by: K. Y. Srinivasan
---
drivers/net/hyperv/hyperv_net.h |2 ++
drivers/net/hyperv/netvsc.c | 33 ++---
2 files changed, 12 insertions(+), 23 deletions(-)
diff --git a/drive
This structure is redundant; get rid of it make the code little more efficient -
get rid of the unnecessary indirection.
Signed-off-by: K. Y. Srinivasan
Reviewed-by: Haiyang Zhang
---
drivers/net/hyperv/hyperv_net.h |6 -
drivers/net/hyperv/netvsc_drv.c |2 +-
drivers/net/hyperv
Make the receive path a little more efficient by parameterizing the
required state rather than re-establishing that state.
Signed-off-by: K. Y. Srinivasan
Reviewed-by: Haiyang Zhang
---
drivers/net/hyperv/netvsc.c | 29 +
1 files changed, 13 insertions(+), 16 delet
Get rid of some unnecessary code and some general cleanup.
K. Y. Srinivasan (3):
Drivers: net: hyperv: Get rid of the rndis_filter_packet structure
Drivers: net: hyperv: Cleanup the receive path
Drivers: net: hyperv: Cleanup the netvsc receive callback functio
drivers/net/hyperv/hyperv_net
Looks like phys_addr_t's are fully plumbed in the kernel.
Signed-off-by: Tomas Winkler
---
drivers/staging/android/ion/ion.c | 2 +-
drivers/staging/android/ion/ion.h | 12 +++-
drivers/staging/android/ion/ion_carveout_heap.c | 14 +++---
drivers/stag
Implement the file copy service for Linux guests on Hyper-V. This permits the
host to copy a file (over VMBUS) into the guest. This facility is part of
"guest integration services" supported on the Windows platform.
Here is a link that provides additional details on this functionality:
http://tech
On 02/16/2014 03:09 AM, Dan Carpenter wrote:
On Sun, Feb 16, 2014 at 11:02:52AM +0800, Zhao, Gang wrote:
On Sat, 2014-02-15 at 06:54:06 +0800, Larry Finger wrote:
This alignment entry in union recv_frame does nothing. It certainly
dues not ensure alignment.
^
typo here.
I accident
fixed up a couple of indentation issues.
Signed-off-by: Gary Alan Rookard
---
On branch staging-next
drivers/staging/bcm/DDRInit.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/bcm/DDRInit.c b/drivers/staging/bcm/DDRInit.c
index b4d5e64..f1d7cb8 100644
-
On Sun, Feb 16, 2014 at 11:02:52AM +0800, Zhao, Gang wrote:
> On Sat, 2014-02-15 at 06:54:06 +0800, Larry Finger wrote:
> > This alignment entry in union recv_frame does nothing. It certainly
> > dues not ensure alignment.
>^
>typo here.
>
>I accidently sent this as a private mail befo
This patch for hwdrv_apci035.c aligns comment blocks and makes indentation
of comments consistent. Removed all "spaces before tabs" in comment
indentation as well.
Signed-off-by: Chase Southwood
---
.../comedi/drivers/addi-data/hwdrv_apci035.c | 140 ++---
1 file changed,
This patch for hwdrv_apci035.c changes a printk() call to a dev_err call
since this is generally preferred.
Signed-off-by: Chase Southwood
---
drivers/staging/comedi/drivers/addi-data/hwdrv_apci035.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drive
This patch for hwdrv_apci035.c removes a zero initialization from two
static variables. Static variables are initialized to zero by default,
so doing so explicitly is not necessary.
Signed-off-by: Chase Southwood
---
I purposely made this patch the last in the series, because while it is
technic
This patch for hwdrv_apci035 removes some unneeded braces, and moves some
improperly placed braces to the correct position, as found by checkpatch.
It also removes a commented out if-statement that I found whilst cleaning
braces that is identical to another un-commented if-statement directly
above
21 matches
Mail list logo