Re: [PATCH] [RFC] staging: rtl8821ae: fix invalid bit mask on MSR_AP check

2014-02-14 Thread Levente Kurusa
On 02/14/2014 11:00 PM, Dan Carpenter wrote: > [...] >> Hi, >> >> This might not be the real solution since it is also possible that >> the particular condition never really happens. I seek comments >> so that I can post the proper patch. >> > > I can't test it either but I think your fix is c

[PATCH 1/3] staging: r8712u: delete unnecessary field initialization

2014-02-14 Thread Julia Lawall
From: Julia Lawall On success, the function netdev_alloc_skb initializes the dev field of its result to its first argument, so this doesn't have to be done in the calling context. The semantic patch that fixes this problem is as follows: (http://coccinelle.lip6.fr/) // @@ expression skb,privn,

[PATCH 2/3] staging: r8188eu: delete unnecessary field initialization

2014-02-14 Thread Julia Lawall
From: Julia Lawall On success, the function netdev_alloc_skb initializes the dev field of its result to its first argument, so this doesn't have to be done in the calling context. The semantic patch that fixes this problem is as follows: (http://coccinelle.lip6.fr/) // @@ expression skb,privn,

[PATCH] Staging: comedi: kcomedilib: replace deprecated simple_strtoul() with kstrtouint()

2014-02-14 Thread Chase Southwood
Since simple_strtoul() has been deprecated, replace it with kstrtouint(). Also, since return code checking for this new function is enforced, add a check to ensure that the conversion has succeeded. Signed-off-by: Chase Southwood --- drivers/staging/comedi/kcomedilib/kcomedilib_main.c | 3 ++- 1

Re: [patch] Documentation/SubmittingPatches: Reported-by tags and permission

2014-02-14 Thread Randy Dunlap
On 02/14/2014 01:30 AM, Dan Carpenter wrote: > The reported-by text says you have to ask for permission, but that's > only if the bug was reported in private. These days the standard is to > always give reported-by credit or it's considered a bit rude. > > Signed-off-by: Dan Carpenter Acked-by:

[PATCH 12/13] staging: r8188eu: Remove wrapper routine _set_workitem()

2014-02-14 Thread Larry Finger
This is simply a wrapper around schedule_work(). Signed-off-by: Larry Finger --- drivers/staging/rtl8188eu/core/rtw_led.c | 2 +- drivers/staging/rtl8188eu/include/osdep_service.h | 5 - 2 files changed, 1 insertion(+), 6 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw

[PATCH 08/13] staging: r8188eu: Remove unused union

2014-02-14 Thread Larry Finger
Signed-off-by: Larry Finger --- drivers/staging/rtl8188eu/include/rtw_xmit.h | 5 - 1 file changed, 5 deletions(-) diff --git a/drivers/staging/rtl8188eu/include/rtw_xmit.h b/drivers/staging/rtl8188eu/include/rtw_xmit.h index 1ac1dd3..62f5db1 100644 --- a/drivers/staging/rtl8188eu/include/r

[PATCH 11/13] staging: r8188eu: Remove wrapper routine _init_workitem()

2014-02-14 Thread Larry Finger
This is simply another name for INIT_WORK(). Signed-off-by: Larry Finger --- drivers/staging/rtl8188eu/core/rtw_cmd.c | 2 +- drivers/staging/rtl8188eu/core/rtw_led.c | 2 +- drivers/staging/rtl8188eu/include/osdep_service.h | 6 -- 3 files changed, 2 insertions(+), 8 delet

[PATCH 10/13] staging: r8188eu: Remove wrapper _enter_critical_mutex()

2014-02-14 Thread Larry Finger
This wrapper returned the result of mutex_lock_interruptible(); however, none of the callers checked the returned value. As a result of a gcc upgrade to version 4.8.1, two false unitialized variable warnings appeared. To silence the warnings, they are initialized to 0. Signed-off-by: Larry Finger

[PATCH 07/13] staging: r8188eu: Remove get_recvframe_data()

2014-02-14 Thread Larry Finger
This inline function checks that the pointer is not NULL and then returns the rx_data member. Unfortunately, all 3 callers of this function have dereferenced that pointer before this routine is called. As the check for NULL is useless, eliminate the routine. Reported-by: Jes Sorensen Signed-off-b

[PATCH 09/13] staging: r8188eu: Remove wrapper _exit_critical_mutex()

2014-02-14 Thread Larry Finger
This wrapper is a simple call to mutex_exit(). Signed-off-by: Larry Finger --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 2 +- drivers/staging/rtl8188eu/hal/usb_ops_linux.c | 2 +- drivers/staging/rtl8188eu/include/osdep_service.h | 7 --- drivers/staging/rtl8188eu/os_dep/os_in

[PATCH 13/13] staging: r8188eu: Make firmware buffer persistent

2014-02-14 Thread Larry Finger
From: Stas Sergeev The present code reloads the firmware file from the disk every time the interface re-inits. Change to hold the firmware in memory, and only download to the device. Signed-off-by: Stas Sergeev Signed-off-by: Larry Finger --- drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c

[PATCH 06/13] staging: r8188eu: Remove get_recvframe_len()

2014-02-14 Thread Larry Finger
This simple routine is replaced by a simple access of the len member. Reported-by: Jes Sorensen Signed-off-by: Larry Finger Cc: Jes Sorensen --- drivers/staging/rtl8188eu/core/rtw_recv.c| 2 +- drivers/staging/rtl8188eu/include/rtw_recv.h | 5 - 2 files changed, 1 insertion(+), 6 delet

[PATCH 00/13] Cleanups for r8188eu

2014-02-14 Thread Larry Finger
This set of patches removes a number of wrappers that only tend to obfuscate the code. These do not cause any functional changes. The one exception is the last patch. It changes the code to hold the firmware image in memory until the device is closed. That way, it is no longer necessary to reread

[PATCH 04/13] staging: r8188eu: Remove pkt_to_recv{frame, data, mem} routines

2014-02-14 Thread Larry Finger
These functions are not called from the outside source. Suggested-by: Jes Sorensen Signed-off-by: Larry Finger Cc: Jes Sorensen --- drivers/staging/rtl8188eu/include/rtw_recv.h | 38 1 file changed, 38 deletions(-) diff --git a/drivers/staging/rtl8188eu/include/rt

[PATCH 05/13] staging: r8188eu: Remove unused get_rxbuf_desc()

2014-02-14 Thread Larry Finger
Reported-by: Jes Sorensen Signed-off-by: Larry Finger Cc: Jes Sorensen --- drivers/staging/rtl8188eu/include/rtw_recv.h | 9 - 1 file changed, 9 deletions(-) diff --git a/drivers/staging/rtl8188eu/include/rtw_recv.h b/drivers/staging/rtl8188eu/include/rtw_recv.h index 81fdcf5..2159639

[PATCH 01/13] staging: r8188eu: Remove unnecessary list_head entry from recv_frame union

2014-02-14 Thread Larry Finger
Struct recv_frame_hdr already contains a list head. This one is pointless. Suggested-by: Jes Sorensen Signed-off-by: Larry Finger Cc: Jes Sorensen --- drivers/staging/rtl8188eu/core/rtw_recv.c| 7 --- drivers/staging/rtl8188eu/include/rtw_recv.h | 1 - 2 files changed, 4 insertions(+),

[PATCH 02/13] staging: r8188eu: Remove pointless "alignment" entry in recv_frame

2014-02-14 Thread Larry Finger
This alignment entry in union recv_frame does nothing. It certainly dues not ensure alignment. Suggested-by: jes.soren...@redhat.com Signed-off-by: Larry Finger Cc: jes.soren...@redhat.com --- drivers/staging/rtl8188eu/include/rtw_recv.h | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers

RE: [PATCH] hyperv_fb: Add support for Gen2 VM

2014-02-14 Thread Haiyang Zhang
> -Original Message- > From: linux-fbdev-ow...@vger.kernel.org [mailto:linux-fbdev- > ow...@vger.kernel.org] On Behalf Of Haiyang Zhang > Sent: Saturday, February 8, 2014 12:26 PM > To: florianschandi...@gmx.de; a...@linux-foundation.org; linux- > fb...@vger.kernel.org > Cc: Haiyang Zhang

RE: [PATCH] hyperv_fb: Add screen refresh after pause/resume operation

2014-02-14 Thread Haiyang Zhang
> -Original Message- > From: Haiyang Zhang [mailto:haiya...@microsoft.com] > Sent: Monday, January 13, 2014 7:21 PM > To: florianschandi...@gmx.de; a...@linux-foundation.org; linux- > fb...@vger.kernel.org > Cc: Haiyang Zhang; KY Srinivasan; o...@aepfle.de; jasow...@redhat.com; > linux-ke

Re: [PATCH] [RFC] staging: rtl8821ae: fix invalid bit mask on MSR_AP check

2014-02-14 Thread Dan Carpenter
On Fri, Feb 14, 2014 at 10:50:23PM +0100, Levente Kurusa wrote: > Since MSR_AP is 0x3, ANDing it with 0xFC will never be true. > Add a NOT operation to 0xFC so that we will AND with the last > three bits which will result in a possibility that the condition > will succeed. > > Signed-off-by: Leven

[PATCH] [RFC] staging: rtl8821ae: fix invalid bit mask on MSR_AP check

2014-02-14 Thread Levente Kurusa
Since MSR_AP is 0x3, ANDing it with 0xFC will never be true. Add a NOT operation to 0xFC so that we will AND with the last three bits which will result in a possibility that the condition will succeed. Signed-off-by: Levente Kurusa --- Hi, This might not be the real solution since it is also p

[GIT PULL] Staging driver fixes for 3.14-rc3

2014-02-14 Thread Greg KH
The following changes since commit 38dbfb59d1175ef458d006556061adeaa8751b72: Linus 3.14-rc1 (2014-02-02 16:42:13 -0800) are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git/ tags/staging-3.14-rc3 for you to fetch changes up to ddf5eb564d9

Re: [PATCH RFC 01/17 v2] staging: dgap: Merge dgap_fep5.c into dgap_driver.c

2014-02-14 Thread Greg Kroah-Hartman
On Fri, Feb 14, 2014 at 12:45:30PM -0500, Mark Hounschell wrote: > On 02/14/2014 12:38 PM, Greg Kroah-Hartman wrote: > > On Wed, Feb 12, 2014 at 03:32:10PM -0500, Mark Hounschell wrote: > >> There is a lot of cleanup work to do on these digi drivers and merging as > >> much as is possible will make

RE: [PATCH] Staging: comedi: clean up conditional statement in addi_apci_3xxx.c

2014-02-14 Thread Hartley Sweeten
On Friday, February 14, 2014 4:50 AM, Ian Abbott wrote: > On 2014-02-13 18:25, Hartley Sweeten wrote: >> On Wednesday, February 12, 2014 8:29 PM, Chase Southwood wrote: >>> In this if-else conditional statement, if (chan < 16), but >>> (data[0] == INSN_CONFIG_DIO_QUERY), the function does not retur

Re: [PATCH RFC 01/17 v2] staging: dgap: Merge dgap_fep5.c into dgap_driver.c

2014-02-14 Thread Mark Hounschell
On 02/14/2014 12:38 PM, Greg Kroah-Hartman wrote: > On Wed, Feb 12, 2014 at 03:32:10PM -0500, Mark Hounschell wrote: >> There is a lot of cleanup work to do on these digi drivers and merging as >> much as is possible will make it easier. I also notice that many merged >> drivers are single source

Re: [PATCH RFC 01/17 v2] staging: dgap: Merge dgap_fep5.c into dgap_driver.c

2014-02-14 Thread Mark Hounschell
On 02/14/2014 12:34 PM, Greg Kroah-Hartman wrote: > Minor nits for future patch submissions: > > On Wed, Feb 12, 2014 at 03:32:10PM -0500, Mark Hounschell wrote: >> There is a lot of cleanup work to do on these digi drivers and merging as >> much as is possible will make it easier. I also notice t

Re: [PATCH RFC 01/17 v2] staging: dgap: Merge dgap_fep5.c into dgap_driver.c

2014-02-14 Thread Greg Kroah-Hartman
On Wed, Feb 12, 2014 at 03:32:10PM -0500, Mark Hounschell wrote: > There is a lot of cleanup work to do on these digi drivers and merging as > much as is possible will make it easier. I also notice that many merged > drivers are single source and header. > > Merge dgap_fep5.c into dgap_driver.c

Re: [PATCH RFC 01/17 v2] staging: dgap: Merge dgap_fep5.c into dgap_driver.c

2014-02-14 Thread Greg Kroah-Hartman
Minor nits for future patch submissions: On Wed, Feb 12, 2014 at 03:32:10PM -0500, Mark Hounschell wrote: > There is a lot of cleanup work to do on these digi drivers and merging as > much as is possible will make it easier. I also notice that many merged > drivers are single source and header.

Re: [PATCH] staging: r8188eu: Remove dead code

2014-02-14 Thread Greg Kroah-Hartman
On Thu, Feb 13, 2014 at 01:00:18PM +0100, Paul Bolle wrote: > There are a few lines in this driver that depend on a macro > CONFIG_BT_COEXIST. But there's no Kconfig symbol of that name nor is > there a preprocessor define for that string. So remove these lines. > > Signed-off-by: Paul Bolle > --

[PATCH] staging:lustre: Fix typo in comment and printk within lustre/obdclass

2014-02-14 Thread Masanari Iida
This patch fixed spelling typo within lustre/lustre/obdclass. Signed-off-by: Masanari Iida --- drivers/staging/lustre/lustre/obdclass/cl_io.c | 2 +- drivers/staging/lustre/lustre/obdclass/cl_object.c | 2 +- drivers/staging/lustre/lustre/obdclass/genops.c| 6 +++--- drivers/

[PATCH 2/2] Documentation: iio: Extend documentation for hmc5843 bindings.

2014-02-14 Thread Marek Belisko
Signed-off-by: Marek Belisko --- Documentation/devicetree/bindings/iio/magnetometer/hmc5843.txt | 3 +++ 1 file changed, 3 insertions(+) diff --git a/Documentation/devicetree/bindings/iio/magnetometer/hmc5843.txt b/Documentation/devicetree/bindings/iio/magnetometer/hmc5843.txt index 90d5f34..b8

[PATCH 1/2] staging: iio: hmc5843: Add all available models to device tree id table.

2014-02-14 Thread Marek Belisko
Signed-off-by: Marek Belisko --- drivers/staging/iio/magnetometer/hmc5843.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/drivers/staging/iio/magnetometer/hmc5843.c b/drivers/staging/iio/magnetometer/hmc5843.c index d4f4dd9..f595fdc 100644 --- a/drivers/staging/iio/magne

Re: [PATCH v2] Staging: comedi: clean up conditional statement in addi_apci_3xxx.c

2014-02-14 Thread Ian Abbott
On 2014-02-14 01:02, Chase Southwood wrote: In this conditional statement, if (chan < 16), but the instruction passed in data[0] is INSN_CONFIG_DIO_QUERY, the function does not return early, but the else-branch does not get executed either. As a result, mask would be used uninitialized in the ne

Re: [PATCH] Staging: comedi: clean up conditional statement in addi_apci_3xxx.c

2014-02-14 Thread Ian Abbott
On 2014-02-13 10:08, Ian Abbott wrote: On 2014-02-13 03:29, Chase Southwood wrote: In this if-else conditional statement, if (chan < 16), but (data[0] == INSN_CONFIG_DIO_QUERY), the function does not return early, but the else-branch does not get executed either. As a result, mask would be used

Re: [PATCH] Staging: comedi: clean up conditional statement in addi_apci_3xxx.c

2014-02-14 Thread Ian Abbott
On 2014-02-13 18:25, Hartley Sweeten wrote: On Wednesday, February 12, 2014 8:29 PM, Chase Southwood wrote: In this if-else conditional statement, if (chan < 16), but (data[0] == INSN_CONFIG_DIO_QUERY), the function does not return early, but the else-branch does not get executed either. As a r

Re: [PATCH v4 1/3] mfd: Add realtek USB card reader driver

2014-02-14 Thread Lee Jones
On Wed, 12 Feb 2014, rogera...@realtek.com wrote: > From: Roger Tseng > > Realtek USB card reader provides a channel to transfer command or data to > flash > memory cards. This driver exports host instances for mmc and memstick > subsystems > and handles basic works. > > Signed-off-by: Roger

[patch] Documentation/SubmittingPatches: Reported-by tags and permission

2014-02-14 Thread Dan Carpenter
The reported-by text says you have to ask for permission, but that's only if the bug was reported in private. These days the standard is to always give reported-by credit or it's considered a bit rude. Signed-off-by: Dan Carpenter diff --git a/Documentation/SubmittingPatches b/Documentation/Sub