From: Roger Tseng
Realtek USB memstick host driver provides memstick host support based on the
Realtek USB card reader MFD driver.
Signed-off-by: Roger Tseng
---
drivers/memstick/host/Kconfig | 10 +
drivers/memstick/host/Makefile | 1 +
drivers/memstick/host/rtsx_usb_ms.c | 855
From: Roger Tseng
Realtek USB card reader provides a channel to transfer command or data to flash
memory cards. This driver exports host instances for mmc and memstick subsystems
and handles basic works.
Signed-off-by: Roger Tseng
---
drivers/mfd/Kconfig | 10 +
drivers/mfd/Makefile
From: Roger Tseng
Realtek USB SD/MMC host driver provides mmc host support based on the Realtek
USB card reader MFD driver.
Signed-off-by: Roger Tseng
---
drivers/mmc/host/Kconfig |7 +
drivers/mmc/host/Makefile |1 +
drivers/mmc/host/rtsx_usb_sdmmc.c | 1509 ++
From: Roger Tseng
This patchset adds modules to support Realtek USB vendor specific class flash
card reader: one base module in MFD subsystem and two host modules in both mmc
and memstick subsystems. The architecture is similar to rtsx_pci.
This work is done primarily to replace the staging driv
On Mon, Jan 13, 2014 at 07:16:14PM -0800, Joe Perches wrote:
> On Mon, 2014-01-13 at 21:13 -0600, Chase Southwood wrote:
> > This patch for ni_mio_common.c silences a checkpatch error due to a
> > trailing statement.
> []
> > diff --git a/drivers/staging/comedi/drivers/ni_mio_common.c
> > b/driver
On Mon, Jan 13, 2014 at 09:13:16PM -0600, Chase Southwood wrote:
> This patch for pcl711.c removes braces causing a checkpatch.pl warning.
> It also removes an empty else arm of an if-else statement.
>
> Signed-off-by: Chase Southwood
> ---
>
> I removed the "else" arm of this statement because
On Tue, Jan 14, 2014 at 12:43:58AM +, Dilger, Andreas wrote:
> On 2014/01/13, 6:41 AM, "Salym Senyonga" wrote:
>
> >This patch removes consecutive blank lines.
>
> ... but it doesn't leave a single blank line in those places, and in two
> cases also appears to remove a single blank line.
>
Add a missing newline to each message.
Standardize style to "%s: ...", __func__.
Signed-off-by: Joe Perches
---
There are a _lot_ of function tracing style
uses of dev_dbg that could/should be deleted.
This patch doesn't attempt to delete them.
drivers/staging/ced1401/ced_ioc.c | 151
Implement the file copy service for Linux guests on Hyper-V. This permits the
host to copy a file (over VMBUS) into the guest. This facility is part of
"guest integration services" supported on the Windows platform.
Here is a link that provides additional details on this functionality:
http://tech
Hi Martyn,
On Mon, Jan 13, 2014 at 6:49 AM, Michael Kenney wrote:
> Hi Martyn,
>
> On Mon, Jan 13, 2014 at 4:00 AM, Martyn Welch wrote:
> [snip]
>>
>> Hi Mike,
>>
>> I'm a little bemused by this one - I haven't managed to replicate it yet. I
>> have a feeling that the VME driver in version 3.2
On Mon, 2014-01-13 at 21:13 -0600, Chase Southwood wrote:
> This patch for ni_mio_common.c silences a checkpatch error due to a
> trailing statement.
[]
> diff --git a/drivers/staging/comedi/drivers/ni_mio_common.c
> b/drivers/staging/comedi/drivers/ni_mio_common.c
[]
> @@ -692,7 +692,8 @@ static
This patch for ni_mio_common.c silences a checkpatch error due to a
trailing statement.
Signed-off-by: Chase Southwood
---
drivers/staging/comedi/drivers/ni_mio_common.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/ni_mio_common.c
b/driver
This patch for pcl711.c removes braces causing a checkpatch.pl warning.
It also removes an empty else arm of an if-else statement.
Signed-off-by: Chase Southwood
---
I removed the "else" arm of this statement because it was empty, save for the
"ignore" comment. If it is instead preferred kerne
On Mon, 2014-01-13 at 15:56 -0800, Greg KH wrote:
> On Mon, Jan 13, 2014 at 08:41:40PM +0100, Pol Eyschen wrote:
[]
> > diff --git a/drivers/staging/ced1401/ced_ioc.c
> > b/drivers/staging/ced1401/ced_ioc.c
[]
> > @@ -41,7 +41,8 @@ static void FlushOutBuff(DEVICE_EXTENSION *pdx)
> > {
> > dev
From: Wei Yongjun
Fixes the following sparse warnings:
drivers/staging/android/ion/ion_dummy_driver.c:26:19: warning:
symbol 'idev' was not declared. Should it be static?
drivers/staging/android/ion/ion_dummy_driver.c:27:17: warning:
symbol 'heaps' was not declared. Should it be static?
driver
On 2014/01/13, 6:41 AM, "Salym Senyonga" wrote:
>Just a few minor changes to make columns line up.
I'd prefer that if you are going to line up the columns that this be
done with tabs instead of spaces. That avoids (or at least reduces)
the need to re-align all of the lines if these structures a
On 2014/01/13, 6:41 AM, "Salym Senyonga" wrote:
>This patch removes consecutive blank lines.
... but it doesn't leave a single blank line in those places, and in two
cases also appears to remove a single blank line.
To be honest, I'd rather not see minor whitespace-only changes like this
one,
s
Hi all,
Given that 3.13 will be out in a few days, it's time to close my trees
for new patches until 3.14-rc1 is out.
Please feel free to send me patches for these trees, but note that I'll
be ignoring them until 3.14-rc1 is out, at which point in time I'll
start reviewing them again and applying
On Mon, Jan 13, 2014 at 08:41:40PM +0100, Pol Eyschen wrote:
> From: Pol Eyschen
>
> All comments fixed to match the kernel coding style.
>
> Signed-off-by: Pol Eyschen
> ---
> drivers/staging/ced1401/ced_ioc.c | 382
> -
> 1 file changed, 249 insertions(+
On Mon, Jan 13, 2014 at 11:19:15PM +, Joe Borg wrote:
> Fixed an error flagged by checkpatch.pl, 'foo * bar should be foo
> *bar' in the parameters of function munge_data().
>
> Signed-off-by: Joe Borg
> ---
> drivers/staging/comedi/drivers/das1800.c | 2 +-
> 1 file changed, 1 insertion(+),
On Mon, Jan 13, 2014 at 11:19:15PM +, Joe Borg wrote:
> Fixed an error flagged by checkpatch.pl, 'foo * bar should be foo
> *bar' in the parameters of function munge_data().
Ok, real minor nits here, but I'd like you to make them for future
patches as it makes my life easier, and I don't like
This is necessary because after VM is pause/resumed, some portion of
the screen may need refresh.
Signed-off-by: Haiyang Zhang
Reviewed-by: K. Y. Srinivasan
---
drivers/video/hyperv_fb.c | 10 +-
1 files changed, 9 insertions(+), 1 deletions(-)
diff --git a/drivers/video/hyperv_fb.c
Now that the DWC2 driver has been moved to drivers/usb, move its
bindings doc to the correct place
Cc: Rob Herring
Signed-off-by: Paul Zimmerman
---
Greg,
I missed this file when moving the rest of the dwc2 files.
Documentation/devicetree/bindings/{staging => usb}/dwc2.txt | 0
1 file changed,
Fixed an error flagged by checkpatch.pl, 'foo * bar should be foo
*bar' in the parameters of function munge_data().
Signed-off-by Joe Borg
---
drivers/staging/comedi/drivers/das1800.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/das1800.c
b/
On Tue, Dec 31, 2013 at 10:52:37PM +0100, Pavel Machek wrote:
> __u32 is only useful for kernel-user interface, u32 should be enough
> for kernel. Formatting was very confusing around __get_free_pages().
>
> Signed-off-by: Pavel Machek
This doesn't apply to my char-misc.git tree, care to redo it
On Mon, Jan 13, 2014 at 01:50:09PM -0800, Paul Zimmerman wrote:
> The DWC2 driver should now be in good enough shape to move out of
> staging. I have stress tested it overnight on RPI running mass
> storage and Ethernet transfers in parallel, and for several days
> on our proprietary PCI-based plat
On Mon, Jan 13, 2014 at 11:31:29PM +0100, Pol Eyschen wrote:
>
> On 13.01.2014, at 22:44, Dan Carpenter wrote:
>
> > On Mon, Jan 13, 2014 at 09:35:53PM +, Mark Einon wrote:
> >> On Mon, Jan 13, 2014 at 08:41:40PM +0100, Pol Eyschen wrote:
> >>> From: Pol Eyschen
> >>>
> >>> All comments fix
On Mon, Jan 13, 2014 at 11:31:29PM +0100, Pol Eyschen wrote:
> >
> I took the original comments that were there, and just formatted them
> to be in order with the coding style, I didn't add or remove
> anything. This is my first patch so I didn't want to mess too much
> with what was there before,
On 13.01.2014, at 22:44, Dan Carpenter wrote:
> On Mon, Jan 13, 2014 at 09:35:53PM +, Mark Einon wrote:
>> On Mon, Jan 13, 2014 at 08:41:40PM +0100, Pol Eyschen wrote:
>>> From: Pol Eyschen
>>>
>>> All comments fixed to match the kernel coding style.
>>>
>>> Signed-off-by: Pol Eyschen
>>>
> From: Greg KH [mailto:gre...@linuxfoundation.org]
> Sent: Monday, January 13, 2014 2:04 PM
>
> On Mon, Jan 13, 2014 at 01:50:09PM -0800, Paul Zimmerman wrote:
>> The DWC2 driver should now be in good enough shape to move out of
>> staging. I have stress tested it overnight on RPI running mass
>>
On Mon, Jan 13, 2014 at 01:50:09PM -0800, Paul Zimmerman wrote:
> The DWC2 driver should now be in good enough shape to move out of
> staging. I have stress tested it overnight on RPI running mass
> storage and Ethernet transfers in parallel, and for several days
> on our proprietary PCI-based plat
On Mon, Jan 13, 2014 at 09:47:59PM +, Joe Borg wrote:
> Fixed an error flagged by checkpatch.pl, 'foo * bar should be foo *bar' in
> the parameters of function munge_data().
Please wrap your changelog comments at 72 colums, like git asks you to
when you type them in.
> Signed-off-by Joe Borg
The DWC2 driver should now be in good enough shape to move out of
staging. I have stress tested it overnight on RPI running mass
storage and Ethernet transfers in parallel, and for several days
on our proprietary PCI-based platform.
Signed-off-by: Paul Zimmerman
---
v4: Also change directory path
Fixed an error flagged by checkpatch.pl, 'foo * bar should be foo *bar' in the
parameters of function munge_data().
Signed-off-by Joe Borg
---
drivers/staging/comedi/drivers/das1800.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/das1800.c
b
On Mon, Jan 13, 2014 at 09:35:53PM +, Mark Einon wrote:
> On Mon, Jan 13, 2014 at 08:41:40PM +0100, Pol Eyschen wrote:
> > From: Pol Eyschen
> >
> > All comments fixed to match the kernel coding style.
> >
> > Signed-off-by: Pol Eyschen
> > ---
>
> This patch doesn't apply to my staging-ne
The DWC2 driver should now be in good enough shape to move out of
staging. I have stress tested it overnight on RPI running mass
storage and Ethernet transfers in parallel, and for several days
on our proprietary PCI-based platform.
Signed-off-by: Paul Zimmerman
---
Greg,
I believe I have addres
On Mon, Jan 13, 2014 at 08:41:40PM +0100, Pol Eyschen wrote:
> From: Pol Eyschen
>
> All comments fixed to match the kernel coding style.
>
> Signed-off-by: Pol Eyschen
> ---
This patch doesn't apply to my staging-next branch. Are you making your
changes to the staging-next branch of
git://git
On Mon, Jan 13, 2014 at 09:23:11PM +, Joe Borġ wrote:
> Ok, will do the change log.
>
> Yes, it's my real name and email... I know the email address is embarrassing,
> but genuine :).
>
>
>
> Regards,
> Joseph David Borġ
There's nothing wrong with using "Joe Borġ" as your signed-off-by: li
On Mon, Jan 13, 2014 at 08:10:36PM +, Joe Borg wrote:
> Signed-off-by Joe Borg
> ---
> drivers/staging/android/alarm-dev.c | 10 ++
> 1 file changed, 6 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/android/alarm-dev.c
> b/drivers/staging/android/alarm-dev.c
> index
On Mon, Jan 13, 2014 at 08:14:46PM +, Joe Borg wrote:
> Signed-off-by Joe Borg
You need a changelog comment here, please.
And is that your "real" email address and name?
greg k-h
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev
On Mon, Jan 13, 2014 at 08:10:36PM +, Joe Borg wrote:
> Signed-off-by Joe Borg
> ---
> drivers/staging/android/alarm-dev.c | 10 ++
> 1 file changed, 6 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/android/alarm-dev.c
> b/drivers/staging/android/alarm-dev.c
> index
Signed-off-by Joe Borg
---
drivers/staging/comedi/drivers/das1800.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/das1800.c
b/drivers/staging/comedi/drivers/das1800.c
index 1880038..8fb87df 100644
--- a/drivers/staging/comedi/drivers/das1800.c
Signed-off-by Joe Borg
---
drivers/staging/android/alarm-dev.c | 10 ++
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/android/alarm-dev.c
b/drivers/staging/android/alarm-dev.c
index 647694f..87f2a02 100644
--- a/drivers/staging/android/alarm-dev.c
+++ b/dr
From: Pol Eyschen
All comments fixed to match the kernel coding style.
Signed-off-by: Pol Eyschen
---
drivers/staging/ced1401/ced_ioc.c | 382 -
1 file changed, 249 insertions(+), 133 deletions(-)
diff --git a/drivers/staging/ced1401/ced_ioc.c
b/drivers/s
On Sat, Jan 11, 2014 at 02:48:48PM +, Joe Borg wrote:
> ---
> drivers/staging/comedi/drivers/das6402.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
Please always run your patches through the checkpatch.pl script, so that
we don't have to tell you the results of it as to why we can'
On Sat, Jan 11, 2014 at 04:37:32PM -0800, Insop Song wrote:
> On Sat, Jan 11, 2014 at 4:10 PM, Greg KH wrote:
> > On Sat, Jan 11, 2014 at 03:56:48PM -0800, Insop Song wrote:
> >> On Sat, Jan 11, 2014 at 1:05 PM, Greg KH
> >> wrote:
> >> > On Sat, Jan 11, 2014 at 12:51:28PM -0800, Greg KH wrote:
From: Julia Lawall
The variable status is initialized to either 0 or an error code. Return
status to propagate the error value.
A simplified version of the semantic patch that fixes this problem is as
follows: (http://coccinelle.lip6.fr/)
//
@@
type T;
identifier i;
constant c;
@@
-T i;
<...
On Mon, Jan 13, 2014 at 05:17:27PM +0100, Julia Lawall wrote:
> From: Julia Lawall
>
> The variable status is initialized to either 0 or an error code. Return
> status to propagate the error value.
>
Could you update the subject to say that the patch was a bugfix.
regards,
dan carpenter
From: Julia Lawall
The variable status is initialized to either 0 or an error code. Return
status to propagate the error value.
A simplified version of the semantic patch that fixes this problem is as
follows: (http://coccinelle.lip6.fr/)
//
@@
type T;
identifier i;
constant c;
@@
-T i;
<...
These patches delete declarations and initializations of variables that are
only assigned to constants but never used otherwise.
The complete semantic patch that makes this change is as follows:
(http://coccinelle.lip6.fr/)
//
@r exists@
type T;
identifier i,i2;
position p;
@@
T i@p;
...
i = i
Hi Martyn,
On Mon, Jan 13, 2014 at 4:00 AM, Martyn Welch wrote:
[snip]
>
> Hi Mike,
>
> I'm a little bemused by this one - I haven't managed to replicate it yet. I
> have a feeling that the VME driver in version 3.2 won't use 16-bit transfers
> at the beginning of blocks that aren't naturally ali
Just a few minor changes to make columns line up.
Signed-off-by: Salym Senyonga
---
.../lustre/include/linux/libcfs/libcfs_debug.h | 24 ++--
1 files changed, 12 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/lustre/include/linux/libcfs/libcfs_debug.h
b/drive
Hi Greg,
Greg KH writes:
> It's been pointed out to me that there hasn't been any forward
> development on the sbe-2t3e3 in almost a year now. Is development dead,
> and I should delete it, or are you planning on doing more work on it
> soon so that it can be merged out of the staging tree?
To
Uniformly align backslashes to improve readability.
Signed-off-by: Salym Senyonga
---
.../lustre/include/linux/libcfs/libcfs_debug.h | 70 ++--
1 files changed, 35 insertions(+), 35 deletions(-)
diff --git a/drivers/staging/lustre/include/linux/libcfs/libcfs_debug.h
b/dri
This patch removes consecutive blank lines.
Signed-off-by: Salym Senyonga
---
.../lustre/include/linux/libcfs/libcfs_debug.h |8
1 files changed, 0 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/lustre/include/linux/libcfs/libcfs_debug.h
b/drivers/staging/lustre/in
Give all the constants a uniform alignment.
Signed-off-by: Salym Senyonga
---
.../lustre/include/linux/libcfs/libcfs_debug.h | 108 ++--
1 files changed, 54 insertions(+), 54 deletions(-)
diff --git a/drivers/staging/lustre/include/linux/libcfs/libcfs_debug.h
b/drivers/sta
On 07/01/14 16:14, Michael Kenney wrote:
> Hi Martyn,
>
> On Fri, Dec 27, 2013 at 4:34 PM, Michael Kenney wrote:
>>
>> Hi Martyn,
>>
>> On Fri, Dec 27, 2013 at 4:23 PM, Martyn Welch wrote:
>>> On 27/12/13 20:15, Michael Kenney wrote:
We are using the vme_tsi148 bridge driver along with
On Monday, January 13, 2014 at 11:24:33 AM, Lothar Waßmann wrote:
> This patch allows to select a specific video mode from a list of modes
> defined in DT by setting the 'native-mode' property appropriately.
>
> Since all current users of this driver have only one mode defined in
> their .dts file
This patch allows to select a specific video mode from a list of modes
defined in DT by setting the 'native-mode' property appropriately.
Since all current users of this driver have only one mode defined in
their .dts files, the patch does not change the behaviour of this
driver on the affected pl
On 2014-01-11 03:56, Chase Southwood wrote:
This patch series fixes several warnings reported by checkpatch.pl in
ni_mio_common.c of the comedi driver.
Among the issues fixed:
*Many unnecessary braces have been removed.
*Improper indentation has been corrected.
*Extra whitespace before semicolon
On Mon, Jan 13, 2014 at 09:02:33AM +, Joe Borġ wrote:
> Apologies for missing that.
>
> Feel free to add signed-off-by Joe Borg to the
> commit message.
>
Unless it's a bugfix for a security issue then we don't fix other
people's patches. You have to resend.
regards,
dan carpenter
__
Am Samstag, den 11.01.2014, 11:23 +0800 schrieb Shawn Guo:
> On Fri, Jan 10, 2014 at 03:22:24PM +0100, Philipp Zabel wrote:
> > Due to the voltage divider on the HPD line, the HDMI connector on
> > imx6q-sabrelite doesn't reliably detect connected DVI monitors.
> > This patch allows to use the RX_S
Am Samstag, den 11.01.2014, 11:40 + schrieb Russell King - ARM
Linux:
> On Sat, Jan 11, 2014 at 12:31:19PM +0100, Robert Schwebel wrote:
> > On Fri, Jan 10, 2014 at 11:23:37PM +, Russell King - ARM Linux wrote:
> > > We do this in DT by providing a "superdevice" node which specifies
> > > t
On Mon, Jan 13, 2014 at 01:15:17AM +0900, Masanari Iida wrote:
> This patch fixed "ERROR: do not use C99 // comments"
> found by checkpatch.pl.
>
Almost all these comments are pointless and should just be deleted.
regards,
dan carpenter
___
devel mail
On Sun, Jan 12, 2014 at 01:45:51AM +0530, Monam Agarwal wrote:
> This introduces fls in lustre/ldlm/ldlm_extent.c
> to find the last set bit.
>
> Signed-off-by: Monam Agarwal
> ---
> Changes since v1:
> * Incorrect commit message
> * Use of fls function
> Changes since v2:
> * Removal of extra va
No signed-off line. Just merge both patches since they do the same
thing and go to the same maintainers.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
66 matches
Mail list logo