NO_FS_PHY_HW_CHECKS is never defined, so remove the conditional
code that checks for it being set
Signed-off-by: Paul Zimmerman
---
drivers/staging/dwc2/core.c | 18 --
1 file changed, 18 deletions(-)
diff --git a/drivers/staging/dwc2/core.c b/drivers/staging/dwc2/core.c
index 8
Fix some functions called by dwc2_hcd_qtd_add() to return either
a proper error code or 0, instead of somewhat random values.
Then change the caller of dwc2_hcd_qtd_add() to just check the
return value for 0.
Signed-off-by: Paul Zimmerman
---
drivers/staging/dwc2/hcd.c | 6 +++---
drivers/
Rename dwc2_check_core_status() to dwc2_is_controller_alive(), and
make it a boolean function. Also change the message when the
controller is dead to say "dead" instead of "disconnected".
Signed-off-by: Paul Zimmerman
---
drivers/staging/dwc2/core.c | 6 +++---
drivers/staging/dwc2/core.h
Remove useless cast in dwc2_get_otg_version()
Signed-off-by: Paul Zimmerman
---
drivers/staging/dwc2/core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/dwc2/core.c b/drivers/staging/dwc2/core.c
index 6149fbc..5b490a4 100644
--- a/drivers/staging/dwc2/core.
Remove #ifdef DEBUG from a couple of places where it is not needed
Signed-off-by: Paul Zimmerman
---
drivers/staging/dwc2/core_intr.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/dwc2/core_intr.c b/drivers/staging/dwc2/core_intr.c
index c78bb5d..8205799 100644
--- a/d
We were not checking the return value from any of these functions,
so make them void functions
Signed-off-by: Paul Zimmerman
---
drivers/staging/dwc2/core.c | 193
drivers/staging/dwc2/core.h | 60 +++---
drivers/staging/dwc2/hcd.h | 4 +-
DWC2_PARAM_TEST is not a very good name for this macro, so rename
it to DWC2_OUT_OF_BOUNDS
Signed-off-by: Paul Zimmerman
---
drivers/staging/dwc2/core.c | 32
1 file changed, 16 insertions(+), 16 deletions(-)
diff --git a/drivers/staging/dwc2/core.c b/drivers/st
dwc2_process_non_isoc_desc() can potentially free the qtd, so null
out the qtd pointer if the call fails so we don't try to access it
later
Signed-off-by: Paul Zimmerman
---
drivers/staging/dwc2/hcd_ddma.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/dwc
This is a series of cleanups to the DWC2 driver, in response to Dan
Carpenter's review on 11/15/2013. I believe I have addressed all of
Dan's suggestions, except for removing the validation checks from
the dwc2_set_param_* functions. We depend on the validation checks
for setting a default value fo
Defining DEBUG_STATUS_A enables dumping of a status register during the
interrupt. These messages are just added noise. Remove them.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_mio_common.c | 31 --
1 file
This debug message is just added noise. Remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl818.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/comedi/drivers/pcl818.c
b/drivers/staging/comedi/drivers/p
Use dev_dbg(), or pr_debug() when dev is not valid, instead of the
DPRINTK macro to output the comedi debugging information.
Remove the debug messages for allocation failures. The failure will
have already generated a message.
Reword the messages that include the dev->minor number. This number
wi
The A2150_DEBUG define enables some development messages, specifically
the ni_dum_regs() function. These messages are just added noise. Remove
them.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_at_a2150.c | 25
This define is not used by the driver. Just remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/fl512.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/comedi/drivers/fl512.c
b/drivers/staging/comedi/drivers
The DEBUG_FLAGS define enables some development code that outputs
interrupt flags and status information in the interrupt handler.
This information is just added noise. Remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_pcidi
Remove the DPRINTK messages that are just function trace noise.
Use dev_dbg() instead of the DPRINTK macro to output the comedi
debugging information.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_pcidio.c | 34 ++-
Currently the COMEDI_DEBUG option enables the comedi_debug module parameter as
well as a DPRINTK() macro. To actually get debug messages to display the
kernel
still needs to be built with the -DDEBUG flag.
Cleanup all the custom uses of DEBUG in comedi and use the COMEDI_DEBUG option
to enable th
The DPRINTK messages in this driver are just added noise.
Remove them.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/dt2801.c | 9 -
1 file changed, 9 deletions(-)
diff --git a/drivers/staging/comedi/drivers/dt2801.c
b/drive
All users of this macro have been converted to use dev_dbg(). Remove
the unused macro.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/comedidev.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/comedi/comedidev.h
b/driver
The pwm subdevice in this driver sets the subdev_flags to SDF_WRITEABLE
so the s->insn_read callback is not needed. Since this callback simply
outputs a printk(KERN_DEBUG ... message jsut remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/come
Defining DEBUG_INTERRUPT enables some function trace messages during the
interrupt. These messages are just added noise. Remove them.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_mio_common.c | 24
1 file
Defining DEBUG_STATUS_B enables dumping of a status register during the
interrupt. These messages are just added noise. Remove them.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_mio_common.c | 29 --
1 file
Defining DEBUG_DIO simply enables some function trace messages. These are
just added noise. Remove them.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_mio_common.c | 22 ++
1 file changed, 2 insertions(+), 20 de
The code blocked by #ifdef NI_CS5529_DEBUG is not used by the driver.
Just remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_mio_common.c | 30 --
1 file changed, 30 deletions(-)
diff --git a/drivers
These debug messages are just added noise. Remove them.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/dmm32at.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/comedi/drivers/dmm32at.c
b/drivers/staging/comed
The irq probe code in dt2814_attach() is disabled by an #if 0 block.
Just remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/dt2814.c | 26 --
1 file changed, 26 deletions(-)
diff --git a/drivers/staging
Remove the commented out code in init_asics() that enables the rising
edge interrupts on port0 of both asics.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcmmio.c | 7 ---
1 file changed, 7 deletions(-)
diff --git a/drivers/sta
Convert a printk(KERN_DEBUG ... message to dev_dbg().
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcmmio.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/comedi/drivers/pcmmio.c
b/drivers/
Convert a printk(KERN_DEBUG ... message to dev_dbg().
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/dyna_pci10xx.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/comedi/drivers/dyna_pci10xx.c
b/
These debug messages are just added noise. Remove them.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcmmio.c | 22 --
1 file changed, 22 deletions(-)
diff --git a/drivers/staging/comedi/drivers/pcmmio.c
b/drive
This define is not used in the driver. Remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/cb_pcimdas.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/comedi/drivers/cb_pcimdas.c
b/drivers/staging/comedi/d
This define is not used in the driver. Remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_pcimio.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ni_pcimio.c
b/drivers/staging/comedi/driv
The DEBUG_PRINT macro in this driver is used to output development
debug tracing messages. These messages are just added noise. Remove
them.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/gsc_hpdi.c | 78 ---
The DEBUG_PRINT macro in this driver is used to output development
debug tracing messages. These messages are just added noise. Remove
them.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/cb_pcidas64.c | 126 +--
This macro is used by the comedi drivers that usee the mite module to
output development function trace messages. These are just added noise.
Remove the messages as well as the macro.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite
The code protected by the DEBUG_MITE define outputs some development
debug information. This information is just added noise in the final
driver. Remove the code.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/mite.c | 134 ---
This function is not used by the driver. Just remove it.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_pcidio.c | 31 --
1 file changed, 31 deletions(-)
diff --git a/drivers/staging/comedi/drivers/ni_pc
Use dev_dbg() instead of the DPRINTK macro to output the comedi
debugging information.
The dev_dbg() will prefix the messages appropriately so remove the
"comedi%d: amplc_pci230: " portion and use __func__ to show the
actual function name for debugging.
Signed-off-by: H Hartley Sweeten
Cc: Ian A
Remove the DPRINTK messages that are just function trace noise.
Use dev_dbg() instead of the DPRINTK macro to output the comedi
debugging information.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/pcl816.c | 8 ++--
1 file change
Use dev_dbg() instead of the DPRINTK macro to output the comedi
debugging information.
The dev_dbg() will prefix the messages appropriately so remove the
"comedi%d: " DRIVER_NAME portion and use __func__ to show the actual
function name for debugging.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abb
Use dev_dbg() instead of the DPRINTK macro to output the comedi
debugging information.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/range.c | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/comedi/r
Remove this module parameter and use the CONFIG_COMEDI_DEBUG option to
enable normal kernel debugging with -DDEBUG flag.
Remove the #undef DEBUG from all the comedi source files so they will
honour the -DDEBUG flag.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
dr
This define unables some debug code that prints the status flags
during the interrupt handler. These messages are just added noise
and it's probably not a good idea to spew them during the interrupt
anyway.
Remove the DEBUG define as well as the debug code.
Signed-off-by: H Hartley Sweeten
Cc: I
This define is only used to enable some debug messages during the
board attach. These are just added noise, remove them as well as
the DEBUG define.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/ni_atmio.c | 15 ---
1 file
The comedi core defines a DPRINTK macro in comedidev.h. Use that macro
instead of defining a private version in this driver.
Also, remove the DEBUG define since it was only used to enable the
DPRINTK macro.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/sta
This define is only used to enable a debug message during the board attach.
The message is just added noise, remove it as well as the DEBUG define.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/dt282x.c | 10 --
1 file changed
This macro is only used to output some function tracing debug messages.
These messages are just added noise so remove the DEBUG macro as well
as the noise.
Also, remove pcl816_cmdtest_out() which was only called as part of the
DEBUG() in pcl816_ai_cmdtest().
Signed-off-by: H Hartley Sweeten
Cc:
The private data does not contain 'das6402_irqcount' or 'das6402_wordsread'
members so the printk noise produces build errors when DEBUG is defined.
The other printk is just added noise.
Remove the printk's to fix the build errors and remove the noise.
Signed-off-by: H Hartley Sweeten
Cc: Ian Ab
remove items that have been done
Signed-off-by: ZHAO Gang
Acked-by: Mark Einon
---
v3 -> v4 -> v5: version bump, sequence number bump
drivers/staging/et131x/README | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/et131x/README b/drivers/staging/et131x/README
index 8da96a
adapter->lock is only used in et131x_multicast(), which is eventually
called by network stack function __dev_set_rx_mode(). __dev_set_rx_mode()
is always called by (net_device *)dev->addr_list_lock hold, to protect from
concurrent access. So adapter->lock is redundant.
Signed-off-by: ZHAO Gang
Ac
stop read and return error when hit max delay time.
Signed-off-by: ZHAO Gang
Acked-by: Mark Einon
---
v3 -> v4 -> v5: version bump, sequence number bump
drivers/staging/et131x/et131x.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/staging/et131x/et131x.c b/drivers/staging/et131
As TODO file suggested, drop packet instead of return NETDEV_TX_BUSY
when tx failed.
et131x_tx calls function et131x_send_packets, I put the work of
et131x_send_packets directly into et131x_tx, and made some changes to
let the code more readable.
Signed-off-by: ZHAO Gang
---
v3 -> v4: no change
Variable u32 numrfd is not necessary in this function.
Signed-off-by: ZHAO Gang
---
drivers/staging/et131x/et131x.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/et131x/et131x.c b/drivers/staging/et131x/et131x.c
index 0a6cc62..6df7145 100644
--- a/drivers
Change function name from et1310_phy_power_down to et1310_phy_power_switch
to better describe its functionality.
Signed-off-by: ZHAO Gang
---
drivers/staging/et131x/et131x.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/et131x/et131x.c b/drivers/stagin
1. As TODO list suggested, do this sort of things to reduce split lines:
struct fbr_lookup *fbr;
fbr = rx_local->fbr[id];
Then replace all the instances of "rx_local->fbr[id]" with fbr.
2. Some code style changes
Signed-off-by: ZHAO Gang
---
v4 -> v5: split "[PATCH v4 1/5
On Fri, Nov 22, 2013 at 08:35:39PM +0800, ZHAO Gang wrote:
> On Fri, Nov 22, 2013 at 8:13 PM, Dan Carpenter
> wrote:
> > On Fri, Nov 22, 2013 at 07:37:58PM +0800, ZHAO Gang wrote:
> >> On Fri, Nov 22, 2013 at 5:00 PM, Dan Carpenter
> >> wrote:
> >> > On Fri, Nov 22, 2013 at 04:44:48PM +0800, ZH
On Fri, Nov 22, 2013 at 8:13 PM, Dan Carpenter wrote:
> On Fri, Nov 22, 2013 at 07:37:58PM +0800, ZHAO Gang wrote:
>> On Fri, Nov 22, 2013 at 5:00 PM, Dan Carpenter
>> wrote:
>> > On Fri, Nov 22, 2013 at 04:44:48PM +0800, ZHAO Gang wrote:
>> >> >
>> >> > Otherwise this patch seems nice but it ne
On Fri, Nov 22, 2013 at 7:56 PM, Denis Kirjanov wrote:
> If you have no free TX descriptors that means that something went
> wrong and it's a BUG. You have to tell the stack to stop sending
> packets using netif_stop_queue() and reenable transmissions once tx
> descriptors will be available. There
On Fri, Nov 22, 2013 at 07:37:58PM +0800, ZHAO Gang wrote:
> On Fri, Nov 22, 2013 at 5:00 PM, Dan Carpenter
> wrote:
> > On Fri, Nov 22, 2013 at 04:44:48PM +0800, ZHAO Gang wrote:
> >> >
> >> > Otherwise this patch seems nice but it needs to be split up and resent.
> >>
> >> By the way, this mail
If you have no free TX descriptors that means that something went
wrong and it's a BUG. You have to tell the stack to stop sending
packets using netif_stop_queue() and reenable transmissions once tx
descriptors will be available. There are a lot of live examples in the
source tree.
On 11/22/13, ZH
On Fri, Nov 22, 2013 at 5:17 PM, Denis Kirjanov wrote:
> On 11/22/13, Mark Einon wrote:
>> On Wed, Nov 20, 2013 at 03:55:27PM +0800, ZHAO Gang wrote:
>>> As TODO file suggested, drop packet instead of return NETDEV_TX_BUSY
>>> when tx failed.
>>>
>>> et131x_tx calls function et131x_send_packets,
On Fri, Nov 22, 2013 at 5:00 PM, Dan Carpenter wrote:
> On Fri, Nov 22, 2013 at 04:44:48PM +0800, ZHAO Gang wrote:
>> >
>> > Otherwise this patch seems nice but it needs to be split up and resent.
>>
>> By the way, this mailing list is surely an open list, but I can't find
>> how to subscribe it -
On Fri, Nov 22, 2013 at 4:57 PM, Dan Carpenter wrote:
> This is a lot of spaghetti. Just write it like this:
>
>
> if (adapter->tx_ring.used >= NUM_TCB)
> goto drop;
> if (adapter->flags & FMP_ADAPTER_FAIL_SEND_MASK)
> goto drop;
> if (!neti
On 11/22/13, Mark Einon wrote:
> On Wed, Nov 20, 2013 at 03:55:27PM +0800, ZHAO Gang wrote:
>> As TODO file suggested, drop packet instead of return NETDEV_TX_BUSY
>> when tx failed.
>>
>> et131x_tx calls function et131x_send_packets, I put the work of
>> et131x_send_packets directly into et131x_t
On Fri, Nov 22, 2013 at 04:44:48PM +0800, ZHAO Gang wrote:
> >
> > Otherwise this patch seems nice but it needs to be split up and resent.
>
> By the way, this mailing list is surely an open list, but I can't find
> how to subscribe it - the website at driverdev.osuosl.org said it has
> no publicl
On Thu, Nov 21, 2013 at 09:19:21PM +, Mark Einon wrote:
> On Wed, Nov 20, 2013 at 03:55:27PM +0800, ZHAO Gang wrote:
> > As TODO file suggested, drop packet instead of return NETDEV_TX_BUSY
> > when tx failed.
> >
> > et131x_tx calls function et131x_send_packets, I put the work of
> > et131x_s
On Fri, Nov 22, 2013 at 4:08 PM, Dan Carpenter wrote:
> On Fri, Nov 22, 2013 at 10:54:27AM +0800, ZHAO Gang wrote:
>> 1. change function name: et1310_phy_power_down -> et1310_phy_power_switch
>> change function name to better describe its functionality.
>>
>> 2. as TODO file suggested, do th
On Fri, Nov 22, 2013 at 10:54:27AM +0800, ZHAO Gang wrote:
> 1. change function name: et1310_phy_power_down -> et1310_phy_power_switch
> change function name to better describe its functionality.
>
> 2. as TODO file suggested, do this sort of things to reduce split lines
> struct fbr_l
68 matches
Mail list logo