On Fri, Sep 06, 2013 at 04:48:30PM -0400, Lidza Louina wrote:
> This patch removes the error messages associated
> with errors in kzalloc. The driver doesn't need to
> add the error message because kzalloc already prints
> a more useful message.
>
> Signed-off-by: Lidza Louina
> ---
> drivers/st
The current code does not correctly negotiate the version numbers for the util
driver when hosted on earlier hosts. The version numbers presented by this
driver were not compatible with the version numbers supported by Windows Server
2008. Fix this problem.
I would like to thank Olaf Hering (oher.
On Fri, Sep 06, 2013 at 04:48:32PM -0400, Lidza Louina wrote:
> The arguments that are passed into sizeof were
> generic. This patch changes this by putting
> the actual item that we need a size of instead.
>
> For example:
> - kzalloc(sizeof(struct dgnc_board), GFP_KERNEL);
> + kzalloc(sizeof
This patch removes the conditionals that make sure
the driver supports various versions of the kernel.
They aren't needed.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/dgnc_driver.c | 12
drivers/staging/dgnc/dgnc_kcompat.h | 24 ---
drivers/staging/dgnc/dgnc_tty.c
This patch removes parentheses around return
statements. They aren't needed.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/dgnc_cls.c| 8 +-
drivers/staging/dgnc/dgnc_driver.c | 106 +--
drivers/staging/dgnc/dgnc_mgmt.c | 22 ++--
drivers/staging/dgnc/dgnc_neo.c
This patch removes casting around kzalloc calls.
The casts aren't needed because kzalloc returns
a void pointer.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/dgnc_driver.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_driver.c
b/driver
This patch removes the error messages associated
with errors in kzalloc. The driver doesn't need to
add the error message because kzalloc already prints
a more useful message.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/dgnc_driver.c | 2 --
drivers/staging/dgnc/dgnc_tty.c| 4
The arguments that are passed into sizeof were
generic. This patch changes this by putting
the actual item that we need a size of instead.
For example:
- kzalloc(sizeof(struct dgnc_board), GFP_KERNEL);
+ kzalloc(sizeof(brd), GFP_KERNEL);
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/
This patch renames the struct board_t to dgnc_board. board_t
wasn't a good name for it since the _t suffix is for typedefs.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/dgnc_cls.c| 14 +--
drivers/staging/dgnc/dgnc_driver.c | 20 +++
drivers/staging/dgnc/dgnc_driv
replaced the printk debug lines with respective netdev_warn()/netdev_err()
Signed-off-by: Avinash kumar
---
drivers/staging/wlan-ng/hfa384x_usb.c | 90 -
1 file changed, 45 insertions(+), 45 deletions(-)
diff --git a/drivers/staging/wlan-ng/hfa384x_usb.c
b/dri
replaced printk functions used for debug messages by respective netdev_warn
netdev_err functions.
Signed-off-by: Avinash Kumar
---
drivers/staging/wlan-ng/cfg80211.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/wlan-ng/cfg80211.c
b/drivers/staging
Calling handle_pending_slot_free() for every RW operation may
cause unneccessary slot_free_lock locking, because most likely
process will see NULL slot_free_rq. handle_pending_slot_free()
only when current detects that slot_free_rq is not NULL.
v2: protect handle_pending_slot_free() with zram rw_l
`zram->init_done' in fact mimics `zram->meta != NULL' value. Introduce
init_done() function that checks zram->meta (iow, checks if initialisation
was performed), so `zram->init_done' can be removed.
v2: introduce init_done()
Signed-off-by: Sergey Senozhatsky
---
drivers/staging/zram/zram_drv.
On (09/06/13 16:50), Jerome Marchand wrote:
> On 09/06/2013 03:52 PM, Sergey Senozhatsky wrote:
> > `zram->init_done != 0' equals to `zram->meta != NULL', so init_done
> > can be removed.
>
> The name init_done is self explanatory, meta isn't. You could for
> instance write a function with an expl
On (09/06/13 16:42), Jerome Marchand wrote:
> On 09/06/2013 03:47 PM, Sergey Senozhatsky wrote:
> > Calling handle_pending_slot_free() for every RW operation may
> > cause unneccessary slot_free_lock locking, because most likely
> > process will see NULL slot_free_rq. handle_pending_slot_free()
> >
On Fri, Sep 6, 2013 at 4:42 PM, Larry Finger wrote:
> On 09/06/2013 07:45 AM, Geert Uytterhoeven wrote:
>> drivers/staging/rtl8188eu/core/rtw_wlan_util.c: In function
>> ‘WMMOnAssocRsp’:
>> drivers/staging/rtl8188eu/core/rtw_wlan_util.c:634: warning: ‘change_inx’
>> may be used uninitialized in th
On 09/06/2013 03:52 PM, Sergey Senozhatsky wrote:
> `zram->init_done != 0' equals to `zram->meta != NULL', so init_done
> can be removed.
The name init_done is self explanatory, meta isn't. You could for
instance write a function with an explicit name to test for
initialization.
Jerome
>
> Sign
On 09/06/2013 07:45 AM, Geert Uytterhoeven wrote:
drivers/staging/rtl8188eu/core/rtw_wlan_util.c: In function ‘WMMOnAssocRsp’:
drivers/staging/rtl8188eu/core/rtw_wlan_util.c:634: warning: ‘change_inx’ may
be used uninitialized in this function
And the compiler is right: change_inx should be ini
On 09/06/2013 03:47 PM, Sergey Senozhatsky wrote:
> Calling handle_pending_slot_free() for every RW operation may
> cause unneccessary slot_free_lock locking, because most likely
> process will see NULL slot_free_rq. handle_pending_slot_free()
> only when current detects that slot_free_rq is not NU
I'm not familiar with the zram code, but looking through the code and
init_done flag it's obvious what is going on rather then looking at
zram->meta field checks.
On 9/6/13, Sergey Senozhatsky wrote:
> `zram->init_done != 0' equals to `zram->meta != NULL', so init_done
> can be removed.
>
> Signe
`zram->init_done != 0' equals to `zram->meta != NULL', so init_done
can be removed.
Signed-off-by: Sergey Senozhatsky
---
drivers/staging/zram/zram_drv.c | 18 +++---
drivers/staging/zram/zram_drv.h | 1 -
2 files changed, 7 insertions(+), 12 deletions(-)
diff --git a/drivers/sta
Calling handle_pending_slot_free() for every RW operation may
cause unneccessary slot_free_lock locking, because most likely
process will see NULL slot_free_rq. handle_pending_slot_free()
only when current detects that slot_free_rq is not NULL.
Signed-off-by: Sergey Senozhatsky
---
drivers/sta
Dear Jürgen Beisert,
> On Friday 06 September 2013 14:26:11 Dan Carpenter wrote:
> > On Fri, Sep 06, 2013 at 12:08:42PM +0200, Juergen Beisert wrote:
> > > +static int mxs_lradc_read_ts_channel(struct mxs_lradc *lradc)
> > > +{
> > > + u32 reg;
> > > + int val;
> > > +
> > > + reg = readl(lradc->b
drivers/staging/rtl8188eu/core/rtw_wlan_util.c: In function ‘WMMOnAssocRsp’:
drivers/staging/rtl8188eu/core/rtw_wlan_util.c:634: warning: ‘change_inx’ may
be used uninitialized in this function
And the compiler is right: change_inx should be initialized to false.
Signed-off-by: Geert Uytterhoeve
On Friday 06 September 2013 14:26:11 Dan Carpenter wrote:
> On Fri, Sep 06, 2013 at 12:08:42PM +0200, Juergen Beisert wrote:
> > +static int mxs_lradc_read_ts_channel(struct mxs_lradc *lradc)
> > +{
> > + u32 reg;
> > + int val;
> > +
> > + reg = readl(lradc->base + LRADC_CTRL1);
> > +
> > +
On Fri, Sep 06, 2013 at 12:08:42PM +0200, Juergen Beisert wrote:
> +static int mxs_lradc_read_ts_channel(struct mxs_lradc *lradc)
> +{
> + u32 reg;
> + int val;
> +
> + reg = readl(lradc->base + LRADC_CTRL1);
> +
> + /* only channels 3 to 5 are of interest here */
> + if (reg &
Signed-off-by: Juergen Beisert
CC: linux-arm-ker...@lists.infradead.org
CC: de...@driverdev.osuosl.org
CC: Marek Vasut
CC: Fabio Estevam
CC: Jonathan Cameron
---
drivers/staging/iio/adc/mxs-lradc.c | 165
1 file changed, 165 deletions(-)
diff --git a/drive
For battery driven systems it is a very bad idea to collect the touchscreen
data within a kernel busy loop.
This change uses the features of the hardware to delay and accumulate samples in
hardware to avoid a high interrupt and CPU load.
Note: this is only tested on a i.MX23 SoC yet.
Signed-off-
In order to support i.MX23 and i.MX28 within one driver we need to separate the
register definitions which differ in both SoC variants.
Signed-off-by: Juergen Beisert
CC: linux-arm-ker...@lists.infradead.org
CC: de...@driverdev.osuosl.org
CC: Marek Vasut
CC: Fabio Estevam
CC: Jonathan Cameron
The LRADC units in i.MX23 and i.MX28 differ and we need to distinguish both
SoC variants in order to make the touchscreen work on i.MX23
Signed-off-by: Juergen Beisert
CC: linux-arm-ker...@lists.infradead.org
CC: de...@driverdev.osuosl.org
CC: Marek Vasut
CC: Fabio Estevam
CC: Jonathan Cameron
Distinguish i.MX23 and i.MX28 at runtime and do the same for both SoC at least
for the 4 wire touchscreen.
Signed-off-by: Juergen Beisert
CC: linux-arm-ker...@lists.infradead.org
CC: de...@driverdev.osuosl.org
CC: Marek Vasut
CC: Fabio Estevam
CC: Jonathan Cameron
---
drivers/staging/iio/adc/
The following series replaces the current busy loop touchscreen implementation
for i.MX28/i.MX23 SoCs by a fully interrupt driven implementation.
Since i.MX23 and i.Mx28 silicon differs, the existing implementation can
be used for the i.MX28 SoC only.
So, the first two patches of this series move
On Thu, Sep 05, 2013 at 05:15:02PM -0300, Fabio Estevam wrote:
> Looks good, just one minor suggestion:
>
> On Thu, Sep 5, 2013 at 3:16 PM, Dan Carpenter
> wrote:
> > +static void lradc_reg_set(struct mxs_lradc *lradc, u32 val, size_t chan)
> > +{
> > + writel(val, lradc->base + chan + STM
On Fri, Sep 06, 2013 at 09:01:01AM +0200, Jürgen Beisert wrote:
>
> Oh, I did the same yesterday in preparation of the v2 of my patch series.
> I will send this new version out today.
>
Ah fine. Then let's drop my version.
regards,
dan carpenter
___
Hi Dan,
On Thursday 05 September 2013 20:16:39 Dan Carpenter wrote:
> I have introduced lradc_reg_set() and lradc_reg_clear(). It simplifies
> the callers and makes the lines shorter.
>
> Signed-off-by: Dan Carpenter
>
> diff --git a/drivers/staging/iio/adc/mxs-lradc.c
> b/drivers/staging/iio/ad
35 matches
Mail list logo