On (08/23/13 09:48), Greg KH wrote:
> Subject: Re: [PATCH] LMK: Optimize lowmem_shrink
> User-Agent: Mutt/1.5.21 (2010-09-15)
>
> On Wed, Aug 21, 2013 at 09:41:05AM +0800, Leon Ma wrote:
> > From: Leon Ma
> > Date: Mon, 19 Aug 2013 14:22:38 +0800
> > Subject: [PATCH] LMK: Optimize lowmem_shrink.
On Wed, Aug 21, 2013 at 09:48:38PM -0400, Lidza Louina wrote:
> -static int dgap_tty_ioctl(struct tty_struct *tty, struct file *file,
> unsigned int cmd,
> +static int dgap_tty_ioctl(struct tty_struct *tty, unsigned int cmd,
> unsigned long arg)
Btw, now that this file compiles I se
Increase interrupt end point buffer size & convert hard coded
value to macro for better readability.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/oz
We have icreased interrupt end point buffer size to 512 bytes,
Change variable data type to accomodate it.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/o
Max. TX frame size supported is changed to 760 bytes.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozproto.h |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ozwpan/ozproto.h b/drivers/staging/ozwpan/ozproto.h
index e532347..0c49c8a 100644
--- a/d
Make sure that we return negative value if oz_build_frame()
returns NULL.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozpd.c |8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ozwpan/ozpd.c b/drivers/staging/ozwpan/ozpd.c
index daaff2a..e17
Use macro instead of hard coded value for readability.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/ozhcd.c
index 83ed64c..89e498b 100644
--- a/driv
Check for valid config number before completing set interface.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/ozhcd.c
index ab93b74..83ed64c 100644
---
On Fri, Aug 23, 2013 at 05:46:48PM +0200, Geert Uytterhoeven wrote:
> On 32-bit m68k, I get lots of warnings like:
>
> warning: integer constant is too large for ‘long’ type
>
> Switch the L*_POISON definitions from too-large constants and casts
> to the proper constant types to fix this.
>
Bonjour,
Nous sommes une agence de publicité spécialisée dans le marketing
direct. Nous réalisons régulièrement des sites internet. Nous
recherchons actuellement deux types de prestataires :
D’une part un WEBDESIGNER. Attention, il nous faut une personne ayant
d’authentiques connaissances en ergo
On Fri, Aug 23, 2013 at 02:23:49PM +0200, Geert Uytterhoeven wrote:
> m68k/sparc64 allmodconfig:
>
> drivers/staging/dgnc/dgnc_driver.c: In function ‘dgnc_cleanup_board’:
> drivers/staging/dgnc/dgnc_driver.c:459: error: implicit declaration of
> function ‘kfree’
> drivers/staging/dgnc/dgnc_driver
On Wed, Aug 21, 2013 at 09:41:05AM +0800, Leon Ma wrote:
> From: Leon Ma
> Date: Mon, 19 Aug 2013 14:22:38 +0800
> Subject: [PATCH] LMK: Optimize lowmem_shrink.
Why is all of this in the patch body?
And what does "LMK:" stand for?
> By comparing with selected_oom_score_adj instead of min_score_
On 32-bit m68k, I get lots of warnings like:
warning: integer constant is too large for ‘long’ type
Switch the L*_POISON definitions from too-large constants and casts
to the proper constant types to fix this.
Signed-off-by: Geert Uytterhoeven
---
The values in drivers/staging/lustre/lustre
On Thu, Jul 25, 2013 at 7:50 PM, Dave Kleikamp wrote:
> Change the direct_IO aop to take an iov_iter argument rather than an iovec.
> This will get passed down through most filesystems so that only the
> __blockdev_direct_IO helper need be aware of whether user or kernel memory
> is being passed t
As we are initialising structure, we do not require
memset().
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozpd.c |1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/ozwpan/ozpd.c b/drivers/staging/ozwpan/ozpd.c
index 06004c8..5d24af3 100644
--- a/drivers/staging/ozw
schedule_work() returns true if succeeded & false on failure,
error check was doing exactly reverse.
Also removes extra variable.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozpd.c |6 +-
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/drivers/staging/ozwpan/ozpd
On Friday, August 23, 2013 6:45 AM, Ian Abbott wrote:
> If a DIO subdevice has more than 32 channels, its 'insn_bits' handler is
> supposed to take account of the base channel from
> `CR_CHAN(insn->chanspec)`. (The comedi core will adjust the base
> channel to 0 and shift the mask and data to comp
Correct spelling typo in staging/bcm
Signed-off-by: Masanari Iida
---
drivers/staging/bcm/Ioctl.h | 2 +-
drivers/staging/bcm/Misc.c | 2 +-
drivers/staging/bcm/nvm.c | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/bcm/Ioctl.h b/drivers/staging/bcm/Ioctl
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/comedi_bond.c | 47 ++--
1 file changed, 24 insertions(+), 23 deletions(-)
diff --git a/drivers/staging/comedi/drivers/comedi_bond.c
b/drivers/staging/comedi/drivers/comedi_bond.c
index a995b0b..253a67d 100644
The "comedi_bond" driver can be used to map the DIO subdevices of some
other comedi devices into one, giant, uber DIO subdevice. However, it
has a few bugs such as memory leaks (but only if a memory allocation
fails), buffer overflow when more than 256 channels are added, not
handling `COMEDI_INSN
Reformat some comments according to CodingStyle and remove some comments
inherited from the comedi 'skel' example driver.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/comedi_bond.c | 141 ++-
1 file changed, 73 insertions(+), 68 deletions(-)
diff --git a/
`do_dev_config()` is called from the comedi 'attach' handler,
`bonding_attach()`. The device private data structure contains a
dynamically allocated array of pointers to "bonded" device structures
which grows during the `do_dev_config()` call. The length of this array
is in `devpriv->ndevs`. It
The board name for "comedi_bond" is constructed from a space-separated
list of items of the form "minor:subdevice" where "minor" is a minor
device number and "subdevice" is a subdevice number. Currently, all the
"minor" device numbers are for the "comedi_bond" device itself and the
"subdevice" num
The DIO subdevice of the "comedi_bond" device attempts to remember the
directions of DIO channels itself in the `io_bits` member of the
subdevice, but that is only large enough for the first 32 channels and
it might not be accurate anyway as changing the direction of one channel
may have affected a
Change `do_dev_config()` to return an error code on failure and 0 on
success, instead of 0 on failure and 1 on success.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/comedi_bond.c | 23 ---
1 file changed, 12 insertions(+), 11 deletions(-)
diff --git a/drivers
The `char file[]` variable in `do_dev_config()` doesn't need to be
initialized as it gets overwritten with a `snprintf()`. It just needs
to be long enough.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/comedi_bond.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --gi
`bonding_attach()` is the comedi "attach" handler for the driver. Any
non-negative return value is treated as successful, but 0 is the
preferred return value on success.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/comedi_bond.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion
If a DIO subdevice has more than 32 channels, its 'insn_bits' handler is
supposed to take account of the base channel from
`CR_CHAN(insn->chanspec)`. (The comedi core will adjust the base
channel to 0 and shift the mask and data to compensate if the subdevice
has less than or equal to 32 channels.
`do_dev_config()` currently records the comedi minor devices it has
opened by setting `devs_opened[minor]` to the pointer returned by
`comedi_open()`. This is checked to avoid opening the same minor device
twice. The pointer values in `devs_opened[]` aren't needed; we only
need to record which mi
The private data structure (`struct comedi_bond_private`) for the
overall "comedi_bond" device maps each channel individually to a pointer
to the `struct bonded_device` it belongs to via array member
`chan_id_dev_map[MAX_CHANS]`. This speeds up look-ups from channel
number to bonded device a bit, b
The `while` loop in `bonding_detach()` doesn't need to check
`devpriv->devs` each time round the loop. Move the test outside the
loop. The enclosing `if (devpriv)` can be changed to `if (devpriv &&
devpriv->devs)` as everything in this `if` statement is associated with
`devpriv->devs` anyway.
Si
The `subdev_type` member of `struct bonded_device` is set but not used.
Remove it.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/comedi_bond.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/comedi/drivers/comedi_bond.c
b/drivers/staging/comedi/drivers/comedi
The comedi core will free `dev->private` if it is non-NULL after calling
the "detach" handler (`bonding_detach()`), so don't bother freeing it in
`bonding_detach()`.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/comedi_bond.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/dr
Omit the fanciful prose from the MODULE_DESCRIPTION() line and combine
concantenated string literals.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi/drivers/comedi_bond.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/staging/comedi/drivers/comedi_bond.c
b/
Correct spelling typo in comments within staging/gdm724x
Signed-off-by: Masanari Iida
---
drivers/staging/gdm724x/gdm_lte.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/gdm724x/gdm_lte.c
b/drivers/staging/gdm724x/gdm_lte.c
index 7165d3a..bc0d510 100644
On Fri, Aug 23, 2013 at 06:24:02PM +0530, navin patidar wrote:
> struct pt_regs pointer is no longer passed as a irq handler
> argument.
>
> v2:
> remove rtl8180_interrupt cast to (void *) .
>
> Signed-off-by: navin patidar
Great. Thanks.
regards,
dan carpenter
__
struct pt_regs pointer is no longer passed as a irq handler
argument.
v2:
remove rtl8180_interrupt cast to (void *) .
Signed-off-by: navin patidar
---
drivers/staging/rtl8187se/r8180_core.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8187se/r8
On Fri, Aug 23, 2013 at 4:47 AM, Dan Carpenter wrote:
> On Wed, Aug 21, 2013 at 09:48:38PM -0400, Lidza Louina wrote:
>> The declaration for the ioctl function has changed. The previous version
>> of this declaration took struct file *file as a parameter and the new
>> one does not. This patch rem
On Fri, Aug 23, 2013 at 4:40 AM, Dan Carpenter wrote:
> On Wed, Aug 21, 2013 at 01:27:15PM -0400, Lidza Louina wrote:
>> This patch fixes the error: "foo* bar" should be "foo *bar".
>>
>
> I have a nit pick about this changelog. It's not something to
> resend over, of course, but for future patch
m68k/sparc64 allmodconfig:
drivers/staging/dgnc/dgnc_driver.c: In function ‘dgnc_cleanup_board’:
drivers/staging/dgnc/dgnc_driver.c:459: error: implicit declaration of function
‘kfree’
drivers/staging/dgnc/dgnc_driver.c: In function ‘dgnc_driver_kzmalloc’:
drivers/staging/dgnc/dgnc_driver.c:905:
On August 23, 2013 at 5:18 PM Dan Carpenter wrote:
> On Fri, Aug 23, 2013 at 05:00:06PM +0530, navin patidar wrote:
> > struct pt_regs pointer is no longer passed as a irq handler
> > argument.
> >
>
> Good eye.
>
> Could you also remove the cast to (void *) so the compiler can catch
> this in the
On Fri, Aug 23, 2013 at 02:06:21PM +0200, Bjørn Mork wrote:
> Dan Carpenter writes:
>
> > Ah... Here is the first patch which adds eth_hw_addr_inherit()
> >
> > http://patchwork.ozlabs.org/patch/269365/
> >
> > I don't think we've actually set dst->addr_len yet at this point so
> > it doesn't do
Dan Carpenter writes:
> Ah... Here is the first patch which adds eth_hw_addr_inherit()
>
> http://patchwork.ozlabs.org/patch/269365/
>
> I don't think we've actually set dst->addr_len yet at this point so
> it doesn't do the memcpy(). This doesn't work.
Ouch. Yes, I see. The net_device is all
On Fri, Aug 23, 2013 at 05:00:06PM +0530, navin patidar wrote:
> struct pt_regs pointer is no longer passed as a irq handler
> argument.
>
Good eye.
Could you also remove the cast to (void *) so the compiler can catch
this in the future?
- if (request_irq(dev->irq, (void *)rtl8180_interru
Sehr geehrter Herr.
Entschuldigen Sie meine Stцrung; Mein Name ist Lieutenant Andrew Ferrara,
derzeit bin ich im aktiven Dienst in Afghanistan. Bitte, muss ich eine verdeckt
Business-Angebot, die von gegenseitigem Nutzen fьr uns beide werden.
Am Samstag 20. Juli, meine Kollegen und ich abgefang
Commit dcd7b8bd63cb81c5b973bf86510ca3c80bbbd162 ("staging: comedi: put
module _after_ detach" by myself) reversed a couple of calls in
`comedi_device_attach()` when recovering from an error returned by the
low-level driver's 'attach' handler. Unfortunately, that introduced a
NULL pointer dereferen
struct pt_regs pointer is no longer passed as a irq handler
argument.
Signed-off-by: navin patidar
---
drivers/staging/rtl8187se/r8180_core.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8187se/r8180_core.c
b/drivers/staging/rtl8187se/r8180_core.
On 23/08/13 10:05, Dan Carpenter wrote:
On Thu, Aug 22, 2013 at 05:38:51PM +0100, Rupesh Gujare wrote:
+/*--
* Context: softirq-serialized
*/
Don't resend the patch, but these comments are not in kernel style.
It'
Ah... Here is the first patch which adds eth_hw_addr_inherit()
http://patchwork.ozlabs.org/patch/269365/
I don't think we've actually set dst->addr_len yet at this point so
it doesn't do the memcpy(). This doesn't work.
regards,
dan carpenter
___
de
Dan Carpenter writes:
> On Fri, Aug 23, 2013 at 11:35:13AM +0200, Bjørn Mork wrote:
>> Cc: Forest Bond
>> Signed-off-by: Bjørn Mork
>> ---
>
> The changlog is missing.
Yes, right. Sorry about that.
> Why does this patch help?
It ensures that addr_assign_type is set to the same value as the
On 22/08/13 18:45, Sergei Shtylyov wrote:
+void oz_pd_destroy(struct oz_pd *pd)
+{
+int ret;
+
+if (hrtimer_active(&pd->timeout))
+hrtimer_cancel(&pd->timeout);
+if (hrtimer_active(&pd->heartbeat))
+hrtimer_cancel(&pd->heartbeat);
+
+memset(&pd->workitem, 0, sizeof
On Fri, Aug 23, 2013 at 11:35:13AM +0200, Bjørn Mork wrote:
> Cc: Forest Bond
> Signed-off-by: Bjørn Mork
> ---
The changlog is missing. Why does this patch help?
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driv
Copying the dev_addr from a parent device is an operation
common to a number of drivers. The addr_assign_type should
be updated accordingly, either by reusing the value from
the source device or explicitly indicating that the address
is stolen by setting addr_assign_type to NET_ADDR_STOLEN.
This p
Cc: Forest Bond
Signed-off-by: Bjørn Mork
---
drivers/staging/vt6655/hostap.c |2 +-
drivers/staging/vt6655/ioctl.c |2 +-
drivers/staging/vt6655/wpactl.c |2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/vt6655/hostap.c b/drivers/staging/vt6655/h
Cc: Forest Bond
Signed-off-by: Bjørn Mork
---
drivers/staging/vt6656/hostap.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/vt6656/hostap.c b/drivers/staging/vt6656/hostap.c
index c699a30..3ddef9d 100644
--- a/drivers/staging/vt6656/hostap.c
+++ b/drivers
On Thu, Aug 22, 2013 at 05:38:51PM +0100, Rupesh Gujare wrote:
> +/*--
> * Context: softirq-serialized
> */
Don't resend the patch, but these comments are not in kernel style.
It's explained in Documentation/kernel-doc
On Thu, Aug 22, 2013 at 06:00:14PM +0200, Wolfram Sang wrote:
> I2C of helpers used to live in of_i2c.c but experience (from SPI) shows
> that it is much cleaner to have this in the core. This also removes a
> circular dependency between the helpers and the core, and so we can
> finally register ch
On Wed, Aug 21, 2013 at 09:48:38PM -0400, Lidza Louina wrote:
> The declaration for the ioctl function has changed. The previous version
> of this declaration took struct file *file as a parameter and the new
> one does not. This patch removes that parameter.
>
> It also removes cases for the comm
On Wed, Aug 21, 2013 at 01:27:15PM -0400, Lidza Louina wrote:
> This patch fixes the error: "foo* bar" should be "foo *bar".
>
I have a nit pick about this changelog. It's not something to
resend over, of course, but for future patches. The word "fix"
should only be used for bugfixes. The word
59 matches
Mail list logo