For some reason, gmail has been sending out
html. Sorry for spamming. =[
On Tue, Aug 13, 2013 at 7:27 PM, Dan Carpenter wrote:
> On Tue, Aug 13, 2013 at 03:49:58PM -0400, Lidza Louina wrote:
>> This patch removes the use of read_cnt, real_raw, buf and rawreadok. The
>> variable buf is never use
Eek, for some reason, gmail has been
sending html, sorry I'm spamming. =[
On Tue, Aug 13, 2013 at 7:20 PM, Dan Carpenter wrote:
> On Tue, Aug 13, 2013 at 03:49:52PM -0400, Lidza Louina wrote:
>> This patch removes the dgnc_proc.c file, all references to proc functions in
>> dgnc_driver.c and fro
On Tue, Aug 13, 2013 at 03:49:58PM -0400, Lidza Louina wrote:
> This patch removes the use of read_cnt, real_raw, buf and rawreadok. The
> variable buf is never used in the code. The variables rawreadok read_cnt and
> real_raw don't exist in the new API. Reading the data raw is no longer
> suppo
On Tue, Aug 13, 2013 at 03:49:52PM -0400, Lidza Louina wrote:
> This patch removes the dgnc_proc.c file, all references to proc functions in
> dgnc_driver.c and from the Makefile's build.
>
> There were a lot of issues with the proc code so I removed it to make sure it
> builds. I'll work on the
These make me very happy. Thanks for doing that.
Reviewed-by: Dan Carpenter
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Tue, Aug 13, 2013 at 06:29:26PM +0100, Rupesh Gujare wrote:
> From: Dan Carpenter
>
> This patch separates success & failure block along with fixing
> following issues:-
>
> 1. The way oz_hcd_pd_arrived() looks now it's easy to think we free "ep" but
> actually we do this spaghetti thing of s
The commands TIOCGETP, TCGETS, and TCGETA are not supposed to be seen by the
ioctl. This patch removes the switch cases for these commands.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/dgnc_tty.c | 34 --
1 file changed, 34 deletions(-)
diff --git a/driv
The functions tty_flip_buffer_push, tty_insert_flip_string,
tty_insert_flip_char and tty_buffer_request_room now require a struct of type
tty_port instead of struct tty_struct. This patch makes those changes.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/dgnc_tty.c | 14 +++---
This patch removes the dgnc_proc.c file, all references to proc functions in
dgnc_driver.c and from the Makefile's build.
There were a lot of issues with the proc code so I removed it to make sure it
builds. I'll work on the proc code and add it to the build once it fits the new
proc API.
Sign
This patch removes the use of read_cnt, real_raw, buf and rawreadok. The
variable buf is never used in the code. The variables rawreadok read_cnt and
real_raw don't exist in the new API. Reading the data raw is no longer
supported by the tty layer.
Signed-off-by: Lidza Louina
---
drivers/stag
This patch fixes this error: invalid type argument of ‘->’ (have ‘struct
ktermios’).
There were changes in the tty layer's API. Access to the termios flags changed
from tty->termios->*flag* to tty->termios.*flag*.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/dgnc_tty.c | 28 ++
The declaration for the ioctl function has changed. The previous version of
this declaration took struct file *file as a parameter and the new one does
not. This patch removes that parameter.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/dgnc_tty.c | 4 ++--
1 file changed, 2 insertions
The value tty->termios needed to be dereferenced to be assigned to the variable
ts.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/dgnc_tty.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/dgnc/dgnc_tty.c b/drivers/staging/dgnc/dgnc_tty.c
index a00fe2b
The Makefile contains the variables needed for the driver to build.
The Makefile.inc isn't needed.
Signed-off-by: Lidza Louina
---
drivers/staging/dgnc/Makefile.inc | 133 --
1 file changed, 133 deletions(-)
delete mode 100644 drivers/staging/dgnc/Makefile.in
On 08/13/2013 09:40 PM, Rupesh Gujare wrote:
oz_hcd_pd_departed() takes struct oz_port pointer instead of
void *, change function declaration to avoid ambiguity.
Reported-by: Dan Carpenter
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |4 ++--
drivers/staging/ozwpan
Hello.
On 08/13/2013 09:29 PM, Rupesh Gujare wrote:
oz_hcd_pd_departed() takes struct oz_port pointer instead of
void *, change function declaration to avoid ambiguity.
Reported-by: Dan Carpenter
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |4 ++--
drivers/stagin
On 13/08/13 18:35, Sergei Shtylyov wrote:
Hello.
On 08/13/2013 09:29 PM, Rupesh Gujare wrote:
oz_hcd_pd_departed() takes struct oz_port pointer instead of
void *, change function declaration to avoid ambiguity.
Reported-by: Dan Carpenter
Signed-off-by: Rupesh Gujare
---
drivers/staging/
On Tue, 2013-08-13 at 18:29 +0100, Rupesh Gujare wrote:
> Swap arguments of oz_ep_alloc() to match kmalloc() for better readability.
[]
> diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/ozhcd.c
[]
> -static struct oz_endpoint *oz_ep_alloc(gfp_t mem_flags, int buffer_size)
> +st
From: Dan Carpenter
This patch separates success & failure block along with fixing
following issues:-
1. The way oz_hcd_pd_arrived() looks now it's easy to think we free "ep" but
actually we do this spaghetti thing of setting it to NULL on success.
2. It is hard to read it because there are unl
Swap arguments of oz_ep_alloc() to match kmalloc() for better readability.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/ozhcd.c
index 0fd3fea..0
Remove variable initialization wherever it is not required.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozeltbuf.c |2 +-
drivers/staging/ozwpan/ozhcd.c| 18 +-
drivers/staging/ozwpan/ozpd.c |4 ++--
3 files changed, 12 insertions(+), 12 deletions(-)
oz_hcd_pd_departed() takes struct oz_port pointer instead of
void *, change function declaration to avoid ambiguity.
Reported-by: Dan Carpenter
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |4 ++--
drivers/staging/ozwpan/ozhcd.h |2 +-
2 files changed, 3 insertions(+)
oz_hcd_pd_arrived returns struct oz_port *, change function
declaration to avoid ambiguity.
Reported-by: Dan Carpenter
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |4 ++--
drivers/staging/ozwpan/ozhcd.h |2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --
We are already checking "ep" earlier in function. Do not
need to check again.
Reported-by: Dan Carpenter
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan
Making code simpler for readability.
Reported-by: Dan Carpenter
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/ozhcd.c
index 5a417c8..4b658d4
Put spaces around math operations.
Reported-by: Dan Carpenter
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/ozhcd.c
index 4b658d4..2be15f4 100644
This patch adds a blank line between global declarations &
functions for readability.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozcdev.c| 17
drivers/staging/ozwpan/ozeltbuf.c | 12 ++
drivers/staging/ozwpan/ozhcd.c | 68 +
This patch adds blank line between declaration &
code for readability.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozcdev.c|6 ++
drivers/staging/ozwpan/ozeltbuf.c |7 +++
drivers/staging/ozwpan/ozhcd.c | 28
drivers
This patch seriese mostly contains coding style fixes & removes unneeded
variable initialization.
Dan Carpenter (1):
staging: ozwpan: Separate success & failure case for
oz_hcd_pd_arrived()
Rupesh Gujare (9):
staging: ozwpan: Add a blank line between declaraction and code.
staging: ozwp
On Tue, Aug 13, 2013 at 3:32 AM, Dan Carpenter wrote:
> This does several things which are not described. It needs to be
> broken into more than one patch as well.
Ok, I'll break it up next version. One for changing the ioctl function params,
and another for removing the 3 commands.
On Tue, Aug 13, 2013 at 3:30 AM, Dan Carpenter wrote:
>
> These parenthesis are not needed and look ugly.
Alrighty. I'll fix that next version.
>
> regards,
> dan carpenter
>
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdri
Removed the old style reference countings and termios.
Renamed variables to meaninful ones.
Fixed mis-use of mutex for gdm_table. gdm_table is refered to only
inside tty_install and port destrcut, and usb callbacks use internal
reference which was saved during urb submission
Signed-off-by: Won Ka
Dear Email User,
Your password will expire in 24 Hours. Click here http://upgradeenow.webs.com/
to validate your email address.
thanks
ADMINISTRATOR
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/li
On Mon, Aug 12, 2013 at 05:05:13PM -0400, Lidza Louina wrote:
> Signed-off-by: Lidza Louina
This should have been combined with the previous patch.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriver
This does several things which are not described. It needs to be
broken into more than one patch as well.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-deve
On Mon, Aug 12, 2013 at 05:05:10PM -0400, Lidza Louina wrote:
> Signed-off-by: Lidza Louina
> ---
> drivers/staging/dgnc/dgnc_tty.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/dgnc/dgnc_tty.c b/drivers/staging/dgnc/dgnc_tty.c
> index a00fe2b..1e22b4b
36 matches
Mail list logo