Convert the drivers with complex, port programmable i/o, to use the
comedi_dio_insn_config() helper function.
All of these drivers have some sort of 'port' programmable i/o where multiple
i/o channels are configured as a group. The 'mask' associated with the group
is passed to comedi_dio_insn_conf
DIO subdevices always handle the INSN_CONFIG_DIO_{INPUT,OUTPUT} instructions
to configure the dio channels. They also always handle the INSN_CONFIG_DIO_QUERY
instruction to query the configuration of a dio channel.
Introduce a helper function to handle the (*insn_config) boilerplate for
comedi DIO
Convert this driver to use the comedi_dio_insn_config() helper function.
Tidy up the comments to reflect the new code.
Signed-off-by: H Hartley Sweeten
Cc: Ian Abbott
Cc: Greg Kroah-Hartman
---
drivers/staging/comedi/drivers/skel.c | 42 ---
1 file changed, 19
Convert the drivers with simple, per channel programmable i/o, to use the
comedi_dio_insn_config() helper function.
All of these pass a 'mask' of '0' to comedi_dio_insn_config() this causes
the per channel mask to be used to configure the i/o direction.
Signed-off-by: H Hartley Sweeten
Cc: Ian A
All the comedi drivers that have DIO subdevices implement a (*insn_config)
callback. This callback always handles the INSN_CONFIG_DIO_{INPUT,OUTPUT}
istructions to configure the dio channels. They also always handle the
INSN_CONFIG_DIO_QUERY instruction to query the configuration of a dio channel.
Here is what oz_hcd_pd_arrived() looks like after my changes:
These lines:
- if (ozhcd == NULL)
+ if (!ozhcd)
were personal preference and not official kernel style guidelines.
Either way is fine for pointers.
oz_ep_alloc() can return NULL. There was no check for failure in
the origi
On Mon, Aug 05, 2013 at 07:43:16PM +0100, Rupesh Gujare wrote:
> On 05/08/13 18:53, Dan Carpenter wrote:
> >On Mon, Aug 05, 2013 at 06:40:13PM +0100, Rupesh Gujare wrote:
> >>This patch fixes crash issue when there is quick cycle of
> >>de-enumeration & enumeration due to loss of wireless link.
> >
Hi folks,
I'm working on an issue of HyperV synthetic frame buffer driver, which seems to
have
a conflict with the generic vga driver (not the vesa driver). I hope to read
and trace into
the source code for the generic vga driver...
Can anyone point me to the source code file for the generic v
On Mon, Aug 05, 2013 at 08:00:59PM +0100, Rupesh Gujare wrote:
> Ok. I will rework on style nits.
Do it in a follow on patch. It's fine.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org
Web de administración de notificación de e-mail
Este mensaje es del centro de mensajes de administración para toda nuestra
cuenta
de correo electrónico owners.We está eliminando el acceso a todos nuestros
clientes
de correo web. Su correo electrónico cuenta se actualizará a una interfaz de
On 05/08/13 19:56, Dan Carpenter wrote:
On Mon, Aug 05, 2013 at 06:40:15PM +0100, Rupesh Gujare wrote:
Fix a bug where we were not returning correct hub status
for 8th port.
What are the user visible effects of this bug?
8 th port is never assigned to new device & we loose one port.
Style n
On 05/08/13 19:21, Dan Carpenter wrote:
On Mon, Aug 05, 2013 at 06:40:14PM +0100, Rupesh Gujare wrote:
Make sure that we reset port configuration no. when PD departs.
What happens if we don't do this? What is the user visible effect
of this patch?
There is no user visible effect at the mo
On Mon, Aug 05, 2013 at 06:40:15PM +0100, Rupesh Gujare wrote:
> Fix a bug where we were not returning correct hub status
> for 8th port.
What are the user visible effects of this bug?
Style nits below.
>
> Signed-off-by: Rupesh Gujare
> ---
> drivers/staging/ozwpan/ozhcd.c | 11 +--
On 05/08/13 18:53, Dan Carpenter wrote:
On Mon, Aug 05, 2013 at 06:40:13PM +0100, Rupesh Gujare wrote:
This patch fixes crash issue when there is quick cycle of
de-enumeration & enumeration due to loss of wireless link.
It is found that sometimes new device (or coming back device)
returns very
On Mon, Aug 05, 2013 at 06:40:14PM +0100, Rupesh Gujare wrote:
> Make sure that we reset port configuration no. when PD departs.
>
What happens if we don't do this? What is the user visible effect
of this patch?
regards,
dan carpenter
___
devel maili
On Mon, Aug 05, 2013 at 06:40:12PM +0100, Rupesh Gujare wrote:
> This patch fixes kernel crash issue, when we receive URB request
> after de-enumerating device.
>
In other words we were getting a NULL dereference dereferencing
"ep". There is an existing check already, which should be cleaned
up.
On Mon, Aug 05, 2013 at 06:40:13PM +0100, Rupesh Gujare wrote:
> This patch fixes crash issue when there is quick cycle of
> de-enumeration & enumeration due to loss of wireless link.
>
> It is found that sometimes new device (or coming back device)
> returns very fast, even before USB core read o
This patch fixes crash issue when there is quick cycle of
de-enumeration & enumeration due to loss of wireless link.
It is found that sometimes new device (or coming back device)
returns very fast, even before USB core read out hub status,
resulting in allocation of same port, which results in uns
This patch series fixes crash issues observed,
& fix a bug in hub status code.
Rupesh Gujare (4):
staging: ozwpan: Fixes crash due to invalid port aceess.
staging: ozwpan: Increment port number for new device.
staging: ozwpan: Reset port configuration number.
staging: ozwpan: Return correc
Make sure that we reset port configuration no. when PD departs.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/ozhcd.c
index a739986..b060e43 100644
--- a/drivers/stagi
This patch fixes kernel crash issue, when we receive URB request
after de-enumerating device.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c |9 +++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/oz
Fix a bug where we were not returning correct hub status
for 8th port.
Signed-off-by: Rupesh Gujare
---
drivers/staging/ozwpan/ozhcd.c | 11 +--
1 file changed, 9 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/ozwpan/ozhcd.c b/drivers/staging/ozwpan/ozhcd.c
index b060e43..
On Mon, Aug 05, 2013 at 08:20:53AM -0700, H. Peter Anvin wrote:
> On 08/05/2013 07:34 AM, Konrad Rzeszutek Wilk wrote:
> >
> > Could you provide me with a git branch so I can test it overnight please?
> >
>
> Pull tip:x86/paravirt.
It works for me. Thanks.
>
> -hpa
>
>
On 08/05/2013 07:34 AM, Konrad Rzeszutek Wilk wrote:
>
> Could you provide me with a git branch so I can test it overnight please?
>
Pull tip:x86/paravirt.
-hpa
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriver
On Mon, Aug 05, 2013 at 11:38:14AM +0800, Jason Wang wrote:
> On 07/25/2013 04:54 PM, Jason Wang wrote:
> > We try to handle the hypervisor compatibility mode by detecting hypervisor
> > through a specific order. This is not robust, since hypervisors may
> > implement
> > each others features.
> >
On Sun, Aug 04, 2013 at 08:06:20PM +0800, Jeff Liu wrote:
> From: Jie Liu
>
> Free sc->sc_page when releasing a struct o2net_sock_container
> object to avoid memory leaks.
>
> This issue has been fixed by Younger Liu for OCFS2, so I sync
> that patch to zcache as we share the same network code b
This patch fix following issues reported by Dan:-
1) There is no check limiting the size to 32 and it could be up to
253 bytes.
2) Use defines instead of magic numbers.
3) The oz_farewell struct is supposed to be a variable length struct
but the variable part is put in the middle. It doesn'
This patch fixes following build warning.
drivers/built-in.o: In function `oz_hcd_heartbeat':
>> (.text+0x30aadd): undefined reference to `__divdi3'
drivers/built-in.o: In function `oz_hcd_heartbeat':
>> (.text+0x30ac85): undefined reference to `__divdi3'
Signed-off-by: Rupesh Gujare
---
dri
On 04/08/13 19:17, Anca Emanuel wrote:
Why do not use div_u64() ?
[quote]unsigned 64bit divide with 32bit divisor
This is the most common 64bit divide and should be used if possible,
as many 32bit archs can optimize this variant better than a full 64bit
divide.
[/quote]
- ep->cr
Fixed some coding style issues
Signed-off-by: Iker Pedrosa
---
drivers/staging/winbond/mds.c | 56 +--
1 file changed, 33 insertions(+), 23 deletions(-)
diff --git a/drivers/staging/winbond/mds.c b/drivers/staging/winbond/mds.c
index faa93f0..fcc3d21 1006
Fixed some coding style issues.
Signed-off-by: Iker Pedrosa
---
drivers/staging/winbond/mds_f.h | 12
1 file changed, 8 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/winbond/mds_f.h b/drivers/staging/winbond/mds_f.h
index ce8be07..ce5a78c 100644
--- a/drivers/staging/w
Deleted an extern function that wasn't used in this driver.
Signed-off-by: Iker Pedrosa
---
drivers/staging/winbond/mds_f.h | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/winbond/mds_f.h b/drivers/staging/winbond/mds_f.h
index ce5a78c..159b2eb 100644
--- a/drivers/staging/win
Prototype of a function added to the header to avoid the use of extern.
Signed-off-by: Iker Pedrosa
---
drivers/staging/winbond/phy_calibration.h | 1 +
drivers/staging/winbond/wb35reg.c | 3 +--
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/winbond/phy_c
Changed sleep function from msleep to usleep according to the documentation.
Signed-off-by: Iker Pedrosa
---
drivers/staging/winbond/wb35reg.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/winbond/wb35reg.c
b/drivers/staging/winbond/wb35reg.c
index
White space deleted before a semicolon.
Signed-off-by: Iker Pedrosa
---
drivers/staging/winbond/wb35reg.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/winbond/wb35reg.c
b/drivers/staging/winbond/wb35reg.c
index 34a2618..1314f93 100644
--- a/drivers/staging
Fixes some coding style issues from drivers/staging/winbond
Iker Pedrosa (6):
Staging: winbond: wb35reg: changed sleep function from msleep to
usleep
Staging: winbond: wb35reg: white space deleted
Staging: winbond: wb35reg: avoided use of extern function
Staging: winbond: mds: fixed so
36 matches
Mail list logo