Fix a couple of checkpatch errors and a bunch of warnings.
Signed-off-by: Tobin C Harding
---
Two occurences of (foo != NULL) changed to (!foo) even though not picked up by
checkpatch.pl
drivers/gpu/drm/gma500/cdv_intel_lvds.c | 39 +++--
1 file changed, 18
kzalloc call followed by copy_to_user can be replaced by call to memdup_user.
Signed-off-by: Tobin C Harding
---
drivers/gpu/drm/gma500/gma_display.c | 2 +-
drivers/staging/lustre/lustre/llite/dir.c | 22 +++---
2 files changed, 8 insertions(+), 16 deletions(-)
diff
kzalloc call followed by copy_to_user can be replaced by call to memdup_user.
Signed-off-by: Tobin C Harding
---
drivers/gpu/drm/gma500/gma_display.c | 2 +-
drivers/staging/lustre/lustre/llite/dir.c | 22 +++---
2 files changed, 8 insertions(+), 16 deletions(-)
diff
On Sun, Oct 01, 2017 at 03:30:38PM -0400, Jérémy Lefaure wrote:
> Hi everyone,
> Using ARRAY_SIZE improves the code readability. I used coccinelle (I
> made a change to the array_size.cocci file [1]) to find several places
> where ARRAY_SIZE could be used instead of other macros or sizeof
> divisio