On 1/6/22 18:49, Matthew Auld wrote:
Purging can happen during swapping out, or directly invoked with the
madvise ioctl. In such cases this doesn't involve a ttm move, which
skips umapping the object.
v2(Thomas):
- add ttm_truncate helper, and just call into i915_ttm_move_notify() to
handle
On 1/6/22 18:49, Matthew Auld wrote:
Ensure we call ttm_bo_unmap_virtual when releasing the pages.
Importantly this should now handle the ttm swapping case, and all other
places that already call into i915_ttm_move_notify().
v2: fix up the selftest
Fixes: cf3e3e86d779 ("drm/i915: Use ttm mmap
Reviewed-by: Vinay Simha BN
Jiri Vanek,
Could you please share the part number or datasheet of the dual-link LVDS
display/panel used.
On Fri, Jan 7, 2022 at 12:30 AM Jiri Vanek wrote:
> Fixed wrong register shift for single/dual link LVDS output.
>
> Tested-by: Jiri Vanek
> Signed-off-by: Ji
Hi Matthias,
>> I'm still not happy with the commit subject, I think it is misleading. Clang
>> only helped to find the bug, but the we are fixing something else, that's
>> not
>> just a clang warning. But I don't want to nit-pick too much so:
>>
>> Reviewed-by: Matthias Brugger
> thanks. I
The reference taken by 'of_find_device_by_node()' must be released when
not needed anymore.
Add the corresponding 'put_device()' in the error handling path.
Fixes: 9bf3797796f5 ("drm/sun4i: dw-hdmi: Make HDMI PHY into a platform device")
Signed-off-by: Miaoqian Lin
---
drivers/gpu/drm/sun4i/sun8
The reference taken by 'of_find_device_by_node()' must be released when
not needed anymore.
Add the corresponding 'put_device()' in the error handling path.
Fixes: e00012b256d4 ("drm/msm/hdmi: Make HDMI core get its PHY")
Signed-off-by: Miaoqian Lin
---
drivers/gpu/drm/msm/hdmi/hdmi.c | 7 ++
Am 06.01.22 um 17:51 schrieb Felix Kuehling:
Am 2022-01-06 um 11:48 a.m. schrieb Christian König:
Am 06.01.22 um 17:45 schrieb Felix Kuehling:
Am 2022-01-06 um 4:05 a.m. schrieb Christian König:
[SNIP]
Also, why does your ACK or NAK depend on this at all. If it's the right
thing to do, it's the
Il 06/01/22 19:14, Rob Clark ha scritto:
From: Rob Clark
System suspend uses pm_runtime_force_suspend(), which cheekily bypasses
the runpm reference counts. This doesn't actually work so well when the
GPU is active. So add a reasonable delay waiting for the GPU to become
idle.
Alternatively
Il 06/01/22 10:13, Chunfeng Yun ha scritto:
On Mon, 2022-01-03 at 15:53 +0100, AngeloGioacchino Del Regno wrote:
Use the dev_err_probe() helper to simplify error handling during
probe.
Signed-off-by: AngeloGioacchino Del Regno <
angelogioacchino.delre...@collabora.com>
---
drivers/phy/mediate
For adapting radeon rx6600 xt on arm64 platform,
there report some compile errors.
Zhenneng Li (2):
drm/amdgpu: fix compile error for dcn on arm64
drm/amdgpu: enable dcn support on arm64
drivers/gpu/drm/amd/display/Kconfig | 2 +-
drivers/gpu/drm/amd/display/dc/calcs/Makefile | 6
Signed-off-by: Zhenneng Li
---
drivers/gpu/drm/amd/display/Kconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/amd/display/Kconfig
b/drivers/gpu/drm/amd/display/Kconfig
index 127667e549c1..1c6c4cb1fd0a 100644
--- a/drivers/gpu/drm/amd/display/Kconfig
+++ b
For adapting radeon rx6600 xt on arm64,
I enabled dcn on arm64 platform, compiler
report not compatible with -mgeneral-regs-only
and -mhard-float when compiling some source file.
Signed-off-by: Zhenneng Li
---
drivers/gpu/drm/amd/display/dc/calcs/Makefile | 6 +
.../gpu/drm/amd/display/dc/c
Am 06.01.22 um 20:04 schrieb Hridya Valsaraju:
On Thu, Jan 6, 2022 at 12:59 AM Christian König
wrote:
Am 05.01.22 um 00:51 schrieb Hridya Valsaraju:
Recently, we noticed an issue where a process went into direct reclaim
while holding the kernfs rw semaphore for sysfs in write(exclusive)
mode.
On Wed, 05 Jan 2022, Kees Cook wrote:
> On Wed, Jan 05, 2022 at 08:00:50PM +0200, Jani Nikula wrote:
>> On Wed, 05 Jan 2022, Kees Cook wrote:
>> > The link_status array was not large enough to read the Adjust Request
>> > Post Cursor2 register, so remove the common helper function to avoid
>> > a
On Thu, 6 Jan 2022 at 12:47, Miaoqian Lin wrote:
>
> The pm_runtime_enable will increase power disable depth.
> If the probe fails, we should use pm_runtime_disable() to balance
> pm_runtime_enable().
>
> Fixes: 57692c9 ("drm/v3d: Introduce a new DRM driver for Broadcom V3D V3.x+")
> Signed-off-by
The vga16fb framebuffer driver supports both Enhanced Graphics Adapter
(EGA) and Video Graphics Array (VGA) 16 color graphic cards.
But the logic to check whether the EGA or VGA standard are used is not
correct. It just checks if screen_info.orig_video_isVGA is set, but it
should check if is set t
The vga16fb framebuffer driver only supports Enhanced Graphics Adapter
(EGA) and Video Graphics Array (VGA) 16 color graphic cards.
But it doesn't check if the adapter is one of those or if a VGA16 mode
is used. This means that the driver will be probed even if a VESA BIOS
Extensions (VBE) or Grap
This patch series contains two fixes for the vga16fb driver. I looked at
the driver due a regression reported [0], caused by commit d391c5827107
("drivers/firmware: move x86 Generic System Framebuffers support").
The mentioned commit didn't change any logic but just moved the platform
device regis
https://bugzilla.kernel.org/show_bug.cgi?id=215001
--- Comment #8 from Javier Martinez Canillas (jav...@dowhile0.org) ---
Hello Kris,
(In reply to Kris Karas from comment #7)
> Hi Javier - I tested the (updated) patch from comment 6 on three different
> systems, two servers with a character-graph
https://bugzilla.kernel.org/show_bug.cgi?id=215001
--- Comment #9 from The Linux kernel's regression tracker (Thorsten Leemhuis)
(regressi...@leemhuis.info) ---
(In reply to Kris Karas from comment #7)
>
> ... I filed this bug nearly 2 months ago with the "Regression = Y" metadata
> clearly set;
On Thu, 06 Jan 2022, Stephen Boyd wrote:
> This allows aggregate driver writers to use the device passed to their
> probe/remove/shutdown functions properly instead of treating it as an
> opaque pointer.
You say it like having opaque pointers with interfaces instead of
exposed data is a bad thing
This patch series introduces infrastructure for asynchronous vma
unbinding. The single enabled use-case is initially at buffer object
migration where we otherwise sync when unbinding vmas before migration.
This in theory allows us to pipeline any number of migrations, but in
practice the number is
Introduce vma resources, sort of similar to TTM resources, needed for
asynchronous bind management. Initially we will use them to hold
completion of unbinding when we capture data from a vma, but they will
be used extensively in upcoming patches for asynchronous vma unbinding.
v6:
- Some document
When introducing asynchronous unbinding, the vma itself may no longer
be alive when the actual binding or unbinding takes place.
Update the gtt i915_vma_ops accordingly to take a struct i915_vma_resource
instead of a struct i915_vma for the bind_vma() and unbind_vma() ops.
Similarly change the ins
A pin-count is already held by vma->pages so taking an additional pin
during async binds is not necessary.
When we introduce async unbinding we have other means of keeping the
object pages alive.
Signed-off-by: Thomas Hellström
Reviewed-by: Matthew Auld
---
drivers/gpu/drm/i915/i915_vma.c | 5
Implement async (non-blocking) unbinding by not syncing the vma before
calling unbind on the vma_resource.
Add the resulting unbind fence to the object's dma_resv from where it is
picked up by the ttm migration code.
Ideally these unbind fences should be coalesced with the migration blit
fence to a
Add a selftest to exercise asynchronous migration and -unbining.
Extend the gem_migrate selftest to perform the migrations while
depending on a spinner and a bound vma set up on the migrated
buffer object.
Signed-off-by: Thomas Hellström
---
drivers/gpu/drm/i915/gem/i915_gem_object.c| 12 ++
There is always a struct vma_resource guaranteed to be alive when we
access a corresponding struct vma_snapshot.
So ditch the latter and instead of allocating vma_snapshots, reference
the already existning vma_resource.
This requires a couple of extra members in struct vma_resource but that's
a s
The Amlogic G12A, G12B & SM1 SoCs embeds a Synopsys DW-MIPI-DSI transceiver
(ver 1.21a),
with a custom glue managing the IP resets, clock and data input similar to the
DW-HDMI
glue on the same Amlogic SoCs.
This adds support for the glue managing the transceiver, mimicing the init flow
provided
The Amlogic G12A, G12B & SM1 SoCs embeds a Synopsys DW-MIPI-DSI transceiver
(ver 1.21a),
with a custom glue managing the IP resets, clock and data input similar to the
DW-HDMI Glue
on the same Amlogic SoCs.
Signed-off-by: Neil Armstrong
---
.../display/amlogic,meson-dw-mipi-dsi.yaml| 118 +
Add third port corresponding to the ENCL DPI encoder used to connect
to DSI or LVDS transceivers.
Signed-off-by: Neil Armstrong
---
.../devicetree/bindings/display/amlogic,meson-vpu.yaml | 5 +
1 file changed, 5 insertions(+)
diff --git a/Documentation/devicetree/bindings/display/amlo
The DSI path used the ENCL pixel encoder, thus this adds a clock
config using the HDMI PLL in order to feed the ENCL encoder via the
VCLK2 path and the CTS_ENCL clock output.
Signed-off-by: Neil Armstrong
---
drivers/gpu/drm/meson/meson_vclk.c | 47 ++
drivers/gpu/drm
This adds supports for the ENCL encoder connected to a MIPI-DSI transceiver on
the
Amlogic AXG SoCs.
Signed-off-by: Neil Armstrong
---
drivers/gpu/drm/meson/meson_venc.c | 230 -
drivers/gpu/drm/meson/meson_venc.h | 6 +
drivers/gpu/drm/meson/meson_vpp.h | 2 +
The Amlogic G12A/G12B/SM1 SoCs embeds a Synopsys DW-MIPI-DSI transceiver (ver
1.21a),
with a custom glue managing the IP resets, clock and data input similar to the
DW-HDMI
Glue on other Amlogic SoCs.
This adds support for the Glue managing the transceiver, mimicing the init flow
provided
by Am
This adds an encoder bridge designed to drive a MIPI-DSI display
by using the ENCL encoder through the internal MIPI DSI transceiver
connected to the output of the ENCL pixel encoder.
Signed-off-by: Neil Armstrong
---
drivers/gpu/drm/meson/Makefile| 2 +-
drivers/gpu/drm/meson/meso
On 26/12/2021 22:24, Arunpravin wrote:
Move the base i915 buddy allocator code into drm
- Move i915_buddy.h to include/drm
- Move i915_buddy.c to drm root folder
- Rename "i915" string with "drm" string wherever applicable
- Rename "I915" string with "DRM" string wherever applicable
- Fix header
Am 07.01.22 um 16:49 schrieb Matthew Auld:
On 26/12/2021 22:24, Arunpravin wrote:
Move the base i915 buddy allocator code into drm
- Move i915_buddy.h to include/drm
- Move i915_buddy.c to drm root folder
- Rename "i915" string with "drm" string wherever applicable
- Rename "I915" string with "D
On 2022-01-07 12:46 a.m., JingWen Chen wrote:
On 2022/1/7 上午11:57, JingWen Chen wrote:
On 2022/1/7 上午3:13, Andrey Grodzovsky wrote:
On 2022-01-06 12:18 a.m., JingWen Chen wrote:
On 2022/1/6 下午12:59, JingWen Chen wrote:
On 2022/1/6 上午2:24, Andrey Grodzovsky wrote:
On 2022-01-05 2:59 a.m., C
On Thu, 6 Jan 2022 at 20:22, Vinay Simha B N wrote:
>
> Reviewed-by: Vinay Simha BN
>
> Jiri Vanek,
> Could you please share the part number or datasheet of the dual-link LVDS
> display/panel used.
>
>
> On Fri, Jan 7, 2022 at 12:30 AM Jiri Vanek wrote:
>>
>> Fixed wrong register shift for sing
This series and this patch looks good to me. I'll hold off a few days
before merging this in order to give Andrzej some time to have a
second look.
Hi Simon,
On Wed, Jan 05, 2022 at 11:54:43PM +, Simon Ser wrote:
> Pushed patches 1 & 2 to drm-misc-next. Thanks for your contribution!
Thanks a lot for the review and for applying the changes, appreciate it.
Is there something that needs to improve in the other 4 patches?
Or just waiting on
On Friday, January 7th, 2022 at 18:26, José Expósito
wrote:
> Is there something that needs to improve in the other 4 patches?
> Or just waiting on maintainers input?
Yeah, these patches look good to me. Feel free to add my R-b.
Maintainers for these drivers still need to review/ack/apply them
The pull request you sent on Fri, 7 Jan 2022 13:23:45 +1000:
> git://anongit.freedesktop.org/drm/drm tags/drm-fixes-2022-01-07
has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/7a6043cc2e863ab45016622c30879e23ee13
Thank you!
--
Deet-doot-dot, I am a bot.
https://ko
On Thu, Jan 6, 2022 at 7:23 PM Dave Airlie wrote:
>
> There is only the amdgpu runtime pm regression fix in here.
Thanks, from a quick test it works for me - the backlight actually
does eventually go away.
It does so only on the second time the monitors say "no signal, going
to power save", but
Am 2022-01-07 um 3:56 a.m. schrieb Christian König:
> Am 06.01.22 um 17:51 schrieb Felix Kuehling:
>> Am 2022-01-06 um 11:48 a.m. schrieb Christian König:
>>> Am 06.01.22 um 17:45 schrieb Felix Kuehling:
Am 2022-01-06 um 4:05 a.m. schrieb Christian König:
[SNIP]
Also, why does your A
The TTM acronym is defined for the first time in the documentation as
"Translation Table Maps". Afterwards, "Translation Table Manager" is
used as definition.
Fix the first definition to avoid confusion.
Signed-off-by: José Expósito
---
Documentation/gpu/drm-mm.rst | 2 +-
1 file changed, 1 ins
Move the logic to create an overlay plane to its own function.
Refactor, no functional changes.
Signed-off-by: José Expósito
---
drivers/gpu/drm/vkms/vkms_output.c | 26 +++---
1 file changed, 19 insertions(+), 7 deletions(-)
diff --git a/drivers/gpu/drm/vkms/vkms_output.c
Create 8 overlay planes instead of 1 when the "enable_overlay" module
parameter is set.
The following igt-gpu-tools tests were executed without finding
regressions. Notice than the numbers are identical:
| master branch | this patch |
| S
Remove the task from the TODO list.
Signed-off-by: José Expósito
---
Documentation/gpu/vkms.rst | 2 --
1 file changed, 2 deletions(-)
diff --git a/Documentation/gpu/vkms.rst b/Documentation/gpu/vkms.rst
index 941f0e7e5eef..9c873c3912cc 100644
--- a/Documentation/gpu/vkms.rst
+++ b/Documentatio
Allow a privacy screen provider to stash its private data pointer in the
drm_privacy_screen, and update the drm_privacy_screen_register() call to
accept that. Also introduce a *_get_drvdata() so that it can retrieved
back when needed.
This also touches the IBM Thinkpad platform driver, the only us
On Wed, Dec 29, 2021 at 11:07 PM Liu Ying wrote:
>
> Actual hardware state of CRTC is controlled by the member 'active' in
> struct drm_crtc_state instead of the member 'enable', according to the
> kernel doc of the member 'enable'. In fact, the drm client modeset
> and atomic helpers are using t
Quoting Jani Nikula (2022-01-07 05:07:59)
> On Thu, 06 Jan 2022, Stephen Boyd wrote:
> > This allows aggregate driver writers to use the device passed to their
> > probe/remove/shutdown functions properly instead of treating it as an
> > opaque pointer.
>
> You say it like having opaque pointers w
On Thu, Jan 6, 2022 at 4:56 AM Greg Kroah-Hartman
wrote:
>
> There are currently 2 ways to create a set of sysfs files for a
> kobj_type, through the default_attrs field, and the default_groups
> field. Move the amdgpu sysfs code to use default_groups field which has
> been the preferred way sinc
On Thu, Jan 6, 2022 at 4:57 AM Greg Kroah-Hartman
wrote:
>
> There are currently 2 ways to create a set of sysfs files for a
> kobj_type, through the default_attrs field, and the default_groups
> field. Move the amdkfd sysfs code to use default_groups field which has
> been the preferred way sinc
On Fri, Jan 7, 2022 at 3:56 PM Neil Armstrong wrote:
>
> Add third port corresponding to the ENCL DPI encoder used to connect
> to DSI or LVDS transceivers.
>
> Signed-off-by: Neil Armstrong
Reviewed-by: Martin Blumenstingl
Hi Neil,
On Fri, Jan 7, 2022 at 3:57 PM Neil Armstrong wrote:
>
> This adds supports for the ENCL encoder connected to a MIPI-DSI transceiver
> on the
> Amlogic AXG SoCs.
Should this be "AXG and newer SoCs" or is this really AXG specific?
[...]
> +#define GAMMA_VCOM_POL7 /* RW */
> +#d
Hi Neil,
On Fri, Jan 7, 2022 at 3:57 PM Neil Armstrong wrote:
[...]
> + writel_bits_relaxed(BIT(3), BIT(3), priv->io_base +
> _REG(ENCL_VIDEO_MODE_ADV));
see my comment on patch #3 from this series for BIT(3)
Best regards,
Martin
Hi Neil,
some high-level comments from me below.
On Fri, Jan 7, 2022 at 3:58 PM Neil Armstrong wrote:
[...]
> +/* MIPI DSI Relative REGISTERs Definitions */
> +/* For MIPI_DSI_TOP_CNTL */
> +#define BIT_DPI_COLOR_MODE20
> +#define BIT_IN_COLOR_MODE 16
> +#define BIT_CHROMA_SUBSA
Hi Zhenneng,
+ some display folks
First of all, thanks a lot for your patch.
We had a similar patch in the past, but we had to revert it because we
cannot simply enable DCN for ARM-based systems. You can refer to this
commit message to get a better context:
https://gitlab.freedesktop.org/ag
https://bugzilla.kernel.org/show_bug.cgi?id=215001
--- Comment #10 from Kris Karas (bugs-...@moonlit-rail.com) ---
Hi Thorsten -
Thanks for the helpful pointer on bug reporting (comment 9). I've been so used
to dealing with LKML and Bugzilla (since 1993) that I'd rather forgotten about
Lore. :-
On Tue, Dec 21, 2021 at 11:26 PM Miaoqian Lin wrote:
> Since drm_prime_pages_to_sg() function return error pointers.
> The drm_gem_shmem_get_sg_table() function returns error pointers too.
> Using IS_ERR() to check the return value to fix this.
>
> Fixes: f651c8b05542("drm/virtio: factor out the
Quoting Rob Clark (2022-01-06 10:14:46)
> From: Rob Clark
>
> System suspend uses pm_runtime_force_suspend(), which cheekily bypasses
> the runpm reference counts. This doesn't actually work so well when the
> GPU is active. So add a reasonable delay waiting for the GPU to become
> idle.
Maybe
On Fri, 2022-01-07 at 14:53 -0500, Alex Deucher wrote:
> On Wed, Dec 29, 2021 at 11:07 PM Liu Ying wrote:
> >
> > Actual hardware state of CRTC is controlled by the member 'active'
> > in
> > struct drm_crtc_state instead of the member 'enable', according to
> > the
> > kernel doc of the member '
For the whole series:
Tested-by: Huacai Chen
On Fri, Jan 7, 2022 at 12:30 AM Bjorn Helgaas wrote:
>
> [+to Maarten, Maxime, Thomas: sorry, I forgot to use
> get_maintainer.pl so I missed you the first time. Beginning of thread:
> https://lore.kernel.org/all/20220106000658.243509-1-helg...@kerne
64 matches
Mail list logo