[airlied:drm-intel-display-refactor 7/9] drivers/gpu/drm/i915/display/intel_fbdev.c:251:60: sparse: sparse: incorrect type in argument 3 (different address spaces)

2021-10-10 Thread kernel test robot
tree: git://people.freedesktop.org/~airlied/linux.git drm-intel-display-refactor head: 57c0bb98bd7351cfb13403dd854cc9a0fc9ad5df commit: 0f3c35589c8c2924d384164482aa273def8aaf1a [7/9] drm/i915/display: refactor fbdev pin/unpin out into functions. config: i386-randconfig-s001-20211010

Re: [PATCH 2/2] fbdev: fbmem: Fix double free of 'fb_info->pixmap.addr'

2021-10-10 Thread Sam Ravnborg
Hi Zheyu, On Sun, Oct 10, 2021 at 06:42:28AM +, Zheyu Ma wrote: > savagefb and some other drivers call kfree to free 'info->pixmap.addr' > even after calling unregister_framebuffer, which may cause double free. > > Fix this by setting 'fb_info->pixmap.addr' to NULL after kfree in > unregister

Re: [PATCH v5 2/2] drm/bridge: lvds-codec: Add support for LVDS data mapping select

2021-10-10 Thread Sam Ravnborg
Hi Marek, On Sun, Oct 10, 2021 at 12:41:52AM +0200, Marek Vasut wrote: > Decoder input LVDS format is a property of the decoder chip or even > its strapping. Handle data-mapping the same way lvds-panel does. In > case data-mapping is not present, do nothing, since there are still > legacy bindings

[PATCH] [v5] dt-bindings: drm/msm/gpu: convert to YAML

2021-10-10 Thread David Heidelberg
Conversion of text binding for Adreno GPU to the YAML format. Signed-off-by: David Heidelberg --- v2: - added compatbile description from Rob Clark - dropped reg description - reg numbers increased to 3 (since we also have uncommon cx_dbgc) - specified interconnect-names items range - de

Re: [PATCH v5 2/2] drm/bridge: lvds-codec: Add support for LVDS data mapping select

2021-10-10 Thread Laurent Pinchart
Hi Sam, On Sun, Oct 10, 2021 at 10:16:22AM +0200, Sam Ravnborg wrote: > On Sun, Oct 10, 2021 at 12:41:52AM +0200, Marek Vasut wrote: > > Decoder input LVDS format is a property of the decoder chip or even > > its strapping. Handle data-mapping the same way lvds-panel does. In > > case data-mapping

Re: [PATCH v5 2/2] drm/bridge: lvds-codec: Add support for LVDS data mapping select

2021-10-10 Thread Sam Ravnborg
Hi Laurent, > > > + > > > + /* > > > + * Decoder input LVDS format is a property of the decoder chip or even > > > + * its strapping. Handle data-mapping the same way lvds-panel does. In > > > + * case data-mapping is not present, do nothing, since there are still > > > + * legacy bindings whi

[PATCH v3 0/5] Panel replay phase1 implementation

2021-10-10 Thread Animesh Manna
Panel Replay is a power saving feature for DP 2.0 monitor and similar to PSR on EDP. These patches are basic enablement patches and reused psr framework to add panel replay related new changes which may need further fine tuning to fill the gap if there is any. Note: The patches are not tested due

[PATCH v3 1/5] drm/i915/panelreplay: dpcd register definition for panelreplay

2021-10-10 Thread Animesh Manna
DPCD register definition added to check and enable panel replay capability of the sink. Signed-off-by: Animesh Manna --- include/drm/drm_dp_helper.h | 6 ++ 1 file changed, 6 insertions(+) diff --git a/include/drm/drm_dp_helper.h b/include/drm/drm_dp_helper.h index b52df4db3e8f..8a2b929c3f8

[PATCH v3 2/5] drm/i915/panelreplay: HAS_PR() macro added for panel replay

2021-10-10 Thread Animesh Manna
Platforms having Display 13 and above will support panel replay feature of DP 2.0 monitor. Added a HAS_PR() macro to check for panel replay capability. v1: Initial version. v2: DISPLAY_VER macro used instead of has_pr flag. [Jose] v3: HAS_PR renamed to HAS_PANEL_REPLAY. [Jani] Signed-off-by: Anim

[PATCH v3 3/5] drm/i915/panelreplay: Initializaton and compute config for panel replay

2021-10-10 Thread Animesh Manna
As panel replay feature similar to PSR feature of EDP panel, so currently utilized existing psr framework for panel replay. v1: RFC version. v2: optimized code, pr_enabled and pr_dpcd variable removed. [Jose] v3: - code comments improved. [Jani] - dpcd_readb used instead of dpcd_read. [Jani] - pan

[PATCH v3 4/5] drm/i915/panelreplay: enable/disable panel replay

2021-10-10 Thread Animesh Manna
TRANS_DP2_CTL register is programmed to enable panel replay from source and sink is enabled through panel replay dpcd configuration address. Signed-off-by: Animesh Manna --- drivers/gpu/drm/i915/display/intel_psr.c | 30 drivers/gpu/drm/i915/i915_reg.h | 1 + 2

[PATCH v3 5/5] drm/i915/panelreplay: Added state checker for panel replay state

2021-10-10 Thread Animesh Manna
has_panel_replay flag is used to check panel replay state which is part of crtc_state structure. v1: RFC version. v2: has_panel_replay flag updated as per hw readout. [Jani] Signed-off-by: Animesh Manna --- drivers/gpu/drm/i915/display/intel_display.c | 1 + drivers/gpu/drm/i915/display/intel_p

Re: [PATCH] dma-buf: move dma-buf symbols into the DMA_BUF module namespace

2021-10-10 Thread Greg Kroah-Hartman
On Tue, Sep 28, 2021 at 09:31:45AM +0200, Daniel Vetter wrote: > On Sat, Sep 25, 2021 at 03:47:00PM +0200, Greg Kroah-Hartman wrote: > > In order to better track where in the kernel the dma-buf code is used, > > put the symbols in the namespace DMA_BUF and modify all users of the > > symbols to pro

Re: [PATCH] dma-buf: move dma-buf symbols into the DMA_BUF module namespace

2021-10-10 Thread Greg Kroah-Hartman
On Mon, Sep 27, 2021 at 12:08:45PM +0200, Christian König wrote: > Am 25.09.21 um 15:47 schrieb Greg Kroah-Hartman: > > In order to better track where in the kernel the dma-buf code is used, > > put the symbols in the namespace DMA_BUF and modify all users of the > > symbols to properly import the

Re: [PATCH] dma-buf: move dma-buf symbols into the DMA_BUF module namespace

2021-10-10 Thread Greg Kroah-Hartman
On Mon, Sep 27, 2021 at 11:39:21AM +0200, Arnd Bergmann wrote: > On Sat, Sep 25, 2021 at 7:41 PM Arnd Bergmann wrote: > > On Sat, Sep 25, 2021 at 3:47 PM Greg Kroah-Hartman > > wrote: > > > > Only test-built on x86 allmodconfig, don't know what other arches will > > > pick up, will let 0-day ru

Re: [PATCH] dma-buf: move dma-buf symbols into the DMA_BUF module namespace

2021-10-10 Thread Greg Kroah-Hartman
On Mon, Sep 27, 2021 at 11:00:14AM -0400, Alex Deucher wrote: > On Mon, Sep 27, 2021 at 7:15 AM Sumit Semwal wrote: > > > > Hello Greg, > > > > Thanks for the patch! > > > > On Sat, 25 Sept 2021 at 19:17, Greg Kroah-Hartman > > wrote: > >> > >> In order to better track where in the kernel the dm

[PATCH v2] dma-buf: move dma-buf symbols into the DMA_BUF module namespace

2021-10-10 Thread Greg Kroah-Hartman
In order to better track where in the kernel the dma-buf code is used, put the symbols in the namespace DMA_BUF and modify all users of the symbols to properly import the namespace to not break the build at the same time. Now the output of modinfo shows the use of these symbols, making it easier t

[PATCH] drm: Remove redundant 'flush_workqueue()' calls

2021-10-10 Thread Christophe JAILLET
'destroy_workqueue()' already drains the queue before destroying it, so there is no need to flush it explicitly. Remove the redundant 'flush_workqueue()' calls. This was generated with coccinelle: @@ expression E; @@ - flush_workqueue(E); destroy_workqueue(E); Signed-off-by: Chris

[PATCH] drm/i915: replacing drm_modeset_lock_all for DRM_MODESET_LOCK_ALL_*

2021-10-10 Thread Maíra Canal
As requested in GPU Driver Developers Guide TODO list, replaces all drm_lock boilerplates for DRM_MODESET_LOCK_ALL_* helpers. Signed-off-by: Maíra Canal --- drivers/gpu/drm/i915/display/intel_display.c | 13 ++--- 1 file changed, 2 insertions(+), 11 deletions(-) diff --git a/drivers/gpu

Re: [PATCH v5 2/2] drm/bridge: lvds-codec: Add support for LVDS data mapping select

2021-10-10 Thread Marek Vasut
On 10/10/21 2:27 PM, Sam Ravnborg wrote: Hi, [...] + if (!bus_node) { + dev_dbg(dev, "bus DT node not found\n"); + return -ENXIO; + } + + ret = of_property_read_string(bus_node, "data-mapping", +

[PATCH v6 2/2] drm/bridge: lvds-codec: Add support for LVDS data mapping select

2021-10-10 Thread Marek Vasut
Decoder input LVDS format is a property of the decoder chip or even its strapping. Handle data-mapping the same way lvds-panel does. In case data-mapping is not present, do nothing, since there are still legacy bindings which do not specify this property. Reviewed-by: Laurent Pinchart Signed-off-

[PATCH v6 1/2] dt-bindings: display: bridge: lvds-codec: Document LVDS data mapping select

2021-10-10 Thread Marek Vasut
Decoder input LVDS format is a property of the decoder chip or even its strapping. Add DT property data-mapping the same way lvds-panel does, to define the LVDS data mapping. Reviewed-by: Laurent Pinchart Reviewed-by: Rob Herring Signed-off-by: Marek Vasut Cc: Laurent Pinchart Cc: Rob Herring

Re: [RFC PATCH v2 2/2] RDMA/rxe: Add dma-buf support

2021-10-10 Thread Zhu Yanjun
On Tue, Oct 5, 2021 at 6:20 PM Shunsuke Mie wrote: > > ping Sorry. I will check it soon. Zhu Yanjun > > 2021年10月1日(金) 12:56 Shunsuke Mie : > > > > 2021年9月30日(木) 23:41 Daniel Vetter : > > > > > > On Wed, Sep 29, 2021 at 01:19:05PM +0900, Shunsuke Mie wrote: > > > > Implement a ib device operation

Re: [RFC PATCH v2 0/2] RDMA/rxe: Add dma-buf support

2021-10-10 Thread Zhu Yanjun
On Wed, Sep 29, 2021 at 12:19 PM Shunsuke Mie wrote: > > This patch series add a dma-buf support for rxe driver. > > A dma-buf based memory registering has beed introduced to use the memory > region that lack of associated page structures (e.g. device memory and CMA > managed memory) [1]. However,

imx_ldb: lockdep warning on 5.14.x

2021-10-10 Thread Fabio Estevam
Hi, I am getting the lockdep warning below on a imx6q-sabred running 5.14.9. Haven't debugged this yet, but just wanted to report in case someone has any suggestions. Thanks, Fabio Estevam [4.913294] imx-drm display-subsystem: bound imx-ipuv3-crtc.2 (ops ipu_crtc_ops) [4.921640] imx-dr

Re: [PATCH v6 2/2] drm/bridge: lvds-codec: Add support for LVDS data mapping select

2021-10-10 Thread Sam Ravnborg
Hi Marek, On Sun, Oct 10, 2021 at 04:49:19PM +0200, Marek Vasut wrote: > Decoder input LVDS format is a property of the decoder chip or even > its strapping. Handle data-mapping the same way lvds-panel does. In > case data-mapping is not present, do nothing, since there are still > legacy bindings

Re: [PATCH v6 2/2] drm/bridge: lvds-codec: Add support for LVDS data mapping select

2021-10-10 Thread Sam Ravnborg
On Sun, Oct 10, 2021 at 06:02:44PM +0200, Sam Ravnborg wrote: > Hi Marek, > On Sun, Oct 10, 2021 at 04:49:19PM +0200, Marek Vasut wrote: > > Decoder input LVDS format is a property of the decoder chip or even > > its strapping. Handle data-mapping the same way lvds-panel does. In > > case data-mapp

Re: [PATCH v6 2/2] drm/bridge: lvds-codec: Add support for LVDS data mapping select

2021-10-10 Thread Marek Vasut
On 10/10/21 6:02 PM, Sam Ravnborg wrote: Hi Marek, On Sun, Oct 10, 2021 at 04:49:19PM +0200, Marek Vasut wrote: Decoder input LVDS format is a property of the decoder chip or even its strapping. Handle data-mapping the same way lvds-panel does. In case data-mapping is not present, do nothing, si

[PATCH v2] drm/r128: fix build for UML

2021-10-10 Thread Randy Dunlap
Fix a build error on CONFIG_UML, which does not support (provide) wbinvd(). UML can use the generic mb() instead. ../drivers/gpu/drm/r128/ati_pcigart.c: In function ‘drm_ati_pcigart_init’: ../drivers/gpu/drm/r128/ati_pcigart.c:218:2: error: implicit declaration of function ‘wbinvd’ [-Werror=impli

Re: [PATCH v5 0/2] Add support for Sharp LS060T1SX01 panel

2021-10-10 Thread Sam Ravnborg
Hi Dmitry, On Sat, Oct 09, 2021 at 11:38:04PM +0300, Dmitry Baryshkov wrote: > Add driver to support Sharp LS06T1SX01 6.0" FullHD panel found e.g. in > the kwaek.ca Dragonboard Display Adapter Bundle. > > Changes since v4: > - Use MIPI_DSI_MODE_NO_EOT_PACKET instead of the old name > > Changes

Re: [v2] drm/panel: panel-simple: Add delay for LG LP120UP1

2021-10-10 Thread Sam Ravnborg
Hi Rex-BC On Thu, Oct 07, 2021 at 07:05:47PM +0800, Rex-BC Chen wrote: > Add power sequence for LG LP120UP1. > > Signed-off-by: Rex-BC Chen Patch failed to apply to drm-misc-next. Please fix and resend. Sam > --- > drivers/gpu/drm/panel/panel-simple.c | 5 + > 1 file changed, 5 in

Re: [Intel-gfx] [PATCH v3 3/5] drm/i915/panelreplay: Initializaton and compute config for panel replay

2021-10-10 Thread kernel test robot
] [If your patch is applied to the wrong git tree, kindly drop us a note. And when submitting patch, we suggest to use '--base' as documented in https://git-scm.com/docs/git-format-patch] url: https://github.com/0day-ci/linux/commits/Animesh-Manna/Panel-replay-phase1-implementation/20211

Re: DSI Bridge switching

2021-10-10 Thread Jagan Teki
Hi Andrzej, On Fri, Oct 8, 2021 at 6:57 PM Andrzej Hajda wrote: > > Hi, > > Removed my invalid email (I will update files next week). > > > On 08.10.2021 13:14, Jagan Teki wrote: > > Hi, > > > > I think this seems to be a known use case for industrial these days with > > i.mx8m. > > > > The host

Re: DSI Bridge switching

2021-10-10 Thread Jagan Teki
Hi Dave, On Fri, Oct 8, 2021 at 9:32 PM Dave Stevenson wrote: > > On Fri, 8 Oct 2021 at 14:37, Laurent Pinchart > wrote: > > > > Hello, > > > > On Fri, Oct 08, 2021 at 03:27:43PM +0200, Andrzej Hajda wrote: > > > Hi, > > > > > > Removed my invalid email (I will update files next week). > > > > >

Re: 572994bf18ff prevents system boot

2021-10-10 Thread Chuck Lever III
> On Oct 8, 2021, at 4:49 AM, Thomas Zimmermann wrote: > > Hi > > Am 04.10.21 um 16:11 schrieb Chuck Lever III: >>> On Oct 4, 2021, at 10:07 AM, Thomas Zimmermann wrote: >>> >>> Hi >>> >>> Am 04.10.21 um 15:34 schrieb Chuck Lever III: > On Oct 4, 2021, at 3:07 AM, Thomas Zimmermann wro

Re: [PATCH v2] drm/r128: fix build for UML

2021-10-10 Thread Sam Ravnborg
Hi Randy, On Sun, Oct 10, 2021 at 10:29:55AM -0700, Randy Dunlap wrote: > Fix a build error on CONFIG_UML, which does not support (provide) > wbinvd(). UML can use the generic mb() instead. > > ../drivers/gpu/drm/r128/ati_pcigart.c: In function ‘drm_ati_pcigart_init’: > ../drivers/gpu/drm/r128/at

Re: [PATCH -next] drm/connector: fix all kernel-doc warnings

2021-10-10 Thread Sam Ravnborg
Hi Randy, I noticed a few things that in my opinion could be improved. See below. Sam On Wed, Oct 06, 2021 at 05:53:05PM -0700, Randy Dunlap wrote: > Clean up all of the kernel-doc issues in drm_connector.c: > > drivers/gpu/drm/drm_connector.c:2611: warning: Excess function parameter

Re: [Intel-gfx] [PATCH v3 3/5] drm/i915/panelreplay: Initializaton and compute config for panel replay

2021-10-10 Thread kernel test robot
patch is applied to the wrong git tree, kindly drop us a note. And when submitting patch, we suggest to use '--base' as documented in https://git-scm.com/docs/git-format-patch] url: https://github.com/0day-ci/linux/commits/Animesh-Manna/Panel-replay-phase1-implementation/20211010-2

Re: [PATCH v6 2/2] drm/bridge: lvds-codec: Add support for LVDS data mapping select

2021-10-10 Thread Marek Vasut
On 10/10/21 7:12 PM, Sam Ravnborg wrote: On Sun, Oct 10, 2021 at 06:02:44PM +0200, Sam Ravnborg wrote: Hi Marek, On Sun, Oct 10, 2021 at 04:49:19PM +0200, Marek Vasut wrote: Decoder input LVDS format is a property of the decoder chip or even its strapping. Handle data-mapping the same way lvds-

Re: [PATCH v2] drm/r128: fix build for UML

2021-10-10 Thread Randy Dunlap
On 10/10/21 12:49 PM, Sam Ravnborg wrote: Hi Randy, On Sun, Oct 10, 2021 at 10:29:55AM -0700, Randy Dunlap wrote: Fix a build error on CONFIG_UML, which does not support (provide) wbinvd(). UML can use the generic mb() instead. ../drivers/gpu/drm/r128/ati_pcigart.c: In function ‘drm_ati_pcigar

Re: [PATCH -next] drm/connector: fix all kernel-doc warnings

2021-10-10 Thread Randy Dunlap
Hi Sam, On 10/10/21 1:04 PM, Sam Ravnborg wrote: Hi Randy, I noticed a few things that in my opinion could be improved. See below. Sam On Wed, Oct 06, 2021 at 05:53:05PM -0700, Randy Dunlap wrote: Clean up all of the kernel-doc issues in drm_connector.c: drivers/gpu/drm/drm_connect

Re: [PATCH v5 0/2] Add support for Sharp LS060T1SX01 panel

2021-10-10 Thread Dmitry Baryshkov
On Sun, 10 Oct 2021 at 20:33, Sam Ravnborg wrote: > > Hi Dmitry, > > On Sat, Oct 09, 2021 at 11:38:04PM +0300, Dmitry Baryshkov wrote: > > Add driver to support Sharp LS06T1SX01 6.0" FullHD panel found e.g. in > > the kwaek.ca Dragonboard Display Adapter Bundle. > > > > Changes since v4: > > - Us

[PATCH -next v2] drm/connector: fix all kernel-doc warnings

2021-10-10 Thread Randy Dunlap
Clean up all of the kernel-doc issues in drm_connector.c: drivers/gpu/drm/drm_connector.c:2611: warning: Excess function parameter 'connector' description in 'drm_connector_oob_hotplug_event' drivers/gpu/drm/drm_connector.c:2611: warning: Function parameter or member 'connector_fwnode' not descr

Re: imx_ldb: lockdep warning on 5.14.x

2021-10-10 Thread Fabio Estevam
On Sun, Oct 10, 2021 at 12:39 PM Fabio Estevam wrote: > > Hi, > > I am getting the lockdep warning below on a imx6q-sabred running 5.14.9. > > Haven't debugged this yet, but just wanted to report in case someone > has any suggestions. git bisect shows that the guilty commit is: commit f4b34faa08

linux-next: manual merge of the drm tree with Linus' tree

2021-10-10 Thread Stephen Rothwell
Hi all, Today's linux-next merge of the drm tree got a conflict in: drivers/gpu/drm/amd/display/include/dal_asic_id.h between commit: 7ab0965079bb ("drm/amd/display: USB4 bring up set correct address") from Linus' tree and commit: 13900e6fde3f ("drm/amd/display: Fix for null pointer acc

[PATCH] drm: of: Add drm_of_lvds_get_data_mapping

2021-10-10 Thread Marek Vasut
Add helper function to convert DT "data-mapping" property string value into media bus format value, and deduplicate the code in panel-lvds.c and lvds-codec.c . Signed-off-by: Marek Vasut Cc: Laurent Pinchart Cc: Sam Ravnborg To: dri-devel@lists.freedesktop.org --- drivers/gpu/drm/bridge/lvds-c

Re: [PATCH] drm: of: Add drm_of_lvds_get_data_mapping

2021-10-10 Thread kernel test robot
esktop.org/drm/drm-tip drm-tip config: i386-randconfig-m021-20211010 (attached as .config) compiler: gcc-9 (Debian 9.3.0-22) 9.3.0 reproduce (this is a W=1 build): # https://github.com/0day-ci/linux/commit/d9a4ed21a0ee9b11df5d862e54876002751fbd45 git remote add linux-review https://

Re: [PATCH v6, 12/15] media: mtk-vcodec: Support 34bits dma address for vdec

2021-10-10 Thread yunfei.d...@mediatek.com
Hi Benjiamin, On Thu, 2021-10-07 at 13:37 +0200, Benjamin Gaignard wrote: > Le 01/09/2021 à 10:32, Yunfei Dong a écrit : > > Use the dma_set_mask_and_coherent helper to set vdec > > DMA bit mask to support 34bits iova space(16GB) that > > the mt8192 iommu HW support. > > > > Whole the iova range

Re: [PATCH] drm: of: Add drm_of_lvds_get_data_mapping

2021-10-10 Thread kernel test robot
Hi Marek, I love your patch! Yet something to improve: [auto build test ERROR on drm-tip/drm-tip] [cannot apply to drm-intel/for-linux-next drm-exynos/exynos-drm-next tegra-drm/drm/tegra/for-next linus/master airlied/drm-next v5.15-rc5 next-20211008] [If your patch is applied to the wrong git t