-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256
On Thu, 2019-09-05 at 20:53 +0200, Daniel Vetter wrote:
> The -modesetting ddx has a totally broken idea of how atomic works:
> - doesn't disable old connectors, assuming they get auto-disable like
> with the legacy setcrtc
> - assumes ASYNC_FLIP i
On Fri, May 8, 2020 at 8:39 AM Christoph Hellwig wrote:
>
> Use __anon_inode_getfd instead of opencoding the logic using
> get_unused_fd_flags + anon_inode_getfile. Also switch the
> bpf_link_new_file calling conventions to match __anon_inode_getfd.
>
> Signed-off-by: Christoph Hellwig
> ---
>
On Fri, May 08, 2020 at 04:40:09PM +0200, Arnd Bergmann wrote:
> CONFIG_DEVICE_PRIVATE cannot be selected in configurations
> without ZONE_DEVICE:
It is kind of unfortunate to lift dependencies from DEVICE_PRIVATE
into the users, is this really how kconfig is supposed to work or is
something else
On Fri, May 08, 2020 at 05:05:03PM +0200, Arnd Bergmann wrote:
> On Fri, May 8, 2020 at 5:00 PM Jason Gunthorpe wrote:
> >
> > On Fri, May 08, 2020 at 04:40:09PM +0200, Arnd Bergmann wrote:
> > > CONFIG_DEVICE_PRIVATE cannot be selected in configurations
> > > without ZONE_DEVICE:
> >
> > It is ki
Hi Daniel,
> > Looking at this patch series, feels a bit like hand-rolling of bridge
> > code, badly. We should get away from that.
> >
> > Once you have that I think the end result is tiny enough that it can
> > stay, bridges intergrate quite well into simple display pipe drivers.
> >
> > > BTW s
On 5/8/20 7:40 AM, Arnd Bergmann wrote:
> CONFIG_DEVICE_PRIVATE cannot be selected in configurations
> without ZONE_DEVICE:
>
> WARNING: unmet direct dependencies detected for DEVICE_PRIVATE
> Depends on [n]: ZONE_DEVICE [=n]
> Selected by [y]:
> - DRM_NOUVEAU_SVM [=y] && HAS_IOMEM [=y] && D
From: Sam Ravnborg
Date: 2020-05-08 15:52:10
To: Bernard
Cc: Inki Dae ,Joonyoung Shim
,Seung-Woo Kim ,Kyungmin Park
,David Airlie ,Daniel Vetter
,Kukjin Kim ,Krzysztof Kozlowski
,dri-devel@lists.freedesktop.org,linux-arm-ker...@lists.infradead.org,linux-samsung-...@vger.kernel.org,linux-
On Fri, May 08, 2020 at 05:36:31PM +0200, Christoph Hellwig wrote:
> Use __anon_inode_getfd instead of opencoding the logic using
> get_unused_fd_flags + anon_inode_getfile.
>
> Signed-off-by: Christoph Hellwig
> ---
> drivers/infiniband/core/rdma_core.c | 17 -
> 1 file changed,
From: "赵军奎"
Date: 2020-04-24 19:37:36
To: Liviu Dudau
Cc: Brian Starkey ,David Airlie
,Daniel Vetter
,dri-devel@lists.freedesktop.org,linux-ker...@vger.kernel.org,opensource.ker...@vivo.com
Subject: Re:Re: [PATCH v2] drm/arm: fixes pixel clock enabled with wrong format
From: Liviu Dudau
Hi sam, all,
i'm not sure you had receive this mail , as gmail's html encoded
messages blocked by linux arm kernel mailing list.
so, resent it in plain text again. with my name "dillon: " at left
sorry for trouble.
dillon
best regards
dillon min 于2020年5月8日周五 下午6:13写道:
>
Hi Sam,
Thanks fo
Hi Sam,
Thanks for your comments, i will rework this panel driver after l3gd20
patch submission.
Sam Ravnborg 于2020年5月8日周五 下午5:02写道:
> Hi Dillon.
>
> Patch submissions starts to look fine.
>
> On Fri, May 08, 2020 at 12:13:14PM +0800, dillon.min...@gmail.com wrote:
> > From: dillon min
> >
>
Fix the following build warning:
WARNING: modpost: missing MODULE_LICENSE() in
drivers/gpu/drm/panel/panel-visionox-rm69299.o
see include/linux/module.h for more information
Signed-off-by: Jason Yan
---
drivers/gpu/drm/panel/panel-visionox-rm69299.c | 1 +
1 file changed, 1 insertion(+)
diff
On 5/8/20 11:30 PM, Jason Yan wrote:
> Fix the following build warning:
>
> WARNING: modpost: missing MODULE_LICENSE() in
> drivers/gpu/drm/panel/panel-visionox-rm69299.o
> see include/linux/module.h for more information
>
> Signed-off-by: Jason Yan
> ---
> drivers/gpu/drm/panel/panel-visionox
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256
On Fri, 2020-05-08 at 11:54 +0200, Greg KH wrote:
> > Hi Daniel and Greg (especially). It seems that this patch was never
> > applied to
> > stable, maybe it fell through the cracks?
>
> What patch is "this patch"?
Sorry, the patch was in the mail
Fix the following gcc warning:
drivers/gpu/drm/amd/amdgpu/gmc_v6_0.c:65:18: warning: ‘crtc_offsets’
defined but not used [-Wunused-const-variable=]
static const u32 crtc_offsets[6] =
^~~~
Reported-by: Hulk Robot
Signed-off-by: Jason Yan
---
drivers/gpu/drm/amd/amdgpu
On Fri, May 8, 2020 at 7:09 PM Rodrigo Vivi wrote:
>
> On Fri, Apr 17, 2020 at 09:28:34PM +0300, Ville Syrjälä wrote:
> > On Fri, Apr 17, 2020 at 08:10:26PM +0200, Daniel Vetter wrote:
> > > On Fri, Apr 17, 2020 at 5:43 PM Ville Syrjälä
> > > wrote:
> > > >
> > > > On Fri, Apr 17, 2020 at 05:23:1
So I did a 'make allmodconfig' and then a 'make' on an RPi4 ARM box, and it
decided that CONFIG_SPARSEMEM=n was OK (so an include of linux/mmzone.h doesn't
define some needed values).
The offending code in resource.c is wrapped in a #ifdef CONFIG_DEVICE_PRIVATE,
which throws a whinge during 'make
Hi
[This is an automated email]
This commit has been processed because it contains a "Fixes:" tag
fixing commit: bb2bb9030425 ("dma-buf: add DMA_BUF_SET_NAME ioctls").
The bot has tested the following trees: v5.6.11, v5.4.39.
v5.6.11: Build OK!
v5.4.39: Failed to apply! Possible dependencies:
The series adds support for adreno a405 found on MSM8936/MSM8939 and APQ
variants.
Shawn Guo (2):
drm/msm/a4xx: add adreno a405 support
drm/msm/a4xx: add a405_registers for a405 device
drivers/gpu/drm/msm/adreno/a4xx_gpu.c | 82 ++
drivers/gpu/drm/msm/adreno/adreno_d
It adds support for adreno a405 found on MSM8939. The adreno_is_a430()
check in adreno_submit() needs an extension to cover a405. The
downstream driver suggests it should cover the whole a4xx generation.
That's why it gets changed to adreno_is_a4xx(), while a420 is not
tested though.
Signed-off-
A405 device has a different set of registers than a4xx_registers. It
has no VMIDMT or XPU registers, and VBIF registers are different. Let's
add a405_registers for a405 device.
As adreno_is_a405() works only after adreno_gpu_init() gets called, the
assignments get moved down after adreno_gpu_ini
On Sat, May 09, 2020 at 12:48:10PM +0200, Konrad Dybcio wrote:
> This change adds MDP5 configuration for MSM8x36-based SoCs,
> like MSM8936, 8939 and their APQ variants.
> The configuration is based on MSM8916's, but adds some notable
> features, like ad and pp blocks, along with some register
> ch
Hi, Anand:
Anand Mistry 於 2020年5月7日 週四 下午7:56寫道:
>
> On Wed, May 6, 2020 at 10:59 PM Chun-Kuang Hu wrote:
> >
> > Hi, Anand:
> >
> > Anand Mistry 於 2020年5月6日 週三 下午7:03寫道:
> > >
> > > On Wed, May 6, 2020 at 10:25 AM Chun-Kuang Hu
> > > wrote:
> > > >
> > > > Hi, Anand,
> > > >
> > > > Chun-Kua
Hi Richard,
Thank you for the patch.
On Sat, May 09, 2020 at 01:17:31PM +0200, s...@48.io wrote:
> From: Marek Vasut
>
> Add DT bindings for ITE IT6251 LVDS-to-eDP bridge.
>
> Signed-off-by: Marek Vasut
> Signed-off-by: Richard Marko
> Cc: Daniel Vetter
> Cc: Rob Herring
> Cc: Sean Cross
Hi, Emil:
Emil Velikov 於 2020年5月7日 週四 下午11:11寫道:
>
> From: Emil Velikov
>
> Spelling out _unlocked for each and every driver is a annoying.
> Especially if we consider how many drivers, do not know (or need to)
> about the horror stories involving struct_mutex.
>
> Just drop the suffix. It makes
Hi Richard,
Thank you for the patch.
On Sat, May 09, 2020 at 01:17:32PM +0200, s...@48.io wrote:
> From: Marek Vasut
>
> Add driver for the ITE IT6251 LVDS-to-eDP bridge.
>
> Signed-off-by: Marek Vasut
> Signed-off-by: Richard Marko
> Cc: Daniel Vetter
> Cc: Sean Cross
> To: dri-devel@list
Since the USB gadget/device has to reach into the DRM internals, part of
the code is placed in the DRM subsystem as a separate module. All calls
into this module runs in process context and are serialized, except one
function that runs in interrupt context.
Since both the gadget side and the DRM s
This adds a generic USB display driver with the intention that it can be
used with future USB interfaced low end displays/adapters. The Linux
gadget device driver will serve as the canonical device implementation.
The following DRM properties are supported:
- Plane rotation
- Connector TV properti
Add a way to lookup a backlight device based on its name.
Will be used by a USB display gadget getting the name from configfs.
Cc: Lee Jones
Cc: Daniel Thompson
Cc: Jingoo Han
Reviewed-by: Sam Ravnborg
Reviewed-by: Daniel Thompson
Acked-by: Lee Jones
Signed-off-by: Noralf Trønnes
---
drive
Hi,
A while back I had the idea to turn a Raspberry Pi Zero into a $5
USB to HDMI/SDTV/DSI/DPI display adapter.
This series adds a USB host driver and a device/gadget driver to achieve
that.
The reason for calling it 'Generic' is so anyone can make a USB
display/adapter against this driver, all
Some drivers need explicit flushing of buffer changes, add a function
that does that.
v2:
- Put all clip rect stuff inside if statement (Sam)
Reviewed-by: Sam Ravnborg
Signed-off-by: Noralf Trønnes
---
drivers/gpu/drm/drm_client.c | 33 +
include/drm/drm_client.
Add a way for client to check the configuration before comitting.
v2:
- Fix docs (Sam)
Reviewed-by: Sam Ravnborg
Signed-off-by: Noralf Trønnes
---
drivers/gpu/drm/drm_client_modeset.c | 35
include/drm/drm_client.h | 1 +
2 files changed, 32 insertions
Add a way for clients to disable all outputs.
Signed-off-by: Noralf Trønnes
---
drivers/gpu/drm/drm_client_modeset.c | 20
include/drm/drm_client.h | 1 +
2 files changed, 21 insertions(+)
diff --git a/drivers/gpu/drm/drm_client_modeset.c
b/drivers/gpu/drm/drm
This adds functions for clients that need more control over the
configuration than what's setup by drm_client_modeset_probe().
Connector, fb and display mode can be set using drm_client_modeset_set().
Plane rotation can be set using drm_client_modeset_set_rotation() and
other properties using drm_c
This adds the gadget side support for the Generic USB Display. It presents
a DRM display device as a USB Display configured through configfs.
The display is implemented as a vendor type USB interface with one bulk
out endpoint. The protocol is implemented using control requests.
lz4 compressed fra
drm_client_init_from_id() provides a way for clients to add a client based
on the minor. drm_client_register() is changed to return whether it was
registered or not depending on the unplugged status of the DRM device.
Its only caller drm_fbdev_generic_setup() runs inside probe() so it
doesn't have
This replaces drm_fb_swab16() with drm_fb_swab() supporting 16 and 32-bit.
Also make pixel line caching optional.
v2:
- Bail out on cpp != 2 && 4 (Sam)
Reviewed-by: Sam Ravnborg
Signed-off-by: Noralf Trønnes
---
drivers/gpu/drm/drm_format_helper.c | 61 +++--
drivers/gp
Also avoid GPU recovery if device is unplagged
Signed-off-by: Andrey Grodzovsky
---
drivers/gpu/drm/amd/amdgpu/amdgpu.h | 1 +
drivers/gpu/drm/amd/amdgpu/amdgpu_dma_buf.c | 27 +--
drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c | 4 +++-
drivers/gpu/drm/amd/amdgpu/
Signed-off-by: Andrey Grodzovsky
---
drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 4 +++-
drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c| 14 ++
drivers/gpu/drm/amd/amdgpu/amdgpu_object.c | 4
3 files changed, 17 insertions(+), 5 deletions(-)
diff --git a/drivers/gpu/drm/amd/amdg
This RFC is a more of a proof of concept then a fully working solution as there
are a few unresolved issues we are hopping to get advise on from people on the
mailing list.
Until now extracting a card either by physical extraction (e.g. eGPU with
thunderbold connection or by emulation through sy
Signed-off-by: Andrey Grodzovsky
---
drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c| 4
drivers/gpu/drm/amd/amdgpu/amdgpu_object.c | 11 +++
drivers/gpu/drm/amd/amdgpu/amdgpu_object.h | 1 +
3 files changed, 16 insertions(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
b/dri
This will allow to invalidate, destroy backing storage and notify users
of BOs when device is unpluged.
Signed-off-by: Andrey Grodzovsky
---
drivers/gpu/drm/amd/amdgpu/amdgpu_debugfs.c | 2 +-
drivers/gpu/drm/amd/amdgpu/amdgpu_object.c | 2 +-
drivers/gpu/drm/nouveau/nouveau_drm.c | 2
Signed-off-by: Andrey Grodzovsky
---
drivers/gpu/drm/amd/amdgpu/amdgpu.h| 2 ++
drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 3 +++
drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c| 2 ++
drivers/gpu/drm/amd/amdgpu/amdgpu_kms.c| 4
4 files changed, 11 insertions(+)
diff --git a/drive
Signed-off-by: Andrey Grodzovsky
---
drivers/gpu/drm/ttm/ttm_bo.c| 22 +-
include/drm/ttm/ttm_bo_driver.h | 2 ++
2 files changed, 23 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/ttm/ttm_bo.c b/drivers/gpu/drm/ttm/ttm_bo.c
index c5b516f..eae61cc 100644
--- a
https://bugzilla.kernel.org/show_bug.cgi?id=207665
Bug ID: 207665
Summary: virtio GPU driver dereferences null pointer while
using some Wayland applications
Product: Drivers
Version: 2.5
Kernel Version: 5.6.11
Hardware:
https://bugzilla.kernel.org/show_bug.cgi?id=207665
--- Comment #1 from c3bac...@protonmail.com ---
Created attachment 289031
--> https://bugzilla.kernel.org/attachment.cgi?id=289031&action=edit
My kernel config
--
You are receiving this mail because:
You are watching the assignee of the bug.
_
On Fri, May 08, 2020 at 03:59:01PM -0700, Douglas Anderson wrote:
> This panel appears to be the same or nearly the same as the BOE
> NV133FHM-N61, but since (in the very least) it identifies itself as a
> different model in the EDID we should add a new compatible string for
> it.
>
> Signed-off-b
Hi Douglas
On Fri, May 08, 2020 at 03:59:00PM -0700, Douglas Anderson wrote:
> The BOE NV133FHM-N61 is documented in the original commit to be a
> 13.3" panel, but the size listed in our struct doesn't match.
> Specifically:
>
> math.sqrt(30.0 * 30.0 + 18.7 * 18.7) / 2.54 ==> 13.92
>
> Searchi
Hi Dillon.
On Fri, May 08, 2020 at 06:13:43PM +0800, dillon min wrote:
> Hi Sam,
>
> Thanks for your comments, i will rework this panel driver after l3gd20
> patch submission.
>
> Sam Ravnborg 于2020年5月8日周五 下午5:02写道:
>
> > Hi Dillon.
> >
> > Patch submissions starts to look fine.
> >
> > On F
Hi Douglas.
On Thu, May 07, 2020 at 02:34:54PM -0700, Douglas Anderson wrote:
>
> As talked about in commit c2bfc223882d ("drm/bridge: ti-sn65dsi86:
> Remove the mystery delay"), the normal HPD pin on ti-sn65dsi86 is
> kinda useless, at least for embedded DisplayPort (eDP). However,
> despite th
https://bugzilla.kernel.org/show_bug.cgi?id=207667
Bug ID: 207667
Summary: power_dpm_force_performance_level set to "low" reduces
CPU performance (Vega 8 / Ryzen 2200G)
Product: Drivers
Version: 2.5
Kernel Version: 5.6.8
On Thu, May 07, 2020 at 10:49:28AM +0800, Samuel Zou wrote:
> Fix the following sparse warning:
>
> drivers/gpu/drm/i2c/tda998x_drv.c:1136:5: warning:
> symbol 'tda998x_audio_digital_mute' was not declared. Should it be static?
>
> Reported-by: Hulk Robot
> Signed-off-by: Samuel Zou
Thanks.
P
Hi Jason.
On Wed, May 06, 2020 at 02:17:45PM +0800, Jason Yan wrote:
> No other functions use the return value of pxa168fb_init_mode() and the
> return value is always 0 now. Make it return void. This fixes the
> following coccicheck warning:
>
> drivers/video/fbdev/pxa168fb.c:565:5-8: Unneeded v
Hi Jason.
On Wed, May 06, 2020 at 02:17:45PM +0800, Jason Yan wrote:
> No other functions use the return value of pxa168fb_init_mode() and the
> return value is always 0 now. Make it return void. This fixes the
> following coccicheck warning:
>
> drivers/video/fbdev/pxa168fb.c:565:5-8: Unneeded v
Hi,
On Sat, May 9, 2020 at 1:00 PM Sam Ravnborg wrote:
>
> Hi Douglas
>
> On Fri, May 08, 2020 at 03:59:00PM -0700, Douglas Anderson wrote:
> > The BOE NV133FHM-N61 is documented in the original commit to be a
> > 13.3" panel, but the size listed in our struct doesn't match.
> > Specifically:
> >
Hi,
On Sat, May 9, 2020 at 1:15 PM Sam Ravnborg wrote:
>
> Hi Douglas.
>
> On Thu, May 07, 2020 at 02:34:54PM -0700, Douglas Anderson wrote:
> >
> > As talked about in commit c2bfc223882d ("drm/bridge: ti-sn65dsi86:
> > Remove the mystery delay"), the normal HPD pin on ti-sn65dsi86 is
> > kinda u
On Fri, 1 May 2020 15:20:44 -0300 Jason Gunthorpe wrote:
> From: Jason Gunthorpe
>
> There is no reason for a user to select this or not directly - it should
> be selected by drivers that are going to use the feature, similar to how
> CONFIG_HMM_MIRROR works.
>
> Currently all drivers provide
Hi, Enric:
Enric Balletbo i Serra 於 2020年5月4日 週一 下午10:14寫道:
>
> The mtk-dpi driver still uses the drm_encoder API which is now somehow
> deprecated. We started to move all the Mediatek drivers to the drm_bridge API,
> like we did for the mtk-dsi driver [1], this is another small step to be able
Hi, Bernard:
Bernard Zhao 於 2020年5月6日 週三 下午8:34寫道:
>
> This code change is to make code bit more readable.
>
Applied to mediatek-drm-next [1], thanks.
[1]
https://git.kernel.org/pub/scm/linux/kernel/git/chunkuang.hu/linux.git/log/?h=mediatek-drm-next
Regards,
Chun-Kuang
> Signed-off-by: Bern
Hi, Bernard:
Bernard Zhao 於 2020年5月6日 週三 下午8:43寫道:
>
> Eiminate the magic number in array size, there macro defines in
> hdmi.h.
Applied to mediatek-drm-next [1], thanks.
[1]
https://git.kernel.org/pub/scm/linux/kernel/git/chunkuang.hu/linux.git/log/?h=mediatek-drm-next
Regards,
Chun-Kuang
>
60 matches
Mail list logo