On 3/20/20 12:47 PM, Thomas Hellström (VMware) wrote:
On 3/20/20 12:27 PM, Simon Ser wrote:
On Friday, March 20, 2020 11:59 AM, Thomas Hellström
wrote:
On 3/20/20 10:13 AM, Pekka Paalanen wrote:
It seems people are also forgetting the problem of associating the
cursor plane with an input d
From: Jason Gunthorpe
This code can be compiled when CONFIG_TRANSPARENT_HUGEPAGE is off, so
remove the ifdef.
Signed-off-by: Jason Gunthorpe
---
mm/hmm.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/mm/hmm.c b/mm/hmm.c
index 7f77fb6e35cf78..a09b4908e9c81a 100644
--- a/mm/hmm.c
+++
From: Jason Gunthorpe
I've had these in my work queue for a bit, nothing profound here, just some
small edits for clarity.
Ralph's hmm tester will need a small diff to work after this - which
illustrates how setting default_flags == 0 is the same as what was called
SNAPSHOT:
diff --git a/lib/te
Add the devicetree binding for Starry KR070PE2T
Signed-off-by: Pascal Roeleven
---
.../devicetree/bindings/display/panel/panel-simple.yaml | 2 ++
1 file changed, 2 insertions(+)
diff --git a/Documentation/devicetree/bindings/display/panel/panel-simple.yaml
b/Documentation/devicetree/b
Add the bindings for Topwise A721 tablet
Signed-off-by: Pascal Roeleven
---
Documentation/devicetree/bindings/arm/sunxi.yaml | 5 +
1 file changed, 5 insertions(+)
diff --git a/Documentation/devicetree/bindings/arm/sunxi.yaml
b/Documentation/devicetree/bindings/arm/sunxi.yaml
index abf2d97
Hi Andrzej ,
在 2020/3/19 下午5:54, Andrzej Pietrasiewicz 写道:
Hi Sandy,
W dniu 19.03.2020 o 03:57, Sandy Huang pisze:
Hi Emil,
--
2.17.1
Heiko, Sandy, being the maintainers of the Rockchip driver, can you
review/ack this patch?
I believe the intention is to merge the series via drm-misc
Add DISP_CC_MDSS_ROT_CLK and DISP_CC_MDSS_AHB_CLK
in the assigned clocks list as these are display
specific clocks and needs to be initialized from
the client side. Adding the default rate of
19.2 mhz for these clocks for sc7180 target.
Signed-off-by: Krishna Manikandan
Changes in v3:
-
From: Jason Gunthorpe
Now that flags are handled on a fine-grained per-page basis this global
flag is redundant and has a confusing overlap with the pfn_flags_mask and
default_flags.
Normalize the HMM_FAULT_SNAPSHOT behavior into one place. Callers needing
the SNAPSHOT behavior should set a pfn_
From: Jason Gunthorpe
Using two bools instead of flags return is not necessary and leads to
bugs. Returning a value is easier for the compiler to check and easier to
pass around the code flow.
Convert the two bools into flags and push the change to all callers.
Signed-off-by: Jason Gunthorpe
-
On Thu, Mar 19, 2020 at 06:33:04PM -0700, Ralph Campbell wrote:
> > > + .default_flags = dmirror_hmm_flags[HMM_PFN_VALID] |
> > > + (write ? dmirror_hmm_flags[HMM_PFN_WRITE] : 0),
> > > + .dev_private_owner = dmirror->mdevice,
> > > + };
> > > + int ret = 0;
Topwise Communication Co,. Ltd. is a company based in Shenzhen. They
manufacture all kind of products but seem to be focusing on POS nowadays.
Signed-off-by: Pascal Roeleven
---
Documentation/devicetree/bindings/vendor-prefixes.yaml | 2 ++
1 file changed, 2 insertions(+)
diff --git a/Documenta
From: Jason Gunthorpe
swp_offset() should not be called directly, the wrappers are supposed to
abstract away the encoding of the device_private specific information in
the swap entry.
Signed-off-by: Jason Gunthorpe
---
mm/hmm.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --
于 2020年3月19日 GMT+08:00 下午10:14:27, Linus Walleij 写到:
>Hi Icenowy,
>
>On Mon, Mar 16, 2020 at 2:37 PM Icenowy Zheng wrote:
>
>> Xingbangda XBD599 is a 5.99" 720x1440 MIPI-DSI LCD panel.
>>
>> Add its device tree binding.
>>
>> Signed-off-by: Icenowy Zheng
>(...)
>
>> +properties:
>> + compatib
This series add support for the Topwise A721 tablet and it's display.
It is an old tablet (around 2012) but it might be useful as reference
as the devicetree is pretty complete.
Changes from v1:
* Split into multiple patches
* dt-binding: use yaml instead of txt
* dt-binding: add Topwise A721 to s
On Mon, Mar 16, 2020 at 08:32:16PM +0100, Christoph Hellwig wrote:
> diff --git a/mm/hmm.c b/mm/hmm.c
> index cfad65f6a67b..b75b3750e03d 100644
> +++ b/mm/hmm.c
> @@ -216,6 +216,14 @@ int hmm_vma_handle_pmd(struct mm_walk *walk, unsigned
> long addr,
> unsigned long end, uint64_t *pf
The KR070PE2T is a 7" panel with a resolution of 800x480.
KR070PE2T is the marking present on the ribbon cable. As this panel is
probably available under different brands, this marking will catch
most devices.
As I can't find a datasheet for this panel, the bus_flags are instead
from trial-and-er
On Fri, Mar 20, 2020 at 11:51:47AM -0700, Ralph Campbell wrote:
>
> On 3/20/20 9:48 AM, Jason Gunthorpe wrote:
> > From: Jason Gunthorpe
> >
> > I've had these in my work queue for a bit, nothing profound here, just some
> > small edits for clarity.
>
> The hmm tester changes are clear enough b
于 2020年3月20日 GMT+08:00 下午5:11:22, Linus Walleij 写到:
>On Fri, Mar 20, 2020 at 9:07 AM Icenowy Zheng wrote:
>> 于 2020年3月19日 GMT+08:00 下午10:14:27, Linus Walleij
> 写到:
>> >On Mon, Mar 16, 2020 at 2:37 PM Icenowy Zheng
>wrote:
>
>> >As noticed in the review of the driver, this display is very close
From: Jason Gunthorpe
The checking boils down to some racy check if the pagemap is still
available or not. Instead of checking this, rely entirely on the
notifiers, if a pagemap is destroyed then all pages that belong to it must
be removed from the tables and the notifiers triggered.
Signed-off-
The Topwise A721/LY-F1 tablet is a tablet sold around 2012 under
different brands. The mainboard mentions A721 clearly, so this tablet
is best known under this name.
Signed-off-by: Pascal Roeleven
---
arch/arm/boot/dts/Makefile | 3 +-
arch/arm/boot/dts/sun4i-a10-topwise-a721
From: Jason Gunthorpe
Delete several functions that are never called, fix some desync between
comments and structure content, remove an unused ret, and move one
function only used by hmm.c into hmm.c
Signed-off-by: Jason Gunthorpe
---
include/linux/hmm.h | 50 --
This is a giant CC list.
There was one version where you CC'd me on patch 6/12 but after that you
just CC'd me on the cover page. Something is messed up in your scripts
because Cc'ing me on just the cover is pointless.
regards,
dan carpenter
___
dri-d
https://bugzilla.kernel.org/show_bug.cgi?id=206895
stefansp...@gmail.com changed:
What|Removed |Added
CC||stefansp...@gmail.com
--- Comment
The previous memset operation was not correctly setting zero on the
alpha channel to compute the crc, and as a result, the
pipe-A-cursor-alpha-transparent subtest of the IGT test kms_cursor_crc
was crashing. To avoid errors of misinterpretation related to
endianness, this solution uses a bitfield o
This patch proposes a change in the behavior of the cursor to enable it as
soon as the vkms module is added. Enabling the cursor by default appears
to be an expected and more friendly behavior, especially when running IGT
tests.
Signed-off-by: Melissa Wen
---
drivers/gpu/drm/vkms/vkms_drv.c | 2
On Fri, Mar 20, 2020 at 01:35:31PM +0100, Noralf Trønnes wrote:
>
>
> Den 20.03.2020 13.28, skrev Sam Ravnborg:
> > Hi Noralf.
> >
> > On Mon, Mar 16, 2020 at 05:42:49PM +0100, Geert Uytterhoeven wrote:
> >> mipi_dbi_command_stackbuf() copies the passed buffer data, so it can be
> >> const.
> >>
On Sat, Mar 21, 2020 at 09:22:36AM +0100, Christoph Hellwig wrote:
> On Fri, Mar 20, 2020 at 10:41:09AM -0300, Jason Gunthorpe wrote:
> > Thinking about this some more, does the locking work out here?
> >
> > hmm_range_fault() runs with mmap_sem in read, and does not lock any of
> > the page table
Hi Laurent.
On Tue, Mar 17, 2020 at 09:25:22PM +0200, Laurent Pinchart wrote:
> Hi Sam,
>
> Thank you for the patch.
>
> On Sat, Mar 14, 2020 at 04:30:47PM +0100, Sam Ravnborg wrote:
> > Fix a few grammar/editorial issues spotted by Laurent Pinchart.
> >
> > Signed-off-by: Sam Ravnborg
> > Cc:
Nothing uses the always-0 return value.
Signed-off-by: Maya Rashish
---
drivers/gpu/drm/drm_dp_mst_topology.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/drm_dp_mst_topology.c
b/drivers/gpu/drm/drm_dp_mst_topology.c
index 4b255e25e4a1..398da29ba1bd 1006
https://bugzilla.kernel.org/show_bug.cgi?id=206895
--- Comment #4 from bigbeesh...@gmail.com ---
If that is the case isn't the issue the kernel rather than the user space
applications ?
As in that case amdgpu is incompatible with any of the OpenCL 2.x
implementation's
--
You are receiving this
Thanks for review and test. Applied patch 1~4 to drm-misc-next.
As patch 5, due to related with non-continuous command stream,
I'd like to apply it when non-continuous command stream has been
implemented which may need a more common VA interface.
Thanks,
Qiang
On Sun, Mar 15, 2020 at 12:32 PM Vas
Applied to drm-misc-next.
Regards,
Qiang
On Wed, Mar 18, 2020 at 5:11 AM Vasily Khoruzhick wrote:
>
> On Mon, Mar 16, 2020 at 6:41 PM Qiang Yu wrote:
>
> > Not concrete reason, as the comment, trace point when
> > dma_fence_signal act as the task completion event, so not add duplicate
> > one.
Looks good for me, patch is:
Reviewed-by: Qiang Yu
Regards,
Qiang
On Fri, Mar 20, 2020 at 4:35 AM Martin Blumenstingl
wrote:
>
> The GPU can be one of the big heat sources on a SoC. Allow the
> "#cooling-cells" property to be specified for ARM Mali Utgard GPUs so
> the GPU clock speeds (and vol
Looks good for me, patch is:
Reviewed-by: Qiang Yu
Regards,
Qiang
On Fri, Mar 20, 2020 at 4:35 AM Martin Blumenstingl
wrote:
>
> Most platforms with a Mali-400 or Mali-450 GPU also have support for
> changing the GPU clock frequency. Add devfreq support so the GPU clock
> rate is updated based
34 matches
Mail list logo