On 21.09.2017 19:06, Sean Paul wrote:
> This patch adds state tracking to the drm_panel functions which keep
> track of enabled and prepared. If the calls are unbalanced, a WARNING is
> issued.
>
> The motivation for this change is that a number of panel drivers
> (including panel-simple) all do th
On 22.09.2017 09:13, Andrzej Hajda wrote:
> On 21.09.2017 19:06, Sean Paul wrote:
>> This patch adds state tracking to the drm_panel functions which keep
>> track of enabled and prepared. If the calls are unbalanced, a WARNING is
>> issued.
>>
>> The motivation for this change is that a number of p
This patchset introduces drm_dev_get() and drm_dev_put() functions that are
intented to be replacements for drm_dev_{ref/unref}.
Then all usages of ref/reference and unref/unreference suffixes are replaced by
get/put reference count functions in tilcdc. The following cocci script was used
to make
On Mon, Sep 18, 2017 at 04:37:52PM +0200, Hans Verkuil wrote:
> On 09/18/2017 04:15 PM, Maciej Purski wrote:
> > Hi Hans,
> > some time ago in reply to your email I described what messages does
> > the MHL driver receive and at what time intervals.
> > Regarding that information, do you think that
Remove casting the values returned by memory allocation functions like
kmalloc, kzalloc, kmem_cache_alloc, kmem_cache_zalloc etc."
Found by coccinelle spatch "api/alloc/alloc_cast.cocci"
Signed-off-by: Thomas Meyer
---
diff -u -p a/drivers/gpu/drm/amd/powerplay/hwmgr/vega10_processpptables.c
b/
Remove obsolete comment which was initially added in 2008 to annotate
that idr_find() was used before idr_remove() since idr_remove() didn't
use to return feedback. The comment now is irrelevant with
commit f6cd7daecff5 ("drm: Release driver references to handle before
making it available again").
On Wed, 20 Sep 2017 16:56:48 -0300
Mauro Carvalho Chehab wrote:
> Em Wed, 20 Sep 2017 20:59:53 +0200
> Wolfram Sang escreveu:
>
> > Signed-off-by: Wolfram Sang
>
> Documentation looks OK on my eyes. So:
>
> Reviewed-by: Mauro Carvalho Chehab
Really minor suggestion inline. I don't really
Use vma_pages function on vma object instead of explicit computation.
Found by coccinelle spatch "api/vma_pages.cocci"
Signed-off-by: Thomas Meyer
---
diff -u -p a/drivers/gpu/drm/rockchip/rockchip_drm_gem.c
b/drivers/gpu/drm/rockchip/rockchip_drm_gem.c
--- a/drivers/gpu/drm/rockchip/rockchip_d
On Thu, 21 Sep 2017 14:59:22 +0100
Jonathan Cameron wrote:
> On Wed, 20 Sep 2017 20:59:52 +0200
> Wolfram Sang wrote:
>
> > One helper checks if DMA is suitable and optionally creates a bounce
> > buffer, if not. The other function returns the bounce buffer and makes
> > sure the data is proper
Remove obsolete comment which was initially added in 2008 to annotate
that idr_find() was used before idr_remove() since idr_remove() didn't
use to return feedback. The comment now is irrelevant with
commit f6cd7daecff5 ("drm: Release driver references to handle before
making it available again").
On Wed, 20 Sep 2017 20:59:52 +0200
Wolfram Sang wrote:
> One helper checks if DMA is suitable and optionally creates a bounce
> buffer, if not. The other function returns the bounce buffer and makes
> sure the data is properly copied back to the message.
>
> Signed-off-by: Wolfram Sang
One min
On Wed, 20 Sep 2017 20:59:56 +0200
Wolfram Sang wrote:
> Signed-off-by: Wolfram Sang
Makes sense as do the other drivers.
Feel free to add
Reviewed-by: Jonathan Cameron
to all of them (though they hardly took a lot of reviewing given how simple
the patches were :)
> ---
> drivers/i2c/i2c-
For maintaining consistency with kernel coding style replace
reference/unreference in ref counting functions with get/put.
The following cocci script was used to generate the tilcdc patch:
@@
expression ex;
@@
(
-drm_framebuffer_unreference(ex);
+drm_framebuffer_put(ex);
|
-drm_dev_unref(ex);
+d
On Thu, Sep 21, 2017 at 11:16:44PM +0200, Julia Lawall wrote:
>
>
> On Thu, 21 Sep 2017, Haneen Mohammed wrote:
>
> > Remove obsolete comment which was initially added in 2008 to annotate
> > that idr_find() was used before idr_remove() since idr_remove() didn't
> > use to return feedback. The c
Reference counting functions in the kernel typically use get/put suffixes. For
maintaining coding style consistency, introduce drm_dev_{get/put} functions
and let the old APIs (with ref/unref suffixes) remain for compatibility.
Signed-off-by: Aishwarya Pant
---
drivers/gpu/drm/drm_drv.c | 64 +++
On Thu, 21 Sep 2017 16:15:28 +0200
Wolfram Sang wrote:
> > > > +/**
> > > > + * i2c_release_dma_safe_msg_buf - release DMA safe buffer and sync
> > > > with i2c_msg
> > > > + * @msg: the message to be synced with
> > > > + * @buf: the buffer obtained from i2c_get_dma_safe_msg_buf(). May be
> >
https://bugs.freedesktop.org/show_bug.cgi?id=44995
--- Comment #7 from weizoujian ---
This card is "video memory" = 0,framebuffer can't used! Why!
--
You are receiving this mail because:
You are the assignee for the bug.___
dri-devel mailing list
dri-
Hi Dave,
just two small etnaviv fixes, one fixing a list corruption, the other
fixing a NULL ptr deref in an error path.
Regards,
Lucas
The following changes since commit 569dbb88e80deb68974ef6fdd6a13edb9d686261:
Linux 4.13 (2017-09-03 13:56:17 -0700)
are available in the git repository at:
Move backlight helpers from tinydrm-helpers.c to
tinydrm-backlight.c
Signed-off-by: Meghana Madhyastha
---
drivers/gpu/drm/tinydrm/core/Makefile| 2 +-
drivers/gpu/drm/tinydrm/core/tinydrm-backlight.c | 103 +++
drivers/gpu/drm/tinydrm/core/tinydrm-helpers.c |
On Fri, Sep 22, 2017 at 04:27:28PM +0530, Meghana Madhyastha wrote:
> Move backlight helpers from tinydrm-helpers.c to
> tinydrm-backlight.c
That says _what_ you did, but not _why_ you are doing it, which really
is the more important part.
thanks,
greg k-h
___
On Thu, 2017-09-21 at 16:17 +, Wang, Zhi A wrote:
> Hi Joonas:
>
> Thanks for the introduction. I have been thinking about the
> possibility of introducing GEM_BUG_ON into GVT-g recently and
> investigating on it. I'm just a bit confused about the usage between
> GEM_BUG_ON and WARN_ON.
GEM_B
On Fri, 22 Sep 2017, Robert Foss wrote:
> After talking to Liviu Dudau at LPC and Sean Paul & Kaveh Nasri at XDC
> it seems that we all could benefit from community maintainership of
> drm_hwcomposer.
Sounds good!
> Regarding contributions, they are accepted on the dri-devel list, using
> the pa
From: Christian König
Nobody is actually using that, remove it.
Signed-off-by: Christian König
---
drivers/gpu/drm/ttm/ttm_memory.c | 6 ++
drivers/gpu/drm/ttm/ttm_page_alloc.c | 3 +--
drivers/gpu/drm/ttm/ttm_page_alloc_dma.c | 3 +--
include/drm/ttm/ttm_memory.h |
From: Christian König
Try to allocate huge pages when it makes sense.
v2: fix comment and use ifdef
Signed-off-by: Christian König
---
drivers/gpu/drm/ttm/ttm_page_alloc_dma.c | 217 ---
1 file changed, 169 insertions(+), 48 deletions(-)
diff --git a/drivers/gpu/d
From: Christian König
Correctly handle different page sizes in the memory accounting.
Signed-off-by: Christian König
---
drivers/gpu/drm/ttm/ttm_memory.c | 10 +-
drivers/gpu/drm/ttm/ttm_page_alloc.c | 5 +++--
drivers/gpu/drm/ttm/ttm_page_alloc_dma.c | 7 ---
include
From: Christian König
Try to allocate huge pages when it makes sense.
Signed-off-by: Christian König
---
drivers/gpu/drm/ttm/ttm_page_alloc.c | 49 ++--
1 file changed, 41 insertions(+), 8 deletions(-)
diff --git a/drivers/gpu/drm/ttm/ttm_page_alloc.c
b/driver
From: Christian König
Instead of mapping them bit by bit map/unmap the whole
compound pages as in one call.
Signed-off-by: Christian König
---
drivers/gpu/drm/ttm/ttm_page_alloc.c | 31 +++
1 file changed, 23 insertions(+), 8 deletions(-)
diff --git a/drivers/gpu/d
From: Christian König
Make it easier to add huge page pool.
Signed-off-by: Christian König
---
drivers/gpu/drm/ttm/ttm_page_alloc.c | 98 +++-
1 file changed, 52 insertions(+), 46 deletions(-)
diff --git a/drivers/gpu/drm/ttm/ttm_page_alloc.c
b/drivers/gpu/drm
From: Christian König
Fix two minor 80 char issues.
Signed-off-by: Christian König
---
drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
b/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
index 8fcc743
From: Christian König
Convert GTT mappings into linear ones for huge page handling.
Signed-off-by: Christian König
---
drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c | 24 +---
1 file changed, 21 insertions(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_vm.c
b/
From: Christian König
Totally surprisingly this is more efficient than doing it page by page.
Signed-off-by: Christian König
---
drivers/gpu/drm/ttm/ttm_page_alloc.c | 29 ++---
1 file changed, 14 insertions(+), 15 deletions(-)
diff --git a/drivers/gpu/drm/ttm/ttm_page
https://bugs.freedesktop.org/show_bug.cgi?id=99553
--- Comment #17 from darkbasic ---
Hi, any news on the OpenCL image support? I really miss darktable support.
--
You are receiving this mail because:
You are the assignee for the bug.___
dri-devel mai
On 09/05/2017 04:33 PM, Dmitry Osipenko wrote:
On 05.09.2017 11:10, Mikko Perttunen wrote:
... >> diff --git a/drivers/gpu/host1x/hw/channel_hw.c
b/drivers/gpu/host1x/hw/channel_hw.c
index 8447a56c41ca..0161da331702 100644
--- a/drivers/gpu/host1x/hw/channel_hw.c
+++ b/drivers/gpu/host1x/hw/ch
Replace functions with reference/unreference suffix with
get/put suffix. Get/put is shorter and more consistent with
the kernel function suffixes.
Signed-off-by: Meghana Madhyastha
---
drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd.c| 4 ++--
drivers/gpu/drm/amd/amdgpu/amdgpu_benchmark.c | 4 ++-
Move backlight helpers from tinydrm-helpers.c to
tinydrm-backlight.c. This is because it is organizationally
simpler to understand and advantageous to group functions
performing a similar function to a separate file as opposed to
having one helper file with heteregenous helper functions.
Signed-of
Hey Jani,
On Fri, 2017-09-22 at 14:21 +0300, Jani Nikula wrote:
> On Fri, 22 Sep 2017, Robert Foss wrote:
> > After talking to Liviu Dudau at LPC and Sean Paul & Kaveh Nasri at
> > XDC
> > it seems that we all could benefit from community maintainership of
> > drm_hwcomposer.
>
> Sounds good!
>
Hey Chih-Wei,
On Fri, 2017-09-22 at 10:40 +0800, Chih-Wei Huang wrote:
> Great news!
> Thanks a lot to make it happen.
>
> I hope I am wrong.
> From my understanding most x86 GPUs still
> cannot work with drm_hwcomposer since
> they lack of atomic mode-setting API support
> required by drm_hwcomp
Make the docs read a little better.
Cc: Laurent Pinchart
Cc: Daniel Vetter
Signed-off-by: Noralf Trønnes
---
Changes since version 2:
- Capitalized start of sentences/descriptions
- Made sure all functions have Returns:
- Added some info about how things tie together
drivers/gpu/drm/drm_gem_
Set frames before SU entry value for max resync frame count of
dpcd register 2009, bit field 0:3.
v2 :
- add macro EDP_PSR2_FRAME_BEFORE_SU (Rodrigo)
- remove EDP_FRAMES_BEFORE_SU_ENTRY (Rodrigo)
- add check ==1 for dpcd_read call (ville)
Cc: Rodrigo Vivi
CC: Puthikorn Voravootivat
Signed-o
From: Colin Ian King
The functions tve200_display_disable and tve200_display_funcs are
local to the source and do not need to be in global scope, so make
them static.
Cleans up sparse warnings:
symbol 'tve200_display_disable' was not declared. Should it be static?
symbol 'tve200_display_funcs' w
On Thu, Sep 21, 2017 at 5:37 PM, Robert Foss wrote:
> Some basic guidelines for contributions could come in handy.
>
> These are copied from IGT and modified to be suitable.
>
> Signed-off-by: Robert Foss
Reviewed-by: Zach Reizner
> ---
> CONTRIBUTING | 31 +++
> 1 f
On Fri, Sep 22, 2017 at 02:37:18AM +0200, Robert Foss wrote:
> Some basic guidelines for contributions could come in handy.
>
> These are copied from IGT and modified to be suitable.
>
> Signed-off-by: Robert Foss
> ---
> CONTRIBUTING | 31 +++
> 1 file changed, 31 i
On Thu, Sep 21, 2017 at 05:02:21PM -0700, Zach Reizner wrote:
> On Thu, Sep 21, 2017 at 4:53 PM, Adrian Salido wrote:
> > Precomp layers may be added to the back at different points which may
> > cause elements to be unsorted. Make sure that these are sorted after
> > provisioning planes to ensure
Gerd Hoffmann writes:
>> I can simply disable X, lightdm or whatever is using it and then
>> rmmod.
>
> Works for me only with CONFIG_FBCON=n, otherwise the fbcon framebuffer
> keeps qxl busy. So is most cases (typical distro kernel build with
> FBCON=y) you simply can't rmmod qxl.
>
> I agree t
Andrzej Hajda writes:
> On 21.09.2017 19:06, Sean Paul wrote:
>> This patch adds state tracking to the drm_panel functions which keep
>> track of enabled and prepared. If the calls are unbalanced, a WARNING is
>> issued.
>>
>> The motivation for this change is that a number of panel drivers
>> (i
Thanks for the reply. Learned a lot. :)
GEM_BUG_ON is new to me since it wasn't there at the beginning of GVT-g
upstream. It showed up later. So I left a lot of WARN_ON in the code and some
of them should be GEM_BUG_ON now.
Now I can figure out those differences. We can discuss with our QA to s
Noralf Trønnes writes:
> Make the docs read a little better.
This all looks nice to me.
Reviewed-by: Eric Anholt
signature.asc
Description: PGP signature
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailm
Pushed!
On Fri, 2017-09-22 at 09:23 -0700, Sean Paul wrote:
> On Fri, Sep 22, 2017 at 02:37:18AM +0200, Robert Foss wrote:
> > Some basic guidelines for contributions could come in handy.
> >
> > These are copied from IGT and modified to be suitable.
> >
> > Signed-off-by: Robert Foss
> > ---
>
Hello Linus Walleij,
This is a semi-automatic email about new static checker warnings.
The patch 001485d5255c: "drm/pl111: Replace custom connector with
panel bridge" from Sep 8, 2017, leads to the following Smatch
complaint:
drivers/gpu/drm/pl111/pl111_drv.c:130 pl111_modeset_init()
err
As part of Treble project in Android O, all the device specific files have
to be located in a separate vendor partition. This is done by setting
LOCAL_PROPRIETARY_MODULE (the name is misleading). This change will not
break existing platforms without a vendor partition as it will just move
files to
Hi Nickey,
El Mon, Sep 18, 2017 at 05:05:33PM +0800 Nickey Yang ha dit:
> This patch correct Feedback divider setting:
> 1、Set Feedback divider [8:5] when HIGH_PROGRAM_EN
> 2、Due to the use of a "by 2 pre-scaler," the range of the
> feedback multiplication Feedback divider is limited to even
> di
https://bugs.freedesktop.org/show_bug.cgi?id=99191
Christoph Haag changed:
What|Removed |Added
Status|REOPENED|RESOLVED
Resolution|---
On Fri, Sep 22, 2017 at 03:58:36PM +, vathsala nagaraju wrote:
> Set frames before SU entry value for max resync frame count of
> dpcd register 2009, bit field 0:3.
>
> v2 :
> - add macro EDP_PSR2_FRAME_BEFORE_SU (Rodrigo)
> - remove EDP_FRAMES_BEFORE_SU_ENTRY (Rodrigo)
> - add check ==1 f
Nice patch series. I wasn't expecting that so quickly.
Patches 4-7 change the ttm_page_alloc allocator, which isn't used by
amdgpu (as far as I can tell). Did you test those changes with a
different driver? I didn't review them in as much detail as the rest.
Someone with a stake in them should pro
Set frames before SU entry value for max resync frame count of
dpcd register 2009, bit field 0:3.
v2 :
- add macro EDP_PSR2_FRAME_BEFORE_SU (Rodrigo)
- remove EDP_FRAMES_BEFORE_SU_ENTRY (Rodrigo)
- add check ==1 for dpcd_read call (ville)
v3 : (Rodrigo)
- move macro EDP_PSR2_FRAME_BEFORE_SU
Add defines for dpcd register 2009 (synchronization latency
in sink).
Cc: Rodrigo Vivi
CC: Puthikorn Voravootivat
Reviewed-by: Rodrigo Vivi
Signed-off-by: Vathsala Nagaraju
---
include/drm/drm_dp_helper.h | 3 +++
1 file changed, 3 insertions(+)
diff --git a/include/drm/drm_dp_helper.h b/inc
56 matches
Mail list logo