[Bug 73420] [HAWAII] atombios stuck executing errors

2014-01-29 Thread bugzilla-dae...@freedesktop.org
... URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140129/5377ec8d/attachment.html>

[Bug 73420] [HAWAII] atombios stuck executing errors

2014-01-29 Thread bugzilla-dae...@freedesktop.org
ppening. -- You are receiving this mail because: You are the assignee for the bug. -- next part -- An HTML attachment was scrubbed... URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140129/10478f57/attachment-0001.html>

[Bug 60879] [radeonsi] X11 can't start with acceleration enabled

2014-01-29 Thread bugzilla-dae...@freedesktop.org
assignee for the bug. -- next part -- An HTML attachment was scrubbed... URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140129/cadfce4e/attachment.html>

[PATCH v5 00/23]

2014-01-29 Thread Jean-Francois Moine
This patch set contains various extensions to the tda998x driver: - simplify the i2c read/write - code cleanup and fix some small errors - use global constants - don't read write-only registers - add DT support - use IRQ for connection status and EDID read - v5 - remarks from Russell King

[PATCH] drm/nouveau: fix lock unbalance in nouveau_crtc_page_flip

2014-01-29 Thread Maarten Lankhorst
Fixes a regression introduced by d5c1e84b3a130f0 "drm/nouveau: hold mutex while syncing to kernel channel". Cc: stable at vger.kernel.org #3.13 Reported-by: Fengguang Wu Signed-off-by: Maarten Lankhorst --- diff --git a/drivers/gpu/drm/nouveau/nouveau_display.c b/drivers/gpu/drm/nouveau/nouveau

[PATCH] drm/gma500: remove stub .open/postclose

2014-01-29 Thread David Herrmann
These are unused and can safely be dropped. DRM core verifies they're non-NULL before it calls them. Cc: Patrik Jakobsson Signed-off-by: David Herrmann --- drivers/gpu/drm/gma500/psb_drv.c | 11 --- 1 file changed, 11 deletions(-) diff --git a/drivers/gpu/drm/gma500/psb_drv.c b/drivers

[RFCv4 09/14] drm: convert plane to properties/state

2014-01-29 Thread Rob Clark
On Tue, Jan 28, 2014 at 4:52 PM, Sean Paul wrote: > On Mon, Nov 25, 2013 at 9:47 AM, Rob Clark wrote: >> Break the mutable state of a plane out into a separate structure >> and use atomic properties mechanism to set plane attributes. This >> makes it easier to have some helpers for plane->set_pr

[PATCH 00/13] DRM Reliable Minor-IDs

2014-01-29 Thread David Herrmann
Hi I was looking into our minor-allocation code and it has one major drawback: char-dev minor-IDs are unreliable. The +128 hacks we use in user-space to calculate render-node IDs based on the original card just does not work. Instead of allocating dummy IDs for each driver, I went ahead and tried

[PATCH 01/13] drm: group dev-lifetime related members

2014-01-29 Thread David Herrmann
These members are all managed by DRM-core, lets group them together so they're not split across the whole device. Signed-off-by: David Herrmann --- include/drm/drmP.h | 21 - 1 file changed, 12 insertions(+), 9 deletions(-) diff --git a/include/drm/drmP.h b/include/drm/drmP.

[PATCH 02/13] drm: skip redundant minor-lookup in open path

2014-01-29 Thread David Herrmann
The drm_open_helper() function is only used internally for drm_open() so we can safely pass in the minor-object directly instead of the minor-id. This way, we avoid the additional minor IDR lookup, which we already do twice in drm_stub_open() and drm_open(). Signed-off-by: David Herrmann --- dri

[PATCH 03/13] drm: remove unused DRM_MINOR_UNASSIGNED

2014-01-29 Thread David Herrmann
This constant is unused, remove it. Signed-off-by: David Herrmann --- include/drm/drmP.h | 1 - 1 file changed, 1 deletion(-) diff --git a/include/drm/drmP.h b/include/drm/drmP.h index 6bd2d74..89b9d58 100644 --- a/include/drm/drmP.h +++ b/include/drm/drmP.h @@ -1005,7 +1005,6 @@ struct drm_dri

[PATCH 04/13] drm: turn DRM_MINOR_* into enum

2014-01-29 Thread David Herrmann
Use enum for DRM_MINOR_* constants to avoid hard-coding the IDs. Furthermore, add a DRM_MINOR_CNT so we can perform range-checks in follow-ups. This changes the IDs of the minor-types by -1, but they're not used as indices so this is fine. Signed-off-by: David Herrmann --- include/drm/drmP.h |

[PATCH 05/13] drm: provide device-refcount

2014-01-29 Thread David Herrmann
Lets not trick ourselves into thinking "drm_device" objects are not ref-counted. That's just utterly stupid. We manage "drm_minor" objects on each drm-device and each minor can have an unlimited number of open handles. Each of these handles has the drm_minor (and thus the drm_device) as private-dat

[PATCH 06/13] drm: add minor-lookup/release helpers

2014-01-29 Thread David Herrmann
Instead of accessing drm_minors_idr directly, this adds a small helper to hide the internals. This will help us later to remove the drm_global_mutex requirement for minor-lookup. Furthermore, this also makes sure that minor->dev is always valid and takes a reference-count to the device as long as

[PATCH 07/13] drm: allocate minors early

2014-01-29 Thread David Herrmann
Instead of waiting for device-registration, we now allocate minor-objects during device allocation. The minors are not registered or assigned an ID. This is still postponed to device-registration. While at it, remove the superfluous output-parameter in drm_get_minor(). The reason for this early a

[PATCH 08/13] drm: move drm_put_minor() to drm_minor_free()

2014-01-29 Thread David Herrmann
_put/get() are used for ref-counting, which we clearly don't do here. Rename it to _free() and also use the common drm_minor_* prefix. Furthermore, avoid passing the minor directly but instead use the type like the other functions do, this allows us to reset the slot. We also drop the redundant ca

[PATCH 09/13] drm: rename drm_unplug/get_minor() to drm_minor_register/unregister()

2014-01-29 Thread David Herrmann
drm_get_minor() no longer allocates objects, and drm_unplug_minor() is now the exact reverse of it. Rename it to _register/unregister() so their name actually says what they do. Furthermore, remove the direct minor-ptr and instead pass the minor-type. This way we know the actualy slot of the minor

[PATCH 10/13] drm: remove unneeded #ifdef CONFIG_DEBUGFS

2014-01-29 Thread David Herrmann
No need to check for DEBUGFS, we already have dummy-fallbacks in our headers. Signed-off-by: David Herrmann --- drivers/gpu/drm/drm_stub.c | 7 --- 1 file changed, 7 deletions(-) diff --git a/drivers/gpu/drm/drm_stub.c b/drivers/gpu/drm/drm_stub.c index 853026a..d564a5d 100644 --- a/drivers

[PATCH 11/13] drm: remove redundant minor->device field

2014-01-29 Thread David Herrmann
Whenever we access minor->device, we are in a minor->kdev->...->fops callback so the minor->kdev pointer *must* be valid. Thus, simply use minor->kdev->devt instead of minor->device and remove the redundant field. Signed-off-by: David Herrmann --- drivers/gpu/drm/drm_drv.c | 4 ++-- drivers/gpu

[PATCH 12/13] drm: make minor-IDs reliable

2014-01-29 Thread David Herrmann
A DRM device may (or may not!) have multiple char-devs registered. For each char-dev type, we use a different minor-ID range. However, imagine the following situation: UDL device: - card0 as: 0 i915 device: - card1 as: 1 - renderD128 as: 128 Due to dynamic bus-probing we have no guarantee of d

[PATCH 13/13] drm: remove redundant minor->index

2014-01-29 Thread David Herrmann
The index of a minor can be easily calculated, no reason to store it. Furthermore, it's actually only really used in drm_sysfs.c during device-registration, so we don't win anything by caching it. All other uses of it are dev->primary->index accesses, which are equivalent to dev->minor_base now. R

[Bug 74190] New: scrypt doesn't do anything with bfgminer on CAYMAN

2014-01-29 Thread bugzilla-dae...@freedesktop.org
--- An HTML attachment was scrubbed... URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140129/ab8416fa/attachment.html>

[PATCH v5 17/23] drm/i2c: tda998x: set the PLL division factor in range 0..3

2014-01-29 Thread Joe Perches
On Sat, 2014-01-25 at 18:14 +0100, Jean-Francois Moine wrote: > The predivider division factor of the register PLL_SERIAL_2 is in the > range 0..3, the value 0 being used for a division by 1. trivia: > diff --git a/drivers/gpu/drm/i2c/tda998x_drv.c > b/drivers/gpu/drm/i2c/tda998x_drv.c [] > @@ -

[Bug 66963] Rv6xx dpm problems

2014-01-29 Thread bugzilla-dae...@freedesktop.org
new version of xf86-video-ati?! Also can I do anything against the seldom hangs? Best Regards, Paul -- You are receiving this mail because: You are the assignee for the bug. -- next part -- An HTML attachment was scrubbed... URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140129/42429286/attachment.html>

[Bug 66963] Rv6xx dpm problems

2014-01-29 Thread bugzilla-dae...@freedesktop.org
se: You are the assignee for the bug. -- next part -- An HTML attachment was scrubbed... URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140129/43c7e496/attachment.html>

[Bug 73759] Graphics corruption in KDE logout effect

2014-01-29 Thread bugzilla-dae...@freedesktop.org
ttp://lists.freedesktop.org/archives/dri-devel/attachments/20140129/eac2d63f/attachment.html>

[Bug 73420] [HAWAII] atombios stuck executing errors

2014-01-29 Thread bugzilla-dae...@freedesktop.org
nt was scrubbed... URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140129/e8f109cb/attachment.html>

[Bug 73420] [HAWAII] atombios stuck executing errors

2014-01-29 Thread bugzilla-dae...@freedesktop.org
> Do those warrant a new bugreport ? Yes, please open a new bug report for those. -- You are receiving this mail because: You are the assignee for the bug. -- next part -- An HTML attachment was scrubbed... URL: <http://lists.freedesktop.org/archives/dri-devel/at

[Bug 73420] [HAWAII] atombios stuck executing errors

2014-01-29 Thread bugzilla-dae...@freedesktop.org
d... URL: <http://lists.freedesktop.org/archives/dri-devel/attachments/20140129/9b88dd33/attachment.html>

[pull] radeon drm-next-3.14

2014-01-29 Thread Alex Deucher
Hi Dave, A few more fixes for 3.14. The following changes since commit 45ab1e07808585c645bc82afd7487a91390f5511: Merge tag 'drm/for-3.14-rc1-20140123' of git://anongit.freedesktop.org/tegra/linux into drm-next (2014-01-29 12:03:56 +1000) are available in the git repository at: git://p

[Bug 73530] Asus U38N: Black screen with Radeon driver in Linux 3.10, 3.11 and 3.12

2014-01-29 Thread bugzilla-dae...@freedesktop.org
if (radeon_dp_link_train_finish(&dp_info)) return; } -- 1.9.rc1 I?ll post the errors tomorrow. -- You are receiving this mail because: You are the assignee for the bug. -- next part -- An HTML attachment was scrubbed.

[RFC] Documentation: devicetree: bindings: drm: Xylon binding

2014-01-29 Thread Mark Rutland
On Mon, Jan 27, 2014 at 05:33:51PM +, Davor Joja wrote: > Hi Mark, > > > On Mon, Jan 27, 2014 at 03:47:42PM +, Davor Joja wrote: > > > Hi, > > > > Hi, > > > > > > > > Can I please get comments about adding new vendor prefix "xylon", and on > > > following devicetree binding for Xylon c

[RFC] Documentation: devicetree: bindings: drm: Xylon binding

2014-01-29 Thread Davor Joja
Hi, Can I get some comments on below mails? I want to create devicetree node for Xylon logiCVC DRM device driver, and get comments and suggestions from community. At the end I would send driver and devicetree binding to mainline. Thank you, Davor > Hi Mark, > > > On Mon, Jan 27, 2014 at 03:4

[PATCH] drm/nouveau: set irq_enabled manually

2014-01-29 Thread Ilia Mirkin
Since commit 0fa9061ae8c ("drm/nouveau/mc: handle irq-related setup ourselves"), drm_device->irq_enabled remained unset. This is needed in order to properly wait for a vblank event in the generic drm code. See https://bugs.freedesktop.org/show_bug.cgi?id=74195 Reported-by: Jan Janecek Signed-off

[git pull] drm next tree

2014-01-29 Thread Linus Torvalds
On Wed, Jan 29, 2014 at 6:49 PM, Dave Airlie wrote: > > For some reason the request-pull and the merge into your tree look different, > since some of the changes in this have already gone in via the arm-soc tree > and dma stuff, all for tegra. Hopefully nobody rebased when they shouldn't. Looks m