[PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-19 Thread Hans Verkuil
Hi Sean, I'm taking over this patch series from Kamil for the time being with his permission (he's switching jobs and moving house so he can't spend any time on this for a while). On 05/13/15 13:10, Sean Young wrote: > On Mon, May 04, 2015 at 07:32:59PM +0200, Kamil Debski wrote: >> From: Hans Ve

[PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-13 Thread Sean Young
On Mon, May 04, 2015 at 07:32:59PM +0200, Kamil Debski wrote: > From: Hans Verkuil > > The added HDMI CEC framework provides a generic kernel interface for > HDMI CEC devices. > > Signed-off-by: Hans Verkuil -snip- > +int cec_create_adapter(struct cec_adapter *adap, const char *name, u32 caps

[PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-13 Thread Hans Verkuil
Typo and question: On 05/04/15 19:32, Kamil Debski wrote: > +static long cec_ioctl(struct file *filp, unsigned int cmd, unsigned long arg) > +{ > + struct cec_devnode *cecdev = cec_devnode_data(filp); > + struct cec_adapter *adap = to_cec_adapter(cecdev); > + void __user *parg = (void

[PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-13 Thread Hans Verkuil
Hi Kamil, Here is the first cec-compliance bug report: CEC_G_CAPS doesn't zero the reserved field! cec.c needs a memset there. I think this is missing in cec.c for all structs with a reserved field in them. Only G_EVENT looks to be OK. Regards, Hans

[PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-13 Thread Hans Verkuil
Hi Kamil, I've started work on a cec-compliance utility and while doing that I noticed a confusing name: On 05/04/15 19:32, Kamil Debski wrote: > +struct cec_caps { > + __u32 available_log_addrs; > + __u32 capabilities; > + __u32 vendor_id; > + __u8 version; > + __u8 reserve

[PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-08 Thread Hans Verkuil
Hi Kamil, Just two tiny issues, and after that you can add my: Reviewed-by: Hans Verkuil to this. On 05/04/2015 07:32 PM, Kamil Debski wrote: > diff --git a/include/uapi/linux/cec.h b/include/uapi/linux/cec.h > new file mode 100644 > index 000..67b0049 > --- /dev/null > +++ b/include/uapi/

[PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-04 Thread Kamil Debski
From: Hans Verkuil The added HDMI CEC framework provides a generic kernel interface for HDMI CEC devices. Signed-off-by: Hans Verkuil [k.debski at samsung.com: Merged CEC Updates commit by Hans Verkuil] [k.debski at samsung.com: Merged Update author commit by Hans Verkuil] [k.debski at samsung.