[PATCH] drm: cleanup: use drm_framebuffer_reference instead of a kref_get

2013-04-10 Thread Archit Taneja
drm_framebuffer_lookup() does a kref_get() for the framebuffer if it finds one corresponding to the fb id passed to it. Use drm_framebuffer_reference() instead for clarity since it's the function used in other places to take a reference. Signed-off-by: Archit Taneja --- drivers/gpu/drm/drm_crtc.

[PATCH] drm: cleanup: use drm_framebuffer_reference instead of a kref_get

2013-04-10 Thread Daniel Vetter
On Wed, Apr 10, 2013 at 02:29:39PM +0530, Archit Taneja wrote: > drm_framebuffer_lookup() does a kref_get() for the framebuffer if it finds one > corresponding to the fb id passed to it. Use drm_framebuffer_reference() > instead > for clarity since it's the function used in other places to take a

Re: [PATCH] drm: cleanup: use drm_framebuffer_reference instead of a kref_get

2013-04-10 Thread Daniel Vetter
On Wed, Apr 10, 2013 at 02:29:39PM +0530, Archit Taneja wrote: > drm_framebuffer_lookup() does a kref_get() for the framebuffer if it finds one > corresponding to the fb id passed to it. Use drm_framebuffer_reference() > instead > for clarity since it's the function used in other places to take a

[PATCH] drm: cleanup: use drm_framebuffer_reference instead of a kref_get

2013-04-10 Thread Archit Taneja
drm_framebuffer_lookup() does a kref_get() for the framebuffer if it finds one corresponding to the fb id passed to it. Use drm_framebuffer_reference() instead for clarity since it's the function used in other places to take a reference. Signed-off-by: Archit Taneja --- drivers/gpu/drm/drm_crtc.