Hi Jerry
One more small comment.
> +
> + pinfo->reset_gpio = devm_gpiod_get_optional(dev, "enable",
> + GPIOD_OUT_LOW);
> + if (IS_ERR(pinfo->reset_gpio)) {
> + err = PTR_ERR(pinfo->reset_gpio);
> + dev_err(dev, "fail
Hi Jerry.
Thanks for this nice patch.
It triggered a few review comments, please see below.
In general it is considered good style to prefix all local function,
to avoid name clash with global function and to make it obvious
when the local function is called direct.
So
panel_unprepare() becomes