On 5/21/2015 1:28 AM, Jani Nikula wrote:
> On Thu, 21 May 2015, Todd Previte wrote:
>> Passive DP->DVI/HDMI dongles show up to the system as HDMI devices, as they
>> do not have a sink device in them to respond to any AUX traffic. When
>> probing these dongles over the
nce and still continue operations. A second NAK will result
in breaking the loop as it would have before and stopping the DDC probe.
Signed-off-by: Todd Previte
Cc: intel-gfx at lists.freedesktop.org
---
drivers/gpu/drm/drm_edid.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --gi
:
- Updated for versioning and patch swizzle
- Revised the title to more accurately reflect the nature and contents of
the patch
- Fixed formatting/whitespace problems
- Added set flag when computed checksum is invalid
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu
count.
- Combined the increment of the defer count into the if-statement
V4:
- Removed i915 tag from subject as the patch is not i915-specific
V5:
- Updated the for-loop to add the number of i2c defers to the retry
counter such that the correct number of retry attempts will be
made
Signed-off-by:
- Revised the title to more accurately reflect the nature and contents of
the patch
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_edid.c | 30 --
drivers/gpu/drm/drm_edid_load.c | 7 +--
include/drm/drm_crtc.h
count.
- Combined the increment of the defer count into the if-statement
V4:
- Removed i915 tag from subject as the patch is not i915-specific
V5:
- Updated the for-loop to add the number of i2c defers to the retry
counter such that the correct number of retry attempts will be
made
Signed-off-by:
- Revised the title to more accurately reflect the nature and contents of
the patch
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_edid.c | 30 --
drivers/gpu/drm/drm_edid_load.c | 7 +--
include/drm/drm_crtc.h
header_corrupt flag from the test handler in intel_dp.c
- Added clearing of header_corrupt flag in the drm_edid_block_valid function
V9:
- Renamed header_corrupt flag to edid_corrupt to more accurately reflect its
value and purpose
- Updated commit message
Signed-off-by: Todd Previte
Cc: dri-devel at
On 4/16/2015 6:34 AM, Paulo Zanoni wrote:
> 2015-04-15 19:03 GMT-03:00 Todd Previte :
>> Displayport compliance test 4.2.2.6 requires that a source device be capable
>> of
>> detecting a corrupt EDID. The test specification states that the sink device
>> sets
handler in intel_dp.c
- Added clearing of header_corrupt flag in the drm_edid_block_valid function
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_edid.c | 35 +--
drivers/gpu/drm/drm_edid_load.c | 7 +--
drivers/gpu
On 4/15/2015 1:25 PM, Paulo Zanoni wrote:
> 2015-04-15 14:15 GMT-03:00 Todd Previte :
>> Displayport compliance test 4.2.2.6 requires that a source device be capable
>> of
>> detecting a corrupt EDID. The test specification states that the sink device
>> sets
flag to the end of the test handler
in intel_dp.c
- Changed the usage of the new function prototype in several places to use
NULL where it is not needed by compliance testing
V7:
- Updated to account for long_pulse flag propagation
Signed-off-by: Todd Previte
Cc: dri-devel at
The debug message is missing a newline at the end and it makes the
logs hard to read when a device defers a lot. Simple 2-character fix
adds the newline at the end.
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
Reviewed-by: Paulo Zanoni
Reviewed-by: Alex Deucher
count.
- Combined the increment of the defer count into the if-statement
V4:
- Removed i915 tag from subject as the patch is not i915-specific
V5:
- Updated the for-loop to add the number of i2c defers to the retry
counter such that the correct number of retry attempts will be
made
Signed-off-by:
flag to the end of the test handler
in intel_dp.c
- Changed the usage of the new function prototype in several places to use
NULL where it is not needed by compliance testing
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_edid.c | 30
On 4/13/15 3:18 PM, Paulo Zanoni wrote:
> 2015-04-13 11:53 GMT-03:00 Todd Previte :
>> Displayport compliance test 4.2.2.6 requires that a source device be capable
>> of
>> detecting a corrupt EDID. The test specification states that the sink device
>> sets up the ED
variable
is actually declared
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_edid.c| 31 ++-
drivers/gpu/drm/drm_edid_load.c | 7 +--
drivers/gpu/drm/i2c/tda998x_drv.c | 4 ++--
drivers/gpu/drm/i915
d the increment of the defer count into the if-statement
V4:
- Removed i915 tag from subject as the patch is not i915-specific
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_dp_helper.c | 7 ++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/dr
compliance variable and check_link_status update; those
have been moved to a later patch
- Removed variable assignment from the bottom of the test handler
V4:
- Removed i915 tag from subject line as the patch is not i915-specific
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
Easy enough to do. Tag removed and updated patch posted. Thanks Emil!
On 4/10/2015 10:45 AM, Emil Velikov wrote:
> Hi Todd
>
> On 10/04/15 16:12, Todd Previte wrote:
>> Displayport compliance test 4.2.2.6 requires that a source device be capable
>> of
>> detecti
The debug message is missing a newline at the end and it makes the
logs hard to read when a device defers a lot. Simple 2-character fix
adds the newline at the end.
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_dp_helper.c | 2 +-
1 file changed, 1
d the increment of the defer count into the if-statement
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_dp_helper.c | 7 ++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/drm_dp_helper.c b/drivers/gpu/drm/drm_dp_helper.c
compliance variable and check_link_status update; those
have been moved to a later patch
- Removed variable assignment from the bottom of the test handler
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_edid.c| 31
On 4/8/2015 3:37 PM, Paulo Zanoni wrote:
> 2015-04-08 18:43 GMT-03:00 Todd Previte:
>> On 4/8/2015 9:51 AM, Paulo Zanoni wrote:
>>> 2015-03-31 14:15 GMT-03:00 Todd Previte:
>>>> Displayport compliance test 4.2.2.6 requires that a source device be
>>>> ca
On 4/8/2015 9:51 AM, Paulo Zanoni wrote:
> 2015-03-31 14:15 GMT-03:00 Todd Previte :
>> Displayport compliance test 4.2.2.6 requires that a source device be capable
>> of detecting
>> a corrupt EDID. To do this, the test sets up an invalid EDID header to be
>> r
On 4/7/15 7:29 AM, Paulo Zanoni wrote:
> 2015-04-06 23:11 GMT-03:00 Todd Previte :
>> For test 4.2.2.5 to pass per the Link CTS Core 1.2 rev1.1 spec, the source
>> device must attempt at least 7 times to read the EDID when it receives an
>> I2C defer. The normal DRM code
umber of I2C Defers to limit the number
of times that the retries variable will be decremented. This
is to address review feedback regarding possible infinite loops
from misbehaving sink devices.
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gp
On 4/6/15 5:05 PM, Paulo Zanoni wrote:
> 2015-03-31 14:15 GMT-03:00 Todd Previte :
>> For test 4.2.2.5 to pass per the Link CTS Core 1.2 rev1.1 spec, the source
>> device must attempt at least 7 times to read the EDID when it receives an
>> I2C defer. The normal DRM code
, however, as a worse case real-world
scenario, it would result in 13 attempts ( 6 native defers, 7 I2C defers)
for a single transaction to complete. The net result is a slightly slower
response to an EDID read that shouldn't significantly impact overall
performance.
Signed-off-by: Todd Previt
The debug message is missing a newline at the end and it makes the
logs hard to read when a device defers a lot. Simple 2-character fix
adds the newline at the end.
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_dp_helper.c | 2 +-
1 file changed, 1
, however, as a worse case real-world
scenario, it would result in 13 attempts ( 6 native defers, 7 I2C defers)
for a single transaction to complete. The net result is a slightly slower
response to an EDID read that shouldn't significantly impact overall
performance.
Signed-off-by: Todd Previt
ce testing code to acknowledge that fact and react
appropriately. The
flag is automatically cleared on read.
This code is designed to expressly work for compliance testing without
disrupting normal
operations for EDID reading and parsing.
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freed
The debug message is missing a newline at the end and it makes the
logs hard to read when a device defers a lot. Simple 2-character fix
adds the newline at the end.
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freedesktop.org
---
drivers/gpu/drm/drm_dp_helper.c | 2 +-
1 file changed, 1
, however, as a worse case real-world
scenario, it would result in 13 attempts ( 6 native defers, 7 I2C defers)
for a single transaction to complete. The net result is a slightly slower
response to an EDID read that shouldn't significantly impact overall
performance.
Signed-off-by: Todd Previt
ce testing code to acknowledge that fact and react
appropriately. The
flag is automatically cleared on read.
This code is designed to expressly work for compliance testing without
disrupting normal
operations for EDID reading and parsing.
Signed-off-by: Todd Previte
Cc: dri-devel at lists.freed
review feedback
- Updated commit message
- Changed from uint8_t to uint32_t
Cc: dri-devel at lists.freedesktop.org
Signed-off-by: Todd Previte
---
drivers/gpu/drm/drm_dp_helper.c | 2 ++
include/drm/drm_dp_helper.h | 1 +
2 files changed, 3 insertions(+)
diff --git a/drivers/gpu/drm
tly.
-T
On 10/21/2014 10:10 AM, Paulo Zanoni wrote:
> 2014-10-09 12:38 GMT-03:00 Todd Previte :
>> These counters are used for Displayort complinace testing to detect error
>> conditions
>> when executing certain compliance tests. Currently these are used in the
>&
lists.freedesktop.org
Signed-off-by: Todd Previte
---
drivers/gpu/drm/drm_dp_helper.c | 2 ++
include/drm/drm_dp_helper.h | 1 +
2 files changed, 3 insertions(+)
diff --git a/drivers/gpu/drm/drm_dp_helper.c b/drivers/gpu/drm/drm_dp_helper.c
index 08e33b8..8353051 100644
--- a/drivers/gpu/drm/drm_dp_helper.c
Sorry for the spam - Ignore the duplicates. There will be one more coming
when I post this series to intel-gfx.
-T
-Original Message-
From: Todd Previte [mailto:tprev...@gmail.com]
Sent: Thursday, October 09, 2014 8:33 AM
To: tprevite at gmail.com
Cc: dri-devel at lists.freedesktop.org
lists.freedesktop.org
Signed-off-by: Todd Previte
---
drivers/gpu/drm/drm_dp_helper.c | 2 ++
include/drm/drm_dp_helper.h | 1 +
2 files changed, 3 insertions(+)
diff --git a/drivers/gpu/drm/drm_dp_helper.c b/drivers/gpu/drm/drm_dp_helper.c
index 08e33b8..8353051 100644
--- a/drivers/gpu/drm/drm_dp_helper.c
lists.freedesktop.org
Signed-off-by: Todd Previte
---
drivers/gpu/drm/drm_dp_helper.c | 2 ++
include/drm/drm_dp_helper.h | 1 +
2 files changed, 3 insertions(+)
diff --git a/drivers/gpu/drm/drm_dp_helper.c b/drivers/gpu/drm/drm_dp_helper.c
index 08e33b8..8353051 100644
--- a/drivers/gpu/drm/drm_dp_helper.c
Hi Rodrigo,
This patch looks good.
Reviewed-by: Todd Previte
-T
-Original Message-
From: Rodrigo Vivi [mailto:rodrigo.v...@gmail.com]
Sent: Tuesday, September 16, 2014 4:18 PM
To: intel-gfx at lists.freedesktop.org
Cc: dri-devel at lists.freedesktop.org; Rodrigo Vivi; Todd Previte
This looks like it's good to go.
As an aside, I don't *think* any of the compliance testing stuff I'm
working on cares whether it's short of long pulse (1.1a compliance), but
it will be interesting to see if/when/where it might have an effect.
Reviewed-by: Todd Pre
These look like they're already integrated into -nightly? But for the
record...
Reviewed-by: Todd Previte
-T
> Dave Airlie <mailto:airlied at gmail.com>
> Tuesday, June 17, 2014 6:29 PM
> From: Daniel Vetter
>
> For no reason at all the public docs lack them, and
Looks good.
Reviewed-by: Todd Previte
> Dave Airlie <mailto:airlied at gmail.com>
> Tuesday, May 20, 2014 7:55 PM
> From: Dave Airlie
>
> DP MST will need connectors that aren't connected to specific
> encoders, add some checks in advance to avoid oopses.
&
Looks good to me.
Reviewed-by: Todd Previte
> Dave Airlie <mailto:airlied at gmail.com>
> Tuesday, May 20, 2014 7:55 PM
> From: Dave Airlie
>
> this is just prep work for mst support.
>
> Signed-off-by: Dave Airlie
> ---
> drivers/gpu/drm/i915/intel_ddi.c |
This patch is a monster, but that's to be expected with MST, I suppose.
:) It has some formatting issues (lines over 80 characters in length)
but that can be cleaned up later (as far as I'm concerned). Otherwise I
don't see anything glaring here, so...
Reviewed-by: Todd P
This one looks fine to me.
Reviewed-by: Todd Previte
> Dave Airlie <mailto:airlied at gmail.com>
> Tuesday, May 20, 2014 7:54 PM
> From: Dave Airlie
>
> This property will be used by the MST code to provide userspace
> with a path to parse so it can recognise co
Minor formatting issues - there's a number of lines that exceed 80
characters in length. One other comment inline below.
Reviewed-by: Todd Previte
> Dave Airlie <mailto:airlied at gmail.com>
> Tuesday, May 20, 2014 7:54 PM
> From: Dave Airlie
>
> This is required to
vice *dev);
> extern bool drm_probe_ddc(struct i2c_adapter *adapter);
> extern struct edid *drm_get_edid(struct drm_connector *connector,
> struct i2c_adapter *adapter);
Reviewed-by: Todd Previte
> Dave Airlie <mailto:airlied at gmail.com>
> Tuesday, May 20, 2014 7:54 PM
> Hey,
N_DONE (1<<12)
> +#define DP_TP_STATUS_PAYLOAD_MAPPING_VC2 (3 << 8)
> +#define DP_TP_STATUS_PAYLOAD_MAPPING_VC1 (3 << 4)
> +#define DP_TP_STATUS_PAYLOAD_MAPPING_VC0 (3 << 0)
>
> /* DDI Buffer Control */
> #define DDI_BUF_CTL_A 0x64000
Definitions look correct
4
> #define DRM_MODE_ENCODER_VIRTUAL 5
> #define DRM_MODE_ENCODER_DSI 6
> +#define DRM_MODE_ENCODER_DPMST 7
>
> struct drm_mode_get_encoder {
> __u32 encoder_id;
Reviewed-by: Todd Previte
> Dave Airlie <mailto:airlied at gmail.com>
> Tuesday, May 20, 2014 7:54 PM
> H
x24
> +#define DP_POWER_DOWN_PHY 0x25
> +#define DP_SINK_EVENT_NOTIFY 0x30
> +#define DP_QUERY_STREAM_ENC_STATUS 0x38
> +
> +/* DP 1.2 MST sideband nak reasons - table 2.84 */
> +#define DP_NAK_WRITE_FAILURE 0x01
> +#define DP_NAK_INVALID_READ 0x02
> +#define DP_NAK_CRC_FA
- DP_TEST_LINK_PATTERN is ambiguous, rename to DP_TEST_LINK_VIDEO_PATTERN to
clarify
- Added DP_TEST_LINK_FAUX_PATTERN to support automated testing of Fast AUX
Signed-off-by: Todd Previte
---
include/drm/drm_dp_helper.h | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a
Looks good.
Reviewed-by: Todd Previte
On Fri, Sep 27, 2013 at 4:48 AM, Jani Nikula wrote:
> Detailed cap info at address 80h is not available with DPCD ver
> 1.0. Whether such devices exist in the wild I don't know, but there
> should be no harm done in having the defines
55 matches
Mail list logo