On 1/8/19, Paul Menzel wrote:
> Dear Maarten,
>
>
> Thank you very much for the quick response.
>
> On 01/08/19 16:37, Maarten Lankhorst wrote:
>> Op 08-01-2019 om 16:07 schreef Paul Menzel:
>
>>> Building Linux 5.0-rc1 fails with the errors below. Please find the
>>> configuration file attached.
This driver depends on the PCI infrastructure but the dependency has not
been explicitly called out.
Fixes: 5d32a66541c46 ("PCI/ACPI: Allow ACPI to be built without CONFIG_PCI set")
Signed-off-by: Sinan Kaya
Reviewed-by: Lukas Wunner
Acked-by: Daniel Vetter
---
drivers/gpu/vga/K
This driver depends on the PCI infrastructure but the dependency has not
been explicitly called out.
Fixes: 5d32a66541c46 ("PCI/ACPI: Allow ACPI to be built without CONFIG_PCI set")
Signed-off-by: Sinan Kaya
Reviewed-by: Lukas Wunner
Acked-by: Daniel Vetter
---
drivers/gpu/vga/K
This driver depends on the PCI infrastructure but the dependency has not
been explicitly called out.
Fixes: 5d32a66541c46 ("PCI/ACPI: Allow ACPI to be built without CONFIG_PCI set")
Signed-off-by: Sinan Kaya
Reviewed-by: Lukas Wunner
Acked-by: Daniel Vetter
---
drivers/gpu/vga/K
This driver depends on the PCI infrastructure but the dependency has not
been explicitly called out.
Signed-off-by: Sinan Kaya
Reviewed-by: Lukas Wunner
---
drivers/gpu/vga/Kconfig | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/vga/Kconfig b/drivers/gpu/vga/Kconfig
index
On 12/23/2018 8:15 PM, Lukas Wunner wrote:
On Sun, Dec 23, 2018 at 02:00:15AM +0300, Sinan Kaya wrote:
On Sat, Dec 22, 2018 at 7:40 PM Lukas Wunner wrote:
On Sat, Dec 22, 2018 at 09:07:12AM +, Sinan Kaya wrote:
This driver depends on the PCI infrastructure but the dependency has not
been
On Sat, Dec 22, 2018 at 7:40 PM Lukas Wunner wrote:
>
> On Sat, Dec 22, 2018 at 09:07:12AM +, Sinan Kaya wrote:
> > This driver depends on the PCI infrastructure but the dependency has not
> > been explicitly called out.
> >
> > Signed-off-by: Sinan Kaya
This driver depends on the PCI infrastructure but the dependency has not
been explicitly called out.
Signed-off-by: Sinan Kaya
Reviewed-by: Lukas Wunner
---
drivers/gpu/vga/Kconfig | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/vga/Kconfig b/drivers/gpu/vga/Kconfig
index
This driver depends on the PCI infrastructure but the dependency has not
been explicitly called out.
Signed-off-by: Sinan Kaya
---
drivers/gpu/vga/Kconfig | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/vga/Kconfig b/drivers/gpu/vga/Kconfig
index b677e5d524e6..d5f1d8e1c6f8
ess instead of PCI bus address in FrameBufferBase of the AST GOP UEFI
driver.
We can drop this patch now.
--
Sinan Kaya
Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm
Technologies, Inc.
Qualcomm Technologies, Inc. is a member of the
they fixed the issue in BIOS by presenting CPU physical
>> address instead of PCI bus address in FrameBufferBase of the AST GOP UEFI
>> driver.
>>
>> We can drop this patch now.
>>
> Excellent! Thanks for following up with the vendor ...
>
Sure, appreciate the help.
--
ue. It may be worth a try to dump the results of
> GetBarAttributes() of all PCI I/O protocol instances (either in UEFI
> or in the stub), to double check that the correct values are returned.
>
Thanks for checking out other platforms. I'll mark the issue as a BIOS
issue and bounce
eference about the definition of this field?
Sinan
--
Sinan Kaya
Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm
Technologies, Inc.
Qualcomm Technologies, Inc. is a member of the Code Aurora Forum, a Linux
Foundation Collaborative Project.
_
Hi Bjorn,
On 6/19/2018 5:59 PM, Bjorn Helgaas wrote:
> On Fri, May 18, 2018 at 10:20:29AM -0400, Sinan Kaya wrote:
>> On 5/18/2018 6:42 AM, Robin Murphy wrote:
>>>
>>> FWIW, now that I've actually gone and looked, it appears you could simplify
>>> the who
Hi Ard,
On 5/18/2018 10:17 AM, Sinan Kaya wrote:
> A host bridge is allowed to remap BAR addresses using _TRA attribute in
> _CRS windows.
>
> pci_bus :00: root bus resource [mem 0x8010010-0x8011fff window]
> (bus address [0x0010-0x1fff])
> pci :02:00
Get rid of base and size variables in favor of a struct resource.
The conditional for checking window can be replaced with
resource_contains().
Signed-off-by: Sinan Kaya
---
drivers/video/fbdev/efifb.c | 17 +++--
1 file changed, 11 insertions(+), 6 deletions(-)
diff --git a
: mode is 800x600x32, linelength=3200, pages=1
efifb: scrolling: redraw
efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
Use the host bridge offset information to convert bus address to
resource address in the fixup.
Signed-off-by: Sinan Kaya
---
drivers/video/fbdev/efifb.c | 5 +
1 file
an
> open-coded resource_contains().
Posted V2 a minute ago. I did the simplification on a prior patch in order not
to
mix the issues.
--
Sinan Kaya
Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm
Technologies, Inc.
Qualcomm Technologies, Inc. is a member of the Code A
On 5/17/2018 6:17 AM, Robin Murphy wrote:
>> + }
>> +
>
> Is this not pretty much just pcibios_bus_to_resource()?
>
Agreed, let me convert the code to use pcibios_bus_to_resource() API.
I wasn't aware of its existence.
> Robin.
--
Sinan Kaya
Qualcomm Datace
.
Signed-off-by: Sinan Kaya
---
drivers/video/fbdev/efifb.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/drivers/video/fbdev/efifb.c b/drivers/video/fbdev/efifb.c
index 46a4484..ea68d5c 100644
--- a/drivers/video/fbdev/efifb.c
+++ b/drivers/video/fbdev/efifb.c
@@ -428,6 +428,8
On 5/16/2018 2:31 PM, Timur Tabi wrote:
> On 05/16/2018 01:23 PM, Sinan Kaya wrote:
>> + win_start = window->res->start - window->offset;
>
> Can you guarantee that window->res->start is always >= window->offset?
>
Resource offset is generally 0 wh
.
Signed-off-by: Sinan Kaya
---
drivers/video/fbdev/efifb.c | 23 +++
1 file changed, 23 insertions(+)
diff --git a/drivers/video/fbdev/efifb.c b/drivers/video/fbdev/efifb.c
index 46a4484..feef02b 100644
--- a/drivers/video/fbdev/efifb.c
+++ b/drivers/video/fbdev/efifb.c
On 5/16/2018 2:23 PM, Sinan Kaya wrote:
> + if (win_start <= base && win_end >= base + win_size - 1) {
> + base += window->offset;
> + break;
> + }
I should probably add window->offset!=0 to the if sta
eviewed-by: Christian König
> Signed-off-by: Robin Murphy
> ---
Much better
Tested-by: Sinan Kaya
for the first two patches. (1/3 and 2/3)
--
Sinan Kaya
Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm
Technologies, Inc.
Qualcomm Technologies, Inc. is a member of
if (dma_sg) {
+ dma_len = sg_dma_len(dma_sg);
+ addr = sg_dma_address(dma_sg);
+ }
}
--
Sinan Kaya
Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm
Technologies, Inc.
Qua
ferent test. Previous DRM library unit test is
still passing. It must have some unique characteristic.
I'll test your patch and report.
--
Sinan Kaya
Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm
Technologies, Inc.
Qualcomm Technologies, Inc. is a member of the Code Aur
On 4/17/2018 5:13 PM, Sinan Kaya wrote:
> Tested-by: Sinan Kaya
>
> using QDF2400 and XFX Vega64 GPU for the first two patches.
>
> ./builddir/tests/amdgpu/amdgpu_test -s 1
>
> Suite: Basic Tests
> Test: Userptr Test ...passed
>
> Userptr Test fails without
> r = -ENOMEM;
> nents = dma_map_sg(adev->dev, ttm->sg->sgl, ttm->sg->nents, direction);
> - if (nents != ttm->sg->nents)
> + if (nents == 0)
> goto release_sg;
>
> drm_prime_sg_to_page_addr_arrays(ttm->sg, ttm-&
On 4/11/2018 8:03 AM, Robin Murphy wrote:
> On 10/04/18 21:59, Sinan Kaya wrote:
>> Code is expecing to observe the same number of buffers returned from
>> dma_map_sg() function compared to sg_alloc_table_from_pages(). This
>> doesn't hold true universally especia
tiple consecutive pages into one entry is just additional
overhead which we don't need.
Signed-off-by: Sinan Kaya
---
drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
b/drivers/gpu/drm/amd/amdgpu/amdgpu_devi
right thing is to tell the DMA layer how much combining
IOMMU can do.
Signed-off-by: Sinan Kaya
---
drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c
b/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c
index e4bb435..02
right thing is to tell the DMA layer how much combining
IOMMU can do.
Signed-off-by: Sinan Kaya
---
drivers/gpu/drm/amd/amdgpu/gmc_v6_0.c | 2 +-
drivers/gpu/drm/amd/amdgpu/gmc_v7_0.c | 1 +
drivers/gpu/drm/amd/amdgpu/gmc_v8_0.c | 1 +
drivers/gpu/drm/amd/amdgpu/gmc_v9_0.c | 1 +
4 files chang
On 12/19/2017 12:37 AM, Sinan Kaya wrote:
> pci_get_bus_and_slot() is restrictive such that it assumes domain=0 as
> where a PCI device is present. This restricts the device drivers to be
> reused for other domain numbers.
>
> Getting ready to remove pci_get_bus_and_slot() funct
On 12/19/2017 12:38 AM, Sinan Kaya wrote:
> pci_get_bus_and_slot() is restrictive such that it assumes domain=0 as
> where a PCI device is present. This restricts the device drivers to be
> reused for other domain numbers.
>
> Getting ready to remove pci_get_bus_and_slot() funct
On 12/19/2017 12:37 AM, Sinan Kaya wrote:
> pci_get_bus_and_slot() is restrictive such that it assumes domain=0 as
> where a PCI device is present. This restricts the device drivers to be
> reused for other domain numbers.
>
> Getting ready to remove pci_get_bus_and_slot() funct
On 12/19/2017 12:37 AM, Sinan Kaya wrote:
> pci_get_bus_and_slot() is restrictive such that it assumes domain=0 as
> where a PCI device is present. This restricts the device drivers to be
> reused for other domain numbers.
>
> Getting ready to remove pci_get_bus_and_slot() funct
from pdev.
Signed-off-by: Sinan Kaya
---
drivers/video/fbdev/intelfb/intelfbhw.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/video/fbdev/intelfb/intelfbhw.c
b/drivers/video/fbdev/intelfb/intelfbhw.c
index 83fec57..57aff74 100644
--- a/drivers/video/fbdev
pci_get_bus_and_slot() with pci_get_domain_bus_and_slot()
and extract the domain number from
1. struct pci_dev
2. struct pci_dev through drm_device->pdev
3. struct pci_dev through fb->subdev->drm_device->pdev
Signed-off-by: Sinan Kaya
---
drivers/gpu/drm/nouveau/dispnv04/arb.c | 4 +++-
pci_get_domain_bus_and_slot().
Signed-off-by: Sinan Kaya
---
drivers/video/fbdev/riva/fbdev.c | 2 +-
drivers/video/fbdev/riva/nv_driver.c | 7 ---
drivers/video/fbdev/riva/riva_hw.c | 20 +---
drivers/video/fbdev/riva/riva_hw.h | 3 ++-
4 files changed, 20 insertions(+), 12
a pointer to struct pci_dev. Use the pci_dev
member to extract the domain information and pass it to
pci_get_domain_bus_and_slot() function.
Signed-off-by: Sinan Kaya
---
drivers/video/fbdev/nvidia/nv_hw.c| 11 ++-
drivers/video/fbdev/nvidia/nv_setup.c | 3 ++-
2 files changed, 8
as 0.
Signed-off-by: Sinan Kaya
Acked-by: Jingoo Han
Acked-by: Daniel Thompson
---
drivers/video/backlight/apple_bl.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/video/backlight/apple_bl.c
b/drivers/video/backlight/apple_bl.c
index d843296..6a34ab9 100644
--- a
change in your tree, it should be safe.
https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/include/linux/pci.h?id=7912af5c835bd86f2b0347a480e0f40e2fab30d0
>
> Regards, Joonas
>
--
Sinan Kaya
Qualcomm Datacenter Technologies, Inc. as an affiliate of Qual
On 11/28/2017 11:29 AM, Sinan Kaya wrote:
> On 11/28/2017 10:30 AM, Ville Syrjälä wrote:
>>> + dev_priv->bridge_dev =
>>> + pci_get_domain_bus_and_slot(domain, 0, PCI_DEVFN(0, 0));
>> Maybe just pci_get_slot(pdev->bus, PCI_DEVFN(0, 0)) ?
>>
>&g
as 0.
Acked-by: Jingoo Han
Acked-by: Daniel Thompson
Signed-off-by: Sinan Kaya
---
drivers/video/backlight/apple_bl.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/video/backlight/apple_bl.c
b/drivers/video/backlight/apple_bl.c
index d843296..6a34ab9 100644
--- a
; bus = pci_find_host_bridge(pdev->bus)->bus;
> pci_get_slot(bus, PCI_DEVFN(0, 0))
>
> but I think the GPU should always be on the root bus, so the simpler
> form should be fine.
>
All three of these should be correct.
I'll use pci_get_slot(pdev->bus, PCI_DEVF
+dri-devel@lists.freedesktop.org
On 11/27/2017 11:57 AM, Sinan Kaya wrote:
> pci_get_bus_and_slot() is restrictive such that it assumes domain=0 as
> where a PCI device is present. This restricts the device drivers to be
> reused for other domain numbers.
>
> Getting
+nouv...@lists.freedesktop.org
On 11/27/2017 11:57 AM, Sinan Kaya wrote:
> pci_get_bus_and_slot() is restrictive such that it assumes domain=0 as
> where a PCI device is present. This restricts the device drivers to be
> reused for other domain numbers.
>
> Getting
+dri-devel@lists.freedesktop.org
On 11/27/2017 11:57 AM, Sinan Kaya wrote:
> pci_get_bus_and_slot() is restrictive such that it assumes domain=0 as
> where a PCI device is present. This restricts the device drivers to be
> reused for other domain numbers.
>
> Getting
pci_get_bus_and_slot() with pci_get_domain_bus_and_slot()
and extract the domain number from
1. struct pci_dev
2. struct pci_dev through drm_device->pdev
3. struct pci_dev through fb->subdev->drm_device->pdev
Signed-off-by: Sinan Kaya
---
drivers/gpu/drm/nouveau/dispnv04/arb.c | 4 +++-
number from drm_device and pass it into
pci_get_domain_bus_and_slot() function.
Signed-off-by: Sinan Kaya
---
drivers/gpu/drm/i915/i915_drv.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/i915/i915_drv.c b/drivers/gpu/drm/i915/i915_drv.c
index 9f45cfe
On 11/22/2017 5:49 PM, Sinan Kaya wrote:
> static int i915_get_bridge_dev(struct drm_i915_private *dev_priv)
> {
> - dev_priv->bridge_dev = pci_get_bus_and_slot(0, PCI_DEVFN(0, 0));
> + u32 domain = pci_domain_nr(dev_priv->drm.pdev->bus);
I'll convert doma
number from drm_device and pass it into
pci_get_domain_bus_and_slot() function.
Signed-off-by: Sinan Kaya
---
drivers/gpu/drm/i915/i915_drv.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/i915/i915_drv.c b/drivers/gpu/drm/i915/i915_drv.c
index 9f45cfe
pci_get_bus_and_slot() with pci_get_domain_bus_and_slot()
and extract the domain number from
1. struct pci_dev
2. struct pci_dev through drm_device->pdev
3. struct pci_dev through fb->subdev->drm_device->pdev
Signed-off-by: Sinan Kaya
---
drivers/gpu/drm/nouveau/dispnv04/arb.c | 4 +++-
, use the actual domain number from
the device.
Signed-off-by: Sinan Kaya
---
drivers/gpu/drm/nouveau/dispnv04/arb.c | 3 ++-
drivers/gpu/drm/nouveau/dispnv04/hw.c| 6 --
drivers/gpu/drm/nouveau/nouveau_drm.c| 3 ++-
drivers/gpu/drm/nouveau/nvkm/subdev/fb/ramn
, use the actual domain number from
the device.
Signed-off-by: Sinan Kaya
---
drivers/gpu/drm/i915/i915_drv.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/i915/i915_drv.c b/drivers/gpu/drm/i915/i915_drv.c
index 9f45cfe..2ca7603 100644
--- a/drivers/gpu/drm
ification, Revision 1.0 for
further details. Default value of this bit is 0b."
Kernel is currently not setting this.
>
> I'm not surprised if a GPU takes longer than 100ms to do device-
> specific, driver-managed, non-PCI things like detect and wake up
> monitors. But I *am* surprised if generic PCI bus-level things like
> config reads take longer than that. I also cc'd Lukas because he
> knows a lot more about PCI PM than I do.
>
> Bjorn
>
--
Sinan Kaya
Qualcomm Datacenter Technologies, Inc. as an affiliate of Qualcomm
Technologies, Inc.
Qualcomm Technologies, Inc. is a member of the Code Aurora Forum, a Linux
Foundation Collaborative Project.
56 matches
Mail list logo