This patch remove the follow complete task from TODO documentation:
drm_mode_config.crtc_idr is misnamed, since it contains all KMS object.
Should be renamed to drm_mode_config.object_idr.
Signed-off-by: Shayenne da Luz Moura
---
Documentation/gpu/todo.rst | 3 ---
1 file changed, 3
This patch solves this TODO task:
drm_mode_config.crtc_idr is misnamed, since it contains all KMS object.
Should be renamed to drm_mode_config.object_idr.
Signed-off-by: Shayenne da Luz Moura
---
Changes in v2:
- Make commit message more clear and change header file
drivers/gpu/drm
This patch solves this TODO task:
drm_mode_config.crtc_idr is misnamed, since it contains all KMS object.
Should be renamed to drm_mode_config.object_idr.
Signed-off-by: Shayenne da Luz Moura
---
Changes in v2:
- Make commit message more clear and change header file
drivers/gpu/drm
Rename 'drm_mode_config.crtc_idr' as 'drm_mode_config.object_idr',
as proposed in the task description in TODO list for KMS cleanups.
Signed-off-by: Shayenne da Luz Moura
---
drivers/gpu/drm/drm_lease.c | 6 +++---
drivers/gpu/drm/drm_mode_config.c | 4 +
Break line after NULL to decrease the line size.
Signed-off-by: Shayenne da Luz Moura
---
Changes in v2:
- Remove aditional variable added in v1 and add a line break
drivers/gpu/drm/drm_mode_object.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm
Add a new variable to make the drm_mode_object comparison before
idr_alloc and decrease line size.
Signed-off-by: Shayenne da Luz Moura
---
drivers/gpu/drm/drm_mode_object.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/drm_mode_object.c
b/drivers/gpu
Use 'unsigned int' with bitfield instead of 'bool' to avoid alignment
issues and remove checkpatch.pl check:
CHECK: Avoid using bool structure members because of possible alignment
issues
Signed-off-by: Shayenne da Luz Moura
---
drivers/gpu/drm/qxl/qxl_drv.h | 10 +
Add space to remove checkpath.pl error:
ERROR: space required before the open parenthesis '('
Signed-off-by: Shayenne da Luz Moura
---
drivers/gpu/drm/qxl/qxl_display.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/qxl/qxl_display.c
b/drive
Use 'usigned int' instead of 'usigned' to remove the checkpath.pl warning:
WARNING: Prefer 'unsigned int' to bare use of 'unsigned'
Signed-off-by: Shayenne da Luz Moura
---
drivers/gpu/drm/qxl/qxl_cmd.c | 2 +-
drivers/gpu/drm/qxl/qxl_debugfs.c | 4
Remove extra whiteline to clean the checkpatch.pl check:
CHECK: Please don't use multiple blank lines
Signed-off-by: Shayenne da Luz Moura
---
drivers/gpu/drm/qxl/qxl_cmd.c | 1 -
drivers/gpu/drm/qxl/qxl_debugfs.c | 1 -
drivers/gpu/drm/qxl/qxl_dev.h | 1 -
drivers/gpu/dr
Add whiteline after variable declarations to remove the checkpath.pl
warning:
WARNING: Missing a blank line after declarations
Signed-off-by: Shayenne da Luz Moura
---
drivers/gpu/drm/qxl/qxl_cmd.c | 4
drivers/gpu/drm/qxl/qxl_display.c | 2 ++
drivers/gpu/drm/qxl/qxl_draw.c| 2
Remove extra tab and space to clean the checkpath.pl error.
ERROR: trailing whitespace
Signed-off-by: Shayenne da Luz Moura
---
drivers/gpu/drm/qxl/qxl_dumb.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/qxl/qxl_dumb.c b/drivers/gpu/drm/qxl/qxl_dumb.c
pen parenthesis '('
CHECK: Avoid using bool structure members because of possible alignment issues
Shayenne da Luz Moura (6):
drm/qxl: Remove trailing whitespace
drm/qxl: Add line after variable declarations
drm/qxl: Remove exceding whiteline
drm/qxl: Use 'unsigned int' ins
13 matches
Mail list logo