Currently pdd is validate after dereferencing it, which is
not correct, Thus validate pdd before its first use.
Signed-off-by: Maninder Singh
---
v1: remove validation of pdd after its usage
v2: do validation at first place rather than removing
drivers/gpu/drm/amd/amdkfd/kfd_process.c |9
pdd is already dereferenced before this check.
So it is redundtant to validate pdd here.
Signed-off-by: Maninder Singh
---
drivers/gpu/drm/amd/amdkfd/kfd_process.c |3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_process.c
b/drivers/gpu
Use kzalloc rather than kcalloc(1.. for allocating
one thing.
Signed-off-by: Maninder Singh
Reviewed-by: Vaneet Narang
Reviewed-by: Christian Konig
---
v2: Chnged shortlog prefix - gpu/amdgpu
drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c |2 +-
1 file changed, 1 insertion(+), 1 deletion
kfree(NULL) is safe and this check is probably not required
Signed-off-by: Maninder Singh
Reviewed-by: Vaneet Narang
Reviewed-by: Christian Konig
---
v2: Chnged shortlog prefix - gpu/amdgpu
drivers/gpu/drm/amd/amdgpu/amdgpu_device.c |3 +--
1 file changed, 1 insertion(+), 2 deletions
kfree(NULL) is safe and this check is probably not required
Signed-off-by: Maninder Singh
Reviewed-by: Vaneet Narang
---
drivers/gpu/drm/amd/amdgpu/amdgpu_device.c |3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
b/drivers/gpu
Use kzalloc rather than kcalloc(1.. for allocating
one thing.
Signed-off-by: Maninder Singh
Reviewed-by: Vaneet Narang
---
drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ttm.c
b/drivers/gpu/drm
Hi,
>The shortlog prefix of both your patches should be "drm/amdgpu:" instead
>of "gpu/drm:". With that fixed, both are
Do i need to send V2 of patch with that change or you have fixed that?
>Reviewed-by: Michel Dänzer
Thanks.
..
he check from
mdfld_dsi_read_mcs and initializing dev struct after NULL check
of sender.
Suggested-by: Patrick Jakobsson
Signed-off-by: Maninder Singh
Reviewed-by: Vaneet Narang
---
v1: removes check from __read_panel_data
v2: remove check from mdfld_dsi_read_mcs instead of __read_panel_data
ing the check from
__read_panel_data.
Signed-off-by: Maninder Singh
Reviewed-by: Vaneet Narang
---
drivers/gpu/drm/gma500/mdfld_dsi_pkg_sender.c |5 -
1 files changed, 0 insertions(+), 5 deletions(-)
diff --git a/drivers/gpu/drm/gma500/mdfld_dsi_pkg_sender.c
b/drivers/g
Hi,
>> - if (!sender || !data_out || !len_out) {
>> - DRM_ERROR("Invalid parameters\n");
>> - return -EINVAL;
>> - }
>> -
>
>I would prefer to have these kind of checks where it actually matters
>(ie. in __read_panel_data()). The saner thing would be to move
Use kzalloc for allocating one thing rather than
kcalloc(1...
The semantic patch that makes this change is as follows:
//
@@
@@
- kcalloc(1,
+ kzalloc(
...)
//
Signed-off-by: Maninder Singh
Reviewed-by: Vaneet Narang
---
drivers/gpu/drm/radeon/radeon_ttm.c |2 +-
1 files
check of sender
Signed-off-by: Maninder Singh
Reviewed-By: Vaneet Narang
---
drivers/gpu/drm/gma500/mdfld_dsi_pkg_sender.c |4 +++-
1 files changed, 3 insertions(+), 1 deletions(-)
diff --git a/drivers/gpu/drm/gma500/mdfld_dsi_pkg_sender.c
b/drivers/gpu/drm/gma500/mdfld_dsi_pkg_sender.c
in
12 matches
Mail list logo