Re: [PATCH v3] drm/vkms: Add overlay plane support

2019-03-13 Thread Mamta Shukla
On Sun, Mar 10, 2019 at 9:00 PM Rodrigo Siqueira wrote: > > Hi, > > Thanks for your patch. > > You can see my comments inline. > > On 03/09, Mamta Shukla wrote: > > Add overlay plane support in vkms aligned with cursor and primary > > plane with module optio

[PATCH v3] drm/vkms: Add overlay plane support

2019-03-11 Thread Mamta Shukla
Add overlay plane support in vkms aligned with cursor and primary plane with module option 'enable_overlay' to enable/disable overlay plane while testing. This currently passes plane-position-covered-pipe-A-plane subtest from IGT kms_plane test. Signed-off-by: Mamta Shukla --- cha

[PATCH v2] drm/vkms: Add overlay plane support

2019-03-06 Thread Mamta Shukla
Add overlay plane support in vkms aligned with cursor and primary plane with module option 'enable_overlay' to enable/disable overlay plane while testing. This currently passes plane-position-covered-pipe-A-plane subtest from IGT kms_plane test. Signed-off-by: Mamta Shukla --- ch

[PATCH] drm/vkms: Add overlay plane support

2019-03-03 Thread Mamta Shukla
Add overlay plane support in vkms aligned with cursor and primary plane with module option 'enable_overlay' to enable/disable overlay plane while testing. This currently passes plane-position-covered-pipe-A-plane subtest from IGT kms_plane test. Signed-off-by: Mamta Shukla --- drive

[PATCH v2 2/2] drm/vkms: Modify memset() in compute_crc function

2019-01-30 Thread Mamta Shukla
Replace memset(vaddr_out + src_offset + 24, 0, 8) with memset(vaddr_out + src_offset + 3, 0, 1) because memset fills memory in bytes and not in bits. Signed-off-by: Mamta Shukla --- No changes in v2. drivers/gpu/drm/vkms/vkms_crc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH v2,1/2] drm/vkms: Use alpha for blending in blend() function

2019-01-30 Thread Mamta Shukla
Use the alpha value to blend vaddr_src with vaddr_dst instead of overwriting it in blend(). Signed-off-by: Mamta Shukla --- changes in v2: -Use macro to avoid code duplication -Add spaces around '/' and '-' -Remove spaces at the end of the line drivers/gpu/drm/

[PATCH 1/2] drm/vkms: Use alpha for blending in blend() function

2019-01-24 Thread Mamta Shukla
Use the alpha value to blend vaddr_src with vaddr_dst instead of overwriting it in blend(). Signed-off-by: Mamta Shukla --- drivers/gpu/drm/vkms/vkms_crc.c | 22 +++--- 1 file changed, 19 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/drm/vkms/vkms_crc.c b/drivers/gpu

[PATCH 2/2] drm/vkms: Modify memset() in compute_crc function

2019-01-24 Thread Mamta Shukla
Replace memset(vaddr_out + src_offset + 24, 0, 8) with memset(vaddr_out + src_offset + 3, 0, 1) because memset fills memory in bytes and not in bits. Signed-off-by: Mamta Shukla --- drivers/gpu/drm/vkms/vkms_crc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu

Re: [PATCH DRM] drm: msm: disp: dpu1: Use DRM_DEV_* instead of DPU_*

2018-11-11 Thread Mamta Shukla
On Wed, Nov 7, 2018 at 12:25 AM Sean Paul wrote: > > On Sat, Oct 20, 2018 at 11:33:54PM +0530, Mamta Shukla wrote: > > Use DRM_DEV_ERROR/DEBUG instead of DPU_ERROR/DEBUG to generate > > drm-formatted specific log messages in the Kernel log in case of > > multiple instance

Re: [PATCH DRM] drm: msm: adreno: Use DRM_DEV_* instead of dev_*

2018-10-22 Thread Mamta Shukla
On Sat, Oct 20, 2018 at 2:11 AM Sean Paul wrote: > > On Thu, Oct 18, 2018 at 2:33 PM Mamta Shukla wrote: > > > > Use DRM_DEV_INFO/ERROR/WARN instead of dev_info/err/debug to generate > > drm-formatted specific log messages so that it will be easy to > > dif

[PATCH DRM] drm: msm: Use DRM_DEV_* instead of dev_*

2018-10-22 Thread Mamta Shukla
Use DRM_DEV_INFO/ERROR/WARN instead of dev_info/err/debug to generate drm-formatted specific log messages so that it will be easy to differentiate in case of multiple instances of driver. Signed-off-by: Mamta Shukla --- drivers/gpu/drm/msm/adreno/a3xx_gpu.c | 4 +-- drivers/gpu/drm

[PATCH DRM] drm: msm: Replace instances of *_reference/unreference() with *_get/put()

2018-10-18 Thread Mamta Shukla
/coccinelle/api/drm-get-put.cocci Signed-off-by: Mamta Shukla --- drivers/gpu/drm/msm/adreno/a5xx_debugfs.c | 4 ++-- drivers/gpu/drm/msm/adreno/a5xx_gpu.c | 2 +- drivers/gpu/drm/msm/adreno/a5xx_power.c| 2 +- drivers/gpu/drm/msm/adreno/a5xx_preempt.c | 2 +- drivers/gpu/drm/msm

[PATCH DRM] drm: msm: adreno: Use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) +PTR_ERR

2018-10-18 Thread Mamta Shukla
Use PTR_ERR_OR_ZERO rather than if(IS_ERR(...)) + PTR_ERR because its better to have inlined function rather than code-opened implementation. Signed-off-by: Mamta Shukla --- drivers/gpu/drm/msm/adreno/a5xx_gpu.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a/drivers/gpu

[PATCH DRM] drm: msm: adreno: Use DRM_DEV_* instead of dev_*

2018-10-18 Thread Mamta Shukla
Use DRM_DEV_INFO/ERROR/WARN instead of dev_info/err/debug to generate drm-formatted specific log messages so that it will be easy to differentiate in case of multiple instances of driver. Signed-off-by: Mamta Shukla --- drivers/gpu/drm/msm/adreno/a5xx_gpu.c | 10 +- 1 file changed, 5

[PATCH DRM] drm: Shift * to be adjacent to pointer name

2018-10-16 Thread Mamta Shukla
Shift * to be adjacent to pointer name to follow Linux coding style. Issue found with checkpatch.pl ERROR: "foo * bar" should be "foo *bar" Signed-off-by: Mamta Shukla --- drivers/gpu/drm/drm_memory.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --g