s/Initializateion/Initialization
Fixes: 9aaf880ed4ee ("imx-drm: Add mx6 hdmi transmitter support")
Signed-off-by: Eugen Hristev
---
drivers/gpu/drm/bridge/synopsys/dw-hdmi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/bridge/synopsys/dw-hdmi.c
r for MT8195")
Signed-off-by: Michael Walle
Reviewed-by: Nícolas F. R. A. Prado
Tested-by: Nícolas F. R. A. Prado
Reviewed-by: AngeloGioacchino Del Regno
I tried this patch as well, hit the crash during my tests. I also
reviewed your changes
Tested-by: Eugen Hristev
Reviewed-by: Eug
Hi Jason,
On 8/7/23 04:51, Jason-JH.Lin wrote:
The plane_state of drm_atomic_state is not sync to the mtk_plane_state
stored in mtk_crtc during crtc enabling.
So we need to update the mtk_plane_state stored in mtk_crtc by the
drm_atomic_state carried from mtk_drm_crtc_atomic_enable().
While up
Hi Xiaoyong,
On 8/3/23 14:10, Xiaoyong Lu wrote:
Fix AV1 decoding failure when the iova is 36bit.
Before this fix, the decoder was accessing incorrect addresses with 36bit
iova tile buffer, leading to iommu faults.
Fixes: 2f5d0aef37c6 ("media: mediatek: vcodec: support stateless AV1 decoder")
On 8/2/23 17:47, Jason-JH.Lin wrote:
1. Add encoder_index function to mtk_ddp_comp_funcs to support dynamic
connector selection for some ddp_comp who has encoder_index.
2. Add mtk_ddp_comp_encoder_index_set function to set encoder_index to
each comp.
Usually a commit that does two things in a
On 8/2/23 17:47, Jason-JH.Lin wrote:
In mtk_drm_kms_init(), each element in all_drm_priv should has one
display path private data only, such as:
all_drm_priv[CRTC_MAIN] should has main_path data only
all_drm_priv[CRTC_EXT] should has ext_path data only
all_drm_priv[CRTC_THIRD] should has third_pa
On 8/2/23 17:47, Jason-JH.Lin wrote:
Add mtk_drm_crtc_path enum for eatch display path.
Typo: each
Instead of using array index of all_drm_priv in mtk_drm_kms_init(),
mtk_drm_crtc_path enum can make more readable.
can make *code* more readable ?
Signed-off-by: Jason-JH.Lin
---
drivers
On 7/31/23 11:21, Jason-JH Lin (林睿祥) wrote:
Hi Eugen,
Thanks for the reviews.
On Fri, 2023-07-28 at 11:47 +0300, Eugen Hristev wrote:
Hi,
On 7/27/23 19:41, Jason-JH.Lin wrote:
Add checking the length of each data path before assigning drm
private
data into all_drm_priv array.
Fixes
Hi,
On 7/27/23 19:41, Jason-JH.Lin wrote:
Add checking the length of each data path before assigning drm private
data into all_drm_priv array.
Fixes: 1ef7ed48356c ("drm/mediatek: Modify mediatek-drm for mt8195 multi mmsys
support")
Signed-off-by: Jason-JH.Lin
---
drivers/gpu/drm/mediatek/mt